blackrack

[WIP][1.8.x-1.9.x] Scatterer-atmospheric scattering (v0.0610 - 25/04/2020)

Recommended Posts

Btw I noticed something really weird the other day, while testing multiplanet support I noticed memory was never freed after unloading a planet (from scatterer). I was doing everything correctly so this was completely weird. I decided to just call the collector myself after each unload operation and it just worked, memory was being freed correctly and everything. So what the hell, does KSP never call the collector on it's own?

Probably. One of the downsides of c# is that the built-in GC makes devs less than responsible with memory. Always call the destructor when removing things.

Share this post


Link to post
Share on other sites

Curious, but is there a reason why, at times, Kerbin is a blue marble with no land from orbit? I've noticed it every once in a while and was wondering if there's a fix?

Share this post


Link to post
Share on other sites

"RSS Compatibility" isn't worth a Dingo's Kidneys.

When it is enabled, the game slows to a standstill and there is NREs. Not a spam of them, but they are definitely there, and definitely caused by Scatterer. I have no issues with Scatterer in stock scale, only in RSS.

Output_Log.txt

EDIT: The problem is that ParentPlanetTransformName = Kerbin instead of ParentPlanetTransformName = Earth. It should say Earth, not Kerbin. Changing that fixed it.

Unfortunately the orbit shader does not appear to function. :/

Edited by GregroxMun

Share this post


Link to post
Share on other sites
"RSS Compatibility" isn't worth a Dingo's Kidneys.

When it is enabled, the game slows to a standstill and there is NREs. Not a spam of them, but they are definitely there, and definitely caused by Scatterer. I have no issues with Scatterer in stock scale, only in RSS.

Output_Log.txt

EDIT: The problem is that ParentPlanetTransformName = Kerbin instead of ParentPlanetTransformName = Earth. It should say Earth, not Kerbin. Changing that fixed it.

Could you stop complaining about this? Every couple pages I have to say this was already reported.

Share this post


Link to post
Share on other sites
Could you stop complaining about this? Every couple pages I have to say this was already reported.

I apologize. Putting it in the OP would help?

Share this post


Link to post
Share on other sites
done.

You could put also "Change the Kerbin in ParentPlanetTransformName to say Earth" so that it is helpful to players who want it to work. :)

Share this post


Link to post
Share on other sites

Is there any way to get rid of the "banding" that occurs at certain altitudes?

Share this post


Link to post
Share on other sites
There would be a limit... I think it is 8K for unity (and most hardware) but I could be wrong.

Damn, thats sad. With 64bit we could finaly have almost unlimited detail, afaik Nasa released Earth textures with over 20000*20000 pixels.

Share this post


Link to post
Share on other sites

Screenshot%20from%202015-11-13%20052001.png

Getting this problem after installing Scatterer for RSS and using EVE/RVE overhaul. There is harsh borders as you can see, plus there is a black halo around the sun. I removed the clouds so you guys can see the problem better.

Share this post


Link to post
Share on other sites

I think RVE pretty explicitly instructs you not to use the RSS version of Scaterrer in its readme.

Share this post


Link to post
Share on other sites
You could put also "Change the Kerbin in ParentPlanetTransformName to say Earth" so that it is helpful to players who want it to work. :)

You could also try to realize that not all players are like you and actually try to figure things out on their own :)

It's also already there:

RSS compatibility:

[spoiler: click to see]

RSS only changes the name of the CelestialBody to Earth; it leaves the scaledversion transform/gameobject named Kerbin. Scatterer now handles this, if you wish to play with RSS, put the following in the "config/PlanetName.txt" file

ParentPlanetCelestialBodyName = Earth

ParentPlanetTransformName = Kerbin

Edited by mythbusters844

Share this post


Link to post
Share on other sites
I think RVE pretty explicitly instructs you not to use the RSS version of Scaterrer in its readme.
Is there any way to get rid of the "banding" that occurs at certain altitudes?

I went back and checked install....it appears I never even had scatter installed fully. My bad.

Share this post


Link to post
Share on other sites

1.0.5 near stock install - during one late afternoon I looked at the slowly setting sun and its awesome lens flare and suddenly my framerates dropped to 1/3. Running on a nVidia 850M here. Any way to get the old lens flare back (or tell me off to not look at the sun? :D) hehe

Share this post


Link to post
Share on other sites
1.0.5 near stock install - during one late afternoon I looked at the slowly setting sun and its awesome lens flare and suddenly my framerates dropped to 1/3. Running on a nVidia 850M here. Any way to get the old lens flare back (or tell me off to not look at the sun? :D) hehe

Yeah jeez Pandoras Kitten! No staring at the sun! :D

:P

Share this post


Link to post
Share on other sites
1.0.5 near stock install - during one late afternoon I looked at the slowly setting sun and its awesome lens flare and suddenly my framerates dropped to 1/3. Running on a nVidia 850M here. Any way to get the old lens flare back (or tell me off to not look at the sun? :D) hehe

to get old flare back you will have to get the sharedasset back from an original KSP repo , unless of course you backed up that file you replaced to get the sunflare

Share this post


Link to post
Share on other sites
You could also try to realize that not all players are like you and actually try to figure things out on their own :)

It's also already there:

I did figure it out on my own, and the instructions in the RSS compatibility spoiler are wrong, because they tell you to put ParentPlanetTransformName equal to Kerbin instead of Earth.

EDIT: The problem is that ParentPlanetTransformName = Kerbin instead of ParentPlanetTransformName = Earth. It should say Earth, not Kerbin. Changing that fixed it.

I figured that out on my own. And given that Blackrack said:

Every couple pages I have to say this was already reported.

It is entirely possible that a lot of players were the type of people who don't try and figure things out on their own. And for those players, a simple fix of the part of the OP that says ParentPlanetTransformName = Kerbin to change it to ParentPlanetTransformName = Earth (which makes it work) would suffice. Simply putting the correct information in the OP is what I was suggesting.

This would be helpful because not all players are like me, they don't all actually try to figure things out on their own. (see what I did there?)

- - - Updated - - -

In fact, pretty much full RSS compatibility can be had if you have:

Settings config


MapViewScale = 10.61
//10.61 because Earth is slightly larger than 10x Kerbin.

and

PlanetName config


ParentPlanetCelestialBodyName = Earth
ParentPlanetTransformName = Earth

Proof:

Javascript is disabled. View full album

Note: In RSS using KSP 1.0.5 you will also get MissingFieldExceptions logspam. This is because of the Kopernicus plugin not being compatible, not because of RSS config and/or Scatterer.

Edited by GregroxMun

Share this post


Link to post
Share on other sites

NathanKell himself said the transform name should be left as kerbin (hardcoded) and the celestialbody name is earth. I don't know how you're getting this to work but something else must be broken somewhere. The op doesn't have false information.

Share this post


Link to post
Share on other sites
NathanKell himself said the transform name should be left as kerbin (hardcoded) and the celestialbody name is earth. I don't know how you're getting this to work but something else must be broken somewhere. The op doesn't have false information.

Well at the very least, it can be made to work this way. I am confused why this works too, actually. It definitely works with the changes to the config that I made. I think that since RSS converted to the Kopernicus plugin it is a new body instead of modifying the stock Kerbin, which might have something to do with it.

RSSKopernicus.cfg

Body
{
name = Kerbin
//nameLater = Earth
cbNameLater = Earth
Template
{
name = Kerbin
}
... more stuff
}

Actually, that does say the name = Kerbin. I really am confused as to why the fix works. The only thing I can say with certainty is that changing the scatterer config seems to work well except for one thing: The tracking station does not show any scatterer on it at all, only in-flight map view.

:(

Edited by GregroxMun

Share this post


Link to post
Share on other sites

Effects are disabled on the tracking station right now, I might enable them later though I don't really see the point, I want the tracking station screen to be snappy and load fast

Share this post


Link to post
Share on other sites
Effects are disabled on the tracking station right now, I might enable them later though I don't really see the point, I want the tracking station screen to be snappy and load fast

I figured that was the case, I just forgot if it was like that normally or not.

Share this post


Link to post
Share on other sites
Effects are disabled on the tracking station right now, I might enable them later though I don't really see the point, I want the tracking station screen to be snappy and load fast

Is there a way to have them off by default in map mode? I kinda want my map to be...a map. :)

Share this post


Link to post
Share on other sites
Is there a way to have them off by default in map mode? I kinda want my map to be...a map. :)

I'll make this an option.

Edited: We space engine now

ba2P6C1.jpg

LAMMZY4.jpg

(decided to stick Kerbin's atmo on Jool for testing, it doesn't even look half bad, will try custom, greener configs soon)

Edited by blackrack

Share this post


Link to post
Share on other sites
I'll make this an option.

Edited: We space engine now

http://i.imgur.com/ba2P6C1.jpg

http://i.imgur.com/LAMMZY4.jpg

(decided to stick Kerbin's atmo on Jool for testing, it doesn't even look half bad, will try custom, greener configs soon)

A few days ago I looked at pictures of the real planets and remembered that for Little Green Men from Mars I had made Mars' atmosphere rims blue, and wondered what the stock planets would look like with blue rims. They look pretty great even in with the default rim effects (modified using Kopernicus to all use bluish tinted ramps) and here's what I got:

Javascript is disabled. View full album

I was going to release it but then remembered scatterer was a thing that was much better anyway, and it would soon have multi-planet support.

Share this post


Link to post
Share on other sites

Do those planets (especially Saturn) really have blue tinged edges that are that noticeable? I'm no expert, but could it look like that because of telescope or camera related reasons?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.