Jump to content

[WIP][1.9 -1.12] Scatterer-atmospheric scattering (0.0772 - 18/06/2021) Test version for multi-sun support inside


blackrack
 Share

Recommended Posts

Some fresh testing pics.

Sunset from space (not be confused with the "oranging" issue):

 

Clouds at dusk:

 

4 hours ago, daniel l. said:

Hey @blackrack any plans to release a standalone flare mod anytime soon ;) We Kopernicus modders would greatly appreciate it.

Not at the moment as I'm focusing on other things.

5 hours ago, SquaredSpekz said:

anyone got any configs for some cool post processing effects for non Atmospheric Planets/Moons? I've seen some around forums but without download.

How would this work exactly?

6 hours ago, Billy_Is_Dead said:

@blackrack What mod is the cockpit in the screenshots from?

OPT, and I'm pretty sure that cockpit was discontinued in later versions or was in some kind of test build, not sure if it's on the latest release.

Edited by blackrack
Link to comment
Share on other sites

2 hours ago, blackrack said:

Some fresh testing pics.

Sunset from space (not be confused with the "oranging" issue):

 

Clouds at dusk:

 

Not at the moment as I'm focusing on other things.

How would this work exactly?

OPT, and I'm pretty sure that cockpit was discontinued in later versions or was in some kind of test build, not sure if it's on the latest release.

Gorgeous.

Link to comment
Share on other sites

16 minutes ago, SquaredSpekz said:

@blackrack I mean in terms of adding some fogging to the mun etc. Not realistic but very cool looking and cinematic. I have seen it somewhere on the forums...

I see, I think I saw those but it was done using EVE in one of the old AVP packs.

Link to comment
Share on other sites

1 hour ago, SquaredSpekz said:

@blackrack I mean in terms of adding some fogging to the mun etc. Not realistic but very cool looking and cinematic. I have seen it somewhere on the forums...

I started to use that trick with EVE, time ago in KSPRC (after start to use layers to simulate fake scartterings) to fake the surface shining on non atmospherical bodies. All packs were using that method in one way or another after a short time because is a "cheap" and easy way to reproduce those effects. But EVE was not designed with that in mind, so the effect was better at high distances than near: if you don't dim the effect rightly (to disappear at near distances) you get that "fog" effect over the bodies... fog which -personally- I have come to hate along the time.

Anyways, and IMHO, combining Planet Shine, Scatterer and EVE you can get that effects again.

But what I wish to see some day is something like this:

On 5/11/2015 at 6:21 PM, blackrack said:

It is rendered behind the sky shader. Also, what am I looking at here?

Edited: now do this

14uwAzZ.jpg

 

Edited by Proot
Link to comment
Share on other sites

On 4/9/2016 at 2:53 PM, Proot said:

But what I wish to see some day is something like this:

Something like this is already done (see here) for the crescent shape, however the brightness isn't quite there yet. Of course setting it to something that looks good at night will look too bright during the day and vice versa, and that is because we don't have adaptation in KSP like the natural eye does. This could change however... In 1.0.5 I could never enable HDR on any of the cameras, it simply did nothing. But on 1.1 I tried it the other day and it seems to have enabled successfully and I even searched for all the rendertextures and saw a bunch of them going from 8-bit per channel to 32-bit per channel (which is required for HDR). I didn't finish testing because I was working on something else but if it works now then it could make that kind of scene and natural adaptation possible, as well as unlock a bunch of other cool effects like dynamic glow/flare from any bright objects (think rocket exhausts).

Also, now that I remember it I will add your suggestions for the lens flare as soon as I can.

Edited: Seems HDR is incompatible with antialiasing, and also requires editing the games lights to have intensitite superior to 1 and a bunch of other stuff so I'll just get back to it later.

On 4/9/2016 at 4:22 PM, _Krieger_ said:

How do I get the lens flare shader to work, when i enable it I don't see either the stock lens flare nor the scatterer flare, I'm running stock KSP with only scatterer installed.

https://imgur.com/c6g3Y3A

If you're running OpenGL I probably can't do much at the moment, anyway, look in the debug log for issues or post your KSP.log file here.

Edited by blackrack
Link to comment
Share on other sites

4 hours ago, Cooboo said:

As you know I'm a mac user, and the sunflare has not been kind to me. I can't seem to get them to work. Heres my output log and a screen cap... Im also using RSS and RO.

From literally 3 posts above yours....

On 9/4/2016 at 9:46 AM, blackrack said:

If you're running OpenGL I probably can't do much at the moment

On 10/4/2016 at 10:11 AM, _Krieger_ said:

Yeah, It's probably because I'm on a Mac, which runs OpenGL, but thanks for the feedback anyway.

 

From the OP

On 12/4/2015 at 6:37 PM, blackrack said:

Try to read at least 10 pages back and check the known issues section in the OP before posting

Edited by GrugInAus
Quote the OP about reading back
Link to comment
Share on other sites

Blackraaaacckkk, I have a bug for you :D I'm going to point you towards this post in the EVE thread. I'm using the latest 1.1 pre-release version of EVE as well as the latest Scatterer (also the .shader file that fixes the black line on the horizon).

 

Link to comment
Share on other sites

1 minute ago, Nhawks17 said:

Blackraaaacckkk, I have a bug for you :D I'm going to point you towards this post in the EVE thread. I'm using the latest 1.1 pre-release version of EVE as well as the latest Scatterer (also the .shader file that fixes the black line on the horizon).

 

@blackrack: I added a few new shader params:

cmr.material.SetFloat("_SunRadius", (float)(Sun.Instance.sun.Radius));
cmr.material.SetVector("_SunPos", Sun.Instance.sun.transform.position);
cmr.material.SetMatrix("_ShadowBodies", bodies);

Do they conflict with scatterer?

Link to comment
Share on other sites

9 hours ago, rbray89 said:

@blackrack: I added a few new shader params:

cmr.material.SetFloat("_SunRadius", (float)(Sun.Instance.sun.Radius));
cmr.material.SetVector("_SunPos", Sun.Instance.sun.transform.position);
cmr.material.SetMatrix("_ShadowBodies", bodies);

Do they conflict with scatterer?

No I don't see why there would be a conflict.

 

9 hours ago, Nhawks17 said:

Blackraaaacckkk, I have a bug for you :D I'm going to point you towards this post in the EVE thread. I'm using the latest 1.1 pre-release version of EVE as well as the latest Scatterer (also the .shader file that fixes the black line on the horizon).

So this only happens in map view right? Does this happen on a planet an active ship is orbiting or only when switching the map view to distant planets?

Link to comment
Share on other sites

44 minutes ago, blackrack said:

So this only happens in map view right? Does this happen on a planet an active ship is orbiting or only when switching the map view to distant planets?

Correct, only in map view, but it happens on any planet no matter where an active ship is. The pictures you see in the thread are with a ship on Kerbin.

Link to comment
Share on other sites

6 minutes ago, Nhawks17 said:

Correct, only in map view, but it happens on any planet no matter where an active ship is. The pictures you see in the thread are with a ship on Kerbin.

Weird, I can't seem to reproduce this, I only get a slight jittering on distant planets so I thought that might be it, nothing as big as the screens you posted though.

Link to comment
Share on other sites

3 minutes ago, blackrack said:

Weird, I can't seem to reproduce this, I only get a slight jittering on distant planets so I thought that might be it, nothing as big as the screens you posted though.

Strange..... And you're using the latest anycpu release he has on github right? The one from 11 hours ago?

Link to comment
Share on other sites

1 minute ago, Nhawks17 said:

Strange..... And you're using the latest anycpu release he has on github right? The one from 11 hours ago?

So wait, this doesn't happen without EVE? Anyway I'm getting worse problems with the latest anycpu release even without scatterer and I'm trying to make sure it's not something wrong on my end before I report anything.

Link to comment
Share on other sites

25 minutes ago, blackrack said:

So wait, this doesn't happen without EVE? Anyway I'm getting worse problems with the latest anycpu release even without scatterer and I'm trying to make sure it's not something wrong on my end before I report anything.

Well everything was working fine in the last dev release between Scatterer and EVE. Once I updated to the "shadows" update of EVE, that's when all of this starting occurring. 

Link to comment
Share on other sites

2 minutes ago, Nhawks17 said:

Well everything was working fine in the last dev release between Scatterer and EVE. Once I updated to the "shadows" update of EVE, that's when all of this starting occurring. 

Alright, at the moment I'm getting issues with the latest EVE update (see here) even without scatterer but once it is sorted I will check this out.

Link to comment
Share on other sites

29 minutes ago, blackrack said:

So wait, this doesn't happen without EVE? Anyway I'm getting worse problems with the latest anycpu release even without scatterer and I'm trying to make sure it's not something wrong on my end before I report anything.

If things are dark, you'll also want to fetch the shadows.cfg file.

Link to comment
Share on other sites

Just now, blackrack said:

Alright, at the moment I'm getting issues with the latest EVE update (see here) even without scatterer but once it is sorted I will check this out.

Interesting, didn't see this myself. I'll let you and rbray discuss this :P 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...