Jump to content

[WIP][1.9 -1.12] Scatterer-atmospheric scattering (0.0772 - 18/06/2021) Test version for multi-sun support inside


blackrack
 Share

Recommended Posts

On 2/21/2020 at 10:51 AM, blackrack said:

Ok guys, so I'm uplading a new version for 1.8.1 for now, it contains the caustics, as well as the ability to have colored suns affect the atmospheres, and some bug fixes.

Holy crap dude, I didn't realise just how much difference the caustics would make until I saw them in game. Fantastic work. :D

Link to comment
Share on other sites

Im really sorry if this has been asked before, but I couldnt find anything pertaining to this..

So I am running 1.8.1  with scatterer with AVP textures and default config, and it looks pretty cool, however kerbin looks pretty milky.. Is there a setting i can tweak to make the atmosphere less "foggy" or is this a bug? Heres a screenshot of my main menu:

https://drive.google.com/open?id=1ylBZaDpRzXjcHWku-MbzVYSxUIrrCoxx

Thanks a ton!

 

Edited by Exynym
Link to comment
Share on other sites

4 hours ago, Exynym said:

Im really sorry if this has been asked before, but I couldnt find anything pertaining to this..

So I am running 1.8.1  with scatterer with AVP textures and default config, and it looks pretty cool, however kerbin looks pretty milky.. Is there a setting i can tweak to make the atmosphere less "foggy" or is this a bug? Heres a screenshot of my main menu:

https://drive.google.com/open?id=1ylBZaDpRzXjcHWku-MbzVYSxUIrrCoxx

Thanks a ton!

 

I just install avp and I found that on Kerbin, the ocean become invisible (you can even see the bottom of the sea), do you have the same problem?

Link to comment
Share on other sites

16 minutes ago, Wang Nima said:

I just install avp and I found that on Kerbin, the ocean become invisible (you can even see the bottom of the sea), do you have the same problem?

This is a 1.9 issue as the mod is not yet compatible with 1.9.

Interestingly, I have the same issue as the above:  Astronomers becomes painfully milky in 1.8.1 with this new build.  It seems to be the new scatterer causing the change.

Link to comment
Share on other sites

10 hours ago, ElonsMusk said:

Thank you so much to everyone helping out with scatterer! I appreaciate it and so many lurkers do, too.

My own experience: 1.8.1 version does not break 1.9 install, but I can report the similar mask0looking problem over the sun in Flight. Hope everyone is enjoying 1.9!

:)

Could you by chance post your modlist? or just your graphical mods really. I feel like there is a conflict somewhere. Some people are having more success than others. Are you running dx9, dx11, or openGL?

Link to comment
Share on other sites

2 hours ago, WallHaxx said:

Could you by chance post your modlist? or just your graphical mods really. I feel like there is a conflict somewhere. Some people are having more success than others. Are you running dx9, dx11, or openGL?

The only one that kinda works is OpenGL, and even it has issues.

So he's probably using OpenGL.

Link to comment
Share on other sites

9 hours ago, R-T-B said:

This is a 1.9 issue as the mod is not yet compatible with 1.9.

Interestingly, I have the same issue as the above:  Astronomers becomes painfully milky in 1.8.1 with this new build.  It seems to be the new scatterer causing the change.

Thanks for your reply, but I'm actually using the 1.8.1 version, :( really sad that you get a perfect view but a ocean no water rofl

Link to comment
Share on other sites

Originally I had a problem with scatterer and SVE, it caused the no oceans, and a white and black sky.  Ever since the 1.8.1 update, and since so many other mods were updated, I've had no issue with that whatsoever.  I did try 1.9, and it didn't work, so I reverted.  I would rather play 1.8.1 with scatterer than 1.9 without.  Also Kepernicus is an absolute must as well. lmao.  In my opinion, the textures with sve look better than 1.9 without ever could. 

1 hour ago, Wang Nima said:

Thanks for your reply, but I'm actually using the 1.8.1 version, :( really sad that you get a perfect view but a ocean no water rofl

Edit: I just read you aren't using SVE but using AVP.... I'm wondering if that could be the issue...... have you tried uninstalling Astronomers visual pack first?  Double check also that you aren't using Stock Visual Enhancements at the same time.  If so, it's likely a conflict.  I love AVP but the clouds on some planets were far too thick, or too thin in some places..... for some reason on Kerbin the clouds were beautiful but the city lights were stretched and looked terrible.  I like SVE simply for the way the clouds are puffy but not over done. lol.  Anyway, just hoping maybe to help you sort it out. ;)

Edited by StoneWolfPC
Didn't fully read a post
Link to comment
Share on other sites

On 2/22/2020 at 7:00 PM, Exynym said:

Im really sorry if this has been asked before, but I couldnt find anything pertaining to this..

So I am running 1.8.1  with scatterer with AVP textures and default config, and it looks pretty cool, however kerbin looks pretty milky.. Is there a setting i can tweak to make the atmosphere less "foggy" or is this a bug? Heres a screenshot of my main menu:

https://drive.google.com/open?id=1ylBZaDpRzXjcHWku-MbzVYSxUIrrCoxx

Thanks a ton!

 

So for the sake of clarity, I now uninstalled all visual mods except scaterer, and it still looks super milky (I updated the screenshot). So this is definitely caused by scatterer, without it the foggines disappears..uc?id=1ylBZaDpRzXjcHWku-MbzVYSxUIrrCoxx&

Any ideas?

*edit* See below for filled in Bug Template:

KSP: 1.8.1 Windows 64bit

Problem: Foggy Kerbin

Mods installed:

Scatterer 0.055

Non-Visual Mods

Reproduction steps:

Main Menu or In-Game Map view

Log:

https://drive.google.com/open?id=1bKJ7_ChwZFFk6mnp0EoWx8QxJ0HcUhjH

Edited by Exynym
Link to comment
Share on other sites

Just now, Windh said:

Is there a way to get "automatic" notice when there's a 1.9 version running? Like Twitter?  Or is this the place to keep an eye on?

 

We just can't live without Scatterer. That's how good it is. 

If you're using AVC it will pop up a message saying Scatterer has an update.  So long as you're connected to the internet that is. :P  I still check in here because CKAN doesn't always have the update when AVC shows there is an update though. I honestly am not concerned about how long it takes for the 1.9 version though.  lol.

Link to comment
Share on other sites

41 minutes ago, Exynym said:

So for the sake of clarity, I now uninstalled all visual mods except scaterer, and it still looks super milky (I updated the screenshot). So this is definitely caused by scatterer, without it the foggines disappears..uc?id=1ylBZaDpRzXjcHWku-MbzVYSxUIrrCoxx&

Any ideas?

*edit* See below for filled in Bug Template:

KSP: 1.8.1 Windows 64bit

Problem: Foggy Kerbin

Mods installed:

Scatterer 0.055

Non-Visual Mods

Reproduction steps:

Main Menu or In-Game Map view

Log:

https://drive.google.com/open?id=1bKJ7_ChwZFFk6mnp0EoWx8QxJ0HcUhjH

That's how it's supposed to look. I'm curious to see how you think it should be.

46 minutes ago, Windh said:

Is there a way to get "automatic" notice when there's a 1.9 version running? Like Twitter?  Or is this the place to keep an eye on?

 

We just can't live without Scatterer. That's how good it is. 

Maybe suscribe on spacedock, I think they send a notification.

Link to comment
Share on other sites

On 2/22/2020 at 10:14 PM, R-T-B said:

The only one that kinda works is OpenGL, and even it has issues.

So he's probably using OpenGL.

I realized that I was still using SVE and that it may have been causing trouble. After that I did get scatterer working on OpenGL, only it runs like a tiny potato. Game time runs at like 1/5th speed. I also confirmed that I still have no water on dx11.

SIGH

I guess I will just turn the ocean shaders off and live with the horribly ugly blue camouflage that is KSP's stock water, until the update drops.

Link to comment
Share on other sites

On 2/21/2020 at 1:21 PM, blackrack said:

Would be nice to try again today.

Had a quick chance to check on this, and from my initial brief investigations -- I'm no longer seeing the errors when HDR is enabled.  The only change I'm seeing at all is a very slight darkening of the rendering to things that are in shadow (barely perceptible); everything else seems to render acceptably.

As I deleted my custom bloom implementation during my recent project cleanup, I'm going to recover those files, and redo the full series of testing that I was previously encountering problems with.  Will let you know of any further information I turn up.

Link to comment
Share on other sites

On 2/23/2020 at 11:09 AM, StoneWolfPC said:

Originally I had a problem with scatterer and SVE, it caused the no oceans, and a white and black sky.  Ever since the 1.8.1 update, and since so many other mods were updated, I've had no issue with that whatsoever.  I did try 1.9, and it didn't work, so I reverted.  I would rather play 1.8.1 with scatterer than 1.9 without.  Also Kepernicus is an absolute must as well. lmao.  In my opinion, the textures with sve look better than 1.9 without ever could. 

Edit: I just read you aren't using SVE but using AVP.... I'm wondering if that could be the issue...... have you tried uninstalling Astronomers visual pack first?  Double check also that you aren't using Stock Visual Enhancements at the same time.  If so, it's likely a conflict.  I love AVP but the clouds on some planets were far too thick, or too thin in some places..... for some reason on Kerbin the clouds were beautiful but the city lights were stretched and looked terrible.  I like SVE simply for the way the clouds are puffy but not over done. lol.  Anyway, just hoping maybe to help you sort it out. ;)

thank you very much, i dont know why but the third time when i install all my mods, it work !! i get the ocean and the sky is blue! :0.0: 

Link to comment
Share on other sites

On 2/23/2020 at 7:43 PM, blackrack said:

That's how it's supposed to look. I'm curious to see how you think it should be.

I'm sorry, I meant no offense! I guess just like it somewhat more transparent when viewed orthogonally, i.e. in the middle, while keeping the cool coloration effects on the edges and on the day/night line.. I think I got more or less what I wanted by reducing the values in the m_betaR vector and increasing HR a little while testing with your config tool, however it seems the additional parameters available in the actual atmo config change the result too much to apply the config from the Config tool 1:1.. Is there a way to change the atmo config ingame or is the only way to tweak it to do so in between game launches? Or is there maybe a cheatsheet i.e. as to what all the parameters do?

Thanks for your help and thank you so much for making this amazing mod!

Link to comment
Share on other sites

2 hours ago, Galileo said:

@Exynym from the OP..

For me that only displays options wrt ocean rendering etc,  no atmo configuration.. :/ or am I doing it wrong?

Edit: Ok actually it does show  atmo settings when the UI is brought up in main menu, however not when in KSC

I managed to reduce the fog by reducing the scattering exposure in the highest layer (just in case anyone also wants to reduce this)

Edited by Exynym
Link to comment
Share on other sites

On 2/22/2020 at 4:58 PM, R-T-B said:

This is a 1.9 issue as the mod is not yet compatible with 1.9.

Interestingly, I have the same issue as the above:  Astronomers becomes painfully milky in 1.8.1 with this new build.  It seems to be the new scatterer causing the change.

Im playing on 1.8.1 and I had this same issue. I did install JNSQ and the water isnt invisible anymore so...i dunno lol. Id have to check and see if JNSQ have scatterer configs or not...but I dont think it does

Link to comment
Share on other sites

14 hours ago, Exynym said:

I'm sorry, I meant no offense! I guess just like it somewhat more transparent when viewed orthogonally, i.e. in the middle, while keeping the cool coloration effects on the edges and on the day/night line.. I think I got more or less what I wanted by reducing the values in the m_betaR vector and increasing HR a little while testing with your config tool, however it seems the additional parameters available in the actual atmo config change the result too much to apply the config from the Config tool 1:1.. Is there a way to change the atmo config ingame or is the only way to tweak it to do so in between game launches? Or is there maybe a cheatsheet i.e. as to what all the parameters do?

Thanks for your help and thank you so much for making this amazing mod!

Yeah, I kinda felt it was more transparent before too, but apparently not.  Probably some config customization I forgot about, no biggie.

Edited by R-T-B
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...