Jump to content

[WIP][1.9 -1.12] Scatterer-atmospheric scattering (0.0772 - 18/06/2021) Test version for multi-sun support inside


blackrack
 Share

Recommended Posts

8 hours ago, blackrack said:

Sounds like you have 3 copies of scatterer installed... Are you on directx11? Post a screenshot from KSC looking towards the mountains at sunset when the sun hits the mountain edges, and your shadows and scattering config screens.

Ok i will. The thing that i did that may cause the 3 preset thing is when i installed the latest version on CKAN it replaced the "pre-realise scatter" folder that i installed manually. When i got in the game i saw that i dont have godrays. So i installed the pre-realise again but it still didnt work. So i changed the version to the previous one in CKAN. But still no godrays. I deleted the folder in Game Data and re installed pre-realise. This time i lost atmospheric effects. So i thought maybe a problem with BH scatter configs. I replaced the scatter folder in BH folder from a backup install that i keep. And it fixed the atmospheric effect but the godrays are still absent and i have 3 copies... probably.

Link to comment
Share on other sites

11 hours ago, blackrack said:

Sounds like you have 3 copies of scatterer installed... Are you on directx11? Post a screenshot from KSC looking towards the mountains at sunset when the sun hits the mountain edges, and your shadows and scattering config screens.

I think i fixed it. I reinstalled the mods and it fixed itself. But thanks for the help!

Also when is the dual sun support comming?

Edited by BlackEyedPhantom
Link to comment
Share on other sites

9 hours ago, blackrack said:

Finally adding support for multiple suns (for real this time)

zMIbTdj.png

 

UawkLzk.png

 

The release of this would be an excellent opportunity to recreate the "Twin Suns" moment from Star Wars. Just sayin'... :D

Edit: Also, the last .dll seems to be working fine for me! Sorry about being slow about reporting stuff...

Edited by Black-Two-
Link to comment
Share on other sites

Kopernicus team wants you to know multi sun support is awesome.  Indeed, do want.

Edited by R-T-B
Link to comment
Share on other sites

KSP: 1.11.1 Windows 64bit

Problem: Shadow Ball

Mods installed:

Scatterer 0.0772

EnvironmentalVisualEnhancements 1.11.3.1

AVP 4.11

TUFX - 1.0.2.3

Distance Object Enhancment v 2.0.2.0

Parallax - 1.2.3

module manager - 4.1.4

Reproduction steps:

Scatterer at very high preset. Launch at dawn

Log:

https://www.dropbox.com/t/2WiXGgL8gxp2I4y6

https://ibb.co/FnCB87k

I am getting this shadow ball since I changed the preset to very high. It is the shadow of my vessel which becomes this ball after the ship reaches a certain height. Before that the shadow is perfectly fine. 

Link to comment
Share on other sites

2 hours ago, Emperoreddy said:

KSP: 1.11.1 Windows 64bit

Problem: Shadow Ball

Mods installed:

Scatterer 0.0772

EnvironmentalVisualEnhancements 1.11.3.1

AVP 4.11

TUFX - 1.0.2.3

Distance Object Enhancment v 2.0.2.0

Parallax - 1.2.3

module manager - 4.1.4

Reproduction steps:

Scatterer at very high preset. Launch at dawn

Log:

https://www.dropbox.com/t/2WiXGgL8gxp2I4y6

https://ibb.co/FnCB87k

I am getting this shadow ball since I changed the preset to very high. It is the shadow of my vessel which becomes this ball after the ship reaches a certain height. Before that the shadow is perfectly fine. 

See https://github.com/LGhassen/Scatterer/issues/68

No real fix apart from lowering shadow distance, increasing shadow resolution or playing with the shadow cascades distribution, it's up to you.

Link to comment
Share on other sites

Getting weird issues with shadows, even with shadow cascades set to max, and fiddling with scatterer’s shadow settings, they’re still really low quality. Any tips?

Link to comment
Share on other sites

8 hours ago, alberro+ said:

Getting weird issues with shadows, even with shadow cascades set to max, and fiddling with scatterer’s shadow settings, they’re still really low quality. Any tips?

What worked for me was increasing the shadow cascade split distance, they're at I think 0.0015, 0.015, and 0.15 by default, and I've set them  probably way higher than i need to at 0.005, 0.03, and 0.3. Also increased the shadowmap resolution all the way up to 8192, which seems overkill, but gets reasonable-looking results up close.

I do have to wonder if I'm just not seeing the most detailed shadows, though, cause I'd expect the shadows at that resolution to be a lot crisper than they are.

Link to comment
Share on other sites

Posted (edited)
7 hours ago, SiCaRiO31 said:

Can this be used to make a full Mun cast shadows at night ?

Shadows no, lights though yes.

22 minutes ago, RyanRising said:

What worked for me was increasing the shadow cascade split distance, they're at I think 0.0015, 0.015, and 0.15 by default, and I've set them  probably way higher than i need to at 0.005, 0.03, and 0.3. Also increased the shadowmap resolution all the way up to 8192, which seems overkill, but gets reasonable-looking results up close.

I do have to wonder if I'm just not seeing the most detailed shadows, though, cause I'd expect the shadows at that resolution to be a lot crisper than they are.

Note that if you increase the first split from 0.0015 to 0.005 you're actually sacrificing the resolution of shadows closest to the camera, because you're making the lowest shadow cascade cover 0.5% of the max shadow distance, while it was 0.15% before. but yeah, adjust to taste.

8 hours ago, alberro+ said:

Getting weird issues with shadows, even with shadow cascades set to max, and fiddling with scatterer’s shadow settings, they’re still really low quality. Any tips?

I really don't have anything to say apart from what the unity documentation says: https://docs.unity.cn/Manual/shadow-cascades.html

Just get a good shadow resolution and try to get an even cascade split distribution. Lower the max shadow distance if it's still not enough so that you get an enough resolution where it matters to you.

Edited by blackrack
Link to comment
Share on other sites

13 minutes ago, blackrack said:

Note that if you increase the first split from 0.0015 to 0.005 you're actually sacrificing the resolution of shadows closest to the camera, because you're making the lowest shadow cascade cover 0.5% of the max shadow distance, while it was 0.15% before. but yeah, adjust to taste.

Ah, that checks out. Was fumbling around in the dark a little there.

Link to comment
Share on other sites

6 hours ago, blackrack said:

Shadows no, lights though yes.

yes! Im using planetshine and distant object, so nights at kerbin are really dark! It always bugged me how the mun doesnt cast any light when full, unlike our own Moon (that almost looks white in those circunstances).

Link to comment
Share on other sites

Been fiddling with the shadow settings, still can’t seem to get it to work nicely. If anyone has found values that work well at all distances, I’d appreciate it greatly if they could let me know.

Link to comment
Share on other sites

Posted (edited)
3 hours ago, pp3d said:

any plans for non-direct x support for the wave/ship interaction?

No, unless unity supports async GPU readback on non-directx.

I had a CPU version but it's too slow. For people with macbooks I'm assuming they don't have heaps of CPU power sitting unused, plus I don't want to support and juggle both implementations. For people with Linux, they can probably run the wave interactions with proton/dxvk.

Edited by blackrack
Link to comment
Share on other sites

2 hours ago, alberro+ said:

Been fiddling with the shadow settings, still can’t seem to get it to work nicely. If anyone has found values that work well at all distances, I’d appreciate it greatly if they could let me know.

This works for me. After reading the post above and learning that these numbers are actually coverage percentages, I just increased the first split and increased the resolution to 16k to compensate for quality drop. If that seems a bit excessive, it actually doesn't eat any more performance than the stock setting from what I've seen. Probably because the actual quality of the shadow stays the same due to splits, it just has more distance to it. 
PpMKvxR.png

With and without full alt+scroll zoom. 
 

Spoiler

GFWPsFX.jpg4d8CvXe.jpg

 

Link to comment
Share on other sites

6 hours ago, dok_377 said:

This works for me. After reading the post above and learning that these numbers are actually coverage percentages, I just increased the first split and increased the resolution to 16k to compensate for quality drop. If that seems a bit excessive, it actually doesn't eat any more performance than the stock setting from what I've seen. Probably because the actual quality of the shadow stays the same due to splits, it just has more distance to it. 
PpMKvxR.png

With and without full alt+scroll zoom. 
 

  Reveal hidden contents

GFWPsFX.jpg4d8CvXe.jpg

 

Thanks man, I really needed some help with these. 

Link to comment
Share on other sites

7 hours ago, blackrack said:

No, unless unity supports async GPU readback on non-directx.

I had a CPU version but it's too slow. For people with macbooks I'm assuming they don't have heaps of CPU power sitting unused, plus I don't want to support and juggle both implementations. For people with Linux, they can probably run the wave interactions with proton/dxvk.

The AsyncGPUReadback Plugin should have support for metal(mac)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...