Jump to content

[WIP][1.9.x-1.12.x] Scatterer-atmospheric scattering (0.0829 - 12/01/2022) Scattering improvements, in-game atmo generation and multi-sun support


blackrack
 Share

Recommended Posts

On 10/29/2016 at 9:16 AM, Nnimrod said:

Would changing the altitude settings be enough to make this work perfectly with the kscale 10x mod? It makes the atmosphere taller, to ~130km or so.

You shouldn't have to change anything, it will resize automatically

On 10/28/2016 at 2:25 PM, Glonor said:

I wanted to share this. As you can see once the mountains exceed the horizon they become white. Is this supposed to be normal?

FHqRQEP.gif

It's normal. If you don't use EVE clouds and want to get rid of this, uncheck "draw atmo over EVE clouds from main menu", you will have to reconfigure the transition to orbit though, you could alternatively get one of the versions before this feature was introduced and copy the config points for Kerbin.

On 10/28/2016 at 1:19 PM, Falco251 said:

I installed KSP on the Win 10 partition (before I used it under MacOS) and I installed the same mods I had before the update.

After some troubleshooting I found that the problem I was experiencing was caused by Scatterer. I removed all the mods and installed them back one at a time, until I found the one that was causing the issue.

Basically, the games loads correctly but when I start a scenario (any kind) data starts to increase in RAM at a rate of 250-300MB per second, until it reaches 32 GB (16GB RAM + 16GB virtual memory). The task manager graph indicates a steady rate throughout.
Upon filling up the memory, KSP crashes because of an access violation error (I guess no more addresses are available).

I can replicate the problem each and every time with scatterer installed (alone, no other mods that use it). If I remove scatterer, the game is perfectly playable.

What can I do? I would like to have those awesome graphics back!

--------------------------

Edit: I seem to have found a possible cause. There was a png file missing in the "config" folder (in the log there is a series of "IsolatedStorageException: Could not find file" errors). Maybe the code could be changed in order to make sure that if a file is not found scatterer doesn't start an endless loop.

Are you sure the png is actually missing? Maybe the path used by scatterer is not good, could you check?

On 10/24/2016 at 11:21 PM, Mystique said:

Sorry for bumping old question, is there any fix for "dark bar" issue? I'm talking about thing like this, when there is transition line clearly visible at some angles:

c2e24eddcc9ad0c5414156d1be83ec88.jpeg

Not at the moment.

On 10/24/2016 at 11:55 PM, skandervr said:

Is it just me or is the ocean sun reflection faded in 0256? Or is it supposed to be this way?

Comparison (can't seem to insert images...):

1.1.3 with 0255 http://imgur.com/OJlsboq

1.2 with 0256 http://imgur.com/e144vaj

You're right and I'm surprised no one else noticed, just today I wanted to fly towards the sunset and saw no reflection on the water. I will fix it soon.

On 10/25/2016 at 0:50 PM, mulfucer said:

@blackrack I'm delete planet entries but no working sunflare

http://imgur.com/xZqoP0c

I don't know, look at the log or something.

Link to comment
Share on other sites

Hi,

I notified few bug with the last version of scatterer :

First one, some interaction with other mods mess up the contract system. A clean reinstalation of mods solve the problem, but i report it for other users.

Second one : Montain, even with EVE, seems to not being rendered when near the ground and when out of atmo.

Thirst one : horizon line are not quite fixed, there is still ugly horizon line when near the ground (very aliaised) and some white line of the same nature in textures.

ab74d734-d5e0-4462-84d7-7e81d86ab46b.jpg

The blue cercle show the "white line texture effect" the red one show the white montain under certain altitude (but i don't know if it's due to a stock ksp bug) and the white cercle show the red horizon line remaining.

Edited by msnbcorp
Link to comment
Share on other sites

2 hours ago, msnbcorp said:

Hi,

I notified few bug with the last version of scatterer :

First one, some interaction with other mods mess up the contract system. A clean reinstalation of mods solve the problem, but i report it for other users.

Second one : Montain, even with EVE, seems to not being rendered when near the ground and when out of atmo.

Thirst one : horizon line are not quite fixed, there is still ugly horizon line when near the ground (very aliaised) and some white line of the same nature in textures.

ab74d734-d5e0-4462-84d7-7e81d86ab46b.jpg

The blue cercle show the "white line texture effect" the red one show the white montain under certain altitude (but i don't know if it's due to a stock ksp bug) and the white cercle show the red horizon line remaining.

All of those have been brought up already. The mountains look like that that because of the post processing.  You can turn it down yourself in the scatterer gui. 

Link to comment
Share on other sites

14 hours ago, msnbcorp said:

Hi,

I notified few bug with the last version of scatterer :

First one, some interaction with other mods mess up the contract system. A clean reinstalation of mods solve the problem, but i report it for other users.

Second one : Montain, even with EVE, seems to not being rendered when near the ground and when out of atmo.

Thirst one : horizon line are not quite fixed, there is still ugly horizon line when near the ground (very aliaised) and some white line of the same nature in textures.

The blue cercle show the "white line texture effect" the red one show the white montain under certain altitude (but i don't know if it's due to a stock ksp bug) and the white cercle show the red horizon line remaining.

White mountains shouldn't happen at sea level, are you using the default config? The other two can't be fixed at the moment.

 

Edited:

Could anybody guess what this is?

 

MCHTcrY.jpg

PxuATM6.jpg

Edited by blackrack
Link to comment
Share on other sites

This is my settings of Scatterer for Kerbin and Duna:

Kerbin:

Sunset from ground:

Spoiler

9E2E3D116DA81B17A8BB34ECD975D809358B351137B8FE146247F640087BE809D6AC2B9C43ECFB15F314387FCD65669D53DC16184C73EA491436E1FB

 

More blue above clouds:

Spoiler

115E526FDB3BDF4A0522EB826DCA9D842A93C4D5CF03EE180EC7FDD0142246D0AFF6A6FC747FCF03

 

In low orbit (no more white mountains):

Spoiler

0246FBA70F97AF5C86E852AE8070807C67BC9ADE0BC6AA1EF4B70DCF69483CF1FE32F7F22AF4BCD2

 

In medium orbit:

Spoiler

6DA8FAC62762470DA2828F6E551E9F87C3B21EC5

 

In high orbit:

Spoiler

7AE5DAB5479B289C3B49DB4E38F8E06A1A48A0E48D29E9EEA85EBD5EAAE58304238FC3B79F774E5D06B6D07C50F0D0E869C1C8385FB1C8A0BB70CE08E7BD085D8E2DB0D94D1C57A038242C05455874B8C2F06CD15FAAE20FF490801C6349D06891060ADF

 

Duna:

Sunset from ground:

Spoiler

734B2037711CD748C1FABE37C714ECD43124726853BCC1BFA2080894EE4E336824C633427CB337F14B384521DAAE31E407395FA0E9933196455A4815

 

In high altitude:

Spoiler

04539C56781C950C32A3562E7883EABEB521D30A

 

In low orbit:

Spoiler

BD8C1A3A71DAFB5C32057B585D976F0FF728223D

 

In high orbit:

Spoiler

6AE2959B2550D29548FBDBD77F8C9749BB746054BA9F90029A40B907F5976E9A4823AA0DE176A299

 

In orbit map:

Spoiler

64E129C2B7910CA6A3EF3141DC6E79C2870BAF99

 

You can download my settings here: Download

Edited by Vandest
Link to comment
Share on other sites

20 minutes ago, The Aziz said:

I think it's scatterer issue, because I can see Kerbin through the Mun when the camera is at certain distance from ground. Liek there
Is there a fix?

Weird, does this go away if you disable "draw atmo over eve clouds" option? what about when you disable the ocean?

Link to comment
Share on other sites

10 minutes ago, Majorjim! said:

Hi @blackrack

 I noticed an ugly new camera/shadow bug in 1.2.1 that is very visible when using scatterer. Can you confirm you see this also?

 Here is the bug report:http://bugs.kerbalspaceprogram.com/issues/13176

And here is a video of the issue:

I haven't even booted up 1.2.1 yet, but this just looks like a bad transition between shadow maps and/or between the shadows of the far camera and the near camera.

Try playing with the shadow cascades setting and the rendering quality setting.

Edited by blackrack
Link to comment
Share on other sites

Just now, blackrack said:

I haven't even booted up 1.2.1 yet, but this just looks like a bad transition between shadow maps and/or between the shadows of the far camera and the near camera.

Try playing with the shadow cascades setting and the rendering quality setting.

My settings have not changed at all between versions. Render always set to highest and shadow cascades always set to highest (4).

59 minutes ago, Vandest said:

You can download my settings here

Duna surface?? How? Amazing atmos BTW, kudos!

Link to comment
Share on other sites

8 hours ago, Majorjim! said:

My settings have not changed at all between versions. Render always set to highest and shadow cascades always set to highest (4).

Duna surface?? How? Amazing atmos BTW, kudos!

Try it anyway, your settings haven't changed but aomething in ksp did.

7 hours ago, Majorjim! said:

HI @blackrack I am getting a strange issue using SVE with scatterer. Galileo says he does not have this issue and suggests it is scatterer.

 Above around 130k meters the planet becomes a blue ball like this:

0D1B7D703858E808893FB459F3224B3B7D23F2F7

Any ideas?

Try the same things I suggested to @The Aziz above.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...