Jump to content

[WIP][1.9.x-1.12.x] Scatterer-atmospheric scattering (0.0835 - 22/04/2022) Scattering improvements, in-game atmo generation and multi-sun support


blackrack
 Share

Recommended Posts

@blackrack I noticed that in the 1.2 versions of scatterer (including the current one) the "disable scaled space ambient light" option doesn't seem to fix planet rendering through the atmosphere. Below is a screenshot of the Mun in early waxing crescent phase right after sunset:

j1kunJY.png

It should be barely visible but it is illuminated on the night side as if there was another star there. Either my install is totally borked, or whatever you did to fix this in earlier versions just unfixed itself

Link to comment
Share on other sites

Small issue with the ocean shaders.

I'm using an Asus 1080 Strix (reference, GTX 1080) GPU and an intel 4790k CPU at 4.0 GHz. And boy has the framerate taken a dump with over 200 parts. As in, noticeable lag (when I shouldn't be getting any since shaders = GPU). 

Link to comment
Share on other sites

1 hour ago, Gamel0rd1 said:

Small issue with the ocean shaders.

I'm using an Asus 1080 Strix (reference, GTX 1080) GPU and an intel 4790k CPU at 4.0 GHz. And boy has the framerate taken a dump with over 200 parts. As in, noticeable lag (when I shouldn't be getting any since shaders = GPU). 

Check your ksp.log file for error spams.

1 hour ago, m4ti140 said:

@blackrack I noticed that in the 1.2 versions of scatterer (including the current one) the "disable scaled space ambient light" option doesn't seem to fix planet rendering through the atmosphere. Below is a screenshot of the Mun in early waxing crescent phase right after sunset:

j1kunJY.png

It should be barely visible but it is illuminated on the night side as if there was another star there. Either my install is totally borked, or whatever you did to fix this in earlier versions just unfixed itself

I mentioned somewhere that it was broken in 1.2

I haven't investigated yet.

Link to comment
Share on other sites

41 minutes ago, blackrack said:

Check your ksp.log file for error spams.

Nothing out of the ordinary loading. No spam, no errors. After removing and reinstalling the mod, it still causes considerable lag. I have also disabled ocean shaders. Version: 1.2

Link to comment
Share on other sites

Station with more of 200 parts cause lags even with KSP vanilia.
This is the black spot of KSP 1.2. My friend with i7+RAM16Gb+GTX1070 is crushed by KSP for this. He love build big stations and now he can't do it.
For me, I do with lag in hope to Squad upgrade it.
 

Link to comment
Share on other sites

23 minutes ago, Gamel0rd1 said:

Nothing out of the ordinary loading. No spam, no errors. After removing and reinstalling the mod, it still causes considerable lag. I have also disabled ocean shaders. Version: 1.2

Oh btw scatterer has nothing to do with part count. If you have an issue with high part counts only it's not me.

Link to comment
Share on other sites

1 minute ago, Gamel0rd1 said:

Not a part count issue, either. It's making me lag a lot more than expected at 1 part

Post log and I will check it when I can. Also maybe try playing with the options and see if there's a difference.

Link to comment
Share on other sites

@blackrack

Hi sir, I was trying to add scatterer to kerbal galaxy revamped mod in a clean install, kerbal galaxy revamped + kopernicus, by themselves work like charm, the moment i add scatterer, and the ksc view opens, there starts a memory leak that would go up to eating all my 32 GB of ram. Unfortunatly, not me, nor the mod developer don't know what is going on and how to handle it. can you please help us? here is the mod i am talking about :

here is a glitch i see in game : http://prnt.sc/cxlg1c

and the memory leaking from memory graph, the arrow shows the moment ksc comes up : http://prnt.sc/cxlg75

finally link to the log file : https://www.dropbox.com/s/lrvnnxjuw5sb7hd/output_log.zip?dl=0

and what catches the eye in that log file :

NullReferenceException: Object reference not set to an instance of an object
  at scatterer.Manager.getDirectionToSun () [0x00000] in <filename unknown>:0
  at scatterer.SkyNode.InitPostprocessMaterial (UnityEngine.Material mat) [0x00000] in <filename unknown>:0
  at scatterer.SkyNode.Start () [0x00000] in <filename unknown>:0
  at scatterer.Manager.Awake () [0x00000] in <filename unknown>:0
  at scatterer.Core.Update () [0x00000] in <filename unknown>:0
 
(Filename:  Line: -1)

please help us

Edited by Jiraiyah
Link to comment
Share on other sites

Uhhh... Where the heck can I download this? I tried from spcaedock but it didnt work. The settings toolbar showed up, but it was tiny and had nothing in it. Pls someone send a link to download a version that works. :) Edit: and yes, I check from space with hyperedit in orbit. It didnt work.

Edited by Vinhero100
Clearing a question up
Link to comment
Share on other sites

46 minutes ago, Vinhero100 said:

Uhhh... Where the heck can I download this? I tried from spcaedock but it didnt work. The settings toolbar showed up, but it was tiny and had nothing in it. Pls someone send a link to download a version that works. :) Edit: and yes, I check from space with hyperedit in orbit. It didnt work.

The spacedock versions works just fine.  Also,  so you know,  saying it doesn't work doesn't help anyone.  Post your logs so we can see what is going on. 

Link to comment
Share on other sites

8 hours ago, Galileo said:

The spacedock versions works just fine.  Also,  so you know,  saying it doesn't work doesn't help anyone.  Post your logs so we can see what is going on. 

I think he means that his planet mod pack is not showing scatterer or something along those lines

Link to comment
Share on other sites

ugh... I cant paste it for some reason I'll do my best to represnt it here

 

                               -------------------------------------------------

                              |            Scatterer: version 0.0255         |

                              |                     (empty)                            |

                                ------------------------------------------------

Edit: wait I installed it wrong woops thx guys

Note: I will try gallelioes sun flares

 

Edited by Vinhero100
Link to comment
Share on other sites

1 hour ago, Vinhero100 said:

ugh... I cant paste it for some reason I'll do my best to represnt it here

 

                               -------------------------------------------------

                              |            Scatterer: version 0.0255         |

                              |                     (empty)                            |

                                ------------------------------------------------

Edit: wait I installed it wrong woops thx guys

Note: I will try gallelioes sun flares

That's an old version.

20 hours ago, Jiraiyah said:

@blackrack

Hi sir, I was trying to add scatterer to kerbal galaxy revamped mod in a clean install, kerbal galaxy revamped + kopernicus, by themselves work like charm, the moment i add scatterer, and the ksc view opens, there starts a memory leak that would go up to eating all my 32 GB of ram. Unfortunatly, not me, nor the mod developer don't know what is going on and how to handle it. can you please help us? here is the mod i am talking about :

here is a glitch i see in game : http://prnt.sc/cxlg1c

and the memory leaking from memory graph, the arrow shows the moment ksc comes up : http://prnt.sc/cxlg75

finally link to the log file : https://www.dropbox.com/s/lrvnnxjuw5sb7hd/output_log.zip?dl=0

and what catches the eye in that log file :

NullReferenceException: Object reference not set to an instance of an object
  at scatterer.Manager.getDirectionToSun () [0x00000] in <filename unknown>:0
  at scatterer.SkyNode.InitPostprocessMaterial (UnityEngine.Material mat) [0x00000] in <filename unknown>:0
  at scatterer.SkyNode.Start () [0x00000] in <filename unknown>:0
  at scatterer.Manager.Awake () [0x00000] in <filename unknown>:0
  at scatterer.Core.Update () [0x00000] in <filename unknown>:0
 
(Filename:  Line: -1)

please help us

I don't know what this mod does but, do you rename the sun using kopernicus? If so you have a variable in the scatterer settings "mainSunCelestialBody" which determines which body acts as the sun.

On 10/22/2016 at 0:06 PM, Moggiog said:

For some reason this mod doesn't work or me in 1.2. When I have it installed the ocean and atmosphere becomes invisible. I have tried it both with and without any other mods.

This doesn't help, post a log or something.

Link to comment
Share on other sites

I absolutely love Scatterer, the atmospheric & especially the ocean effects. But my poor little ol' PC/graphics card is running at it's (acceptable frame rate) limit with SVE LR 1.1.4, Distant objects, & Planetshine. Scatterer looks great, but pushes my system just over the line. :( Could anyone give me suggestions on what edits or fixes I could make to Scatterer to enjoy some of the effects, but be lighter on my system? I would appreciate it, and post any system particulars if it would help. I apologize if this the wrong place to ask.

Edited by sneekyzeke
Diction
Link to comment
Share on other sites

2 hours ago, sneekyzeke said:

I absolutely love Scatterer, the atmospheric & especially the ocean effects. But my poor little ol' PC/graphics card is running at it's (acceptable frame rate) limit with SVE LR 1.1.4, Distant objects, & Planetshine. Scatterer looks great, but pushes my system just over the line. :( Could anyone give me suggestions on what edits or fixes I could make to Scatterer to enjoy some of the effects, but be lighter on my system? I would appreciate it, and post any system particulars if it would help. I apologize if this the wrong place to ask.

I would just disable the ocean shader, once that's done, you can run the mod on anything that already runs KSP.

Also, depending on your specs, forcing the game to run in directx 11 might give you a performance boost. Which GPU and CPU do you have?

Edited by blackrack
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...