Jump to content

[WIP][1.9.x-1.12.x] Scatterer-atmospheric scattering (0.0838 - 14/08/2022) Scattering improvements, in-game atmo generation and multi-sun support


blackrack
 Share

Recommended Posts

10 hours ago, Guardsman111 said:

I hope this hasn't already been reported, but I'm having this issue when about 70'000 at kerbin:

eZPkdgq.png

 

Its playable, but very weird and I was wondering if there was a fix or whether I could provide info so you can work on a fix :) It appears to be stuck to the camera, so if I move the camera, the clouded bit moves with it.

Sorry to quote a large section.  I had pretty much the same thing.  At times, it seemed like I ripped the atmosphere off of Kerbin was drug it anywhere I went, until I did a scene change.

Is there a work around?  In other words, is there a setting that I can change that is prevent this?  Like un-checking the "god rays" to stop the odd streaking of objects.

Thanks,

Link to comment
Share on other sites

7 hours ago, dryer_lint said:

Didn't work unfortunately :/

I enabled 4x filtering from the card's graphics options and it's still the same. I have an integrated card but the rest of the computer is pretty decent.

Try forcing it off and see if it makes a difference.

 

54 minutes ago, Red Iron Crown said:

This isn't a bug report, just a funny glitch that happened when messing around with Hyperedit that I thought might be amusing:

screenshot3.png

Welcome to our orbital pool facility, would you like another drink?

 

2 minutes ago, gamerscircle said:

Sorry to quote a large section.  I had pretty much the same thing.  At times, it seemed like I ripped the atmosphere off of Kerbin was drug it anywhere I went, until I did a scene change.

Is there a work around?  In other words, is there a setting that I can change that is prevent this?  Like un-checking the "god rays" to stop the odd streaking of objects.

Thanks,

Check if rebuilding the ocean fixes it.

Link to comment
Share on other sites

43 minutes ago, blackrack said:

Try forcing it off and see if it makes a difference.

 

Welcome to our orbital pool facility, would you like another drink?

 

Check if rebuilding the ocean fixes it.

I saw a mention of two of that, but I think I missed the "How to" ...  again thanks!

Link to comment
Share on other sites

6 minutes ago, atomontage said:

Yeah sure. You press Alt+F11, then go to Ocean settings, then there is the Rebuild ocean button. 

Is this when you are "in game" vs at the menu?  I see 3 "Ocean" options, but not rebuild.

 

Okay... that is a Crazy Menu!!  It is "in-game" again.. thank yo for the support and help.  Hope that this helps. :)  I enjoy the 'effects'.

Edited by gamerscircle
Link to comment
Share on other sites

Not sure why, but when I use scatterer in 1.1 on a mac I get pretty crippling fps as long as the camera is pointed at Kerbin. If the camera is pointed at an ocean it gets even worse. I used it in 1.0.5 and it worked great, but now suddenly im getting bad fps. 

Link to comment
Share on other sites

Hey @blackrack I have another issue. Its really low priority as many players would not encounter it at all I think. But it might be easy to fix.. I guess.. Never dealt with render engines nor shaders so I have no clue. Anyway...

.There is the SCREENSHOT_SUPERSIZE option in the settings.cfg file that lies in the root KSP directory. One can change it to make screenshots look better. I like to set it to 3 so I get 4800x2700 shots. (Default is 0.)

However with that option changed the lens flares of the Kerbol do not render at all. Everything else renders perfectly.

I can provide more info or screenshots if you need it. Anyway - thanks as always.

Link to comment
Share on other sites

29 minutes ago, atomontage said:

Hey @blackrack I have another issue. Its really low priority as many players would not encounter it at all I think. But it might be easy to fix.. I guess.. Never dealt with render engines nor shaders so I have no clue. Anyway...

.There is the SCREENSHOT_SUPERSIZE option in the settings.cfg file that lies in the root KSP directory. One can change it to make screenshots look better. I like to set it to 3 so I get 4800x2700 shots. (Default is 0.)

However with that option changed the lens flares of the Kerbol do not render at all. Everything else renders perfectly.

I can provide more info or screenshots if you need it. Anyway - thanks as always.

Scatterer doesn't support it - and is completely disabled in those screenshots.

Btw, I've found what causes "tsunami" bug, i.e. ocean out of position. Zooming in in IVA camera, then switching back to EVA. Ocean becomes misplaced, and camera FOV doesn't revert to normal.

Link to comment
Share on other sites

8 minutes ago, sashan said:

Scatterer doesn't support it - and is completely disabled in those screenshots.

Btw, I've found what causes "tsunami" bug, i.e. ocean out of position. Zooming in in IVA camera, then switching back to EVA. Ocean becomes misplaced, and camera FOV doesn't revert to normal.

Nice, noticed this one as well, but couldn't reproduce.

Link to comment
Share on other sites

4 hours ago, sashan said:

Btw, I've found what causes "tsunami" bug, i.e. ocean out of position. Zooming in in IVA camera, then switching back to EVA. Ocean becomes misplaced, and camera FOV doesn't revert to normal.

I've run across this as well. If you jump back into IVA and zoom back out to the original level (this is tricky; it has to be precise), the ocean returns to normal.

The other thing I've found is this: if you are in ship view in orbit, change to map view then shift focus to another body (say, Mun), when you come back to ship view the atmosphere haze stays stuck regardless of the ship's position or distance from Kerbin. I have not tried with other atmospheric bodies. If you rebuild the ocean, the haze disappears. 

Link to comment
Share on other sites

I really like this mod. Once I removed it because I was kinda annoyed by some glitched, but had to reinstall it because stock is not the same anymore.

Hope you can sort out the glitches :)

Btw, here is a funny one I found, lets see if you can guess what it is XD

http://imgur.com/E8cDNZy (can't insert the image in the post, weird)

Edited by federicoaa
Link to comment
Share on other sites

@blackrack with the last version, I noticed while in flight a heavy lag for no apparent reason after a few minutes of flight. I took a look at my output log and I found a plaetora of NullReferenceException coming from Scatterer. There are a little more from other mods, but very few in number. if this can help you to debug maybe some issue, here's my output log: https://www.dropbox.com/s/kcstdu0jhh7ry92/output_log.txt?dl=0

 

Thanks for making KSP a wonderful visual journey!

Link to comment
Share on other sites

Getting some weird bugs with the KSC grass (not sure if this happens elsewhere). No amount of tweaking has seemed to fix it. Sorry if this bug has already been reported, but from the known issues it looks like this is new

WcX5BkMr.jpg

Link to comment
Share on other sites

9 minutes ago, Nhawks17 said:

Whoa, what planet pack is that?

Alternis Kerbol, I replaced the SVE rings with OPM's Sarnus and Urlum rings, and edited Scatterer's Laythe config to work on Jool correctly. https://www.reddit.com/r/KerbalSpaceProgram/comments/4gf9f6/i_thought_i_was_bored_of_vanilla_years_ago_but/

Configs are in that post, if anyone wants to try it out ^.^

Link to comment
Share on other sites

After pairing this mod with Sigma Dimensions and rescaling the kerbol system to 10x, I noticed that the sun flare is very small (because kerbin is now 10x farther away from kerbol). I was wondering how i would go about increasing the size of the flare?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...