Jump to content

[WIP][1.9.x-1.12.x] Scatterer-atmospheric scattering (0.0838 - 14/08/2022) Scattering improvements, in-game atmo generation and multi-sun support


blackrack
 Share

Recommended Posts

1 minute ago, Arco123 said:

I'll do it soon once I get back from school. 

It doesn't work from what I tested. In fact it seems to increase and cause a lot of bugs. setting it to 0 is not a good idea and any other settings don't do much or nothing at all. I'll try to give you a log and stuff and report my skybox issue soon.

Don't set it to 0 though, that's not how it works ;) I'll try to test on my side as well

Link to comment
Share on other sites

28 minutes ago, Arco123 said:

Thanks, I hope I can beta test the mod. I'm making some Iva shots and clipping makes details just disappear. Make sure it works with camera tools so builders and filmers can do this with out problems. 

it's working correctly, here's two examples, top images with the setting disabled, bottom images are with a nearClip plane of 0.01

lnICStN.jpg

 

VGo0uBX.jpg

 

Link to comment
Share on other sites

1 minute ago, Arco123 said:

Hmm, Ima test it. Also, what does restart on disable mean? And how do you turn it on correctly? I cant see the images... 

Enable it and restart the game. "Restart on disable" means you have to restart the game if you disable it for the game to go back to normal.

To turn it on correctly, you put this in scatterer/config/config.cfg

	overrideNearClipPlane = True
	nearClipPlane = 0.01

 

Link to comment
Share on other sites

Can confirm the nearclip works in KSP v1.5.1 w/ Scatterer v0.0336

@Arco123 I can't tell what exactly you're trying to show with any of your pictures. Do this. Load the vessel into the flight scene and use the Aim Camera option in the Part Access Window for any part on the vessel. Choose an orientation and zoom in slowly (using the default game camera not Camera Tools) until the clip happens. Zoom back out and screenshot. Now do the same thing with the nearclip setting reversed. Now post the two images for comparison like this:

OpahlBR.png

above image shows default clip point

VeY6oXi.png

above image shows I can get closer with near clip at 0.01

I also enabled Camera Tools and confirmed it obeys the near clip plane limits as adjusted by Scatterer

Link to comment
Share on other sites

3 hours ago, Arco123 said:

without ks3p: with it enabled

KS3P has nothing to do with this and why are there 8 images I showed you only needed 2 to prove whether the near clip plane is working for you or not. You say it's not working for you but none of those photos offer proof.

First two are from completely different angles

Second two are also from different angles, so a proper comparison is not able to be determined

Third set of two show a non-clip and a clip from the same angle but looking at everything else especially how the workers are so identically placed it seems you just took a photo, zoomed in to clip and took another photo and never restarted the game to change the setting. So again, not a proper comparison

Fourth set doesn't even show any clipping in either one.

Not sure what you're trying to prove here but if you just do what I told you to do we can affirm whether the near clip is working for you or not. Works for me, works for the mod author.

2 minutes ago, Arco123 said:

Can you give me your config so I can use it? 

Use this. You need Module Manager

place only ONE of these in your GameData folder at a time. Scatterer has the near clip disabled by default so you really don't need the disable.cfg in there but just to be sure, use it anyway

Edited by Drew Kerman
Link to comment
Share on other sites

Thank you guys for helping me. As soon as I get back I'll test. I'm probably being small brain and messed up a setting. Also, I'm wondering. What is save planet setting on change or something like that at the top? Does it do anything? 

Link to comment
Share on other sites

At a loss. I've put it in but it sometimes works and sometimes doesn't. I've tried all combinations of it. With both or none. Or sometimes it goes insane and everything in the craft slowly turns invisible. I'll try to post a video. 

Tomorrow I'm going to test more: [After restart.]

1. Near clip off in overlay, build, and flight. with commu 16.

2. Near clip on in menu with top screenshots

3. Near clip on forced with enable both inside and outside the folder it was it. Above pics.

Link to comment
Share on other sites

So it seems like AVP is doing it. Sorry for the useless bickering. Anyways, I've changed the code quite a bit since it works in flight but not IVA. So, I changed AVP's scatterer config and added near clip in the code and saved it. Wish me luck. 

Link to comment
Share on other sites

I'm having an issue with the default scatterer configs.

unknown.png

This is completely stock other than Scatterer, Scatterer - Default Config, and Scatterer - Sunflare. I have no idea why the ocean is doing this, other than it appears to be getting rendered about 100 meters too high?

Edit: Disabling the ocean shaders fixes it but introduces a new bug.

unknown.png

Edited by Tahvohck
More info.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...