Jump to content

[WIP][1.9.x-1.12.x] Scatterer-atmospheric scattering (0.0838 - 14/08/2022) Scattering improvements, in-game atmo generation and multi-sun support


blackrack
 Share

Recommended Posts

2 minutes ago, tilliepops said:

i don't think there are any logs to report (correct me if i'm wrong) so ya anyone know how to fix this?

If KSP runs, there are always logs to share.  Read the How To Get Support topic I linked in the post above yours.

Link to comment
Share on other sites

59 minutes ago, tilliepops said:

ok @Brigadier so i think i found the log but there is so much of it that a can't find scatter

Just send the whole thing. Only the dev in question actually knows what to look for.

Link to comment
Share on other sites

Help! Scatterer breaks my game. When I am on Kerbin with the mod installed, there are odd effects, almost like the ocean texture floating in the sky, also when looking straight up, the sky has a number of black circles in an almost lattice pattern. 

Link to comment
Share on other sites

@tilliepops

I'm not seeing major errors except for Steam complaining and one Module Manager error with KIS, neither of which, I think, are likely to cause your symptoms.  I'll defer to wiser folk.  You do have multiple versions of MM in the install so I recommend removing all but the latest, but I believe MM detects and runs only the most recent version in your install.

Am I correct that you're running on Linux?  Can you run KSP on DirectX instead of OpenGL?

How did you install your mods - manually or through CKAN?  Unless someone else has an easier solution, all I can recommend is that you start with a clean install (see below) and start adding mods in small groups until the problem reappears.

I do have a suggestion for you:  Never run KSP directly from the Steam install.  Instead, download and keep the Steam KSP directory pristine, then copy it to another folder.  Mod and play the copy.  This prevents Steam from updating your current game when you don't want it to.  This is less important now than when KSP was being updated frequently but it also reduces multiple, excessive Steam downloads.  If you're on a limited or a metered connection, this will save time and money.

This copying is legal to do.  You can have as many versions of KSP as you want as you play different KSP versions, mod combinations or game experience experiments without compromising your favorite saves.

@ThatBattleCowplease read the posts above yours for some initial steps you need to take so that others can help you sort that out.

Link to comment
Share on other sites

@Brigadierok so i uninstalled all my mods but it still looks like this:https://drive.google.com/file/d/16qYud4r0WJMVMyFrDmKAsHr6QvX0dkP6/view?usp=sharing has this ever happend to anyone? and does anyone know how to fix this? my log is here:https://drive.google.com/file/d/19BL5-aCD0atOJRzKQyRm1gfoxyTAaaA8/view?usp=sharing

Edited by tilliepops
typo
Link to comment
Share on other sites

@tilliepops it looks like you still have Kopernicus installed, try removing that. I also don't remember seeing a Kopernicus icon for just generic Kopernicus uses, so maybe it is an out of date version causing the game to break. Hope you get this fixed!

Link to comment
Share on other sites

13 hours ago, tilliepops said:

@Brigadierok so i uninstalled all my mods but it still looks like this:https://drive.google.com/file/d/16qYud4r0WJMVMyFrDmKAsHr6QvX0dkP6/view?usp=sharing has this ever happend to anyone? and does anyone know how to fix this? my log is here:https://drive.google.com/file/d/19BL5-aCD0atOJRzKQyRm1gfoxyTAaaA8/view?usp=sharing

Yeah...nope :P.  The log you posted suggests otherwise.  You have plenty of mods installed (see lines 719 to 812) and, as @Benzo Kermansuggests, Kopernicus, which enables KSP to handle planet packs can cause this.

I have you tried removing Kopernicus from your current KSP install (and removing any Kopernicus folder from GameData) and reinstalling it?

Also, install Zero MiniAVC because MiniAVC is known to cause problems.

Aside from that - and this is the brute-force approach - I would suggest starting with a fresh download of KSP from Steam, copy that KSP folder in its entirety to another folder, run it to the main menu and quit (it creates some files on first run), and then start installing mods and their dependencies a few at a time.  Run KSP each time to see if the problem reappears.

I would recommend using CKAN to ensure you capture those dependencies and avoid some basic incompatibilities, if you aren't using it already.  Manual installs will work fine but unless you're really comfortable with managing compatibility issues I would default to CKAN.  Just my personal opinion.

Edited by Brigadier
Vocabulary error.
Link to comment
Share on other sites

15 minutes ago, Brigadier said:

Also, install Zero MiniAVC because MiniAVC is known to cause problems.

@tilliepops

You MUST install ZeroMiniAVC.  If you still have any MiniAVC.dll files installed, all bets are off, it got broken sometime back around 1.8 or so.

 

Link to comment
Share on other sites

8 hours ago, Benzo Kerman said:

@tilliepops it looks like you still have Kopernicus installed, try removing that. I also don't remember seeing a Kopernicus icon for just generic Kopernicus uses, so maybe it is an out of date version causing the game to break. Hope you get this fixed!

Actually, the icon is a newer feature of the latest releases, suggesting he is up to date.

I would agree with the suggestion that the poster should try CKAN, though.

EDIT:  Looking at his log, he is also on AMD hardware on MacOSX in OpenGL mode, if it makes any difference.  Not sure how good AMD drivers are on OSX, but they historically are terrible in OpenGL on windows, so...  then again the only choice he'd have to get better drivers is pretty much "install linux," which I can't advise either.  I'm going to go with "piece by piece reinstall" as my recommendation as well.

Edited by R-T-B
Link to comment
Share on other sites

@Brigadier @R-T-B @linuxgurugamer all of this mods i used ckan to insall all the mods and im NOT useing a MacOSX laptop.  i will intall Zero MiniAVC. i intalled scatter from ckan and i have the  most up to date verson of Kopernicus.  here is my game data:https://drive.google.com/file/d/1BL47nUjOJNcybdLD6cFfaqjwQ_yCINeQ/view?usp=sharing

EDIT: i found a proplem while loading the game https://drive.google.com/file/d/1tWARByfrcZLT7S8fEZmtT_PT3x_aorkR/view?usp=sharing

EDIT 2 i think this is the updated log 

Spoiler

[Giant log file contents snipped by moderator]

or this is:

Spoiler

Mono path[0] = 'C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/Managed'
Mono config path = 'C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/MonoBleedingEdge/etc'
Initialize engine version: 2019.4.18f1 (3310a4d4f880)
[Subsystems] Discovering subsystems at path C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: Intel(R) HD Graphics 4600 (ID=0x412)
    Vendor:   
    VRAM:     2048 MB
    Driver:   20.19.15.4326
Begin MonoManager ReloadAssembly
- Completed reload, in  0.533 seconds
D3D11 device created for Microsoft Media Foundation video decoding.
<RI> Initializing input.
<RI> Input initialized.
<RI> Initialized touch support.
[AlarmClockScenario]: Generating ID, but the scenario is not running at this time - no unique checks 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

The referenced script on this Behaviour (Game Object 'ScreenKerbalsInventory') is missing! 
(Filename:  Line: 334)

UnloadTime: 1.868400 ms
Release Build 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[KSP Version]: 1.12.3.3173 (WindowsPlayer x64) (x64) en-us ============================== 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[Input Devices]:  
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[Input Devices]:  
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Launcher disabled? False 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[SteamManager]: Running under steam name: davecody 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Setting up 2 worker threads for Enlighten.
  Thread -> id: 3b68 -> priority: 1 
  Thread -> id: 6c8 -> priority: 1 
 

 

Edited by Snark
Giant log file contents removed by moderator
Link to comment
Share on other sites

Thanks.  The older log showed quite different output than this one.  You are indeed on a windows machine here, beyond that I am unsure whats going on.

Link to comment
Share on other sites

9 hours ago, tilliepops said:

EDIT 2 i think this is the updated log

Hi @tilliepops,

Just a side note to let you know that we've snipped the large log file contents from your post.  We understand that you mean well, and it's good to share log files.  :)  Please try to avoid pasting really big ones into the forum itself, though, because it causes problems for people.  Even if it's supposedly "hidden" in a spoiler, it forces the web browser to download the entire contents even if the person doesn't open the spoiler.  This can cause problems for folks, especially on mobile devices.

There's nothing wrong with pasting a page or two into a spoiler.  However, if the content is thousands of lines long, best to post it to some third-party file sharing site instead, and then post a link to it here in the forum.  That way, everyone wins.  ;)

We're sorry for the inconvenience, and thank you for your understanding!

Link to comment
Share on other sites

18 minutes ago, TheKrakenHerder said:

Can't get an image right now, but anyone else having an issue where ships are enveloped in a blue-tinted glow around Kerbin? Sort of like the Planetshine effect but on steroids and around the entire ship.

What version of Scatterer are you using? I believe that was a bug from a few versions ago.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...