sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

I Tried installing  (in 1.4.2) and all I get are the legacy parts (which can't even be moved)! I don't know how I can get the foldatrons and wheels showed in the video . !please help!

Share this post


Link to post
Share on other sites
11 hours ago, TeslaPenguin1 said:

I Tried installing  (in 1.4.2) and all I get are the legacy parts (which can't even be moved)! I don't know how I can get the foldatrons and wheels showed in the video . !please help!

follow link in post aqbove and install manualy. CKAN link is not reliable if you use it for this mod. It install only part pack without plugin and that parts will not work properly with next version of plugin due to different varable names used in part config file. You will get both, legacy and new parts as well as new plugin that is reasonable stable for decent gameplay. There is still few issues that need to be ironed out, but it is more/less easy to avoid them if you don't abuse scaling parts too much.

Share this post


Link to post
Share on other sites

I make inverse kinematics robotcontroller plugin. I use the Infernal Robotics API for moving servo motors.

Spoiler

 

 

Edited by Trufiadok

Share this post


Link to post
Share on other sites

Just going to say, this works perfectly fine on 1.4.4(at least the 1.3.1 version of IR) the IR sequencer works perfectly fine aswell.
(I can upload the files to dropbox if its necessary)

Edited by SparkyFox

Share this post


Link to post
Share on other sites

Hello, 

I have been having trouble with IR, I installed but all I got were parts, no controller to make them move, any ideas on how to fix?

Share this post


Link to post
Share on other sites

The mod works in version 1.5.1 incorrectly. Details are displayed in VAB / SHP.  Of them can be done various design. And even can be controlled in demo mode. But the Rovers explode on the runway, and when the spacecraft is put into orbit, it disappears and is ejected into the orbit of the Sun. You can restore the state of the game after that only by restarting it. If you remove parts of the mod, everything works correctly. I have to give up using this mod and it is very sad.

Share this post


Link to post
Share on other sites

Im getting alot of null reference exception with IR sequencer on 1.4.5 anyone else have this?  Mod seems to work just throws up notifications.

Share this post


Link to post
Share on other sites

I am using this in version 1.5.1 with no issues, on large and small craft. I have a new save and a new ships all using hinges/pistons and rotate items(see pics). I cannot find any IR item that does what you describe. this sounds to me more like a conflict with a mod. I have 45 mods running now.

I am only posting this to support that this mod by itself(+ the 44 others that I use) doesn't appear to be as broken as your experience describes for me. hence a possible solution could be found. if it helps I do not have any planet packs. 

screenshot71.png

screenshot72.png

screenshot75.png

now I was intending to post these on the fan art page so this a special preview here.. rofl. assembly in space 11-6 built fresh using 1.5.1 with all mods verified to be at the latest avail.

this vehicle was assemble with 4 flights and 8 docking procedures, then the dock ports were welded

enjoy hope this helps

Jammer-TD

Edited by Jammer-TD
added info

Share this post


Link to post
Share on other sites

Hello. I have tried multiple times to download this mod without knowing how to properly(all failing). I would like instructions on installing Infernal robotics with the rework pack and sequencer.  If you can, please send links to where i can find these mod files.

Share this post


Link to post
Share on other sites
8 hours ago, SuperxGamer0112 said:

Hello. I have tried multiple times to download this mod without knowing how to properly(all failing). I would like instructions on installing Infernal robotics with the rework pack and sequencer.  If you can, please send links to where i can find these mod files.

this link does provide this info as best I can. I would need logs and a screencap of the folders to help more

https://kerbal.curseforge.com/projects/magic-smoke-industries-infernal-robotics?comment=126

hope this helps

Jammer-TD

Share this post


Link to post
Share on other sites

Will you update to 1.6?

Share this post


Link to post
Share on other sites

Thank you for the help. I would like to know if i can now download the rework pack(without it causing problems). Is there also a specific way to downloading it?

Share this post


Link to post
Share on other sites
On ‎1‎/‎17‎/‎2019 at 2:53 PM, SuperxGamer0112 said:

Thank you for the help. I would like to know if i can now download the rework pack(without it causing problems). Is there also a specific way to downloading it?

well the IR-Modelrework has a lot going for it with lots of cool ideas ahead from what I read. this does appear to still be beta(fyi) and there is a process to install that I haven't tried yet. this link is to the latest of the beta's,,https://github.com/meirumeiru/InfernalRobotics/releases

but again use this at your own abilities to evaluate and not get to worked up if it doesn't do the thing you need. this is work in progress that I know I am looking forward to use when released

forum thread here:: 

hope this helps

Jammer-TD

Share this post


Link to post
Share on other sites

While nothing's going on here, I took the courage and unofficially recompiled the current state of Infernal Robotics GitHub master branch for 1.6.1. At the first glance it just works. Try it, but no promises.

InfernalRobotics.dll

Install as usual and replace the .dll

Share this post


Link to post
Share on other sites

I have the parts for Infernal Robotics but not the editing window. Can anyone help? I really wanna use the mod ;.;

(im using KSP 1.6.0 if that will help)

EDIT: I got the mod working with the icon now

Edited by HamMcHam
I got the mod working

Share this post


Link to post
Share on other sites

How did you get 

On 2/2/2019 at 3:27 AM, HamMcHam said:

I have the parts for Infernal Robotics but not the editing window. Can anyone help? I really wanna use the mod ;.;

(im using KSP 1.6.0 if that will help)

EDIT: I got the mod working with the icon now

How did you get it working? Mine crashes while booting due to mono.dll access violation, even if the only mod installed is Infernal Robotics.

Share this post


Link to post
Share on other sites
10 hours ago, saxyomega90125 said:

How did you get 

How did you get it working? Mine crashes while booting due to mono.dll access violation, even if the only mod installed is Infernal Robotics.

if you crash on loading, then your gamedata folder isn't happy, you can delete modulemanger files,except for "MM.dll" latest version file itself(in the gamedata folder0. and lastly you can delete the "partsdatabase" file in the root of ksp. and try again.

 if that fails you must have a mod/folder in the wrong place(nothing gets placed in the squad folder- we leave this folder alone). so a start fresh should help clean it up.

also make sure you have all the dep mod's the directions to install have been posted (follow link above)ps. you also need the IR sequencer to use this.

hope this helps

Jammer_td

Share this post


Link to post
Share on other sites
On ‎1‎/‎30‎/‎2019 at 2:36 PM, whale_2 said:

While nothing's going on here, I took the courage and unofficially recompiled the current state of Infernal Robotics GitHub master branch for 1.6.1. At the first glance it just works. Try it, but no promises.

InfernalRobotics.dll

Install as usual and replace the .dll

I tried your dll in my "working copy" of ksp. it gave me a couple of errors on start up and when I went to VAB, my craft in progress were not usable. claiming mumech (or some such thing) missing part, so I just wanted to let you know. this infernalrobotics.dll posted, did NOT work for me

I am on 1.6.1 with everything else updated to today

fyi

Jammer-TD

Share this post


Link to post
Share on other sites
19 hours ago, Jammer-TD said:

I tried your dll in my "working copy" of ksp.

....

this infernalrobotics.dll posted, did NOT work for me

I am on 1.6.1 with everything else updated to today

fyi

Jammer-TD

Would you mind sending me a log file please?

Share this post


Link to post
Share on other sites
1 hour ago, whale_2 said:

Would you mind sending me a log file please?

I don't mind, I enjoy this stuff.. but it will be a few days before I can recreate this as I am in the middle of a new craft(lots of new ideas i'm working on). but I should be able to retest and send you the logs this weekend.

Jammer-TD

Share this post


Link to post
Share on other sites
On 2/4/2019 at 1:31 PM, Jammer-TD said:

if you crash on loading, then your gamedata folder isn't happy, you can delete modulemanger files,except for "MM.dll" latest version file itself(in the gamedata folder0. and lastly you can delete the "partsdatabase" file in the root of ksp. and try again.

 if that fails you must have a mod/folder in the wrong place(nothing gets placed in the squad folder- we leave this folder alone). so a start fresh should help clean it up.

also make sure you have all the dep mod's the directions to install have been posted (follow link above)ps. you also need the IR sequencer to use this.

hope this helps

Jammer_td

Deleting the MM files got it to boot. I don't know why since those files were created with literally the exact same mod configuration I have now. ¯\_(ツ)_/¯

New problem. When I go to load my save, all craft I have made that use old IR parts are now showing that the parts are unable to load. I don't care if the old mod becomes incompatible soon, but I need to go in there and edit the craft files to use new IR parts then save edit them in place of the existing ones.

I have v2.0.2 of the old mod installed parallel to IR Next and Sequencer. Is there something I'm missing?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.