sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

8 hours ago, saxyomega90125 said:

I have v2.0.2 of the old mod installed parallel to IR Next and Sequencer. Is there something I'm missing?

Could be that you created those crafts with IR next parts, perhaps ?

Both, old IR and IR next parts have same mesh models, textures and descriptions, but have different names in config files and use different MM modules(configs) on parts.

Som, it is quite likely that you have some IR next part on those crafts or maybe from some other mod that you currently don't have installed.

Share this post


Link to post
Share on other sites
5 minutes ago, kcs123 said:

Could be that you created those crafts with IR next parts, perhaps ?

Both, old IR and IR next parts have same mesh models, textures and descriptions, but have different names in config files and use different MM modules(configs) on parts.

Som, it is quite likely that you have some IR next part on those crafts or maybe from some other mod that you currently don't have installed.

Okay, got it working. I think. Don't have time to check but no warnings this time for IR parts when I load the save.

When did IR Next become a thing? I looked in my 1.2.2 install and found IR 2.0.10, which I can find no record of on the web. I copied the parts and the Blizzy file from there into my 1.6.1 MSI folder and that solved the problem, so it must have been the then-new parts.

Share this post


Link to post
Share on other sites
2 hours ago, saxyomega90125 said:

When did IR Next become a thing? I looked in my 1.2.2 install and found IR 2.0.10, which I can find no record of on the web. I copied the parts and the Blizzy file from there into my 1.6.1 MSI folder and that solved the problem, so it must have been the then-new parts.

IIRC, about time when KSP 1.3.x was latest release, but it was also backported and supported for KSP 1.2.x for a while.

Share this post


Link to post
Share on other sites

did anyone make helicopter with working swashplate?

Share this post


Link to post
Share on other sites
8 hours ago, harits said:

did anyone make helicopter with working swashplate?

 

Share this post


Link to post
Share on other sites
Posted (edited)

Needs another mod to connect joystick to IR controls :)

Edited by whale_2

Share this post


Link to post
Share on other sites
Posted (edited)

Can't seem to get this to work so far in 1.7

 

No IR Icon in the VAB or SPH...  

 

Anyone else having issues?

 

 

Edited by Kilo60

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, Kilo60 said:

Can't seem to get this to work so far in 1.7

No IR Icon in the VAB or SPH...

Anyone else having issues?

Are you currently using the unofficial recompiled .dll along with the “core” and “parts” downloads?

1 - Install Infernal Robotics "Core" (no parts in this download) - Optionally install IR Rework "Parts" - The fancy white and orange parts @ZodiusInfuser is famous for

2 - Replace the InfernalRobotics.dll - "GameData/MagicSmokeIndustries/Plugins" - With @whale_2‘s Recompiled .dll

Edited by V8jester

Share this post


Link to post
Share on other sites
16 hours ago, V8jester said:

Are you currently using the unofficial recompiled .dll along with the “core” and “parts” downloads?

1 - Install Infernal Robotics "Core" (no parts in this download) - Optionally install IR Rework "Parts" - The fancy white and orange parts @ZodiusInfuser is famous for

2 - Replace the InfernalRobotics.dll - "GameData/MagicSmokeIndustries/Plugins" - With @whale_2‘s Recompiled .dll

Will do!  Thanks!

Share this post


Link to post
Share on other sites

Hello,

I have version KSP v1.7 and followed the directions above and can't seem to get this to work.

I installed release 2.0.2, Installed IR Rework Parts, and replaced the InfernalRobotics.dll with the one mentioned above. I now get an error and KSP crashes when I launch it. Did I miss something or i doing something wrong? 

Alternatively I tried installing IR - Next and got it running, but it only shows me 2 parts. I put a separate reply in that thread to see what i did wrong there. I would like to get one of these versions running. 

 

 

Share this post


Link to post
Share on other sites

well I have tested this in 1.7.1, and there are 2.5 options that I am aware of that work, but I haven't tried to combine them.

in 1 instance utilizing v2.0.2 and adding v 2.0.14 for parts and rework_core using IR sequencer1.0.3 does work in 1.7.1, and using the above recompiled.dll (option 1.5= the original combined install without the new .dll or rework)

however the @meirumeiru (v3) as well works and has some really nice enhanced parts. 

this works when using InfernalRobotics_v3.0.0_beta3_p7_for_1.4.2 (which incorporates rework core and expansion) and IR_Sequencer_3.0.1_KSP_1.6 in v1.7.1which to me is now my go to mod for MagicSmoke

hope this helps. I didn't provide links here but if you need I will

let me know 

hope this helps

Jammer-TD

Share this post


Link to post
Share on other sites

@Jammer-TD Thanks! I figured out my "problem".  As I said I got the IR Next version working but only saw 2 parts.  I didn't know that the parts were Technology Tree dependent! LOL! I only saw 2 parts because they were from tech that I already unlocked! I went into a Sandbox game and they were all there! 

Thanks anyway! Now for more science so I can get the other parts!

Share this post


Link to post
Share on other sites
Posted (edited)

I HAVE TERRIBLE NEWS!!! the good news is that this mod will get stock by squad BUT THAT TERRIBLE NEWS IS THAT MOD WILL BE PAID ACCESS! SO I WOULD LIKE A UPDATE TO 1.7 ASAP or sorry for caps, any way to make this run on ksp 1.7

Edited by tonimark

Share this post


Link to post
Share on other sites
45 minutes ago, tonimark said:

I HAVE TERRIBLE NEWS!!! the good news is that this mod will get stock by squad BUT THAT TERRIBLE NEWS IS THAT MOD WILL BE PAID ACCESS! SO I WOULD LIKE A UPDATE TO 1.7 ASAP or sorry for caps, any way to make this run on ksp 1.7

Yes, get this version: 

 

Share this post


Link to post
Share on other sites

yes that is bad for them, as it will be the last they see of me and my kind, when this all goes DLC for mods --- bye-bye as has happened to many a decent game, greed for money will shut them down as it has for many a DLC, this game is worth $30 that's it considering it has so many problems...

Share this post


Link to post
Share on other sites
On 5/10/2019 at 6:58 AM, Jammer-TD said:

yes that is bad for them, as it will be the last they see of me and my kind, when this all goes DLC for mods --- bye-bye as has happened to many a decent game, greed for money will shut them down as it has for many a DLC, this game is worth $30 that's it considering it has so many problems...

Your money, your opinion, your choice.  IMHO, the DLC is very reasonably priced, and enables Squad to continue development and bug fixes.

Share this post


Link to post
Share on other sites
On 5/12/2019 at 3:32 PM, linuxgurugamer said:

Your money, your opinion, your choice.  IMHO, the DLC is very reasonably priced, and enables Squad to continue development and bug fixes.

Exactly my opnion. I just don't know currently if the DLC will break my current modded playthrough or not, since it's a bit wonky atm.

Share this post


Link to post
Share on other sites
23 minutes ago, SHiRKiT said:

Exactly my opnion. I just don't know currently if the DLC will break my current modded playthrough or not, since it's a bit wonky atm.

Make a full copy of the install and test the DLC in that

Share this post


Link to post
Share on other sites

Is it possible to have this mod work side/side with the new BGE...?

 

Has anyone been able to get it to work with the new expansion?

Share this post


Link to post
Share on other sites

Yes to both questions. You need to grab the Infernal Robotics - Next version from this forum thread: 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.