sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

Can you try again? We've revently pushed updates everywhere.

I just started using CKAN today. Version listed in the client in CKAN is v0.21. On install IR.version says 0.12.RC1

Running fine with manual install though.

Share this post


Link to post
Share on other sites

Staying on the subject of interactions with ATM (there is of course the possibility this is something else entirely), is anyone else getting toolbar issues? As far as I can tell, I am running the latest version of IR (0.21.1, right?).

OSOlfaC.jpg

A6HA4YK.jpg

Note the additional IR button where the divider between stock and mod buttons normally lies.

EDIT: This is on 1.0.1, though the issue existed in 1.0.0 too

Edited by SufficientAnonymity

Share this post


Link to post
Share on other sites
Staying on the subject of interactions with ATM (there is of course the possibility this is something else entirely), is anyone else getting toolbar issues? As far as I can tell, I am running the latest version of IR (0.21.1, right?).

http://i.imgur.com/OSOlfaC.jpg

http://i.imgur.com/A6HA4YK.jpg

Note the additional IR button where the divider between stock and mod buttons normally lies.

EDIT: This is on 1.0.1, though the issue existed in 1.0.0 too

Yeah, I'm getting a similar issue. Happened occasionally on 1.0. Running 1.0.2 right now and I've still got the issue. I couldn't seem to reliably replicate it in 1.0, it just happened every so often. Hopefully it sorts itself out!

Edited by LemonSkin
spelling

Share this post


Link to post
Share on other sites

So what consists of the full IR pack now? You guys have me and others confused.. you have the reworks.. rework expansion and then the Magic Smoke Industries Infernal Robotics... seriously, there has to be a better way to organize.

Share this post


Link to post
Share on other sites

This is looking really awesome Sirkut, you have put a monumental amount of effort into getting this to the point it is, thank you. I think I might even be getting that itch again after seeing the new interface :0

Share this post


Link to post
Share on other sites
So what consists of the full IR pack now? You guys have me and others confused.. you have the reworks.. rework expansion and then the Magic Smoke Industries Infernal Robotics... seriously, there has to be a better way to organize.

In the original post it says

Model Rework & Expansion - A large collection of robotics and structural parts that really take advantage of what can be done with Infernal Robotics (these will eventually replace the current parts bundled with IR)

How is this confusing? It even says it will EVENTUALLY will replace the current parts.

Share this post


Link to post
Share on other sites
Staying on the subject of interactions with ATM (there is of course the possibility this is something else entirely), is anyone else getting toolbar issues? As far as I can tell, I am running the latest version of IR (0.21.1, right?).

http://i.imgur.com/OSOlfaC.jpg

http://i.imgur.com/A6HA4YK.jpg

Note the additional IR button where the divider between stock and mod buttons normally lies.

EDIT: This is on 1.0.1, though the issue existed in 1.0.0 too

Did you download it manually or used CKAN?

Share this post


Link to post
Share on other sites

I have a few quick questions. I want to build a docking arm with IR but I read on your main post that we can't mix IR parts and docking ports "directly or indirectly". So how indirectly are we talking about here? Is it enough to have a IR part like a hinge then attach something like a Cubic Octagonal Strut then a docking port? Or is it that any vessel which has a docking port and IR parts will have problems? Also if I may ask what is the problem that gets created when this bug gets activated? Crashing? Odd behavior?

Share this post


Link to post
Share on other sites
Manually

Very odd, can you describe steps to reproduce? Can you post logs?

Share this post


Link to post
Share on other sites
Very odd, can you describe steps to reproduce? Can you post logs?

Next time it occurs, I'll post logs. The only thing is, reproducing it is proving... awkward. At some point, after a scene change, it'll be like that.

Share this post


Link to post
Share on other sites

I'm seeing the button-placement bugs from those screenshots occasionally, but for me it's the Final Frontiers button that duplicates itself. I *think* that only happened after I added IR, but can't say for sure.

I'm having a different problem, though:

Built spaceplane with robotic arm mounted on the left wall inside my cargo bay (carrying jet fuel, intake and engine - so pretty heavy payload). Plan: Open bay doors, extend arm until jet assembly centered, then fly. Hyperedited into orbit to test descent properties of craft, opened bay doors etc., but regardless of arm position, plane acted as if CoM was way off to the left. So it seems the entire mass of what I put on the arm will be counted as adding mass to the craft at the arm's own point of attachment to the hull.

Share this post


Link to post
Share on other sites
I'm seeing the button-placement bugs from those screenshots occasionally, but for me it's the Final Frontiers button that duplicates itself. I *think* that only happened after I added IR, but can't say for sure.

I'm having a different problem, though:

Built spaceplane with robotic arm mounted on the left wall inside my cargo bay (carrying jet fuel, intake and engine - so pretty heavy payload). Plan: Open bay doors, extend arm until jet assembly centered, then fly. Hyperedited into orbit to test descent properties of craft, opened bay doors etc., but regardless of arm position, plane acted as if CoM was way off to the left. So it seems the entire mass of what I put on the arm will be counted as adding mass to the craft at the arm's own point of attachment to the hull.

Strange, because I've built kOS powered auto-balancing biped robot that uses it's IR hands and torso to keep balance, just like humans do and I can see the COM shifting. It cannot walk yet, but it can lift one leg and still keep balance.

Try moving parts in editor with COM marker on.

Share this post


Link to post
Share on other sites
Strange, because I've built kOS powered auto-balancing biped robot that uses it's IR hands and torso to keep balance, just like humans do and I can see the COM shifting. It cannot walk yet, but it can lift one leg and still keep balance.

Try moving parts in editor with COM marker on.

That's just it – in the editor, it looked to be adjusting mass perfectly, and when lifting off normally I also had no CoM-related issues. I wish I hadn't tossed the craft file away chasing a different solution. Maybe it was the arm itself generating ridiculous amounts of drag or something, since this was only an issue on reentry with doors open (replicated 3 times before I gave up on it), and since I'm using unfinished nuFAR. Will check back if it appears again.

Share this post


Link to post
Share on other sites
I have a few quick questions. I want to build a docking arm with IR but I read on your main post that we can't mix IR parts and docking ports "directly or indirectly". So how indirectly are we talking about here? Is it enough to have a IR part like a hinge then attach something like a Cubic Octagonal Strut then a docking port? Or is it that any vessel which has a docking port and IR parts will have problems? Also if I may ask what is the problem that gets created when this bug gets activated? Crashing? Odd behavior?

Take what I say with a grain of salt - I saw a post (long since forgotten where) that indicated that if a IR part was between the docked port and the root part you would have problems. With this info I built a mobile gantry and placed the root right behind the docking port - in other words Docking port <-> Root part <-> IR part <-> rest of vehicle. This didn't give me any problem (in 0.90) - used it a number of times over quite a few loads.

Share this post


Link to post
Share on other sites

I get a message on 1.0.2 saying that KSPAPI extensions are incompatible with this version, is that normal?

also I noticed that all the parts are duplicated with one set in the utility panel and the same parts also in the robotics panel, anyone else have that?

Share this post


Link to post
Share on other sites

Having some issues, I've read the past few pages and couldn't see anything but nevertheless sorry if it's already been reported.

When I attach any part to a hinge directly to the node holding the alt key key, it works fine in the VAB but when in flight the hinge remains static and the part goes into disco dance mode. Not complaining as it was highly entertaining and the mods an absolute essential. Hope this helps

Share this post


Link to post
Share on other sites
Take what I say with a grain of salt - I saw a post (long since forgotten where) that indicated that if a IR part was between the docked port and the root part you would have problems. With this info I built a mobile gantry and placed the root right behind the docking port - in other words Docking port <-> Root part <-> IR part <-> rest of vehicle. This didn't give me any problem (in 0.90) - used it a number of times over quite a few loads.

Thanks for the info wasml. :-)

Share this post


Link to post
Share on other sites
Having some issues, I've read the past few pages and couldn't see anything but nevertheless sorry if it's already been reported.

When I attach any part to a hinge directly to the node holding the alt key key, it works fine in the VAB but when in flight the hinge remains static and the part goes into disco dance mode. Not complaining as it was highly entertaining and the mods an absolute essential. Hope this helps

Just to clarify - is it Zodius Rework hinge or Legacy hinge?

- - - Updated - - -

Im having the toolbar issue too, but I DL on CKAN.

Sirkut is busy at the moment, as soon as he has some time we'll release an update for 1.02

Share this post


Link to post
Share on other sites

Sirkut is busy at the moment, as soon as he has some time we'll release an update for 1.02

KSP 1.0.2 has toolbar issue - double icon (1 on off them overlays basic toolbar).

Share this post


Link to post
Share on other sites
Just to clarify - is it Zodius Rework hinge or Legacy hinge?

- - - Updated - - -

Sirkut is busy at the moment, as soon as he has some time we'll release an update for 1.02

It's with legacy, both the 90' hinge and the ..... other one. Cant remember the name :D

Share this post


Link to post
Share on other sites
It's with legacy, both the 90' hinge and the ..... other one. Cant remember the name :D

I strongly recommend to start using Zodius IR part packs, at least the Core pack. Only things that are not implemented there are Gantries and Adjustable rails (although there are Extendatrons).

Share this post


Link to post
Share on other sites

Anyone else have their IR icons appear as black (i.e. the thumnails show just black, featureless shapes)?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.