sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

1 minute ago, Vegetal said:

I tried sending a crane rover to the mun and there was significant part drift, so I don't know about that...

Was it drifting during normal operation or during timewarp?

Share this post


Link to post
Share on other sites
Just now, Ziw said:

Was it drifting during normal operation or during timewarp?

Timewarp. Burned for the transfer, timewarped, and when preparing to land...."hey something is crooked". I am playing a 6.4x game though...

Share this post


Link to post
Share on other sites
Guest

It's happens even if craft not active.

I have 1.1.3 backup, un-archived it, checked satellite on Kerbol orbit - it's ok, all antenna arms are ok. May be a little shifted, but not noticeable without microscope.

Copied persistent.sfs to 1.2.1 - switched from KSC to intermediate satellite on Kerbin orbit - precaution - switched from it to satellite on Kerbol orbit - all the parts, that attached to IR parts are moved a lot, the shutter door with hinged actuator moved inside the battery and so on.

 

May be we can have an temporary solution:

All the IR parts should have a "Emergency" button on RMB menu.

Pressing it causes special dialog window to be shown:

With Store and Restore buttons and label with some explanations.

"Store" button saves coordinates of IR part and all the parts from part tree attached to it relative to "base" - part to which the IR part itself is attached. it also happens when vessel loaded first time. So IR part reacts on every vessel loading, and if storage is empty, it triggers Store action.

"Restore" restores all the part tree coordinates - IR part relative to base, all parts attached to IR part directly and all the descendants tree.

Also, Restore action resets IR part parameters and, if Kraken gone so far, relative position of immovable and movable halves.

Two problems:

one: When restoring, IR module should check, that stored parts still exist and try not to crash.

two: Parts attached after last "Store" button click or automatic action on first ever vessel load are not restored and will hang in the air. Or in vacuum.

Edited by Guest

Share this post


Link to post
Share on other sites
3 hours ago, Ziw said:

 

Your install is missing the AssetBundles subfolder. It was meant to be deleted before you install the 2.0.7 release, not after.

Regarding AssetBundles subfolder, it comes packed with both, IR core files and also with IRSequencer.
Currently it is no issue as sequencer have same file "ir_ui_objects.bundle" as in core archive, but also have another file "ir_ui_objects.ksp" that is not included in main archive.

Just something you should be aware of when new version is released, you need to have proper order of deleting and istalling IR archives in case that core pack is updated but IRSequencer is not against same beta release.

It would be better if both files are in core pack and left out completely, to avoid possible fault installs. If it is possible at all.
If not, users should be informed about proper order of install, at least.

Anyhow, thanks for keeping IR alive, KSP is just not same game without it.

Share this post


Link to post
Share on other sites

does anybody here use IR with Kerbal Joint Reinforcement? They played together at one point, but not IR is completely inoperable with KJR. Does anybody know a workaround?

Share this post


Link to post
Share on other sites
12 minutes ago, KAO said:

does anybody here use IR with Kerbal Joint Reinforcement? They played together at one point, but not IR is completely inoperable with KJR. Does anybody know a workaround?

Thanks to @sdfghdfgjd for that info. It is just few pages back.

Share this post


Link to post
Share on other sites

This mod is the last part I need to start building my orbital bombardment stations. I can't wait to see the new version. After seeing so many mods fall into the outdated bin, I was worried this one would follow suit. Thank you for keeping such a fantastic mod working.

Share this post


Link to post
Share on other sites

Timewarp bug fix.

@ZiwKerman ZiwKerman released this 4 minutes ago

Requires more testing, but it seems I've found a proper workaround.

BETA RELEASE, NO PARTS HERE, USE YOUR OLD PARTS

 

Download: https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/tag/2.0.8

@WildLynx @V8jester @kcs123 Please test the 2.0.8 with your crafts. I've managed to fix the timewarp bug in my test cases, but they were not very extensive.

 

Share this post


Link to post
Share on other sites
Guest

Imgur is bugged. Compressed screens and txt files to tar.gz and uploading to dropbox ... done.

For @Ziw

https://www.dropbox.com/s/r272emhlq7q71il/IR_Screens_0.tar.gz?dl=0

Screens, edited screens with arrows and txt annotations.

It happened on migration from 1.1.3 (with actual IR for 1.1.3) to 1.2.1 (with IR 2.0.8). Retested and made screens right now.

 

Edited by Guest

Share this post


Link to post
Share on other sites

Somehow I have a feeling that is not entierly IR fault. In 1.2.1 career game, I didn't reached nodes for IR parts, although IR is installed.

I noticed similar behaviour on simple crafts. Mk1 pod with parachute, heat shield, decoupler, fuel tank and engine in orbit. Sometimes I noticed gap between decoupler and heat shield. Like cover from decoupler is thrown away while craft is still coupled properly.

I no longer recall exact order for reproducing steps as I didn't pay much attention for it. I was being in orbit accelerating time, switching  scenes between ships, between space center, SPH/VAB, tracking station, etc. Exiting to desktop between sessions too. At one point when I switched back to "broken" craft it was shown normal again.

Now I feel sad that I didn't created screenshot of it. All thing might be just a stock issue, but IR mod or some other have exposed it much quicker.

 

I noticed something else though. Graplers(former active struts I belive) no longer work properly. There is no buttons for links/straight attach etc. in editor. There is option to toggle links in action group menu for same part.

I tried to load craft and subassembly from older KSP release. At first,after loading craft in SPH buttons for strut links are shown, but clicking on them does nothing. When I try to re-attach grapler part on craft, link button is lost in right click menu. Have yet to recreate everything on fresh KSP install with minimum number of mods as I got few in beta phase.
Then I could have more meaningful log and reproducing steps.

 

 

Share this post


Link to post
Share on other sites
8 hours ago, kcs123 said:

Somehow I have a feeling that is not entierly IR fault. In 1.2.1 career game, I didn't reached nodes for IR parts, although IR is installed.

I noticed similar behaviour on simple crafts. Mk1 pod with parachute, heat shield, decoupler, fuel tank and engine in orbit. Sometimes I noticed gap between decoupler and heat shield. Like cover from decoupler is thrown away while craft is still coupled properly.

I no longer recall exact order for reproducing steps as I didn't pay much attention for it. I was being in orbit accelerating time, switching  scenes between ships, between space center, SPH/VAB, tracking station, etc. Exiting to desktop between sessions too. At one point when I switched back to "broken" craft it was shown normal again.

Now I feel sad that I didn't created screenshot of it. All thing might be just a stock issue, but IR mod or some other have exposed it much quicker.

 

I noticed something else though. Graplers(former active struts I belive) no longer work properly. There is no buttons for links/straight attach etc. in editor. There is option to toggle links in action group menu for same part.

I tried to load craft and subassembly from older KSP release. At first,after loading craft in SPH buttons for strut links are shown, but clicking on them does nothing. When I try to re-attach grapler part on craft, link button is lost in right click menu. Have yet to recreate everything on fresh KSP install with minimum number of mods as I got few in beta phase.
Then I could have more meaningful log and reproducing steps.

 

 

ActiveStruts (which are a plugin for Grapplers) are not updated to 1.2+ version of KSP and might not ever be.

Share this post


Link to post
Share on other sites
7 hours ago, Ziw said:

ActiveStruts (which are a plugin for Grapplers) are not updated to 1.2+ version of KSP and might not ever be.

That explains odd behaviour. Maybe to write MM patch that will hide it in editor if proper version of active struts is not present. (any higher version than last available is). If ActiveStruts ever get update grapplers will work again.

More effective way than ask users to delete problematic parts by themself. Less false bug reports that way. Not issue for me, I will handle my install now when I'm aware of issue, but I think ahead after official release.

Share this post


Link to post
Share on other sites
On 11/24/2016 at 6:54 AM, Ziw said:

Timewarp bug fix.

@ZiwKerman ZiwKerman released this 4 minutes ago

Requires more testing, but it seems I've found a proper workaround.

BETA RELEASE, NO PARTS HERE, USE YOUR OLD PARTS

 

Download: https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/tag/2.0.8

@WildLynx @V8jester @kcs123 Please test the 2.0.8 with your crafts. I've managed to fix the timewarp bug in my test cases, but they were not very extensive.

 

Do I delete the assetbundles folder from 2.0.8 prior to copying it to gamedata or do i let it replace as well?

Share this post


Link to post
Share on other sites
On 11/24/2016 at 1:54 AM, Ziw said:

Timewarp bug fix.

@ZiwKerman ZiwKerman released this 4 minutes ago

Requires more testing, but it seems I've found a proper workaround.

BETA RELEASE, NO PARTS HERE, USE YOUR OLD PARTS

 

Download: https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/tag/2.0.8

@WildLynx @V8jester @kcs123 Please test the 2.0.8 with your crafts. I've managed to fix the timewarp bug in my test cases, but they were not very extensive.

 

So this will fix my arm from tweaking out while in time warp? I will test.

Share this post


Link to post
Share on other sites
10 hours ago, Selrinn said:

Do I delete the assetbundles folder from 2.0.8 prior to copying it to gamedata or do i let it replace as well?

Not necessarily. Just make sure your AssetBundles folder only contains one file - "ir_ui_objects.bundle"

Share this post


Link to post
Share on other sites
1 hour ago, Ziw said:

Just make sure your AssetBundles folder only contains one file - "ir_ui_objects.bundle"

What is with IR sequencer ? Does it need "ir_ui_objects.ksp" file or I need to delete it ? Or sequencer is not supported at this point of development ? Asking, just to not provide false bug reports. If sequencer is not supported I need to remove it from install to keep everything clean as much as possible.

Share this post


Link to post
Share on other sites
3 minutes ago, kcs123 said:

What is with IR sequencer ? Does it need "ir_ui_objects.ksp" file or I need to delete it ? Or sequencer is not supported at this point of development ? Asking, just to not provide false bug reports. If sequencer is not supported I need to remove it from install to keep everything clean as much as possible.

Latest Sequencer should also use only .bundle file. If the release zip file still contains the .ksp file it is my mistake. Let me know if its the case for the latest Sequencer

Share this post


Link to post
Share on other sites
11 minutes ago, Ziw said:

Latest Sequencer should also use only .bundle file. If the release zip file still contains the .ksp file it is my mistake. Let me know if its the case for the latest Sequencer

Yes, it still have that file inside. I downloaded IR Sequencer from this link: https://github.com/MagicSmokeIndustries/IR-Sequencer/releases/download/1.0.2/IRSequencer-1.0.2-Final.zip

Maybe to delete AssetBundles folder from IR sequencer will be better ? Just inform users that they also need IR core with sequencer.
I doubt that IR Sequencer users will use it without IR coure pack and some other part pack.

Share this post


Link to post
Share on other sites

@Ziw, don't know if it is harmless or more serious issue. I was inspecting output log that I prepare to upload for kOS team for different issue and I noticed this in log:

Spoiler

AssemblyLoader: Exception loading 'LaserDist': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

Additional information about this exception:

 System.TypeLoadException: Could not load type 'LaserDist.LaserDistModule' from assembly 'LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'LaserDist.LaserPQSUtil' from assembly 'LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null'.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Non platform assembly: E:\Kerbal Space Program\GameData\LightsOut\LightsOut.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\IRActiveStruts\Plugins\ActiveStruts.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\IRSequencer\Plugins\IRSequencer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\Parts\Rework_Utility\Plugins\IRSurfaceSampler.dll (this message is harmless)
AssemblyLoader: Exception loading 'IRSurfaceSampler': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

Additional information about this exception:

 System.TypeLoadException: Could not load type 'IRSurfaceSampler.ModuleIRSurfaceSampler' from assembly 'IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<waitForDeploy>d__0' from assembly 'IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null'.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\Plugins\InfernalRobotics.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\Plugins\Scale_Redist.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\Nereid\FinalFrontier\Plugins\FinalFrontier.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\PlanetShine\Plugins\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\PlanetShine\Plugins\PlanetShine.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\RCSBuildAid\Plugins\RCSBuildAid.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\RCSBuildAid\Plugins\RCSBuildAidToolbar.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\RealChute\Plugins\RealChute.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SCANsat\Plugins\SCANsat.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\scatterer\scatterer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SETIcontracts\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SETIprobeParts\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SETIrebalance\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SmokeScreen\SmokeScreen.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TacFuelBalancer\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TacFuelBalancer\TacFuelBalancer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TextureReplacer\Plugins\TextureReplacer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TriggerTech\KerbalAlarmClock\KerbalAlarmClock.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TriggerTech\KSPAlternateResourcePanel\KSPAlternateResourcePanel.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TriggerTech\TransferWindowPlanner\TransferWindowPlanner.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TweakScale\plugins\Scale.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TweakScale\plugins\Scale_Redist.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\UnmannedBeforeManned\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\WaypointManager\WaypointManager.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\[x] Science!\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\[x] Science!\[x] Science!.dll (this message is harmless)
VesselModules: Found VesselModule of type CommNetVessel with order 999

This part was raised my attention:

Quote

AssemblyLoader: Exception loading 'IRSurfaceSampler': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.

I have B9, IR and kOS mod that were in beta, maybe there is more strange interactions between other installed mods.
Except reported "issue" about graplers, reported earlier, I didn't noticed anything way too strange regarding IR.

EDIT:

More stuff regarding IR in log

Spoiler


[ModuleManager] Post run call threw an exception in loading IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ModuleManager.MMPatchLoader+<ProcessPatch>d__46.MoveNext () [0x00000] in <filename unknown>:0
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[ModuleManager] Post run call threw an exception in loading LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ModuleManager.MMPatchLoader+<ProcessPatch>d__46.MoveNext () [0x00000] in <filename unknown>:0

--------------------- several houndered lines later in log:

ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ContractConfigurator.ContractConfigurator+<GetAllTypes>d__27`1[ContractConfigurator.ParameterFactory].MoveNext () [0x00000] in <filename unknown>:0
Rethrow as Exception: Error loading types from assembly IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
ContractConfigurator.LoggingUtil:LogException(Exception)
ContractConfigurator.<GetAllTypes>d__27`1:MoveNext()
System.Linq.<CreateWhereIterator>c__Iterator1D`1:MoveNext()
ContractConfigurator.ContractConfigurator:RegisterParameterFactories()
ContractConfigurator.ContractConfigurator:PSystemReady()
EventVoid:Fire()
<Start>c__Iterator77:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename:  Line: -1)

ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ContractConfigurator.ContractConfigurator+<GetAllTypes>d__27`1[ContractConfigurator.ParameterFactory].MoveNext () [0x00000] in <filename unknown>:0
Rethrow as Exception: Error loading types from assembly LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
ContractConfigurator.LoggingUtil:LogException(Exception)
ContractConfigurator.<GetAllTypes>d__27`1:MoveNext()
System.Linq.<CreateWhereIterator>c__Iterator1D`1:MoveNext()
ContractConfigurator.ContractConfigurator:RegisterParameterFactories()
ContractConfigurator.ContractConfigurator:PSystemReady()
EventVoid:Fire()
<Start>c__Iterator77:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

 

Other odd things in log belong to kOS mod, I will provide link for full log as soon as I prepare other debug stuff for kOS team members.

EDIT:

Here is link for full log file.

Edited by kcs123
more stuff added

Share this post


Link to post
Share on other sites
6 hours ago, kcs123 said:

@Ziw, don't know if it is harmless or more serious issue. I was inspecting output log that I prepare to upload for kOS team for different issue and I noticed this in log:

  Reveal hidden contents

AssemblyLoader: Exception loading 'LaserDist': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

Additional information about this exception:

 System.TypeLoadException: Could not load type 'LaserDist.LaserDistModule' from assembly 'LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'LaserDist.LaserPQSUtil' from assembly 'LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null'.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Non platform assembly: E:\Kerbal Space Program\GameData\LightsOut\LightsOut.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\IRActiveStruts\Plugins\ActiveStruts.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\IRSequencer\Plugins\IRSequencer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\Parts\Rework_Utility\Plugins\IRSurfaceSampler.dll (this message is harmless)
AssemblyLoader: Exception loading 'IRSurfaceSampler': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

Additional information about this exception:

 System.TypeLoadException: Could not load type 'IRSurfaceSampler.ModuleIRSurfaceSampler' from assembly 'IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<waitForDeploy>d__0' from assembly 'IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null'.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\Plugins\InfernalRobotics.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\MagicSmokeIndustries\Plugins\Scale_Redist.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\Nereid\FinalFrontier\Plugins\FinalFrontier.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\PlanetShine\Plugins\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\PlanetShine\Plugins\PlanetShine.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\RCSBuildAid\Plugins\RCSBuildAid.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\RCSBuildAid\Plugins\RCSBuildAidToolbar.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\RealChute\Plugins\RealChute.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SCANsat\Plugins\SCANsat.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\scatterer\scatterer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SETIcontracts\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SETIprobeParts\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SETIrebalance\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\SmokeScreen\SmokeScreen.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TacFuelBalancer\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TacFuelBalancer\TacFuelBalancer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TextureReplacer\Plugins\TextureReplacer.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TriggerTech\KerbalAlarmClock\KerbalAlarmClock.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TriggerTech\KSPAlternateResourcePanel\KSPAlternateResourcePanel.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TriggerTech\TransferWindowPlanner\TransferWindowPlanner.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TweakScale\plugins\Scale.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\TweakScale\plugins\Scale_Redist.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\UnmannedBeforeManned\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\WaypointManager\WaypointManager.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\[x] Science!\MiniAVC.dll (this message is harmless)
Non platform assembly: E:\Kerbal Space Program\GameData\[x] Science!\[x] Science!.dll (this message is harmless)
VesselModules: Found VesselModule of type CommNetVessel with order 999

This part was raised my attention:

I have B9, IR and kOS mod that were in beta, maybe there is more strange interactions between other installed mods.
Except reported "issue" about graplers, reported earlier, I didn't noticed anything way too strange regarding IR.

EDIT:

More stuff regarding IR in log

  Reveal hidden contents


[ModuleManager] Post run call threw an exception in loading IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ModuleManager.MMPatchLoader+<ProcessPatch>d__46.MoveNext () [0x00000] in <filename unknown>:0
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[ModuleManager] Post run call threw an exception in loading LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ModuleManager.MMPatchLoader+<ProcessPatch>d__46.MoveNext () [0x00000] in <filename unknown>:0

--------------------- several houndered lines later in log:

ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ContractConfigurator.ContractConfigurator+<GetAllTypes>d__27`1[ContractConfigurator.ParameterFactory].MoveNext () [0x00000] in <filename unknown>:0
Rethrow as Exception: Error loading types from assembly IRSurfaceSampler, Version=1.0.1.5, Culture=neutral, PublicKeyToken=null

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
ContractConfigurator.LoggingUtil:LogException(Exception)
ContractConfigurator.<GetAllTypes>d__27`1:MoveNext()
System.Linq.<CreateWhereIterator>c__Iterator1D`1:MoveNext()
ContractConfigurator.ContractConfigurator:RegisterParameterFactories()
ContractConfigurator.ContractConfigurator:PSystemReady()
EventVoid:Fire()
<Start>c__Iterator77:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename:  Line: -1)

ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at ContractConfigurator.ContractConfigurator+<GetAllTypes>d__27`1[ContractConfigurator.ParameterFactory].MoveNext () [0x00000] in <filename unknown>:0
Rethrow as Exception: Error loading types from assembly LaserDist, Version=0.9.2.0, Culture=neutral, PublicKeyToken=null

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
ContractConfigurator.LoggingUtil:LogException(Exception)
ContractConfigurator.<GetAllTypes>d__27`1:MoveNext()
System.Linq.<CreateWhereIterator>c__Iterator1D`1:MoveNext()
ContractConfigurator.ContractConfigurator:RegisterParameterFactories()
ContractConfigurator.ContractConfigurator:PSystemReady()
EventVoid:Fire()
<Start>c__Iterator77:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

 

Other odd things in log belong to kOS mod, I will provide link for full log as soon as I prepare other debug stuff for kOS team members.

EDIT:

Here is link for full log file.

You need an updated version of IR Surface Sampler. You can grab it here: https://github.com/MagicSmokeIndustries/IR-Surface-Sampler/tree/master/GameData/MagicSmokeIndustries/Parts/Rework_Utility/Plugins

Share this post


Link to post
Share on other sites
17 minutes ago, Ziw said:

Thanks. That also mean IR_Rework_Repack_1.1.2. archive need to be updated too.
I picked up obsolete version from that package.

Here is "proper" order for IR packages to install. Please correct me if I'm wrong.
This is reminder for myself and also other user of IR mod.

  1. IR Legacy parts (if someone wants them)
  2. New IR_Rework package
  3. IR Sequencer
  4. Delete "AssetBundles" folder if there is any (Comes with sequencer and core pack)
  5. Install latest IR core pack (contains only plugin, no parts)
  6. Install latest version of IR Surface sampler in folder "..\GameData\MagicSmokeIndustries\Parts\Rework_Utility\Plugins"

Sorry, don't have time right now to put download links, will do it after confirmation and when grab some more free time.

Share this post


Link to post
Share on other sites

@Ziw 2.0.8 looks great! Working smooth as silk so far.

The only "issue" I have managed to find is with RKE Kanadarm parts. These are obviously old / obsolete. But while they work just fine. After a time warp the home / preset settings get barfed. Also any time you attempt to move any RKE / IR part after a warp, it will instantly move to a position about 90 degrees off where it started. Bouncing your contraptions around nearly snapping things. But after all the drama. Everything works fine until you time warp again and the whole thing starts again. I was wondering if you know of anyone that could help me blender rip and rebuild the RKE parts (I do understand though that this is totally a non issue as it doesn't relate to the current IR parts)

 

So besides all that, I give 2.0.8 a clean bill of health :)

 

edit

I may have found the issue in the RKE cfg's - stand by

 

Upon further inspection all IR parts seem to have this same behavior. Especially if you warp wile an arm is still moving. It totally borks the presets for some strange reason.

Also the setup GUI in the SPH / VAB you can click through multiple areas

like the preset setup window

The add group section

And the move part up/down buttons

Edited by V8jester

Share this post


Link to post
Share on other sites

IIRC, I reported clicktrough bug earlier (several weeks or even months ago) with exact described IR menu affected.
Not all of IR menus suffer from this, it is confirmed code oversight for this, but I can't give you exact link to post from top of my head is it in this thread or IR WIP part rework thread.

Share this post


Link to post
Share on other sites

Okay, IR 2.0.8, ModuleManager-2.7.4, fresh install with no other mods.

Log: https://drive.google.com/file/d/0B32vs_YxOWgjSDZaRHc0ZUVOMEU/view?usp=sharing

New game, create craft with IR parts attached, cheat into orbit around Kerbol past Eeloo, return to Space Center for 2-3 seconds, return to craft through tracking station. Is this kind of drift caused by a problem in the default game? I've seen Roverdude's USI Construction robotic parts drift like this using this same method.

Album of screenshots showing the drift:

http://imgur.com/a/qKlQh

Edited by frencrs

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.