sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

Guest
5 hours ago, Ziw said:

I could not find an easy solution so far, the config seems identical, but I'll keep looking. Try this dll version, it fixes one more issue with timewarp someone else found. Can you try the ordinary Hinge?

Tall hinge still look flipped - and it's all about how base half of hinge looks - it still rotates +-90 to the parent part, as it should.

Closed door hinge never had any problems ... except it's too big. Looks like my plans to ditch the TweakScale are ditched.

"Door hinge closed" - scaled to 50% size works as well.

I cannot remember, that in KSP 1.1.3 I had any problems with Tall Hinge appearance. Well, except for drift, dislocation of sub-parts and such...

Legacy part is unchanged for long time ...  parts themselves as models and configs worked in 1.1.3 - instead of falling on the side they formed fancy part clouds.

May be just putting a disclaimer and forgetting about it is an option?

 

Share this post


Link to post
Share on other sites
59 minutes ago, Neroziat said:

tried doing one side, like i said i put each of the 8 wheels initially one by one, now after removing a whole side its still binding as far as possible

Have you tried without that moving rail on left side ? Based on picture seems that this is also part of symetry from whole craft, hard to tell from that angle.
I was hoped that I will be able to create some example rover to share, so you and other users who have troubles can do reverse engineering and compare it to your own crafts. But, as always, real life issues steped in and ruined all plans for today. I hope I will be able to create something worthly to show in day or two, again depending how real life will treat me.

Share this post


Link to post
Share on other sites
1 hour ago, Greystripe3 said:

I cant seem to get the UI to show up to change the position of the actuators. Did 1.2 break this?

Blizzy or stock?

Share this post


Link to post
Share on other sites

Oh dear.... This great mod and such a mess! I read all from page 64 and it is so difficult to understand you people... Quick question though. I am playing ksp 1.2 (not 1.2.1 nor 1.2.2) Should I install Ir finalCore 2.0.10 and Legacy parts 2.0.0   Or is this intended for 1.2.2? I have currently installed IR 2.0.8 and legacy parts I don't know for sure but I guess an older version. The things is, I havent'e noticed yet horrible bugs for the little things  have used this mod. But I am afraid the driffting kraken breaks my rovers. Should I update these 2 mentioned at the begining? Also Why this is not being updated in the main 1st page? Is the developer working on updating this?

Edited by Agustin

Share this post


Link to post
Share on other sites
1 hour ago, Agustin said:

Oh dear.... This great mod and such a mess! I read all from page 64 and it is so difficult to understand you people... Quick question though. I am playing ksp 1.2 (not 1.2.1 nor 1.2.2) Should I install Ir finalCore 2.0.10 and Legacy parts 2.0.0   Or is this intended for 1.2.2? I have currently installed IR 2.0.8 and legacy parts I don't know for sure but I guess an older version. The things is, I havent'e noticed yet horrible bugs for the little things  have used this mod. But I am afraid the driffting kraken breaks my rovers. Should I update these 2 mentioned at the begining? Also Why this is not being updated in the main 1st page? Is the developer working on updating this?

Quick answer - it is not updated on first page because it still have some bugs. Latest provided core works with KSP 1.2.1. and KSP 1.2.2. There was some breaking changes between KSP 1.2.0. and 1.2.1. for many mods, so it is hard to say if it will work properly with 1.2.0. Even harder to expect developer support for obsolet KSP version, while work on latest is still unfinished.

If you expect stable version for longer career gameplay, you should be patient and wait for official update in OP when testing is done.

However, if you don't mind if your game progress become broken for whatever reason, then give this version a try, but I can only suggest with KSP 1.2.2.
Many mods are already properly updated by now and i twill minimize false bug reports for unsuported stock game version.

Share this post


Link to post
Share on other sites

is something wrong with the mk2 rotatron? it only has a mount point on the top and what seems like the rim on the bottom. im tring to find a more stable rotatron for a crane, but they are all slowly drifitng away in the angle they are attached.

 TUPqjCk.jpg

ho7Fmdx.jpg

Edited by Neroziat
added pic

Share this post


Link to post
Share on other sites

Updated to 1.2.2 and last updates on everything. Does Contract Configurator break this? I read there was an incompability and don't know if it was already fixed from here or from there...

Edited by Agustin

Share this post


Link to post
Share on other sites

I have a major problem, I either didn't install the mod correctly, or it's broken for me, I don't see a separate category for your parts, neither do I see a configuration button, I'm running KSP 1.2.2 Windows Steam version and I extracted MagicSmokeIndustries, and TweakScale into the GameData file, together with the Model Rework & Expansion, if you need more information I'm glad to help

Share this post


Link to post
Share on other sites

Hello

Any chance to get a clear summary of what is existing and usable in KSP 1.2 in MagicSmokeIndustries folder ?  Hinges, movatron, extendatron, pivotron,rails,...pistons, etc....where to find all these updated items?

Links to updated folder ? How must be distributed the magicsmoke industries folder If i want to use Legacy part and Rework core and rework expansion ?

Where to find all those subfolders ?

There's a lot of threads and it is not clear...

Thank's

 

Share this post


Link to post
Share on other sites
Guest
58 minutes ago, gilflo said:

Hello

Any chance to get a clear summary of what is existing and usable in KSP 1.2 in MagicSmokeIndustries folder ?  Hinges, movatron, extendatron, pivotron,rails,...pistons, etc....where to find all these updated items?

Links to updated folder ? How must be distributed the magicsmoke industries folder If i want to use Legacy part and Rework core and rework expansion ?

Where to find all those subfolders ?

There's a lot of threads and it is not clear...

Thank's

 

Look up post from Ziw in reverse order.

1). Classic (Legacy) parts - link in Ziw's signature.

2) Repack - too many parts to my taste, but everyone else likes it. - it this post.

3) IR itself - now it gets complicated. You have to reverse-browse this thread noting Ziw's posts. You need both full version and latest dll, if it was posted later. I cannot remember, what come out latter - latest pack or bugfix dll (there were many releases here - beta and (almost )release) since I downloaded either full pack or single DLL every time Ziw updated them.

Share this post


Link to post
Share on other sites
1 hour ago, gilflo said:

Hello

Any chance to get a clear summary of what is existing and usable in KSP 1.2 in MagicSmokeIndustries folder ?  Hinges, movatron, extendatron, pivotron,rails,...pistons, etc....where to find all these updated items?

Links to updated folder ? How must be distributed the magicsmoke industries folder If i want to use Legacy part and Rework core and rework expansion ?

Where to find all those subfolders ?

There's a lot of threads and it is not clear...

Thank's

 

Everything now is in my signature. You should always get the latest release from github, Legacy parts have some issues, but there is nothing I can do about ti for now.

As for other parts - Zodius's rework hasn't been updated for quite some time, but as @WildLynx pointed out there is a (more or less) working repack.

Share this post


Link to post
Share on other sites

 

I'm actually wondering, first if these question can still be answered, second, what parts did you use for the rotational part of the space station in the second video, and how did you get it that stable, if I try something like that, my station wobbles all over the place

Share this post


Link to post
Share on other sites
On 19/12/2016 at 8:00 PM, kcs123 said:

This imgur galery shows workaround for wheel autostruting.

Since a lot of people ask how to turn on visualisation of autostrut links I will put first screenshot from galery in this post too. On flight scene open cheat/debug menu with ALT+F12 on windows os or mod key if you are on linux or MAC.

xyatv59.jpg

 

I appologize for few more pictures from galery, but I feel that is necessary, despite provided link for full galery.
First thing to keep on mind, like mentioned earlier, is to put some non moving IR part as grandparent part, like on this picture:

jct26HG.jpg

However, as shown on picture, when you put wheels in symetry mod, wheels put autostrut to their symetry counterpart too. That create wierd things if you try to move powered hinges.

J6I3eN7.jpg

So, you need to place wheels on craft without symetry. First, I placed wheels in symetry mode. Then, I copied oposite symetry part with ALT + Click. Placed that part to hang in air in SPH editor. After that I placed only left side of wheels without symetry. Next step is to place that copied symetry counterpart without symetry on craft too.

After that, folding of wheels can be done properly:

vCDAQiW.jpg

 

Not tested, BUT I found THIS line in the setting cfg of the whole game:

 


AUTOSTRUT_SYMMETRY = True

MAYBE (it's BIG as a skyscrapers) editing it to "False" could help to the issue for folding rovers???
(In KSP 1.1.3 there was, for example, the "wheel collider fix" in the setting too, that almost ruined any wheel. I found that disabling it, for me, gives almost not any problem in my games, and also it was not accessible by setting menu, so I learned to "read and do experiment" with the whole game setting, to sometime find the right solution for me)

Edited by Araym

Share this post


Link to post
Share on other sites

Not sure if this is a known issue, or I got the wrong build, but for 1.2.2, neither stock or blizzy button show, no other signs for the control interface. 

Also, because of some of the other mods I am using, if the above could be of course addressed, I am looking for ultra fine control positioning to aim another mod's telescopes. Looking at a order of magnitude smaller than when I had this mod (IR) working, so I am thinking 1/10000 of a degree or better on hinge and same on rotatron. Suggestions?

Share this post


Link to post
Share on other sites
1 hour ago, CraftyDwarf said:

Not sure if this is a known issue, or I got the wrong build, but for 1.2.2, neither stock or blizzy button show, no other signs for the control interface. 

Also, because of some of the other mods I am using, if the above could be of course addressed, I am looking for ultra fine control positioning to aim another mod's telescopes. Looking at a order of magnitude smaller than when I had this mod (IR) working, so I am thinking 1/10000 of a degree or better on hinge and same on rotatron. Suggestions?

 
 

I had the same problem, refer to this post for the installation details:

On 23-12-2016 at 9:57 PM, WildLynx said:

Look up post from Ziw in reverse order.

1). Classic (Legacy) parts - link in Ziw's signature.

2) Repack - too many parts to my taste, but everyone else likes it. - it this post.

3) IR itself - now it gets complicated. You have to reverse-browse this thread noting Ziw's posts. You need both full version and latest dll, if it was posted later. I cannot remember, what come out latter - latest pack or bugfix dll (there were many releases here - beta and (almost )release) since I downloaded either full pack or single DLL every time Ziw updated them.

 
 

 

Share this post


Link to post
Share on other sites
16 hours ago, CraftyDwarf said:

Not sure if this is a known issue, or I got the wrong build, but for 1.2.2, neither stock or blizzy button show, no other signs for the control interface. 

Also, because of some of the other mods I am using, if the above could be of course addressed, I am looking for ultra fine control positioning to aim another mod's telescopes. Looking at a order of magnitude smaller than when I had this mod (IR) working, so I am thinking 1/10000 of a degree or better on hinge and same on rotatron. Suggestions?

Important info get buried quickly here. Check out this post from few pages back:

 

Share this post


Link to post
Share on other sites
14 hours ago, Denko666 said:

i suppose this is a bug?

Check few pages back. We were talking about wheel autostruting and how to workaround from that. Most probably you have similar issue.
Turn on autostrut visualisation to find out what is going on.

Share this post


Link to post
Share on other sites

I've studied this thread and tried everything but still the robot parts ain't working. they seem stuck in place but no autostrut weirdness seem to cause this. Is this an old bug? I can't find anything related to that. I'm using KSP 1.2.2, action groups extended, B9, Editor extensions, Infernal Robotics (IR-2.0.2, IR-LegacyParts, IRSequencer-1.0.2-Final, newest DLL, Rework_Repack_1.1.2) KAS, Kerbal Planetary Base Systems, KIS, KSPI Extended, Mech Jeb, Planet Shine, Toolbar and Tweakscale.

I'm very out of ideas what to try next

Here is the problem I'm facing with screenshots

Edited by DamianDrazhar

Share this post


Link to post
Share on other sites
38 minutes ago, DamianDrazhar said:

I've studied this thread and tried everything but still the robot parts ain't working. they seem stuck in place but no autostrut weirdness seem to cause this. Is this an old bug? I can't find anything related to that. I'm using KSP 1.2.2, action groups extended, B9, Editor extensions, Infernal Robotics (IR-2.0.2, IR-LegacyParts, IRSequencer-1.0.2-Final, newest DLL, Rework_Repack_1.1.2) KAS, Kerbal Planetary Base Systems, KIS, KSPI Extended, Mech Jeb, Planet Shine, Toolbar and Tweakscale.

I'm very out of ideas what to try next

Here is the problem I'm facing with screenshots

Because latest version is 2.0.10 and it is available in the first link in my signature.

17 hours ago, Denko666 said:

I found this odd occurance:

a folding wing with one flat pivotron works fine; a folding wing with 2 pivotrons messes stuf up: (anigif)

screenshot20

Using KSP 1.2.2

IR 2.0.9

Happens both with and without KJR 

Log: https://www.dropbox.com/s/d93xapq9wtolxgm/KSP.log?dl=0

i suppose this is a bug?

Same - try using 2.0.10

Share this post


Link to post
Share on other sites
10 minutes ago, Ziw said:

Same - try using 2.0.10

thank you so much for your quick response. I got the same results with 2.0.10 unfortunately. I'm still reading through this thread, maybe the solution lies here somewhere.

Share this post


Link to post
Share on other sites
1 hour ago, Ziw said:

Because latest version is 2.0.10 and it is available in the first link in my signature.

Same - try using 2.0.10

XCLLNT installed 2.0.10, turned off servo locks, disabled all autostruts and put rigid... Works like a charm!  THX! 

Share this post


Link to post
Share on other sites

DamianDrazhar, I was having the exact same issue after updating to 1.2.2 and IR 2.0.10.  I decided to start removing mods and nailed it on the first try: Kerbal Joint Reinforcement was the culprit.  It appears that this is a known issue with KJR acting upon IR parts, based on recent posts in the KJR thread.

Edited by DiabloRojo

Share this post


Link to post
Share on other sites
5 hours ago, DiabloRojo said:

DamianDrazhar, I was having the exact same issue after updating to 1.2.2 and IR 2.0.10.  I decided to start removing mods and nailed it on the first try: Kerbal Joint Reinforcement was the culprit.  It appears that this is a known issue with KJR acting upon IR parts, based on recent posts in the KJR thread.

you can probably remedy that by changing <bool name="multiPartAttachNodeReinforcement">1</bool>  in GameData/KerbalJointReinforcement/Plugin/PluginData/KerbalJointReinforcement/config.xml to <bool name="multiPartAttachNodeReinforcement">0</bool>

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.