sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

Guys, what could be easier than extracting a ZIP file contents properly?

The latest version is 2.0.10, it is available on github. To install you need to download the release ZIP, it contains a a folder named GameData. You should merge it with your existing <Your KSP Folder>/GameData folder.

Make sure you don't create a GameData subfolder inside your GameData. If you do - delete it and extract the zip file properly.

Your folder structure should be like this:

KSP
 -> GameData
	-> MagicSmokeIndustries
		-> Parts
		-> Plugins
		-> ... etc

DO NOT use 2.0.2, it is outdated.

DISABLE built-in auto-struts - the way to do it has been mentioned in this thread multiple times.

Either DON'T use KJR or learn how to make it compatible with IR (has been discussed a million times here).

Share this post


Link to post
Share on other sites
5 minutes ago, Ziw said:

Guys, what could be easier than extracting a ZIP file contents properly?

The latest version is 2.0.10, it is available on github. To install you need to download the release ZIP, it contains a a folder named GameData. You should merge it with your existing <Your KSP Folder>/GameData folder.

Make sure you don't create a GameData subfolder inside your GameData. If you do - delete it and extract the zip file properly.

Your folder structure should be like this:


KSP
 -> GameData
	-> MagicSmokeIndustries
		-> Parts
		-> Plugins
		-> ... etc

DO NOT use 2.0.2, it is outdated.

DISABLE built-in auto-struts - the way to do it has been mentioned in this thread multiple times.

Either DON'T use KJR or learn how to make it compatible with IR (has been discussed a million times here).

 

But the IR-2.0.10-Final-Core zip has no parts in it, so should I add the legacy parts over it?

Share this post


Link to post
Share on other sites
46 minutes ago, Sparky_Sct said:

But the IR-2.0.10-Final-Core zip has no parts in it, so should I add the legacy parts over it?

You can add legacy and/or reworked parts of course. Just make sure you keep the folder structure proper.

Share this post


Link to post
Share on other sites
3 minutes ago, Ziw said:

You can add legacy and/or reworked parts of course. Just make sure you keep the folder structure proper.

Aye, thanks bud got it working. Apart from there is a glitch that cause the hinges to move parts around.

Untitled.jpg?height=224&width=400

Share this post


Link to post
Share on other sites
2 hours ago, Ziw said:

Guys, what could be easier than extracting a ZIP file contents properly?

I don't know. But blaming people for following lackluster instructions certainly is! :wink:

We need the proper, up-to-date links clearly visible and advertised on the first post, or else this kind of thing is just bound to happen. There are 74 pages by now. 74. We are new to this mod, see the first post, download the "most recent version" according to that, and are puzzled why it won't work. We eventually figured out there's a 2.0.10 version out there, and got the core files of that - or did we? It certainly said so on the label, and yet, it still didn't work with the parts we got.

Unless the first post is updated each time, this soft of thing will continue to happen. You obviously know that things have to be mentioned multiple times in this thread already, because people are unable to find it once it's buried. And they don't even have the keywords to search for like we do now, thanks to you.

This mod is way too cool of a thing to be this hard to get into, and that's just because of an outdated first post, mind you.

Share this post


Link to post
Share on other sites
1 hour ago, Sparky_Sct said:

Aye, thanks bud got it working. Apart from there is a glitch that cause the hinges to move parts around.

Untitled.jpg?height=224&width=400

Kerbal Joint Reinforcement caused that to happen for me.  Removed it, and problems went away completely.

Share this post


Link to post
Share on other sites
2 hours ago, Ziw said:

Guys, what could be easier than extracting a ZIP file contents properly?

The latest version is 2.0.10, it is available on github. [ description of common install problems ]

[ description of IR specific issues ]

Well, obviously a lot of players are having problems with installing IR, as some of them are asking for help in this topic.  More are likely just giving up.  And yes, people should read the last 3 pages or more of a topic to get a feel for current issues.  But it doesn't help that the first post hasn't been updated and points to a specific version on Spacedock that isn't current (and Spacedock doesn't have any later versions).  KSP 1.2 has been out for 3 months now.  I understand it can be challenging to upgrade a mod when Squad has changed so much going from 1.1.3 to now 1.2.2.  But people look in the first post for details on installing a mod and any serious issues it is having.

Perhaps between yourself and @sirkut you can either get the first post and the topic title updated or start a new IR thread, with cautions on KSP 1.2 IR still being in prerelease.  That way people wanting to try IR won't depend on finding the download links in your signature and locating this recent post with details on installing IR.  Of course, it still have version specific links.

 

Share this post


Link to post
Share on other sites

@Jacke  is right, I propose the same. There are many 'continue'-mods/threads.
I for myself have removed IR for now, because KJR is more important to me.

Edited by PieBue

Share this post


Link to post
Share on other sites
7 minutes ago, Jacke said:

Well, obviously a lot of players are having problems with installing IR, as some of them are asking for help in this topic.  More are likely just giving up.  [...] But people look in the first post for details on installing a mod and any serious issues it is having.

msty.gif

There are many mods, but this mod in particular deserves more exposure and an easier introduction to interested newcomers. :)

Edited by BlackSun

Share this post


Link to post
Share on other sites

Hi guys, sorry if this has been requested already.

I am trying to make a rotating ring on a space station. The ring is quite large and heavy (a lot of hitchhiker cans), it is supposed to rotate using the rotary plates. I suppose this has been done before.

When just a few objects are attached to the rotating plate, no problem. But when it starts to get big, just a few parts try to rotate (the parts that attach from the central station towards the ring) but even before reaching the ring itself the parts dont seem to want to move. So inner parts try to move, the ring itself does not, causing rapidly the whole structure to break.

Is this a limit to the weight of the ring? Or the part count? Small rings to rotate without problem.
I was expecting it to rotate maybe slowly, or accelerate slowly due to the size of it, but here it completely breaks.

Thanks!

Share this post


Link to post
Share on other sites
20 hours ago, Wintersdark said:

Kerbal Joint Reinforcement caused that to happen for me.  Removed it, and problems went away completely.

Ah, I have that. Will try it out.

Share this post


Link to post
Share on other sites

I have some installation problems. I extracted 2.0.10 into GameData, but the robotic parts do not appear in the game (I have KSP 1.2.2). Here is my directory structure:

GameData/MagicSmokeIndustries/
├── AssetBundles
│   └── ir_ui_objects.bundle
├── blizzy_icon.png
├── Flags
│   └── InfernalRobotics.png
├── InfernalRobotics.version
├── IR_TweakScale.cfg
├── LICENSE.md
├── Parts
├── Plugins
│   ├── InfernalRobotics.dll
│   ├── PluginData
│   │   └── InfernalRobotics
│   └── Scale_Redist.dll
├── Sounds
│   └── infernalRoboticMotor.ogg
└── SupportedLicenses
    └── README-TweakScale.txt

I looked in the log, but I found no problems releated to IR. In fact, IR-related log messages constantly appear in the log.

Share this post


Link to post
Share on other sites
11 minutes ago, petersohn said:

I have some installation problems. I extracted 2.0.10 into GameData, but the robotic parts do not appear in the game (I have KSP 1.2.2). Here is my directory structure:


GameData/MagicSmokeIndustries/
├── AssetBundles
│   └── ir_ui_objects.bundle
├── blizzy_icon.png
├── Flags
│   └── InfernalRobotics.png
├── InfernalRobotics.version
├── IR_TweakScale.cfg
├── LICENSE.md
├── Parts
├── Plugins
│   ├── InfernalRobotics.dll
│   ├── PluginData
│   │   └── InfernalRobotics
│   └── Scale_Redist.dll
├── Sounds
│   └── infernalRoboticMotor.ogg
└── SupportedLicenses
    └── README-TweakScale.txt

I looked in the log, but I found no problems releated to IR. In fact, IR-related log messages constantly appear in the log.

You can find parts pack here:

 

and here

 

https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/download/2.0.0/IR-LegacyParts.zip

Share this post


Link to post
Share on other sites

Question: is it normal for IR parts to have weird symmetry?

Whenever I use symmetry in the SPH, the IR parts contradict the symmetries in the SPH. One hinge opens up, other opens down. This means that I have to place wings (that deploy) on the vessel separately and use the offset tool to align them. This isn't really "game breaking," just downright annoying.

Share this post


Link to post
Share on other sites
57 minutes ago, Astrofox said:

Question: is it normal for IR parts to have weird symmetry?

Whenever I use symmetry in the SPH, the IR parts contradict the symmetries in the SPH. One hinge opens up, other opens down. This means that I have to place wings (that deploy) on the vessel separately and use the offset tool to align them. This isn't really "game breaking," just downright annoying.

That's probably because "mirror" symmetry isn't really mirror symmetry. The position is mirrored, but the part itself is rotated 180 degrees, as can be seen obviously with parts like the Materials bay.

Share this post


Link to post
Share on other sites
16 hours ago, Astrofox said:

Question: is it normal for IR parts to have weird symmetry?

Whenever I use symmetry in the SPH, the IR parts contradict the symmetries in the SPH. One hinge opens up, other opens down. This means that I have to place wings (that deploy) on the vessel separately and use the offset tool to align them. This isn't really "game breaking," just downright annoying.

 

12 hours ago, Astrofox said:

Is there a way to fix that?

If you guys are using Rework parts. Then simply add a (-) in front of one of the moving components.

If you are using legacy. Use the same numbers left and right. In the SPH one wing will move backward. In flight it will move correctly

video with legacy docking washers in 1.0.5. In hanger one wing moves backwards in flight works like a charm.

 

Edited by V8jester

Share this post


Link to post
Share on other sites

Hello, my name is Vito.

I have had some problems with my Infernal robotics rework and expansion pack. For whatever reason, the parts, both new and old, aren't showing up in the editor. But here is the most confusing part, some have time to time. I have downloaded the mod and reinstalled it many times and this has not fixed the issue. The parts that have showed up are the Trusses, the Utilitrons And I think one of the rotatrons... I would really like this issue fixed.

<merged posts>

I have looked at the download file and all the parts are there, but they do not want to load for use in the editor. 

Thanks.

 

Edited by Val
Merged several semi duplicate posts

Share this post


Link to post
Share on other sites
8 hours ago, CGiuffre164 said:

Hello, my name is Vito.

(...)

You'll have to be more specific as for what version of the mods you are using, your installation folder details, or something because it has been discussed before how to install you just have to read the past last pages of this thread. The OP is outdated for now.

Share this post


Link to post
Share on other sites
17 hours ago, Agustin said:

You'll have to be more specific as for what version of the mods you are using, your installation folder details, or something because it has been discussed before how to install you just have to read the past last pages of this thread. The OP is outdated for now.

That's not what I mean. I have downloaded the v02 Pre Release Beta from this website, just some of the parts are not showing up in the editor. I am running on KSP 1.2.2 but I am not fussed on the outdated part of the mod. And when you say OP, what do you mean by that?

 

Share this post


Link to post
Share on other sites
2 minutes ago, CGiuffre164 said:

And when you say OP, what do you mean by that?

It means the first post on the thread :) 

Share this post


Link to post
Share on other sites
2 hours ago, CGiuffre164 said:

That's not what I mean. I have downloaded the v02 Pre Release Beta from this website, just some of the parts are not showing up in the editor. I am running on KSP 1.2.2 but I am not fussed on the outdated part of the mod. And when you say OP, what do you mean by that?

 

So what do you mean? I don't understand. You should have the 2.0.10 version of IR, and install legacy parts and/or rework package to have parts. In the last pages there are instructions to install this.

Edited by Agustin

Share this post


Link to post
Share on other sites

Hey, I have a problem with infernal robotics. 

 

When I use joints, they seem to attempt to move the parts connected to, and not themselves (In VAB, it works fine.) 

Is this on my side? Am I doing something wrong? 

 

 

Share this post


Link to post
Share on other sites

@Rainbowd4sh you have to set it to auto strut to root part of the part that is moving and the IR part that is making it move. Did that make sense...

Like this  

Wing + IR part + moving part......connect IR part as root to wing  and connect moving part to IR part as root as well....hope that make sense.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.