sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

Strengthen join question:

Debug-log:

[LOG 22:25:38.412] Unpacking Bill Kerman
[LOG 22:25:40.013] Unpacking kerbalEVA (Bill Kerman). Vel: (0.0, 0.0, 0.0)
[LOG 22:26:20.055] [SCANsat] Height Map Of [Kerbin] Completed...
[LOG 22:26:20.232] [SCANsat] All Height Maps Generated
[LOG 22:26:31.202] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:26:31.206] AttachOnCollision - Attaching to static : End09_Mesh
[LOG 22:26:31.207] JointToStatic(Base) Create kinematic rigidbody
[LOG 22:26:31.208] JointToStatic(Base) Create fixed joint on the kinematic rigidbody
[LOG 22:26:31.211] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:26:31.213] AttachOnCollision - Attaching to static : End09_Mesh
[LOG 22:26:31.213] JointToStatic(Base) Create kinematic rigidbody
[LOG 22:26:31.214] JointToStatic(Base) Create fixed joint on the kinematic rigidbody
[LOG 22:26:31.216] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:26:31.217] AttachOnCollision - Attaching to static : End09_Mesh
[LOG 22:26:31.217] JointToStatic(Base) Create kinematic rigidbody
[LOG 22:26:31.218] JointToStatic(Base) Create fixed joint on the kinematic rigidbody
[LOG 22:26:31.219] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:26:31.221] AttachOnCollision - Attaching to static : End09_Mesh
[LOG 22:26:31.221] JointToStatic(Base) Create kinematic rigidbody
[LOG 22:26:31.222] JointToStatic(Base) Create fixed joint on the kinematic rigidbody
[WRN 22:26:38.332] OnJointBreak(Core) A joint broken on Utilitron - Grasper !, force: 223.709
[LOG 22:26:38.352] OnSave(Core) Static joint detected, saving info...
[WRN 22:26:38.366] OnJointBreak(Core) A joint broken on Utilitron - Grasper !, force: 227.1754
[LOG 22:26:38.376] OnSave(Core) Static joint detected, saving info...
[WRN 22:26:38.392] WaitAndCheckJoint(Core) Static join broken !
[LOG 22:26:38.394] Detach(Base) Attach mode is Docked:False,Coupled:False,FixedJoint:False,StaticJoint:True
[LOG 22:26:38.396] Detach(Base) Attach type is : StaticJoint
[LOG 22:26:38.397] Detach(Base) Removing static rigidbody and fixed joint on Utilitron - Grasper
[WRN 22:26:38.405] WaitAndCheckJoint(Core) Static join broken !
[LOG 22:26:38.406] Detach(Base) Attach mode is Docked:False,Coupled:False,FixedJoint:False,StaticJoint:True
[LOG 22:26:38.407] Detach(Base) Attach type is : StaticJoint
[LOG 22:26:38.408] Detach(Base) Removing static rigidbody and fixed joint on Utilitron - Grasper
[LOG 22:26:38.597] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:26:38.599] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[WRN 22:26:38.600] OnJointBreak(Core) A joint broken on Utilitron - Grasper !, force: 218.6011
[LOG 22:26:38.609] OnSave(Core) Static joint detected, saving info...
[WRN 22:26:38.619] OnJointBreak(Core) A joint broken on Utilitron - Grasper !, force: 220.618
[LOG 22:26:38.627] OnSave(Core) Static joint detected, saving info...
[WRN 22:26:38.644] WaitAndCheckJoint(Core) Static join broken !
[LOG 22:26:38.645] Detach(Base) Attach mode is Docked:False,Coupled:False,FixedJoint:False,StaticJoint:True
[LOG 22:26:38.646] Detach(Base) Attach type is : StaticJoint
[LOG 22:26:38.646] Detach(Base) Removing static rigidbody and fixed joint on Utilitron - Grasper
[WRN 22:26:38.655] WaitAndCheckJoint(Core) Static join broken !
[LOG 22:26:38.655] Detach(Base) Attach mode is Docked:False,Coupled:False,FixedJoint:False,StaticJoint:True
[LOG 22:26:38.656] Detach(Base) Attach type is : StaticJoint
[LOG 22:26:38.657] Detach(Base) Removing static rigidbody and fixed joint on Utilitron - Grasper
[LOG 22:26:38.689] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:26:38.691] AttachOnCollision - Set collision mode back to Discrete on: IR.MechanicalGrasper (Part)
[LOG 22:27:38.119] [UIMasterController]: ShowUI
[LOG 22:27:38.121] Game Paused!

 

I have the Utilitron Grasper attached to an Extendatron Stackable.

I want the breakingforce of the joint between them to be higher then the detach-value from ground of 200.

That way the grasper wont break from the extendatron, but rather just detach from the ground instead.

 

I toyed abit in the .cfg file with partBreakForce and part by looking in the other files, but to no awail.

breakingForce = 999
breakingTorque = 999
 

Also tried different values in

    partBreakForce = 80                    // The force that needs to be applied on the grapple/part joint to break.
    staticBreakForce = 200                    // The force that needs to be applied on the grapple/static joint to break.
 

 

I'm novice to modding but i've done some coding/scripting in the past so i think i can figure out how to MM or silimar to suit my needs if someone can point me in the right direction.

 

Thanks in advance.

/Rikard

Share this post


Link to post
Share on other sites

I'm having troubles with the Hinges. When I go to the launch pad, the hinges are all wrong and all movement on it is broken.

VBA:

VBA Hinge

Launchpad:

Hinges on Launchpad
It's as if the bases rotate 90 degrees when going to the launchpad.

Edited by g0tchas76

Share this post


Link to post
Share on other sites

Hey is there anyone around willing to help me model rip / fix 3 parts from an old IR pack? Specifically RKE Kanadarm. Everything works except the 2 rotating parts and 1 structural part have issues with there model files rotating 90 degrees in flight / SPH but there function is unchanged.

 

Share this post


Link to post
Share on other sites
On 1/30/2017 at 11:34 PM, ThePhoenixSol said:

Can anyone help me with this? i got a custom tech tree node working, but yet i cant seem to get the parts to move into the node. i have done this with all the stock tree, and a couple mods up to this point. And I cant seem to find the issue with how im doing it to infernal robotics. 

my code:


//Made By MIke12222222222222 & ThePhoenixSol

//IR Node

@TechTree:NEEDS[MagicSmokeIndustries]
{
	@RDNode:HAS[#id[largeUnmanned]]
	{
		@id = IR
		@title = Infernal Robotics
		@description = Mechanics have been a thing for a while, so why not use them with rockets?.
		@cost = 20
		@hideEmpty = False
		@nodeName = node44_IR
		@anyToUnlock = False
		@icon = RDicon_robotics
		@pos = -1500,800,0
		@scale = 0.6
		!Parent,* {}
		Parent
		{
			parentID = science3
			lineFrom = TOP
			lineTo = BOTTOM
		}
}

// Parts

@PART[AdjustableRailScaleable|dockingwasher_stdScaleable|dockingwasher_freeScaleable|GantryLargeScaleable|GantryLargeScaleableVariant|IRHingeClosedScaleable2|IRHingeOpenScaleable|IRHingeTallScaleable|IRHingeTallNDScaleable|IRPistonScaleable|IR_RotatronScaleable|IR_Rotatronmk2Scaleable|IR_RotatronVTOLScaleable|TelescopeFullAScaleable]:NEEDS[MagicSmokeIndustries]:FINAL
{
	@TechRequired = IR
}

 

Is it possible anyone could help me with my previous post? I have posted both here and module manager forum, but as the issue is increasingly more IR related, I am putting hopes here. Any help would be extremely appreciated.

Share this post


Link to post
Share on other sites

hi, I have a weird contagious bug in time warp. Make something please! Many Kerbal lives depend on it! :o 

 

Share this post


Link to post
Share on other sites
10 hours ago, Vince_K said:

hi, I have a weird contagious bug in time warp. Make something please! Many Kerbal lives depend on it! :o 

....

 

Did you use any of these links?

 

Share this post


Link to post
Share on other sites
9 hours ago, V8jester said:

Did you use any of these links?

Yes. My install is ok and I don't use KJR. I play with this add on from the beginning. I don't understand why the rotatron reset is position and break the other after him. If someone have a idea, it would be nice, I have a 225 000$ launch in orbit waiting to land on my Mun base.   And sorry for my bad english....             

 

Ok...I have reinstall  all the thing...again....and again...and some ship work well and other craft are just a big bug...what???:mad:

Edited by Vince_K

Share this post


Link to post
Share on other sites

Fresh install,game folder check, new desing, new test...but...nope....the part bug when they are not return to zero   

 

Share this post


Link to post
Share on other sites
1 hour ago, Vince_K said:

Fresh install,game folder check, new desing, new test...but...nope....the part bug when they are not return to zero   

....

What are the versions you are using for everything? KSP and IR?

Share this post


Link to post
Share on other sites

KSP 1.2.2 and all the stuff you have post. Don't worry, I play this game since 2014 Maybe it's because I start my carrer in 1.2.1? But I have start a new save in 1.2.2 and it's still the same

Edited by Vince_K

Share this post


Link to post
Share on other sites

For what's it's worth, i can reproduce.

 

 

 

PaAXCFk.png

 

Move the arm. Timewarp some then goto 1x and let physics engage.

The hinges are rotated out of original place.

Any movement and it flips around n round.

 

/Rikard

Share this post


Link to post
Share on other sites

Dude this is making me really mad.  The tweakable bar for the limits on rotatrons and other hinges doesn't increase evenly, I can't get a perfect 90 it's either 89 or 91.  It's super annoying and it needs to be fixed, ideally in increments of 5 degrees.

Also, Rotatrons are placed radially with opposite directions of rotation even when placed with mirror symmetry.

Edited by SlabGizor117

Share this post


Link to post
Share on other sites
18 hours ago, SlabGizor117 said:

Dude this is making me really mad.  The tweakable bar for the limits on rotatrons and other hinges doesn't increase evenly, I can't get a perfect 90 it's either 89 or 91.  It's super annoying and it needs to be fixed, ideally in increments of 5 degrees.

Have you tried to enter exact desired value in the box instead using sliding bar ?

Edited by kcs123
typo found

Share this post


Link to post
Share on other sites
1 minute ago, kcs123 said:

Have you tried to enter exact desired vale in the box instead using sliding bar ?

Where??

EDIT:  Nevermind, found it.

Edited by SlabGizor117

Share this post


Link to post
Share on other sites
On ‎2‎/‎2‎/‎2017 at 4:19 PM, mrstoned said:

Hi all.

 

First, i'm running 1.2.2 and dont seem to have any other problems with IR (incl rework etc).

 

Got the following questions;

1; The Utilitron Grabber seems to have a really weak joint between the grabber and other part, see img

Trimmed

Hey I just played around with this today. Fire up Notepad++ and change these two lines for the Magnet / Grasper. I set them to 999 to make then almost unbreakable.

Magnet

name = KASModuleMagnet
breakForce = 999


Mechanical Grasper

name = KASModuleHarpoon
partBreakForce = 999
staticBreakForce = 999

 

 

And because I know it's coming....

For those having install / KJR issues

List of IR download files to work with KSP 1.2.2 courtesy of: @Agustin @V8jester

 

Steps to install Infernal Robotics

1) install Core Download which is the plugin and "core Files" of IR  (No parts are in this download)

2) Install Parts Pack (Legacy is the original parts, and Rework are the new white parts. You can have both installed if you wish)

3) Optional -  If you wish to use the Surface sampler (Install the Surfacesampler.dll into GameData/MagicSmokeIndustries/Parts/Rework_Utility/Plugins)

4) Optional  - If you are using KJR you will need to use the supplied DEV Version Linked below.

 

Core Download

Infernal Robotics (Ziw) 2.0.10 https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/download/2.0.10/IR-2.0.10-Final-Core.zip

 

Parts

Legacy Parts (Ziw) https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/download/2.0.0/IR-LegacyParts.zip

IR Rework Parts (Zodiusinfuser) https://mega.nz/#!rdlHkLAJ!ZizDvd8s7zCIG529FtO8b7wM0avJ8yC3pldIaf6BGFw

IR Surface Sampler dll (Ziw) https://github.com/MagicSmokeIndustries/IR-Surface-Sampler/tree/master/GameData/MagicSmokeIndustries/Parts/Rework_Utility/Plugins

 

Utility

Thread link for IR Sequencer (Ziw) http://forum.kerbalspaceprogram.com/index.php?/topic/104547-12-ir-sequencer-v101-add-on-to-infernal-robotics-updated-30102016/

 

Kerbal Joint Reinforcement - Fixed for IR

"Dev version - use at your own risk"

Dev version of KJR (Ferram4) Download the "Master File" https://github.com/ferram4/Kerbal-Joint-Reinforcement

 

Please feel free to repost / update this list every so often to help a lot of the new comers

Edited by V8jester

Share this post


Link to post
Share on other sites
54 minutes ago, V8jester said:

Hey I just played around with this today. Fire up Notepad++ and change these two lines for the Magnet / Grasper. I set them to 999 to make then almost unbreakable.

Magnet


name = KASModuleMagnet
breakForce = 999


Mechanical Grasper


name = KASModuleHarpoon
partBreakForce = 999
staticBreakForce = 999

 

Ohh, and now it the most evil-genious-mr.burns-kind-of-way-with-fingers-together

vo2sz.jpg

 

I'll just try and see if i can get a MM-patch working for this in order to keep the mods in original shape.

If i remember it's something like this:

// Find Magnetic Grabber in IR/Reworks
@PART[IR_MagneticGrabber]:NEEDS[MagicSmokeIndustries] {
	@MODULE[KASModuleMagnet] {		// This module will make the part acting like a magnet, collided part will be automatically attached
		@breakForce = 999			// Make it "better"
	}
}

// Find Mech Grasper in IR/Reworks
@PART[IR_MechanicalGrasper]:NEEDS[MagicSmokeIndustries] {
	@MODULE[KASModuleHarpoon] {		// This module will make the part acting like a harpoon
		@partBreakForce = 999					// The force that needs to be applied on the grapple/part joint to break.
		@staticBreakForce = 999					// The force that needs to be applied on the grapple/static joint to break.
	}
}

 

Then put that into file MyOwnConfig.cfg inside GameData/MyOwnConfig

It shouldnt need to be reat last? or should i pop in an AFTER someplace?

 

EDIT: Btw, can one hide the "info" in the magnetic grappler part info box? Possibly in the MM-patch?

Not so fun have it read 999 when watching it. Just cosmetics tho.

/Rikard

Edited by mrstoned

Share this post


Link to post
Share on other sites
17 minutes ago, Brainpop14 said:

I'm having a problem with the hinges. They work in the VAB but not out in the world.

Do you have KJR installed?

Are you using Autostruts?

Do you have Tweakscale installed? - What scale are the hinges?

Share this post


Link to post
Share on other sites

I got some trouble with MM-patching this;

I have: GameData/MrStoned/MrStoned.cfg with

// Find Magnetic Grabber in IR/Reworks
@PART[IR_MagneticGrabber]:NEEDS[MagicSmokeIndustries]:FINAL 
{
	@MODULE[KASModuleMagnet] 
	{		// This module will make the part acting like a magnet, collided part will be automatically attached
		@breakForce = 600			// Make it "better"
	}
}

// Find Mech Grasper in IR/Reworks
@PART[IR_MechanicalGrasper]:NEEDS[MagicSmokeIndustries]:FINAL 
{
	@MODULE[KASModuleHarpoon] 
	{		// This module will make the part acting like a harpoon
		@partBreakForce = 999					// The force that needs to be applied on the grapple/part joint to break.
		@staticBreakForce = 600					// The force that needs to be applied on the grapple/static joint to break.
	}
}

The games doesn't show updated figures in SPH. (They do show if i edit the mechgrasper & magnet files directly).

Log spits out:

[LOG 04:52:52.816] Config(@PART[IR_MagneticGrabber]:NEEDS[MagicSmokeIndustries]:FINAL) MrStoned/MrStoned/@PART[IR_MagneticGrabber]:NEEDS[MagicSmokeIndustries]:FINAL
[LOG 04:52:52.817] Config(@PART[IR_MechanicalGrasper]:NEEDS[MagicSmokeIndustries]:FINAL) MrStoned/MrStoned/@PART[IR_MechanicalGrasper]:NEEDS[MagicSmokeIndustries]:FINAL

 

I tried with % instead but no luck.

I'm sure it's something simple i missed but cant figure it out.

 

Any helpful tips is appreciated.

 

/Rikard

Share this post


Link to post
Share on other sites
20 hours ago, mrstoned said:

I got some trouble with MM-patching this;

....

Any helpful tips is appreciated.

Here is my patch for all IR / KAS parts that 1.2.2 affected.
 

//IR - KAS Strength Upgrade - V8Jester

//Infernal Robotics
@PART[IR_MagneticGrabber]
{
	
	@MODULE[KASModuleMagnet] 
	{
		@breakForce = 999
	}

}
@PART[IR_MechanicalGrasper]
{
	
	@MODULE[KASModuleMagnet] 
	{
		@partBreakForce = 999
		@staticBreakForce = 999	
	}

}
	
// KAS
@PART[KAS_Hook_Magnet]
{
	
	@MODULE[KASModuleMagnet] 
	{
		@partBreakForce = 999
	}
	
	@MODULE[KASModulePort]
	{
		@breakForce = 999
	}

}
	
@PART[KAS_Hook_Harpoon]
{
	
	@MODULE[KASModuleHarpoon] 
	{
		@partBreakForce = 999
		@staticBreakForce = 999
	}
	
	@MODULE[KASModulePort]
	{
		@breakForce = 999
	}

}
	
@PART[KAS_Hook_GrapplingHook]
{
	
	@MODULE[KASModuleHarpoon] 
	{
		@partBreakForce = 999
		@staticBreakForce = 999
	}
	
	@MODULE[KASModulePort]
	{
		@breakForce = 999
	}
	
}	
	
@PART[KAS_Hook_Anchor]
{
	
	@MODULE[KASModulePort]
	{
		@breakForce = 999
	}
	
}

 

Edited by V8jester

Share this post


Link to post
Share on other sites
4 hours ago, V8jester said:

Do you have KJR installed?

Are you using Autostruts?

Do you have Tweakscale installed? - What scale are the hinges?

I have the same problem, all is ok in VAB but hinge are not the same position in real.

No KJR, no Autostruts, i have tweakscale but no scale on hinges.

I will do capture.

Share this post


Link to post
Share on other sites
8 hours ago, monmien said:

I have the same problem, all is ok in VAB but hinge are not the same position in real.

No KJR, no Autostruts, i have tweakscale but no scale on hinges.

I will do capture.

Legacy parts have issues with mirror / movement direction. Fix is to either use Rewor Parts, or place one at a time.

Share this post


Link to post
Share on other sites

It doesnt works. Parts are fine, but there is no menu. Where i can find another mod with extending and turning parts?

Share this post


Link to post
Share on other sites
11 minutes ago, spec111 said:

It doesnt works. Parts are fine, but there is no menu. Where i can find another mod with extending and turning parts?

I'm about to use my psychic powers..... You didn't use versions 2.0.10 with all the fixes I posted on this very page did you?.....

 

Share this post


Link to post
Share on other sites

I've been playing KSP on and off (mostly off) for 3 years, I've been pretty heavy into it for the past 3 months and I've been expanding my mod use significantly. Installed this today and my brain pretty much exploded! This is fantastic, thank you. My Mac laptop is crying but I'm stoked to try out all this stuff. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.