sirkut

1.1.2 Magic Smoke Industries Infernal Robotics 2.0.2

Recommended Posts

 

1 hour ago, TheLionsBite said:

Hey, thanks @V8jester! So I actually figured it out before I checked back here, which still only made me feel slightly less noob LMAO!

Edit: I felt complete and total noob-ality when I realized my spider-bot was going to lose her feet the second weight settled on them. I don't know how to use the "MM-patch" you guys referred to so many times in this very thread. Perhaps one of you might link me to a handy tutorial or post one here? The utilitron grabbers are now the only thing stopping me from successful, uh... inversion testing. After that, nothing can stop me from infesting Tylo-- with spidey-lights! 

So copy what was posted. Paste it into a text editor. Then save the file. Rename the file whatever you want anywhere in GameData. Just change the file extention from .txt to .cfg.

Share this post


Link to post
Share on other sites
On 08/02/2017 at 4:44 PM, mrstoned said:

For what's it's worth, i can reproduce.

 

 

 

PaAXCFk.png

 

Move the arm. Timewarp some then goto 1x and let physics engage.

The hinges are rotated out of original place.

Any movement and it flips around n round.

 

/Rikard

did you find a solution for this?or the cause?

Share this post


Link to post
Share on other sites
9 hours ago, Vince_K said:

did you find a solution for this?or the cause?

No, cant find anything in logs, and i have no solution atm.

It doesnt always do this as well, and i havent observed it outside the runway, but then again, i havent played much lately. Mostly doind designs for when i get a new pc. 

I'm on on a 7y old laptop atm. KSP runs so-so on it.

 

/ikard

Share this post


Link to post
Share on other sites

Hey, I'm looking for a clarification on Legacy vs Rework parts. Is it recommended that we no longer use the legacy parts as they are not supported anymore? My only issue with this would be the legacy Adjustable Rail, which I have used in quite a few places and there seems to be no equivalent rework part. 

I recently had some legacy hinges attached to adjustable rails change position by 90 degrees during a flight, I got my contraption to Minmus only to find it was broken. 

Share this post


Link to post
Share on other sites
52 minutes ago, slackitude said:

Hey, I'm looking for a clarification on Legacy vs Rework parts. Is it recommended that we no longer use the legacy parts as they are not supported anymore? My only issue with this would be the legacy Adjustable Rail, which I have used in quite a few places and there seems to be no equivalent rework part. 

I recently had some legacy hinges attached to adjustable rails change position by 90 degrees during a flight, I got my contraption to Minmus only to find it was broken. 

The legacy parts are indeed nolonger being developed / maintained. As none of the current maintainers of IR have the original assets for those parts.

The rails have no equivalent currently. But @ZodiusInfuser is still kicking around and he has some in development. But he has a very demanding School / RL schedule as he works on real robots.

I would say the rails are safe to use (I use them quite heavily) but the hinges I would really start phasing them out. And in that statement I would also say. Try to use mainly rework as it has had the most care put into its creation and maintenance.

Share this post


Link to post
Share on other sites
On ‎2‎/‎13‎/‎2017 at 6:50 PM, starchitect said:

 

I can't find a link to the Dev version on this page you linked. All I see is the latest official release 3.3.1 which when installed definitely causes all the issues people are describing. 

I did manage to get the latest version by going to the Code page on the KJR Github and downloading the whole thing as a zip. Installing that fixed the issue. I would be willing to bet most of the people still having trouble made the same mistake. 

For those still having issues I suggest you try the same. 

Same here -  Looking high and low for a "DEV" version not to be found.    Hoping this correct my problem as well.  Thanks starchitect.  Nice to know that I won't I wasn't the only one not see the forest for the trees.

Share this post


Link to post
Share on other sites

Hello,

 

I got 3 qustions;

 

1-  the mod has TweakScale support but the premade sizes are not enough for me, how can I make them bigger? Or how can I edit which profile has what value?

2- How can I make the legacy parts work again? The new designs look great, clean and thematic but somehow the 3d models look fragile. The legacy parts on the other hand look stronger and more stiff so i would very like to be able to use them again.

3- Are there any other part packs around? I only know the original parts come with the mod.

 

This is a great mod. Too bad it's not giving me what I need right now, and this resulted me getting coldfeet towards the game... I really would like to get back to it.

Share this post


Link to post
Share on other sites
46 minutes ago, Smart Parts Wanter said:

Hello,

 

I got 3 qustions;

 

1-  the mod has TweakScale support but the premade sizes are not enough for me, how can I make them bigger? Or how can I edit which profile has what value?

2- How can I make the legacy parts work again? The new designs look great, clean and thematic but somehow the 3d models look fragile. The legacy parts on the other hand look stronger and more stiff so i would very like to be able to use them again.

3- Are there any other part packs around? I only know the original parts come with the mod.

 

This is a great mod. Too bad it's not giving me what I need right now, and this resulted me getting coldfeet towards the game... I really would like to get back to it.

1 - I can't tell you straight answer, have to inspect/search in config files for proper place and MM commands for that. You might have better chance to get proper answer in tweakscale thread. Sorry, can't help you more on that, maybe someone else can tell you better answer for this.

2 - There is need for original unity/mesh files for legacy parts. People who maintain this mod can't get those because original author of those parts is out of reach. Without it, noone can provide proper fix.

3. I don't know of any. Roverdude made some construction parts pack that is similar to IR parts, but much more simpler and with other goals in mind than IR provide. Maybe some other moder that is good with creating meshes and have some love for this mod can create more parts, but for now we can only hope for it.

 

Your main issue most probably can be solved by editing config files, to increase stiffnes and scale them larger or smaller to your preference. It is not too hard, but it has been a while since I messed with MM patches for my own personal purpose and I no longer recall exact commands from top of my head. But it is not too hard if you open some config file in text editor and compare few things between files for similar parts. Again, sorry, can't be more exact what is necessary on this.

Share this post


Link to post
Share on other sites
59 minutes ago, Smart Parts Wanter said:

Hello,

 

I got 3 qustions;

 

1-  the mod has TweakScale support but the premade sizes are not enough for me, how can I make them bigger? Or how can I edit which profile has what value?

2- How can I make the legacy parts work again? The new designs look great, clean and thematic but somehow the 3d models look fragile. The legacy parts on the other hand look stronger and more stiff so i would very like to be able to use them again.

3- Are there any other part packs around? I only know the original parts come with the mod.

 

This is a great mod. Too bad it's not giving me what I need right now, and this resulted me getting coldfeet towards the game... I really would like to get back to it.

(1) Open part cfg. Change "Scale = 1" larger or smaller to your needs.

(2) Not possible as all original models / asset files are not available to the current maintainer of IR.

(3) there are a few, I do not know of any currently that are not broken though.

 

If parts are too delicate. Try the Dev version (Master file) of KJR I have previously linked in this thread.

Edited by V8jester

Share this post


Link to post
Share on other sites

Followed V8jester post how to run it in 1.2.2. Works fine, until first reload of a ship, I had same issues since 0.23.

problem:

all glitches happen after save loading, leaving ship on launchpad and driving out of physics range and back does the same.

Robotic parts change orientation after loading:

radially(surface) attached hinges tend to reattach themselves facing same direction as part they are attached to. They rotate 90/270 degrees.

all robotic parts attached to node drift in random direction random distance, sometimes rotating too.

tested with legacy parts and buffalo rover grabber.

 

 

 

 

 

Share this post


Link to post
Share on other sites

Hi

I have IR part drift too, no specific direction, just randomly wandering off. Hangar mod had something similar with the grapple node on asteroid hatches ( I think it was because of the flexible joint nature of the grapple ).

KSP seems to dislike flexible joints. Maybe there is a way to "fix" or "strengthen" the nodes while they're not moving, to only make them flexible when there is an input to the servos?

Best regards

Share this post


Link to post
Share on other sites
Spoiler

832377BABC4435683496ADEDD7760DA621FE4077

66ADD665B637F4BDBB0E673BE4919C2D6E0EEFFC

When I try to use the robotics, they work fine in the hanger, but they get all gibbled when I launch. This example is only showing one part, but the pistons, rotaters, etc don't work either. 

The parts on either side of the robotic parts act like they are connected directly, so when I try to move the robotics it just breaks the parts connected to them

Edited by Halitsu
I noticed you could add pictures directly

Share this post


Link to post
Share on other sites
On 1/30/2017 at 11:34 PM, ThePhoenixSol said:

Can anyone help me with this? i got a custom tech tree node working, but yet i cant seem to get the parts to move into the node. i have done this with all the stock tree, and a couple mods up to this point. And I cant seem to find the issue with how im doing it to infernal robotics. 

my code:


//Made By MIke12222222222222 & ThePhoenixSol

//IR Node

@TechTree:NEEDS[MagicSmokeIndustries]
{
	@RDNode:HAS[#id[largeUnmanned]]
	{
		@id = IR
		@title = Infernal Robotics
		@description = Mechanics have been a thing for a while, so why not use them with rockets?.
		@cost = 20
		@hideEmpty = False
		@nodeName = node44_IR
		@anyToUnlock = False
		@icon = RDicon_robotics
		@pos = -1500,800,0
		@scale = 0.6
		!Parent,* {}
		Parent
		{
			parentID = science3
			lineFrom = TOP
			lineTo = BOTTOM
		}
}

// Parts

@PART[AdjustableRailScaleable|dockingwasher_stdScaleable|dockingwasher_freeScaleable|GantryLargeScaleable|GantryLargeScaleableVariant|IRHingeClosedScaleable2|IRHingeOpenScaleable|IRHingeTallScaleable|IRHingeTallNDScaleable|IRPistonScaleable|IR_RotatronScaleable|IR_Rotatronmk2Scaleable|IR_RotatronVTOLScaleable|TelescopeFullAScaleable]:NEEDS[MagicSmokeIndustries]:FINAL
{
	@TechRequired = IR
}

 

@sirkut Would you be able to help me with this? i would REALLY like to get your mod working with mine, but i cant for the life of me figure out whats wrong with what im doing.

Share this post


Link to post
Share on other sites
13 hours ago, Mikeloeven said:

Any idea when the 1.2.2 version is going to be added to the CKAN database

The important matter is when a working (1.2.2 or later compatible) version becomes available.

CKAN after.

Share this post


Link to post
Share on other sites
Guest
On 2/26/2017 at 4:40 PM, JadeOfMaar said:

The important matter is when a working (1.2.2 or later compatible) version becomes available.

CKAN after.

I missed something? IR works well for 1.2.2, except one legacy part (tall hinge) is flipped in flight scene while ok in editor.

Share this post


Link to post
Share on other sites
3 hours ago, WildLynx said:

I missed something? IR works well for 1.2.2, except one legacy part (tall hinge) is flipped in flight scene while ok in editor.

It is still in BETA stage and it is not officialy updated for 1.2.2. Fot those who are not afraid of manual installs from time to time it work properly except some minor still existing issues that were reported earlier.

Share this post


Link to post
Share on other sites

I suppose this is not working as intended. :confused:

jubvHAV.jpg

Edited by Hacki

Share this post


Link to post
Share on other sites

I got a question. I am looking for a part that can be moved by a magic smoke industry arm, and grab onto land/ships while going rather fast. The utilitron grasper seems to be perfect, but randomly detaches even if it just goes a few m/s. Anyone got any ideas? 

 

I do have KAS installed, but none of the parts seem to want to move with arms, or want to attack to land at fast speeds. 

Share this post


Link to post
Share on other sites
23 minutes ago, Hacki said:

I suppose this is not working as intended. :confused:

jubvHAV.jpg

IR parts never worked well with docking ports. It's been always suggested to avoid that interaction. However, sometimes, a F5/F9 cicle will do the trick.

Share this post


Link to post
Share on other sites
4 minutes ago, Nansuchao said:

IR parts never worked well with docking ports. It's been always suggested to avoid that interaction.

That's unfortunate. 

What other mods are there that would allow what i'm doing here? (connecting and disconnecting vessels for resource transfer) 
I know KAS, but i'd like to do it unmanned. 

 

4 minutes ago, Nansuchao said:

However, sometimes, a F5/F9 cicle will do the trick.

That did indeed work, thanks! 
 

If push comes to shove i can always edit the savefiles. 

 

 

Share this post


Link to post
Share on other sites

You will have better luck if you put some structural (non moving IR) part between IR part and dock port.

Share this post


Link to post
Share on other sites
15 hours ago, Rainbowd4sh said:

I got a question. I am looking for a part that can be moved by a magic smoke industry arm, and grab onto land/ships while going rather fast. The utilitron grasper seems to be perfect, but randomly detaches even if it just goes a few m/s. Anyone got any ideas? 

 

I do have KAS installed, but none of the parts seem to want to move with arms, or want to attack to land at fast speeds. 

If you use the MM-patch config posted a few pages back, the joints will be strengthend to almost indestructable.

EDIT: Post-link 

 

/Rikard

15 hours ago, Hacki said:

That's unfortunate. 

What other mods are there that would allow what i'm doing here? (connecting and disconnecting vessels for resource transfer) 
I know KAS, but i'd like to do it unmanned. 

 

 

 

 

The KAS 1.0 beta has the rigid and flexible links that can be operated unmanned by mouse-clicking.

It uses a special connector port that's included. JJ-1 port i think it's named.

The two links docks the vessels.

The tow-bar does not dock vessels.

/Rikard

23 minutes ago, kcs123 said:

You will have better luck if you put some structural (non moving IR) part between IR part and dock port.

I like to use the 1x1 structural plate on the end of any moving IR parts, and sometimes in the middle to be able to attach lights soo i see what i'm doing.

Build: IR-part>1x1 structural>OTHER (winch, dockport etc)

Edited by mrstoned

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.