RoverDude

[1.3] USI Life Support [0.5.0]

4436 posts in this topic

I liked the idea of Snacks! but didn't like that it affected reputation. RoverDude, you continue to make things that are exactly (or very close to) what I'm looking for, thanks sir!

Share this post


Link to post
Share on other sites

Love it. I tweaked the integration into the tech tree. 2.5m can went to Space exploration, and the 3.75 went to Advanced Space Exploration.

Edited by Ekareya

Share this post


Link to post
Share on other sites

Sounds interesting RoverDude. Will have to take a look.

Share this post


Link to post
Share on other sites
Any issues so far folks?

Rookie question: How do I go about activating the mod? I.e, I've installed the mod and can see the parts and the "life support status" screen, but it's blank -- no vessels show up. Kerbals aren't consuming food either. Is there a toggle/options/settings to make the mod active, and if so, where can I find it? (I had been using Blizzy's Toolbar which isn't working for me in 1.0, not sure how else to get to mod options.). Edit: this includes non-orange kerbals.

Thank you

Edited by TheBigOne
Clarity

Share this post


Link to post
Share on other sites
Rookie question: How do I go about activating the mod? I.e, I've installed the mod and can see the parts and the "life support status" screen, but it's blank -- no vessels show up. Kerbals aren't consuming food either. Is there a toggle/options/settings to make the mod active, and if so, where can I find it? (I had been using Blizzy's Toolbar which isn't working for me in 1.0, not sure how else to get to mod options.)

Thank you

Are you using Orange suited kerbals? They don't consume resources.

Share this post


Link to post
Share on other sites
Any issues so far folks?

Only issue I've seen is the one I posted about last night where USI-LS sets off the launch escape system on the Taurus HCV (similar to the conflict that EPL used to have).

Share this post


Link to post
Share on other sites
Any issues so far folks?

Kottabosgames did a spot light on this mod, and couldn't seem to get mulch to convert to organics, was he doing something wrong? because that's how I thought it worked too, I haven't gotten far enough in my career on 1.0 to make use of these parts yet, but I'd like to know for when I do.

Share this post


Link to post
Share on other sites
Orange suited Kerbals (Jeb, Bill, Bob, and Val) are immune to the ill effects of life support. They will still consume supplies if given, but do not leave the job, because they are just that awesome. This always gives a player (especially a new one) an 'out' to test out a manned mission before actually committing your other kerbals, etc. to a horrible fate of snack deprivation.

Anyway to make them like the other kerbals or do I have to just kill them? I don't want super kerbals.

Share this post


Link to post
Share on other sites
Are you using Orange suited kerbals? They don't consume resources.

They do consume resources, they just don't require resources.

Share this post


Link to post
Share on other sites
I have very evil idea about interaction with mod Connected Living Space if it's installed. Should be fully optional and maybe even disabled by default.

Thing is: to make kerbals use only supplies they can access directly or through connected living space or from parts attached to living space but not further.

This could and will impact crewed ship designs dramatically - no more "slap supply container anywhere and be set" as parts accessibility should be considered or whole expedition may die from starvation while having full yearly supply next door inaccessible due to poor engineering.

I would like to second this motion!

Share this post


Link to post
Share on other sites
Rookie question: How do I go about activating the mod? I.e, I've installed the mod and can see the parts and the "life support status" screen, but it's blank -- no vessels show up. Kerbals aren't consuming food either. Is there a toggle/options/settings to make the mod active, and if so, where can I find it? (I had been using Blizzy's Toolbar which isn't working for me in 1.0, not sure how else to get to mod options.). Edit: this includes non-orange kerbals.

Thank you

Silly question. What version of KSP?

Only issue I've seen is the one I posted about last night where USI-LS sets off the launch escape system on the Taurus HCV (similar to the conflict that EPL used to have).

I have an idea on that, may need to fiddle with something.

Anyway to make them like the other kerbals or do I have to just kill them? I don't want super kerbals.

Not at this time.

Share this post


Link to post
Share on other sites
Silly question. What version of KSP?

1.0, clean install, installing USI-LS for first time. I feel like I'm missing something very obvious here.

Edited by TheBigOne

Share this post


Link to post
Share on other sites
Kottabosgames did a spot light on this mod, and couldn't seem to get mulch to convert to organics, was he doing something wrong? because that's how I thought it worked too, I haven't gotten far enough in my career on 1.0 to make use of these parts yet, but I'd like to know for when I do.

Would need some context, since there are no built in converters other than the ones that come with MKS

Share this post


Link to post
Share on other sites
Would need some context, since there are no built in converters other than the ones that come with MKS

He was using a pioneer module and an inflatable storage module. attached to a cupola with a supply canister.

Share this post


Link to post
Share on other sites
They do consume resources, they just don't require resources.

Derp :(

Share this post


Link to post
Share on other sites
Silly question. What version of KSP?

I'm also having the issue with a blank life support status window.

KSP version 1.0.0.830 from Steam. Also modded with Engineer 1.0.16.3.

Currently have a gray suit kerbal in orbit, but still nothing in the window.

Edit: They also don't seem to eat any supplies offered.

Edited by Granite

Share this post


Link to post
Share on other sites
He was using a pioneer module and an inflatable storage module. attached to a cupola with a supply canister.

saw the video.. it was working. The pioneer module goes straight from mulch to supplies.

Share this post


Link to post
Share on other sites

I think I did something wrong in installation - I can't see the parts at all. MKS/OKS works fine, though. Did I need to do anything other than drop the "LifeSupport" folder into /GameData/UmbraSpaceIndustries?

Share this post


Link to post
Share on other sites

Will orange suits be susceptible to death if the death option is activated?

Share this post


Link to post
Share on other sites
Any issues so far folks?

No problems yet, but I do have a few questions:

1) The OP says "The old C3 (now renamed to the Pioneer Module) will have a basic mulcher and greenhouse and can do recycling at 50% efficiency for up to four Kerbals," whereas the Pioneer Module's in-game description mentions "a modest greenhouse (25% efficiency) that can help replenish the initial supplies of your expedition." Which is correct, 50% or 25%?

2) What are the actual supply consumption and mulch production rates per Kerbal? E.g., 0.0001 units/second? 0.00005?

3) I noticed that the Pioneer module does not have any mulch storage. Is mulch storage unnecessary for the mulcher to function properly?

4) You mentioned that the Mk-IV modules will have different efficiencies for surface vs off-world. How is this accomplished, in regard to config code for the ModuleResourceConverter?

Share this post


Link to post
Share on other sites
I'm also having the issue with a blank life support status window.

KSP version 1.0.0.830 from Steam. Also modded with Engineer 1.0.16.3.

Currently have a gray suit kerbal in orbit, but still nothing in the window.

Edit: They also don't seem to eat any supplies offered.

I'm having the exact same issue on Mac OS. With a clean install of KSP, the only mod I have running is USI-LS. The life support window is blank in both sandbox and career modes. I've tried both orange and grey suits. No resources are being used.

Furthermore, with a simple command pod in orbit, no resources whatsoever are consumed. Electricity remains constant, as do supplies. Even when orbiting around the dark side of keratin, no electricity is consumed or lost.

Share this post


Link to post
Share on other sites

I'm looking at the cfg file, and I see a "CauseDeath" flag - but is there any way to make this apply to the Legendary Kerbals as well?

Also, am I reading it right that Kerbals can last indefinitely on EVA? Any way to change that?

Share this post


Link to post
Share on other sites
I'm also having the issue with a blank life support status window.

KSP version 1.0.0.830 from Steam. Also modded with Engineer 1.0.16.3.

Currently have a gray suit kerbal in orbit, but still nothing in the window.

Edit: They also don't seem to eat any supplies offered.

I also have this problem. I have the parts, but nothing shows up on the window ( with the little green cube). I shot a kerbal into orbit just to see the mechanic and he has been there for 50 days now and nothing. He is a regular gray suit. I have KSP 1.0 with only KER and this installed. does it only work in career mode?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now