RoverDude

[1.8.x] USI Life Support [0.5.0]

Recommended Posts

On 3/4/2020 at 2:03 PM, pmborg said:

Hello @RoverDude

"The way to get rid of it is", yes there are probably, several ways to do that, but these ideas applies to Kerbin and to Kerbals, I was not referring neither of those things.

 

I think that I was not very efficient explaining the contextualization of the scenario:

"for those that born in Orbit and that can happen with civilian-population" what I mean with this is, was the following, imagine for those that Born for example in orbit of the Saturn don't needed to be orbit of Kerbin.

Here we are talking about Civilians (from civilian-population) and not Kerbals, they never have put a feet on Kerbin and probably they will never visit Kerbin, why should they miss Kerbin?

What I was proposing was a better application of the Rules for these cases.

 

What do you think?

BR,

PB

 

Ahh.. yeah, nothing like that exists in the mod to support that at this time.  The only home world is Kerbin (or whatever the home world is defined by the planet pack).

On 3/10/2020 at 11:44 PM, dlrk said:

It opens the settings menu

If you want to see LS stats for a vessel open the green icon up in the VAB.

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, RoverDude said:

Ahh.. yeah, nothing like that exists in the mod to support that at this time. 

Can be! It's possible for example, just handle them as 5 stars astronauts and :) that's it... maybe one line one "if"

Maybe one day you will try C.P. and almost for sure you will be impressed with what you are missing :)

The life with these mods and C.P. can be just perfect:

T7g0TQH.png

Edited by pmborg

Share this post


Link to post
Share on other sites
4 minutes ago, pmborg said:

Can be! It's possible for example, just handle them as 5 stars astronauts and :) that's it... maybe one line one "if"

Maybe one day you will try C.P. and almost for sure you will be impressed with what you are missing

It's a lot more than one line - the hard part is likely tracking who was born off-world.

Share this post


Link to post
Share on other sites
Posted (edited)
34 minutes ago, DStaal said:

It's a lot more than one line - the hard part is likely tracking who was born off-world.

They are a different type:

        KERBAL
        {
            name = Pedro Kerman
            gender = Male
            type = Crew
            trait = Pilot

        KERBAL
        {
            name = Zelner Kerman
            gender = Female
            type = Applicant
            trait = Civilian

 

In pseudo code I was imagine, just this:

Actuall USI Code:

if ( "Kerbal" has "5 stars" ) {

// So no homesickness from Kerbin(HomeWorld)

}

 

Updated to USI Code:

if ( "Kerbal" has "5 stars" ||  ( "Kerbal".type == Applicant ) ) {

// So no homesickness from Kerbin(HomeWorld)

}

 

Edited by pmborg

Share this post


Link to post
Share on other sites

Sorry, would not do any hard coding for external mod support.  So it's a bit more involved and in any case would likely have to be done as a hook for other mods to use.  Also, I would argue if one were a colonist that were born on Duna, that would be your home world.  Not every colonist should magically be non-homesick even when sent to another planet.  Home is still home ;)

Share this post


Link to post
Share on other sites
Posted (edited)

I'm having issues with usi where it will say that my kerbals cannot eva because my astronaut complex is not upgraded however it is a science mode save so my astronaut complex is max level. Also, i tried lowering all of the life support settings to the minimum and switching back to the flight and it still wont work. Also, I can't create manuever nodes so my vessel is essentially stuck currently and my game is not playable.

EDIT: Also, sometimes if I reload the game and load into the save it will let me eva but, if i go to the ksc and go back from the tracking center (have to do to time warp), I can no longer eva again.

Edited by ski23

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: Figured it out, but I'll leave this post in case it helps someone else. Once you get your vessel on the pad, you have to right-click the recyclers and the hitchhiker and activate them to get their bonus effects.

Hope I'm not missing something obvious, but I'm having an issue with supplies and habitation not matching between the VAB and the actual vessel at launch. I'm using JNSQ which makes the days 12 hours long, but that doesn't seem to be the problem, because the numbers aren't off by a factor of 2.

Spoiler

 

72m2Vg2.jpg

S0V9vM3.png

 

 

Edited by Kwebib

Share this post


Link to post
Share on other sites
On 3/29/2020 at 1:27 PM, ski23 said:

I'm having issues with usi where it will say that my kerbals cannot eva because my astronaut complex is not upgraded however it is a science mode save so my astronaut complex is max level. Also, i tried lowering all of the life support settings to the minimum and switching back to the flight and it still wont work. Also, I can't create manuever nodes so my vessel is essentially stuck currently and my game is not playable.

EDIT: Also, sometimes if I reload the game and load into the save it will let me eva but, if i go to the ksc and go back from the tracking center (have to do to time warp), I can no longer eva again.

Ski23 welcome to the forums.  More information would be very useful.  You have given about the equivalent of calling your mechanic and saying, my car is broken.  Versions, logs might help.  Also any reason why you think this is a USILS  issue would help.  I have never seen this mod do anything with the complexes in KSP to begin with so I'm having  a tough time understanding how this mod is at fault without some details.

Share this post


Link to post
Share on other sites
Posted (edited)
18 hours ago, goldenpsp said:

Ski23 welcome to the forums.  More information would be very useful.  You have given about the equivalent of calling your mechanic and saying, my car is broken.  Versions, logs might help.  Also any reason why you think this is a USILS  issue would help.  I have never seen this mod do anything with the complexes in KSP to begin with so I'm having  a tough time understanding how this mod is at fault without some details.

The information I have is that this bug is inconsistent. Sometimes it will occur and I can't narrow down how to reproduce it. Also, when it occurs, if I relaunch my game, after about 20 tries or so it works temporarily until I go to the space center and back to the ship and it is broken again. I combed through the save files to try to look for anything that would lock my kerbals inside but I couldn't find anything. Also, usi is the only mod I have equipped that can effect kerbals not being able to leave the command pods. All my other mods are parts packs or visual mods. There doesn't seem to be any useful information in the ksp log file either.

Edited by ski23

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, ski23 said:

The information I have is that this bug is inconsistent. Sometimes it will occur and I can't narrow down how to reproduce it. Also, when it occurs, if I relaunch my game, after about 20 tries or so it works temporarily until I go to the space center and back to the ship and it is broken again. I combed through the save files to try to look for anything that would lock my kerbals inside but I couldn't find anything. Also, usi is the only mod I have equipped that can effect kerbals not being able to leave the command pods. All my other mods are parts packs or visual mods. There doesn't seem to be any useful information in the ksp log file either.

You didn't follow @goldenpsp's advice.  Post a link to a log file for a game session that exhibits the problem (i.e. immediately quit the game and save the log file to a file sharing service such as Dropbox or similar).  Which KSP and mod versions do you have installed?  Please read this post about how you can support your problem report (the same link as the one in my sig block) and find the log file requested.  It's difficult to help without some information on your install and game performance.  If you're as new to the game as you are to the forums, you'll find that mod interactions can be tricky to diagnose and having the actual game data is often crucial to understanding what has happened.

Edited by Brigadier
Clarity

Share this post


Link to post
Share on other sites
53 minutes ago, Brigadier said:

You didn't follow @goldenpsp's advice.  Post a link to a log file for a game session that exhibits the problem (i.e. immediately quit the game and save the log file to a file sharing service such as Dropbox or similar).  Which KSP and mod versions do you have installed?  Please read this post about how you can support your problem report (the same link as the one in my sig block) and find the log file requested.  It's difficult to help without some information on your install and game performance.  If you're as new to the game as you are to the forums, you'll find that mod interactions can be tricky to diagnose and having the actual game data is often crucial to understanding what has happened.

I'm not new to the game or the forums but just my first time posting. I'm very familiar with logs and information. I write code for a living. This is why I looked into the logs myself and saw that there was no relavant information. Regardless, here are the logs:

https://www.mediafire.com/file/duaqd6tw1grvqow/KSP.log/file

 

Share this post


Link to post
Share on other sites
33 minutes ago, ski23 said:

I'm not new to the game or the forums but just my first time posting. I'm very familiar with logs and information. I write code for a living. This is why I looked into the logs myself and saw that there was no relavant information. Regardless, here are the logs:

https://www.mediafire.com/file/duaqd6tw1grvqow/KSP.log/file

 

That's great.  You could also comb through the USI code as it is on github.

However on the forums you still have provided next to nothing to help anyone help you with this.  Have you tried removing USI LS and testing to see if the problem goes away?

 

I do with you the best of luck.  Maybe if you find the source of the bug you can provide @RoverDude a PR to fix it.

Share this post


Link to post
Share on other sites
3 minutes ago, goldenpsp said:

That's great.  You could also comb through the USI code as it is on github.

However on the forums you still have provided next to nothing to help anyone help you with this.  Have you tried removing USI LS and testing to see if the problem goes away?

 

I do with you the best of luck.  Maybe if you find the source of the bug you can provide @RoverDude a PR to fix it.

I provided the logs that you asked for. Do you have any other specific information you'd like. I've given you 100% of the information available to me

Share this post


Link to post
Share on other sites

Just to make sure I understand the recycler math correctly, the most powerful recycler determines the percentage, and adding additional recyclers adds crew capacity at that capacity? And a recyclepercent of 0.5 is a 50% reduction in usage?

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, dlrk said:

Just to make sure I understand the recycler math correctly, the most powerful recycler determines the percentage, and adding additional recyclers adds crew capacity at that capacity? And a recyclepercent of 0.5 is a 50% reduction in usage?

As much as I understood from the Wiki (https://github.com/UmbraSpaceIndustries/USI-LS/wiki/Recycler-Math) it is almost right.

The most powerful recycler determines the maximum percentage (for example, 79%), and covers as many Kerbals as it can. Additional weaker recyclers cover more Kerbals at their own capacity (for example 50%).

Once you have covered all the Kerbals, then adding even more recyclers (even the weakest ones) keep increasing the recycling ratio up to the ratio of the most powerful recycler. By adding more weaker recyclers, you will at some point achieve the maximum ratio for the whole crew.

 

As for the 0.5 being 50%, I believe that you are right here.

Edited by Kazkar
Add more words to clarify the thought.

Share this post


Link to post
Share on other sites

I'm not sure if this a display bug or I'm misunderstanding the format, but

 

		BaseKerbalMonths = 1
		CrewCapacity = 4
		BaseHabMultiplier = 0

is displayed as 5 kerbal months/crew affect 4 in the editor.

Share this post


Link to post
Share on other sites
On 4/1/2020 at 4:23 PM, ski23 said:

 Also, usi is the only mod I have equipped that can effect kerbals not being able to leave the command pods. All my other mods are parts packs or visual mods.

To the best of my understanding, the only way USI-LS can prevent a Kerbal from EVA is if it makes them a tourist and then the game prevents the tourist Kerbal from eva.

As this relies on the game mechanic for tourist EVAs, the only way I can see this happening is if you have no life support grace period(default is 2 weeks), and not enough recycling/supply generation for the number of kerbals you have on board, causing them to rapidly transition back and forth between active and inactive crew.  If this is the scenario you are encountering, I would recommend setting the LS grace period to a minimum of 1 day to prevent this issue.

If your grace period is already 1 day or longer and you have ample supplies and recycling, I would suggest copying your save into a fresh install with only USI-LS and see if you can still replicate the issue.  If you can then it would be reasonable to post the save game file and a description on how to reliably reproduce the bug(if possible) in a bug report on the USI-LS github.

 

Admittedly, I have not looked at the code and generally only use the 'become tourists when out of LS' difficulty, so there may be other no-eva mechanics that I am not aware of.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

I just noticed in my save that EC Ticks down for unfocused ships regardless of solar panels.  Is this normal?

EC eventually expires unless i fly the ship to update the Timer.  Seems that USI LS does not Track EC.

 

edit:  It doesn't seem to cause any problem, i think having the timer static and not dynamic probably helps with load.  As long as the 'game' knows their is EC for other functions im not worried.

Edited by Jayad

Share this post


Link to post
Share on other sites

Can you run this mod with it doing nothing? It holds a lot of the reconfiguration code for MKS.

Share this post


Link to post
Share on other sites
Posted (edited)
49 minutes ago, MoonstreamInSpace said:

Can you run this mod with it doing nothing? It holds a lot of the reconfiguration code for MKS.

USI-LS is stand alone.  MKS makes use of it.  It's why I made sure to include a set of Life Support parts along with it (and modify a few stock ones).

Edited by RoverDude

Share this post


Link to post
Share on other sites

Can i use some of your code for my life support mod?i am realy struggling to code a life suopport

Share this post


Link to post
Share on other sites
45 minutes ago, cukkoo said:

Can i use some of your code for my life support mod?i am realy struggling to code a life suopport

Code's all under a permissive license - but what exactly are you struggling with?

Share this post


Link to post
Share on other sites

The life support configuration UI isn't showing up for me. When I'm in the space center view and I click the life support button, it shows me a blank window.

Share this post


Link to post
Share on other sites
1 hour ago, MoonstreamInSpace said:

The life support configuration UI isn't showing up for me. When I'm in the space center view and I click the life support button, it shows me a blank window.

Nevermind, it fixed itself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.