• 0
Guest

Launcher, Patcher not working and stays at "Checking for updates"

Question

Guest

When I launched the launcher, it said "Checking for Updates..."

After waiting for a whole 10 minutes, it still doesn't work.

Anyone help?

Edited by Goliath

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

You can get the fill zip from your store account downloads page, it's the most reliable method at this time, just copy your existing saves folder over :)

Share this post


Link to post
Share on other sites
  • 0
You can get the fill zip from your store account downloads page, it's the most reliable method at this time, just copy your existing saves folder over :)

Yeah i thought of that. anyway thx

Share this post


Link to post
Share on other sites
  • 0

There's problems with the Squad server that handles requests from the patcher, which is the part of the launcher that's failing for you.

There is no fix yet, we all have to wait for Squad to finish celebrating the 1.0 release, but until then the store still works.

Also the KSP.exe works directly, you don't need the launcher at all.

Sorry but your store download is your only option at this time unless you have KSP on Steam or GOG.

Share this post


Link to post
Share on other sites
  • 0

Okay this is what I've found so far...

The store version no longer downloads the patcher, it pulls down a html file that just opens the Squad website so store customers can download the 1.0.2 installer (it's a bit smaller) or full zip from their account page.

Only the Windows patcher is still available from the Wiki, the OS X and Linux links redirect to the Squad store, I can't test the Windows patcher to see if it still works. The Windows patcher fails, see REGZZZ post below.

The patcher is only useful to players who have bought KSP from the store, as it needs your store login and it checks for a valid store account.

Steam is providing 1.0.2, and can update any prior version, you don't get a patcher with this version.

GoG is providing 1.0.2 as an installer, and is also providing a 1.0.2 patch for the 1.0.0 that was originally on GoG (GoG never saw 1.0.1).

Amazon still has 1.0.0, I have no way to verify this myself, and I do not have knowledge of how Amazon handles patches, so if anyone has bought PC games from Amazon that have patches on Amazon, please let us know how to find them.

According to Squad, Amazon does have 1.0.2

Hi, sal_vager

The amazon installer has been recently updated to 1.0.2 , download this installer and install over your current copy.

Best regards,

KSP support

But shiny_metal and Arfloot tell me that Amazon still has 1.0.0

Edit:

I will ask about getting the 1.0.2 patch added to the store support page so everyone can access it.

Edited by sal_vager

Share this post


Link to post
Share on other sites
  • 0

nop... Just tried the windows patcher and I get :

Authentication

Getting login token...

Unable to authenticate with the server: Received malformed data from the server: File not found.

Share this post


Link to post
Share on other sites
  • 0
or you could ask about the problem status itself...

Nope, I've had enough patcher nonsense to last me to KSP 2.0, I'd rather push for an actual patch.

Share this post


Link to post
Share on other sites
  • 0

Arfloot, I can understand your irritation at not being able to update 1.0.0 to 1.0.2 via Amazon.com at this present time.

However, your first recourse with any purchase is with the retailer, and it is up to them to resolve your issue.

If you had bought KSP via Steam or GoG, you would also have to contact them.

We cannot even help with Squad store purchases here, these are just the forums and we have no access to the store, all we can do is contact Squad on the behalf of members who have made store purchases.

Amazon.com may have the updated version already, but have not reflected that on their customer download page, if that is the case there is nothing Squad can do, and again you will have to raise the matter with the retailer.

According to Squad, Amazon.com does have 1.0.2

Hi, sal_vager

The amazon installer has been recently updated to 1.0.2 , download this installer and install over your current copy.

Best regards,

KSP support

But they don't have it up on Amazon to download, see below.

Edited by sal_vager

Share this post


Link to post
Share on other sites
  • 0

Hi again Arfloot, I'm glad you managed to resolve this, unfortunately you have missed the 25% sale on KSP at GoG.com, Steam, Green Man Gaming or the Squad store, but there will be another I'm sure, the usual discount is 40% off.

Until then there is the demo, as of course you won't by retaining the copies of KSP you have already downloaded :)

Share this post


Link to post
Share on other sites
  • 0

sal_vager, thanks for all your help. You seem like a great member of the community! I've been following this thread for a few days, and figured I would weigh in now. I also purchased from Amazon.com and can't update to 1.0.2, either. I'm not sure what Arfloot's resolution to all this was, but I hope he didn't end up buying the game again. It is not an unreasonable expectation to update a game through the developer -- It's actually quite common.

The Amazon installer is not updated to 1.0.2 as of 9 p.m. Mountain Time 5/11. Fingers crossed that it works soon.

I sent an email to KSP support and was told in a reply to log in to the KSP Store and download from there. Of course, that doesn't work for people who purchased through Amazon. At least I got a reply, I guess (good luck with Amazon).

Any suggestions? You seem to have some sway with KSP support -- or at least they properly read your emails ; )

I guess I'll give it another day or two and see if Amazon gets their installer updated.

Share this post


Link to post
Share on other sites
  • 0

Hi Shiny_Metal, I will be pestering the moderator team leader again over this, he's currently in Mexico so he can pester Squad directly, I have been told that Squad has provided Amazon with the 1.0.2 installer, it's the same installer that is available on the Squad store.

Updating via the developer is very common, however Squad has always pushed updates via their own server (now an Amazon EC2 server ironically), originally as full downloads, then with the patcher, then via Steam updates.

GoG.com and Amazon.com are new retail channels for 1.0, and while GoG.com has updated (I bought KSP again on GoG, I like GoG :P) Amazon has not and I don't know why, I am still waiting to hear from them.

Squad will have to contact Amazon and have the Amazon version changed, I don't know how or if Amazon handles updates, I guess they expect their customers to get any patches elsewhere.

The patcher itself has been nothing but a pain since the beginning, I just recommend anyone struggling with the patcher who has KSP on the Store to download the installer instead.

Share this post


Link to post
Share on other sites
  • 0

"However, the Launcher is not downloading the Patcher, instead it is downloading a zipped Patcher.html document that when opened shows a local version of the KSP website, with links to the real KSP website pages to purchase KSP, the account login button is missing from this page."

The problem with this that my Patcher.zip is corrupt, I'm unable to open or extract it, so I'm not able to access to that html file.

Share this post


Link to post
Share on other sites
  • 0

I now have v1.0.2.8** installed via Steam. I had to wait a few days for my refund from Amazon to come through before I could afford to re-purchase KSP through Steam. I was fortunate enough to have Amazon Prime and to make a proper complaint so that they would issue me a refund. Note: I never requested a refund - Amazon offered one to me because I utilized their complaint process in the correct way.

I have many years of game purchases available to me from my Amazon account. And with every one of those purchases I have to download the version I purchased at that time – and the game is responsible for upgrading itself, or I am required to acquire any updates on my own and apply them myself. Note: Amazon does not continually refresh the customers online library with new versions of software, as they expect the software to update itself after it has been downloaded and installed on the end-users computer. This of course applies to the Amazon.com digital sales only and NOT to any other electronic service that Amazon provides.

Share this post


Link to post
Share on other sites
  • 0

Does anybody know how can I update KSP without the error below? It happens when I try to update KSP from 1.1.3 to 1.2 on MacOS Sierra 10.12 (after clicking update and logging into the KSP store in the Squad Patcher).

Any help will be much appreciated

 

P.S. I have at least 40 mods installed that work with 1.1.3 only.

 

Squad Patcher

Using rsync-2.0.9


Preparation

Detecting if OS-resident rsync is present...

rsync present in PATH, residing at: /usr/bin/rsync

Authentication

Getting login token...

Unable to auth with server, reason: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
On 30/04/2015 at 6:36 AM, vykk_draigo said:

Authentication

Getting login token...

Unable to authenticate with the server: Received malformed data from the server: File not found.

- - - Updated - - -

Squad Patcher

Using rsync-2.0.9

 


Preparation

Detecting if OS-resident rsync is present...

rsync is not already installed, so making use of bin\rsync.exe.

Authentication

Getting login token...

Unable to authenticate with the server: Received malformed data from the server: File not found.

 

On 30/04/2015 at 9:51 AM, deadfolk said:

Having the same issue here.

The patcher is no longer in use, please go to your Squad store account downloads page and download the patch for your version of KSP (windows only) or the full game, thank you.

Share this post


Link to post
Share on other sites
  • 0

I don't understand why Squad just don't disable the Update button in the launcher until they get around to fixing it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now