Jump to content
  • 0

Editor Weirdness Caused by Integer Overflow



So here's the error I'm getting (from the in-game debugger):

[Exception]: ArgumentOutOfRangeException: Argument is out of range.

Parameter name: index

System.Collections.Generic.List`1[Part].get_Item (Int32 index)

ShipConstruct.get_Item (Int32 index)

plugintutorial1.VABScaleDetector.OnStart (StartState state)

Part.ModulesOnStart ()

Part+.MoveNext ()

This happens when I'm trying to load a large ship (only about 900 parts, but with really large fuel tanks and a high cost) in the VAB. Issue is, I'm still not seeing what about it would be causing an out-of-range error. The ship's price is only 44 million, the fuel supply is only a few million units, and nothing else even comes close.

The in-game result of this weirdness is the following:

All of the parts on the left-side parts list disappear. The ship's parts become unselectable (and therefore immovable), though I can still right-click on them. The one decoupler on the ship loops its "firing" animation (complete with smoke effects) in the VAB. The "Action Groups" and "Crew" tabs become inaccessible.

I don't believe this to be mod-related, because I didn't add any new mods between when the ship worked in the editor and when it broke - I just kept building it. Issue is, I'm unsure of how to reproduce it without falling afoul of some other known (though obscure in the community) Unity bugs.

KSP Version

I'm running 32-bit 0.90 on Win7 x64.


Hoooo, boy. In no particular order,

Near Future Electrical 0.3.1

Freight Transport Tech 0.3.1

SmartParts 1.5.1

Kerbal Alarm Clock

Kronal Vessel Viewer

Editor Extensions 2.5.1

Strip Symmetry 1.5

Final Frontier 0.6.4-689

Hangar Extender 3

RCS Build Aid 0.6.1

Kerbal Enginner

Active Texture Management Basic

Stanford Torus 6.1

Lack Luster Labs 13.1

B9 Aerospace Release 5.2.8

Part Icon Fixer 1.2

Kerbal Foundries Wheels and Repulsors 1.8

KAS 0.4.10


Kethane 0.9.2

ModuleManager 2.5.10

Bahamuto EPL Parts 1.2

ExtraPlanetary Launchpads 5.1.2

TweakScale 1.52.1

Infernal Robotics 0.19.3

output.log (fair warning, it's huge)


Edited by NGTOne
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...