MOARdV

[1.6.x] RasterPropMonitor - Development Stopped (v0.30.6, 29 December 2018)

Recommended Posts

RPM remains one of my "required" mods for KSP, absolutely love the depth it adds to the game!

One thing I've been looking for, lately, is an external window which can display an RPM camera feed without needing to be in IVA. I can't seem to find anything that accomplishes this right now. Anyone have any suggestions?

Share this post


Link to post
Share on other sites

@devikwolf Hmmm... Not sure exactly what you are looking for, but if you are talking about external camera views (using actual camera parts you place on the craft), I believe RPM doesnt really have that function by itself.. I believe it uses the Hullcam mod to provide the basic functionality, which RPM then takes the "feed" from, and displays it in an RPM monitor in IVA...

So basically, what it sounds like what you want, is the Hullcam mod itself, or maybe the Docking Camera KURS Style mod...

Share this post


Link to post
Share on other sites

Ahh, I have the camera mods and I can view the camera feeds from IVA. But, I would like a way to be able to view those cameras during ship design as well as when flying the ship while not inside of IVA. I thought it was part of the RPM base package, but I guess it's part of the Hullcam mod instead! I've been installing RPM + a couple of other mod packs combined together for a while, so I forgot they're provided separately. :)

Share this post


Link to post
Share on other sites

Hi all, i was in may way to home from full iva mision ike. and thats what i saw. :D at first i thinked that may can be probe but at close look i saw my own hach with my crew. it stacionary and not travel with me i think he's just always near me(can't see it in eva outside.), kinda creepy :D it may be problem of mod fps droping ? :) 

New_Bitmap_Image_2.jpg

New_Bitmap_Image.jpg

 

Edited by Skylar'

Share this post


Link to post
Share on other sites

Maps in MFDs don't work.

[EXC 21:05:25.344] NullReferenceException: Object reference not set to an instance of an object
    SCANsat.SCANcontroller.unloadPQS (.CelestialBody b, Boolean map)
    SCANsat.SCAN_Map.SCANmap.setBody (.CelestialBody b)
    SCANsat.SCAN_UI.JSISCANsatRPM.RedrawMap ()
    SCANsat.SCAN_UI.JSISCANsatRPM.OnUpdate ()
    InternalProp.OnUpdate ()
    InternalModel.OnUpdate ()
    Part.InternalOnUpdate ()
    Part.Update ()

Share this post


Link to post
Share on other sites
1 hour ago, PyjackMeat said:

Maps in MFDs don't work.

[EXC 21:05:25.344] NullReferenceException: Object reference not set to an instance of an object
    SCANsat.SCANcontroller.unloadPQS (.CelestialBody b, Boolean map)
    SCANsat.SCAN_Map.SCANmap.setBody (.CelestialBody b)
    SCANsat.SCAN_UI.JSISCANsatRPM.RedrawMap ()
    SCANsat.SCAN_UI.JSISCANsatRPM.OnUpdate ()
    InternalProp.OnUpdate ()
    InternalModel.OnUpdate ()
    Part.InternalOnUpdate ()
    Part.Update ()

Please provide a full log.

Share this post


Link to post
Share on other sites
1 hour ago, PyjackMeat said:

Maps in MFDs don't work.

[EXC 21:05:25.344] NullReferenceException: Object reference not set to an instance of an object
    SCANsat.SCANcontroller.unloadPQS (.CelestialBody b, Boolean map)
    SCANsat.SCAN_Map.SCANmap.setBody (.CelestialBody b)
    SCANsat.SCAN_UI.JSISCANsatRPM.RedrawMap ()
    SCANsat.SCAN_UI.JSISCANsatRPM.OnUpdate ()
    InternalProp.OnUpdate ()
    InternalModel.OnUpdate ()
    Part.InternalOnUpdate ()
    Part.Update ()

As I always say on these nullref exceptions: "well, did you try to set the object reference? You should set it to the instance of an object."

Share this post


Link to post
Share on other sites
3 hours ago, PyjackMeat said:

You have a lot of mods installed, and one of them looks like it's throwing an exception every fixed update:

MissingFieldException: Field '.TemperatureGagueSystem.showGagues' not found.

There are a variety of other exceptions in the log.  The SCANsat exception you quoted above is part of SCANsat - it's the plugin from that mod that allows it to render on RPM screens.  You can check on the SCANsat thread to see if it's a known issue, although I'd recommend a better first step would be to make a copy of your KSP install with only RPM and SCANsat installed, and see if it reproduces in that configuration.  The repeated MissingFieldException may be causing problems that interfere with other mods.  Considering that the exception happens in SCANsat's unloadPQS method, and it looks like the dev version of EVE you're using has a 'PQSManager', there could be interactions there as well.  Again, I recommend checking with a minimal installation to see if the problem is reproducible without other mods' interference.

Share this post


Link to post
Share on other sites

I am currently using RPM 0.24.2.1 and MechJeb 2.5.5.0-555, but in the monitor tab "Auto", I'm getting the message "Autopilot software not installed."

Share this post


Link to post
Share on other sites
1 hour ago, PyjackMeat said:

I am currently using RPM 0.24.2.1 and MechJeb 2.5.5.0-555, but in the monitor tab "Auto", I'm getting the message "Autopilot software not installed."

MJ 2.5.5 build 555 is a fairly recent build of MJ.  It is entirely likely that @sarbian made changes to some of the MechJeb interfaces recently.  Since the last official release of MJ works with the current version of RPM, I don't expect to update RasterPropMonitor before KSP 1.1.  Real LifeTM has been extremely busy lately and I don't have the time to work on interim releases (or even play KSP, for that matter :( ).

Share this post


Link to post
Share on other sites
On 1/27/2016 at 4:40 PM, PyjackMeat said:

Maps in MFDs don't work.

 

On 1/28/2016 at 10:14 PM, MOARdV said:

The SCANsat exception you quoted above is part of SCANsat - it's the plugin from that mod that allows it to render on RPM screens.  You can check on the SCANsat thread to see if it's a known issue, although I'd recommend a better first step would be to make a copy of your KSP install with only RPM and SCANsat installed, and see if it reproduces in that configuration.  The repeated MissingFieldException may be causing problems that interfere with other mods.  Considering that the exception happens in SCANsat's unloadPQS method, and it looks like the dev version of EVE you're using has a 'PQSManager', there could be interactions there as well.  Again, I recommend checking with a minimal installation to see if the problem is reproducible without other mods' interference.

All of the SCANsat RPM stuff was moved into SCANsat a long time ago. But this is actually a SCANsat + RMP + Kopernicus problem. I know what the cause is, just a dumb mistake in how RPM maps are created.

Share this post


Link to post
Share on other sites
8 hours ago, MOARdV said:

MJ 2.5.5 build 555 is a fairly recent build of MJ.  It is entirely likely that @sarbian made changes to some of the MechJeb interfaces recently.  Since the last official release of MJ works with the current version of RPM, I don't expect to update RasterPropMonitor before KSP 1.1.  Real LifeTM has been extremely busy lately and I don't have the time to work on interim releases (or even play KSP, for that matter :( ).

I did and there will be even larger change before 1.1 so you are right to wait.

In the mean time it someone can point me to the code RPM use to interface with MJ I can see if I can add some stub to make it work for now.

Share this post


Link to post
Share on other sites
3 hours ago, sarbian said:

I did and there will be even larger change before 1.1 so you are right to wait.

In the mean time it someone can point me to the code RPM use to interface with MJ I can see if I can add some stub to make it work for now.

Pretty messy code (my apology), but it's probably around here:

https://github.com/Mihara/RasterPropMonitor/blob/master/RasterPropMonitor/Handlers/JSIMechJeb.cs#L283

Share this post


Link to post
Share on other sites

It is not as if I never write messy code myself :)

MJ-Dev #557 should work with RPM.

Share this post


Link to post
Share on other sites

So htis mod has transparent windows as well as interior control panels?

Share this post


Link to post
Share on other sites
9 hours ago, Andem said:

So htis mod has transparent windows as well as interior control panels?

If a pod were set up to use the transparent windows, you would get transparent windows.  It doesn't work on stock parts.  The main focus of this mod is making the interior functional and worth visiting.

Share this post


Link to post
Share on other sites
1 hour ago, MOARdV said:

If a pod were set up to use the transparent windows, you would get transparent windows.  It doesn't work on stock parts.  The main focus of this mod is making the interior functional and worth visiting.

Oh. so how would one set up transparent windows?

Share this post


Link to post
Share on other sites
2 hours ago, Andem said:

Oh. so how would one set up transparent windows?

You have to create your mod's models to the specifications and configure it to use the JSITransparentPod module as per the wiki here

Share this post


Link to post
Share on other sites

Uhhh... Anyone else noticed the Mk1 Cockpit doesn't work becuase of its IVA update??? You know, with the stock IVA upgrades and such.

Share this post


Link to post
Share on other sites
4 hours ago, RA3236 said:

Uhhh... Anyone else noticed the Mk1 Cockpit doesn't work becuase of its IVA update??? You know, with the stock IVA upgrades and such.

I mentioned that in release notes in November for v0.24.0.  My comment from that time still stands.

Share this post


Link to post
Share on other sites

This mod...

 

...might solve the MKI IVA issue.

 

Edit: I'm also sure I've seen a mod that does upgraded IVAs as you progress through the tech tree. So it starts out with analogue guages and as you open up more tech you end up with a full glass cockpit....but I can't remember what it was called and my google fu is letting me down.

 

Another Edit: Hah, the other mod I'm thinking of is linked in the OP...AeroKerbin Industries.

Edited by Manwith Noname

Share this post


Link to post
Share on other sites

@MOARdV, I am trying to add an external camera to my part and I cant get it to work. I have it labeled as"cameraTransform" and parented to the model but when I try to view it on a RPM screen it says viewing external screen 1 but just shows a black screen, any ideas? Thanks in advance for your help!

Share this post


Link to post
Share on other sites
12 hours ago, TMasterson5 said:

@MOARdV, I am trying to add an external camera to my part and I cant get it to work. I have it labeled as"cameraTransform" and parented to the model but when I try to view it on a RPM screen it says viewing external screen 1 but just shows a black screen, any ideas? Thanks in advance for your help!

Do you have the external camera module set up correctly on the part? Look at the examples in JSI/RasterPropMonitor/ThirdPartySupport/hullcam-models-as-external-cameras.cfg for examples of the MODULE that needs to be added to the part config.  Also take a look in the log to see if there are errors happening.

Share this post


Link to post
Share on other sites

Hi all,

I'm enjoying laying out the RPM controls for my Mk1-85 Backseat for my MOLE mod, and I have a question about setting up camera pages. I understand that there is a PAGE object of some sort that you define for the monitor, but how do you do that for a specific IVA? For instance, I have defined four camera transforms: cameraTransformFront, cameraTransformLeft, cameraTransformRight, and cameraTransformBottom. I know that the IVA has PROP definitions for RasterPropMonitorBasicMFD. Do I need to add a part module to the IVA to define the pages for the cameras? Are there tutorials on that? I checked the Wiki but couldn't find what I needed. For reference, here is the RPM version of my Backseat's IVA flight controls:

YErPdoQ.png

Thanks for the help. :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.