Jump to content

[1.12.x] Cryogenic Engines: Liquid Hydrogen and Methane Rockets! (Jan 22, 2022)


Nertea
 Share

Recommended Posts

On 9/8/2019 at 11:52 PM, Zorg said:

The picture is 100% KSP. Those are clearly CryoTanks, SSPXr, Near Future Construction, Near Future Solar and ReStock parts. The main reason it looks so much better than a regular Scaterrer and Planetshine install is KS3P with a custom config and a custom Kopernicus sunlight boost for more contrast. The way Orbital Phoenix does this is in the link posted by Friznit above.

Yes KSP can look this good if you put in a bit of effort!

This is my own recreation of a Copernicus mission following Orbital's settings for KS3P. Maybe not quite as nice as Orbitals screens but its not difficult to achieve this look if you follow his instructions.

 

Looks really nice. One thing about the original image I liked is how the foil tanks look so .. real. Mine don't have the same feel to them as his image.

Link to comment
Share on other sites

CryoEngines 1.0.3

  • Updated B9PartSwitch to 2.10.0
  • Updated DynamicBatteryStorage to 2.0.6
  • Updated CryoTanks to 1.3.0
    • Fixed LCH4/Ox tank mass ratio issue
    • Improved end-user documentation for features that are not enabled by default
    • A few under the hood bug fixes/edge cases have been addressed
    • Several under the hood efficiency improvements
    • Some minor UI tweaks and fixes
    • It is now possible to specify different cooling costs per fuel type in configs
Link to comment
Share on other sites

I'm getting an error on the realplume patch for 1.875m lower stage engines.  

:AFTER[ZREALPLUME] pass
[LOG 04:28:32.107] Applying update CryoEngines/Patches/RealPlume/CryoEngines1875Lower/@PART[*]:HAS[@PLUME[CryoEngines1875Lower]]:AFTER[zRealPlume]:NEEDS[SmokeScreen] to CryoEngines/Parts/Engine/0625/cryoengine-stromboli-1.cfg/PART[cryoengine-stromboli-1]
[WRN 04:28:32.111] Cannot find key plumeIdentifier in PLUME
[ERR 04:28:32.111] Error - Cannot parse variable search when inserting new key name = #$/PLUME[CryoEngines1875Lower]/plumeIdentifier$-plume2
[LOG 04:28:32.113] Applying update CryoEngines/Patches/RealPlume/CryoEngines1875Lower/@PART[*]:HAS[@PLUME[CryoEngines1875Lower]]:AFTER[zRealPlume]:NEEDS[SmokeScreen] to CryoEngines/Parts/Engine/125/cryoengine-vesuvius-1.cfg/PART[cryoengine-vesuvius-1]
[WRN 04:28:32.116] Cannot find key plumeIdentifier in PLUME
[ERR 04:28:32.116] Error - Cannot parse variable search when inserting new key name = #$/PLUME[CryoEngines1875Lower]/plumeIdentifier$-plume2
[LOG 04:28:32.117] Applying update CryoEngines/Patches/RealPlume/CryoEngines1875Lower/@PART[*]:HAS[@PLUME[CryoEngines1875Lower]]:AFTER[zRealPlume]:NEEDS[SmokeScreen] to CryoEngines/Parts/Engine/1875/cryoengine-erebus-1.cfg/PART[cryoengine-erebus-1]
[WRN 04:28:32.121] Cannot find key plumeIdentifier in PLUME
[ERR 04:28:32.121] Error - Cannot parse variable search when inserting new key name = #$/PLUME[CryoEngines1875Lower]/plumeIdentifier$-plume2
[LOG 04:28:32.125] Applying update CryoEngines/Patches/RealPlume/CryoEngines1875Lower/@PART[*]:HAS[@PLUME[CryoEngines1875Lower]]:AFTER[zRealPlume]:NEEDS[SmokeScreen] to CryoEngines/Parts/Engine/25/cryoengine-fuji-1.cfg/PART[cryoengine-fuji-1]
[WRN 04:28:32.129] Cannot find key plumeIdentifier in PLUME
[ERR 04:28:32.129] Error - Cannot parse variable search when inserting new key name = #$/PLUME[CryoEngines1875Lower]/plumeIdentifier$-plume2

I may simply have the wrong RP installed, as it was already installed and I didn't merge them... I'll try that.

Edited by AzraelZephyrian
Idiot me
Link to comment
Share on other sites

59 minutes ago, AzraelZephyrian said:

I'm getting an error on the realplume patch for 1.875m lower stage engines.  

I may simply have the wrong RP installed, as it was already installed and I didn't merge them... I'll try that.

Make sure you are using the most up to date version of CryoEngines (there are some fixes to the custom realplumes since they were introduced) and the latest version of RealPlume. I just checked and there are no errors when both mods are up to date.

Link to comment
Share on other sites

31 minutes ago, Zorg said:

Make sure you are using the most up to date version of CryoEngines (there are some fixes to the custom realplumes since they were introduced) and the latest version of RealPlume. I just checked and there are no errors when both mods are up to date.

Ah, I must have screwed up.  Thanks for the tip. Version management can be confusing, what with clipped and continued versioning. 

Link to comment
Share on other sites

I've been getting an error pop-up for B9 partswtch on the loading screen for  the last couple of updates.  I'll post a screenshot when I have a chance, but it mostly looks like errors that say the resource LH2 is being handled by more then one module, or something like that.

Link to comment
Share on other sites

3 hours ago, Capt. Hunt said:

I've been getting an error pop-up for B9 partswtch on the loading screen for  the last couple of updates.  I'll post a screenshot when I have a chance, but it mostly looks like errors that say the resource LH2 is being handled by more then one module, or something like that.

Very likely a mod conflict. Make sure to post your log too.

Link to comment
Share on other sites

6 hours ago, Nertea said:

Very likely a mod conflict. Make sure to post your log too.

that's what I was thinking, but I don't think I have Interstellar Fuel Switch installed right now, and I can't think what else might be trying to handle fuel type switching.  I will post the log as soon as I get a chance.

Edited by Capt. Hunt
Link to comment
Share on other sites

Hi,

Sorry to bother you. I've been updating my game from 145 to 173. I've narrowed down an issue to either cryo tanks or cryo engines. I'm not sure if it affects anything in game outside of the VAB/SPH but I thought i would let you know. Sorry just a little bit poophole in trying to get rid of errors/warnings in the log.

In the log i have on i think all of the cryotank parts.

Spoiler

[LOG 00:21:34.846] PartLoader: Compiling Part 'CryoTanks/Parts/HydrogenTanks/hydrogen-inline/hydrogen-5-3/hydrogen-5-3'
[WRN 00:21:34.852] PartLoader Warning: Variable LH2 not found in Part
[WRN 00:21:34.852] PartLoader Warning: Variable massOffset not found in Part
[WRN 00:21:34.852] PartLoader Warning: Variable costOffset not found in Part

As well as stuff like

Spoiler

[LOG 00:21:56.908] PartLoader: Compiling Part 'Squad/Parts/FuelTank/adapterTanks/Mk3-Mk2/adapterMk3-Mk2'
[WRN 00:21:56.916] PartLoader Warning: Variable LF not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable OX not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable totalCap not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable massOffset not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable costOffset not found in Part

The messages only seem to be present when Tanks/Engines is installed.

It also spams

Spoiler

[LOG 00:30:04.637] [PartSet]: Failed to add Resource 374119730 to Simulation PartSet:10 as corresponding Part FL-T400 Fuel Tank-3739183400 SimulationResource was not found.

When using affected parts that aren't cryo tanks in the VAB/SPH.

Like i say not sure it causes any issues outside building stuff but it was bothering me enough to try find out what was causing it.

Heres the log

In case it can be of use to you

Edit: Apparently have the partloader warnings in 145 logs as well it just never showed the partset logs in the console.

Edited by Ocid
Link to comment
Share on other sites

On 9/18/2019 at 4:52 PM, Ocid said:

Hi,

Sorry to bother you. I've been updating my game from 145 to 173. I've narrowed down an issue to either cryo tanks or cryo engines. I'm not sure if it affects anything in game outside of the VAB/SPH but I thought i would let you know. Sorry just a little bit poophole in trying to get rid of errors/warnings in the log.

In the log i have on i think all of the cryotank parts.

  Reveal hidden contents

[LOG 00:21:34.846] PartLoader: Compiling Part 'CryoTanks/Parts/HydrogenTanks/hydrogen-inline/hydrogen-5-3/hydrogen-5-3'
[WRN 00:21:34.852] PartLoader Warning: Variable LH2 not found in Part
[WRN 00:21:34.852] PartLoader Warning: Variable massOffset not found in Part
[WRN 00:21:34.852] PartLoader Warning: Variable costOffset not found in Part

As well as stuff like

  Reveal hidden contents

[LOG 00:21:56.908] PartLoader: Compiling Part 'Squad/Parts/FuelTank/adapterTanks/Mk3-Mk2/adapterMk3-Mk2'
[WRN 00:21:56.916] PartLoader Warning: Variable LF not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable OX not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable totalCap not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable massOffset not found in Part
[WRN 00:21:56.916] PartLoader Warning: Variable costOffset not found in Part

The messages only seem to be present when Tanks/Engines is installed.

It also spams

  Reveal hidden contents

[LOG 00:30:04.637] [PartSet]: Failed to add Resource 374119730 to Simulation PartSet:10 as corresponding Part FL-T400 Fuel Tank-3739183400 SimulationResource was not found.

When using affected parts that aren't cryo tanks in the VAB/SPH.

Like i say not sure it causes any issues outside building stuff but it was bothering me enough to try find out what was causing it.

Heres the log

In case it can be of use to you

Edit: Apparently have the partloader warnings in 145 logs as well it just never showed the partset logs in the console.

The PartSet thing is not related to my stuff as I recall. The others are harmless. 

Link to comment
Share on other sites

Yeah after looking through other mods and seeing the partset messages coming from there as well they seem to be harmless. 

The ones I mentioned in the post through do come from cryo engines or tanks. Those o es don't show without either of them being installed. 

But as they don't cause any issues be keeping the mods in the install. :D

Link to comment
Share on other sites

  • 3 weeks later...
57 minutes ago, The-Doctor said:

Hey, so I see liquid methane as an option for some tanks and I'm interested in such, but I see non for the engines, is there actually liquid methane engines or is it more likely my end some other mod making it

There aren't any in this mod, but Near Future Launch Vehicles (another mod developed by Nertea) has engines based off them. They run on LFO by default, but there's an optional patch in the download that makes them run on Methane.

Link to comment
Share on other sites

  • 2 weeks later...

I'm a bit overwhelmed by the amount of engines: since they are all so close "together" in numbers it's really hard to figure what is the best. Especially the hecate and pavonis seem to have no place between erebus, sromboli, vesuvius and the vanilla terrier.

 

 

Link to comment
Share on other sites

Running the latest 1.7.3 version of the mod according to CKAN. Erebus and Fuji engines... The Erebus states that it has an ASL thrust of 473kn, vs the Fuji which has 915kn ASL... But the Erebus is physically larger than the Fuji, as well as providing significantly more TWR. I'm guessing somewhere in the configs the models got reversed or something?

Link to comment
Share on other sites

22 hours ago, MysticDaedra said:

Running the latest 1.7.3 version of the mod according to CKAN. Erebus and Fuji engines... The Erebus states that it has an ASL thrust of 473kn, vs the Fuji which has 915kn ASL... But the Erebus is physically larger than the Fuji, as well as providing significantly more TWR. I'm guessing somewhere in the configs the models got reversed or something?

Nope, it's intended. Physical size does not necessarily correlate with engine power. The Erebus is optimized for higher TWR, the other is optimized for more raw thrust. 

On 10/26/2019 at 4:54 PM, paul23 said:

I'm a bit overwhelmed by the amount of engines: since they are all so close "together" in numbers it's really hard to figure what is the best. Especially the hecate and pavonis seem to have no place between erebus, sromboli, vesuvius and the vanilla terrier.

 

I guess you must be running the LF patch, given that you have the Terrier in there? I can't vouch for that balance, it's going to be pretty same-ey, you're right.

Outside of that, the engines have a clear split between vacuum and sea level optimized engines, with one for each size class. That should get you on the right track. 

Link to comment
Share on other sites

CE 1.1.0

  • Rebuilt for KSP 1.8.x
  • Updated B9PartSwitch to 2.12.1
  • Updated DynamicBatteryStorage to 2.1.0
  • Updated DeployableEngines to 1.2.0
  • Updated CryoTanks to 1.4.0
  • Updated ModuleManager to 4.1.0
  • DEPRECATED OLD CRYOENGINES MODELS
  • Etna RealPlume tweak (Zorg
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...