FreeThinker

[1.8.1/1.7.3/1.6.1/1.5.1/1.4.5/1.3.1] Interstellar Fuel Switch (IFS) 3.12.2

Recommended Posts

Does this mean It ignores now fuels added by an alternative mod like real fuels kerosin?

Share this post


Link to post
Share on other sites
Does this mean It ignores now fuels added by an alternative mod like real fuels kerosin?

It ignores any resource you specify in the resourcesToIgnore, the reverse (only affect listed resources is not available). But I shouldn't be hard to add something like that if your interested.

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Now that I think of it, I could implement AutoIgnore by default, which will ignore any resource that is not in the resource name list.

Share this post


Link to post
Share on other sites

[h=2]Version 1.7 for Kerbal Space Program 1.0.2[/h] Released on 2015-06-01

  • All resources that are not mentioned in resourceNames are now automatically ignored when switching tanks (which means resourcesToIgnore has become obsolete)

Share this post


Link to post
Share on other sites

Uhhhh nice. ^^

I just tested it out. It now let you fill in the VAB the fuel that you want, calculate everthing correctly and works fine with procedural parts.

The stock tanks are a little more stupor. They refill itself with the last ISFS setup after loading on the pad.

Share this post


Link to post
Share on other sites

Not really. It's more a cross mod compability issue. See the link to procedural parts above.

It happens to get messy if you try to fill a tank with real fuels by having isfs installed. You end up with a double filled tank. One filled by rf one with isfs.

A possible solution might be if you detect some fuel to ignore, than set the default to be an empty tank? Or the more complicated solution what NatanKell said.

Share this post


Link to post
Share on other sites
Not really. It's more a cross mod compability issue. See the link to procedural parts above.

It happens to get messy if you try to fill a tank with real fuels by having isfs installed. You end up with a double filled tank. One filled by rf one with isfs.

A possible solution might be if you detect some fuel to ignore, than set the default to be an empty tank? Or the more complicated solution what NatanKell said.

Well, there os an option to use structural, it should technically not show anything

Share this post


Link to post
Share on other sites

This mod is far less useful for non-modders now. I used to use this all the time for filling tanks with oxidizer for the LV-N, but that feature appears to have been removed.

Share this post


Link to post
Share on other sites
This mod is far less useful for non-modders now. I used to use this all the time for filling tanks with oxidizer for the LV-N, but that feature appears to have been removed.

Afaik you just need a fitting config. The cryo engine mod includes one.

Share this post


Link to post
Share on other sites

Last time I tried, this removed ElectricCharge from part on which it was active. E.g. hovering on the part's icon in VAB showed it has ElectricCharge, but placing it showed only fuels. ElectricCharge was gone.

I checked part DB and EC was there as well as in MM cache, but not in actual game.

Edit: latest version does not seem to have this problem, though.

Edited by cipherpunks

Share this post


Link to post
Share on other sites

[h=2]Version 1.8 for Kerbal Space Program 1.0.2[/h] Released on 2015-06-06

  • Fixes the incorrect Dry mass representation after rescaling tanks with Tweakscale

Share this post


Link to post
Share on other sites

Hullo, I was wonderingif the difference in attach type between the MicrowaveThermalPowerReceiver-S sized and others is on purpose ?

(allowSrfAttach set to 0 for the little one)

Ty a lot for ur job freethinker, this mod is the main reason im still playing ksp

Share this post


Link to post
Share on other sites
Hullo, I was wonderingif the difference in attach type between the MicrowaveThermalPowerReceiver-S sized and others is on purpose ?

(allowSrfAttach set to 0 for the little one)

Ty a lot for ur job freethinker, this mod is the main reason im still playing ksp

Please ask this question in the KSPI-E threat

Share this post


Link to post
Share on other sites

Hi, I'm having a bit of a problem using this mod. My cfg is pretty simple, just adding a LF/OX, LF, OX switch to the stock tanks, but if I try to use one of the tanks in the VAB, the editor acts like the part has no root and won't let me move it around or anything. Even just dropping in a new command pod doesn't help.

Here's an example of the cfg:


@PART[Size3LargeTank]
{
!RESOURCE[LiquidFuel] {}
!RESOURCE[Oxidizer] {}
MODULE
{
name = InterstellarFuelSwitch
resourceNames = LiquidFuel,Oxidizer;LiquidFuel;Oxidizer
resourceAmounts = 6480,7920;12960;15840
basePartMass =9
displayCurrentTankCost = false
hasGUI = true
availableInFlight = false
availableInEditor = true
showInfo = true
}
}

It's a stock install of KSP, Mod Manager & Interstellar are the only mods installed.

Share this post


Link to post
Share on other sites

Ah, it's a bug, your tankMass is missing, but it should not be required, I will fix it

- - - Updated - - -

[h=2]Version 1.10 for Kerbal Space Program 1.0.2[/h] Released on 2015-06-07

  • Fixed part root problem when tankMass is missing
  • Fixed GUI for radial attached tanks

Share this post


Link to post
Share on other sites

Is the jump from 1.8 to 1.10 intentional? Just wondering as it made me wonder if there was a 1.9 somewhere.

Share this post


Link to post
Share on other sites

It's still being cranky. As long as a fuel tank isn't the root part, it seems to be fine though. I decided to try the cfg in Nertea's Cryogenic engines mod and it didn't make any difference.

Share this post


Link to post
Share on other sites
Is the jump from 1.8 to 1.10 intentional? Just wondering as it made me wonder if there was a 1.9 somewhere.

There was an unresolved bug in 1.9, so I deleted it.

Share this post


Link to post
Share on other sites

I wonder why stack gas tank has MP and ElectricCharge... That's no Service Module, methinks.

- - - Updated - - -

Hm, I'm still having that weird VAB problem when first part to place is IFS-enabled part - can't attach more parts; have to load some craft and press "new" to workaround this IIRC... What can be wrong? Yes I have CryoEngines installed too.

- - - Updated - - -

Oh, and BTW the model of stock PB-X750 Xenon Container, that is, xenonTankLarge, is much more visually appealing to me than the model of PB-X150 that is currently used by IFS part. Please change it.

Also, hiding or somehow getting rid of, stock parts (I mean Squad's radial + two stack Xe tanks) would be good too. But I suspect that doing it so the old crafts won't break AND the RAM will be conserved is impossible, no?

Share this post


Link to post
Share on other sites

There's a lot of decimals attached to the weight of each resource. Might I recommend displaying only 2-4 decimal places?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.