Sign in to follow this  
Kerbonautical

1.01 Broke Mods?

Recommended Posts

So it seems 1.01 was released? I just went to boot up from Steam and I got a message warning me of broken mods that aren't compatible. I could be wrong, but my understanding was that one of the things modders were looking forward to about 1.0 was that from here on mod compatibility would be less of an issue going forward. But it's not even been a week and already my Career file is now botched. Is this just how it's always going to be? Because honestly I'm no longer interested in the career mode at all after this. For the first time I was actually having a whole tone of fun in career, but what's the point if every time I start to make an inch of progress I need to go back to waiting for mods to update due to incremental bug fixes?

I could just be seeing things wrong but I've not had to keep updating mods on a weekly basis in any other version number so this has kind of came out of nowhere to me.

Share this post


Link to post
Share on other sites

Which ones? It may just be that the version numbering needs to be updated.

As for actually breaking, it'll have to be looked at on a mod by mod basis.

Share this post


Link to post
Share on other sites

1.0.1 probably didn't break any mods that worked with 1.0. However the mods are programmed to look specifically at version numbers and warn of incompatibilities. i.e. if version = supported version. Most likely the only ones that will not work are mods that disable themselves if the wrong version is present, all others will continue to function despite the warning.

Share this post


Link to post
Share on other sites

Right now I'm seeing KIS and Mechjeb as dead on my list but there's another coming up called KSPAPIExtensions and I have no idea what it is or even what mod it's tied to. It seems likely it's a version number issue so I may have a shot at tweaking KIS and MJ myself, but that other one is well beyond me.

Share this post


Link to post
Share on other sites

Got an incompatibility message on Kerbal Engineer Redux, KIS and the extended action groups mod.

Share this post


Link to post
Share on other sites

Did you check that they were *actually* broken? KSP will report that any mods that weren't designed with the current version in mind as potentially incompatible, but as the "potenitally" implies, it's not outright confirmation that they won't work. I had some 0.90 mods that were working fine that KSP 1.0 reported as potentially incompatible, for example.

Heck, I have MechJeb as well and it still seems to be working just fine in 1.01 for me.

Share this post


Link to post
Share on other sites
Did you check that they were *actually* broken? KSP will report that any mods that weren't designed with the current version in mind as potentially incompatible, but as the "potenitally" implies, it's not outright confirmation that they won't work. I had some 0.90 mods that were working fine that KSP 1.0 reported as potentially incompatible, for example.

Heck, I have MechJeb as well and it still seems to be working just fine in 1.01 for me.

No, KSP doesn't report anything. The mod itself is doing that, and it is up to the programmer of that mod as to what gets disabled if there is a version incompatibility.

Share this post


Link to post
Share on other sites
Got an incompatibility message on Kerbal Engineer Redux, KIS and the extended action groups mod.

Incompatibility message != mod incompatible. That message is just the version checker.

Share this post


Link to post
Share on other sites
Right now I'm seeing KIS and Mechjeb as dead on my list but there's another coming up called KSPAPIExtensions and I have no idea what it is or even what mod it's tied to. It seems likely it's a version number issue so I may have a shot at tweaking KIS and MJ myself, but that other one is well beyond me.

KSPAPIE is a mod dependency used by stuff like ProceduralFairings and a few other mods (I don't remember which).

Share this post


Link to post
Share on other sites

How can you complain? Seriously, you're using third party software that is, other than being allowed, not supported by the developer and then complain that minutes after the update happens your mods don't work. If you don't want the update until the mods are updated themselves, don't update. Or play stock like the devs intended.

Share this post


Link to post
Share on other sites

Mods are not broke, some of them just look for a certain version number, so that see the ".1" and gives are a warning.

Share this post


Link to post
Share on other sites
How can you complain? Seriously, you're using third party software that is, other than being allowed, not supported by the developer and then complain that minutes after the update happens your mods don't work. If you don't want the update until the mods are updated themselves, don't update. Or play stock like the devs intended.

I don't really get the point of that response. I mean essentially I was pointing out something that I've never encountered before in any other version but it would appear that was possibly just luck. It turned out to be false flags anyway and I played stock for as long as I could until I got a bit bored. Sure we can play stock, but it seems like hardly any of the devs even play stock outside of testing. Mods are huge for this game and practically everyone uses them. I was just a little bit confused about what 1.0 would entail for mod development from here on out.

It's all already been sorted out and it's not like I have anything against the stock game at all.

Share this post


Link to post
Share on other sites

Just don't complain afterwards if something breaks in a not-so-obvious way. It's fine to try unsupported things, just people tend not to remember it when complaining about bugs or corruption afterwards.

Share this post


Link to post
Share on other sites

I've been using Precise Node since 1.0 dropped and it throws an error every time I load up KSP. Still as useful a mod as there ever was.

Share this post


Link to post
Share on other sites

but how often do you start KSP? to click the messages away is the price for having a working game..

Share this post


Link to post
Share on other sites

In the hopes that Interstellar would work, I attempted to run ksp with it in again. It failed. Interstellar still does not work (the mod with all of the nuclear reactors, warp drives, etc.)

:( I hope the people that run interstellar are working on a fix....

Share this post


Link to post
Share on other sites

I wasn't around when v0.90 came out, so I can't make comparisons.

But there has so much been happening in the week since the v1.0 release that I'm feeling a bit lost. There's the traffic on this site announcing new and revised mods, the mods on Curses and Kerbal Stuff, and the warning of mismatches in the precise version number.

It gets a bit wearing.

Some of the mod-updates may be a bit unbalanced. Things are working that may need detail adjustment.

Searching the Forums here has been frustrating sometimes.

And this thread throws up an old programming problem. Do you check for absolute equality (version = 1.0.0) or for a minimum (version ≥ 1.0.0). Plus, do users always react as you expect to warning messages.

I can't write this stuff, the best I ever did was 12 bytes of in-line machine-code in interpreted BASIC.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this