micha

[1.4.x - 1.7.x] Nehemia Engineering Orbital Science Mods (NEOS - Micha's build) (0.8.1)

Recommended Posts

Just now, Sudragon said:

Is there the option to get reputation rather than science? Doing (for example) 'live radio interview of a kerbonaut...in orbit!' (needs kerbonaut and open comms band (link to KSC)?

There isn't, but that's an interesting idea. I guess this could easily be done with a Contract Configrator config and wouldn't need to be tied to any specific mod as it wouldn't actually require any experiments or specific parts to do.

Share this post


Link to post
Share on other sites

The POSA/PPMD/ETC bug seems to be back with 1.2.1. If it's another mod, could someone supply information?

Share this post


Link to post
Share on other sites
On 05/11/2016 at 0:39 AM, Sudragon said:

The POSA/PPMD/ETC bug seems to be back with 1.2.1. If it's another mod, could someone supply information?

Exactly which bug do you mean - not completing missions? Also, what, if any, mods do you have installed (other than MM/KIS)? Finally - logfile?

Share this post


Link to post
Share on other sites

Well so far so good. Right now the only potential bug that I can see is no contracts appearing in the ALL tab of Contract Configure. However still not convinced it is a real bug because of other things are going on in my game right now. If I get time I do a test without any other mods. Just this and Contract Configure installed. If it does turn out to be a real problem then I post link to the logs as well. 

The main thing is it seems to be working so far in career mode. Still have lots of bits to check but I am really enjoying this so far. Honestly without this mod and Station Science. I would start to loose interest pretty quickly in KSP in general. Thank you so much.

Edited by nobodyhasthis2

Share this post


Link to post
Share on other sites
On 11/9/2016 at 0:39 AM, micha said:

Exactly which bug do you mean - not completing missions? Also, what, if any, mods do you have installed (other than MM/KIS)? Finally - logfile?

The POSA goes, the POSA comes down, loaded in a MOLE Appaloosa module. The mission recognises that the research has been done, but not the return.

https://www.dropbox.com/s/00wopjfzoucjhfd/output_log 2DEC2016.txt?dl=0

 

Share this post


Link to post
Share on other sites

Based on GitHub, yours appears to be the most up to date "unofficial" maintenance version.  So, I've forked it and I intend to add configs for Trails and BDB both of which have Gemini capsules like Tantares, hgr, etc.  I'll do a pull request when I'm done.

Share this post


Link to post
Share on other sites

I'm using this with KSP 1.2.2, module manager 2.7.5. I've launched the MSL-600 to low kerbin orbit, I have a scientist in it, I've installed some equipment (ultrasound and glovebox I believe), I have a ship docked with the CCF experiment, appropriate for the 600 and installed equipment, but I never see the "Install CCF" button. I can only move it, and only to the empty slots of the OMS ESC 3 capsule.

Am I missing something that's changed? 

Share this post


Link to post
Share on other sites

Hi guys and gals,

Apologies for the long silence; my personal life has become very busy of late and I haven't had much time to spend on gaming, let alone KSP.  Glad to hear that mostly OMS seems to be ticking along. I was most of the way through a major revamp when I had to park everything.

Just tried to take a look at your issue @viveleroi and it appears that my SSD has packed it in - which contained all my work-in-progress on KSP/OMS. Grr. Currently attempting data recovery, but it's not looking good I'm afraid.

@tg626: Looking forward to your pull request :)

Edited by micha

Share this post


Link to post
Share on other sites

So, as an update, I did find my old spinny-disk (which had since been reformatted but, luckily, not actually used) and have managed to recover the lvm on it. Unfortunately it really is old - Jul2016 - which means that my work-in-progress really is gone apart from what's up on GitHub. But no matter, at least I have my dev environment back!

Share this post


Link to post
Share on other sites
On 5/4/2017 at 2:18 AM, viveleroi said:

I'm using this with KSP 1.2.2, module manager 2.7.5. I've launched the MSL-600 to low kerbin orbit, I have a scientist in it, I've installed some equipment (ultrasound and glovebox I believe), I have a ship docked with the CCF experiment, appropriate for the 600 and installed equipment, but I never see the "Install CCF" button. I can only move it, and only to the empty slots of the OMS ESC 3 capsule.

Am I missing something that's changed? 

Hmm, "works for me". 

Could you please double check:

  • The station has an "MPL-600", not the "MSL-1000".
  • You've installed the "MSG" (Micro-gravity Science Glovebox) equipment
  • The Glovebox equipment is currently empty; that is, there's no experiment currently installed in the MSG.

 

Share this post


Link to post
Share on other sites

Made an early release for KSP 1.3, top-post for links/changes.

Share this post


Link to post
Share on other sites

If anybody wants to do some pre-alpha testing, I've just pushed a rebuilt binary and 'GameData' to the repository into its own branch:

https://github.com/mwerle/OrbitalMaterialScience/tree/mw_feature_new_ui

Contains a new GUI and localisation support. It's still WIP but any early feedback and additional localisation is welcome, although be aware that the dictionaries will probably still change a little.

NB: I've temporarily put the german translation into the english dictionaries in order to test the localisation. To just test the new GUI, swap the english and german dictionaries around!

Share this post


Link to post
Share on other sites

Just did a quick test - nothing more than KSP loading up with this plus 90+ mods and no errors in either log. Took a KEES out for a quick EVA and no issues attaching that to a pod and opening the experiment. :)

Edited by wile1411

Share this post


Link to post
Share on other sites

Tried the pre alpha, now it's all German to me...I think Verner has been messing with something.

 

Swap the dictionaries...hmmm

 

 

Edited by Sudragon

Share this post


Link to post
Share on other sites
12 hours ago, Sudragon said:

Tried the pre alpha, now it's all German to me...I think Verner has been messing with something.

 

Swap the dictionaries...hmmm

 

 

I've since actually found out a way to force language for my own testing.  In either case I think it all works, so I'll make a new alpha release shortly which will have default english again and open to more people testing it :)

Share this post


Link to post
Share on other sites
26 minutes ago, micha said:

I've since actually found out a way to force language for my own testing.  In either case I think it all works, so I'll make a new alpha release shortly which will have default english again and open to more people testing it :)

It's ok...I'm beginning to enjoy Kerbal Raumfahrtprogramm. :P

 

Share this post


Link to post
Share on other sites
1 hour ago, Sudragon said:

It's ok...I'm beginning to enjoy Kerbal Raumfahrtprogramm. :P

 

Well, there's a new version anyway :)

Share this post


Link to post
Share on other sites

And, in return;

 

//---------------------------------- MOLE Brumby & Backseat ------------------------
@PART[WBI_Brumby|WBI_Backseat2] 
{
	MODULE
	{
		name = Kemini_Module

		abbreviation = Gemini Science experiment
		minimumCrew = 1

		NE_KEMINI_LabEquipmentSlot
		{
			NE_LabEquipmentSlot
			{
				type = KEMINI
			}
		}
	}


	MODULE
	{
		name = ExperimentStorage
		identifier = Kemini 1
		chanceTexture = false
		type = KEMINI
	}
	MODULE
	{
		name = ExperimentStorage
		identifier = Kemini 2
		chanceTexture = false
		type = KEMINI
	}
}

 

Share this post


Link to post
Share on other sites

There's also a typo in one of the KEES experiment result text blocks. There's a 'geneni' instead of a 'gemini'

Share this post


Link to post
Share on other sites

@micha hey, I've made a PR with Kemini compatibility for Bluedog Design Bureau. Is there any particular reason that more advanced pods don't have support? I assume the experiments would have been run dry at that point but still... :)

Share this post


Link to post
Share on other sites

@CobaltWolf Yeah, the Kemini experiments were conceived for the early game and early pods. It's trivial for anybody who wants them to be on every pod to just add a MM config that does that ("Kemini-For-All" ?).

Thanks for the PR, I've merged it in (but no ETA yet for next release, sorry).

Share this post


Link to post
Share on other sites
On 6/17/2017 at 0:51 AM, Sudragon said:

And, in return;
 

 

Thanks!

No idea why I didn't get email notifications about these but did for CobaltWolf's (wasn't ignoring you..)

 

23 hours ago, Sudragon said:

There's also a typo in one of the KEES experiment result text blocks. There's a 'geneni' instead of a 'gemini'

EDIT: I can't find the typo. Can you please be more specific?

Edited by micha

Share this post


Link to post
Share on other sites

Hi Micha, thx for keeping this wonderful suite alive. Are those localization bugs known already? I am running:

  • MPP, KLS:  2.3.15
  • NE common: 2.4.15
  • KEES 3.4.15
  • OMS: 7.4.15
  • in english

EBdlT0P.png

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.