• 0
Sign in to follow this  
silvereagle2061

MechJeb 2.5 for KSP 1.0 Not working on landings ...

Question

OK it seems to me that MechJeb 2.5 for KSP 1.0 fails to work on landing on Kerbin unless you choose to land at KSC. "picking a location on the map" DOES NOT WORK. Once initiated it starts to pick out the location you choose, but then veers off course. In my situation, starting out at an orbit of 100 Km. MechJeb, instead of putting me on course for a landing, reversed course and fired my engines relocating my orbit to 130Km. I have KSP .25 with MechJeb and it WORKS. Same settings and all. Something is very wrong here. Before you ask, I set my landing settings as soon as I achieve orbit after liftoff giving me plenty of time. Why don't I manually land? Because that's why I downloaded MechJeb.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Probably better to raise this issue in the MechJeb thread, but I wouldn't bother doing so as I believe this is a known issue stemming from the aerodynamics changes; if you're having the problem I think you are, they already know about it and are working to fix it.

Share this post


Link to post
Share on other sites
  • 0

Dev build 446 set a lander down within walking distance of KSC for me tonight. Build 447 is right now the latest. IIRC something about some code that wasn't removed but should have been or was removed but shouldn't have been...

Anyway, Sarbian found what was causing all the crazy stuff so now it will actually attempt to land and may, if your craft is constructed in a fashion MechJeb can keep pointed firey end downward, not smash it into the landscape.

Share this post


Link to post
Share on other sites
  • 0

While I don't use the Mechjeb landing autopilot, I really like the trajectory + landing site prediction as it seems to be very accurate as long as your craft is pointing the way it would on reentry (and the mod Trajectories hasn't been updated since the guy is having problems with the new atmospheric model)

With this and an 80 m/s burn, I always land in the water ~500m from the KSC :)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this