Z-Key Aerospace

[KSP 1.4.5] [x] Science! - KSP Science report and checklist (V5.17)

Recommended Posts

1 minute ago, strudo76 said:

This doesn't collect the science automatically. It just tells you when there is science experiments available to be run, and provides an interface with buttons to run the experiments, so you don't have to go hunting for the science part. There are other mods that do automate science, but I find this better as sometimes I want to save a particular "run once" experiment until I reach somewhere specific. Using this I can just not click the button to run the experiment until I get to where I want to run it.

so what's the automatic science mod scott uses in his galileos playthrough that makes the bubble noise?

Share this post


Link to post
Share on other sites
Just now, The-Doctor said:

so what's the automatic science mod scott uses in his galileos playthrough that makes the bubble noise?

Hmmm, I thought he uses this one, but never noticed he does automatic science. This one does do a bubble noise when entering a new situation (biome change, etc)

This mod does automate science. Maybe he's using both. I haven't paid enough attention to him doing the actual science to notice if it was automated or not to be honest.

Share this post


Link to post
Share on other sites
5 minutes ago, The-Doctor said:

so what's the automatic science mod scott uses in his galileos playthrough that makes the bubble noise?

 

2 minutes ago, strudo76 said:

Hmmm, I thought he uses this one, but never noticed he does automatic science. This one does do a bubble noise when entering a new situation (biome change, etc)

This mod does automate science. Maybe he's using both. I haven't paid enough attention to him doing the actual science to notice if it was automated or not to be honest.

No, he uses this one- if you pay attention to the video, you'll see him move the mouse over to the window, and the buttons subsequently change as he clicks them. One good spot to look at in his latest Galileo Conquest video is at around 3:50. You can read the name at the top of the window and everything.

Share this post


Link to post
Share on other sites

Running [x] Science! v5.10 alongside Solar Science v1.06, the KMI Doppler observation shows up as an available experiment in any space high or space low situation, even though it is intended to only be used in the sun's SOI.  The CFG file for [x] Science! refers to that experiment id as 'HMI' but it is presently 'KMI' in the Solar Science mod.  I'm guessing this is a versioning thing since the KMI experiment is based on the real-life HMI (Helioseismic and Magnetic Imager), probably used HMI as its experiment id in the past.  I was able to remedy this by adding a KMI = NeedsStar, NeedsInSpaceLow entry in [x] Science!'s science.cfg.

Share this post


Link to post
Share on other sites
		// --- Nehemia Engineering Orbital Science ----------------------------
		// [x] Science should ignore Nehemia Engineering Orbital Science

		// KEES Experiment experimentID
		NE_KEES_OCD =			AvoidAll
		NE_KEES_POSA1 =			AvoidAll
		NE_KEES_POSA2 =			AvoidAll
		NE_KEES_PPMD =			AvoidAll

Are these experiment ID's able to be added into the science.cfg exclusions list for the next release of [x]Science please? Paging @micha as the maintainer of the mod for comment?

All the other experiments (listed below) don't have an experiment ID in the cfg file as they use the module NE_ExperimentModule. Because of this, I'm assuming the below "experiments" won't show up in [X]Science because of this. (Will do further testing tonight to check and edit post if they also need their own exclusions)

Kemini Experiments
Part					NE_ExperimentModule Type
NE_KeminiMSC3				KeminiD5
NE_KeminiD7 				KeminiD7
NE_KeminiD8				KeminiD8
NE_KeminiD10				KeminiD10
NE_KeminiMSC3				KeminiMSC3

KerbalLifeScience
NE_ADUM   				ADUM
NE_SpiU					SpiU

OrbitalMaterialScience
NE_MIS1					MIS1
NE_MIS2					MIS2
NE_MIS3					MIS3
NE_CFI					CFI
NE_FLEX					FLEX
NE_CVB					CVB
NE_PACE					PACE
NE_ExpExp1				MEE1
NE_ExpExp2				MEE2
NE_CCFE					CCF
NE_CFE					CFE



 

Edited by wile1411

Share this post


Link to post
Share on other sites

I'm having an issue with lag/stuttering when I have the Here and Now window open. Whenever i click on the button to collect science, or on the part itself, the game will freeze for a second when it updates the Here and Now window.

Share this post


Link to post
Share on other sites
8 minutes ago, John007qwe said:

I'm having an issue with lag/stuttering when I have the Here and Now window open. Whenever i click on the button to collect science, or on the part itself, the game will freeze for a second when it updates the Here and Now window.

Me too with a heavily modded install, i will post some logs and mod list later - thanks @John007qwe for posting this and reminding me. 

 

Although I suspect it's just the condition checking besides all the other background processes and nothing much you can do about / xscience causes. 

Edited by Theysen

Share this post


Link to post
Share on other sites
On 5/9/2017 at 0:15 PM, Theysen said:

Me too with a heavily modded install, i will post some logs and mod list later - thanks @John007qwe for posting this and reminding me. 

 

Although I suspect it's just the condition checking besides all the other background processes and nothing much you can do about / xscience causes. 

Well I've tried without any other mods as well, and the stutter is still there. I feel like this is something that should be fixable though. Let's just hope @Z-Key Aerospace will be back soon to take a look at it :) The constant stuttering makes it unusable for me!

Edit: both windows cause the stutter (not just Here and Now)

Edited by John007qwe

Share this post


Link to post
Share on other sites

I am seeing the same issue with the stutter lag when the window is open. Whenever I try to get science, etc. it halts the game for 2-3 seconds.

Share this post


Link to post
Share on other sites

I'm getting weird numbers in [X]S. Basically, everything seems to think it has twice as much Maximum return as normal. Takes 2 EVA reports to show complete, or 6 (!) soil samples, etc etc. Heavily modded KSP, but nothing that should be affecting science. Screenshot relevant.
I can post my modlist next time i start the game up if you want.

vmSjszI.png

 

edit:

KSP: 1.3 (Win64) - Unity: 5.4.0p4 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.4.4
Filter Extensions - 3.0.4
Toolbar - 1.7.14
USI Tools - 0.9.3
B9 Animation Modules - 1.0.6
B9 Aerospace - 6.3.2
B9 Aerospace HX Parts - 6.3.2
B9 Aerospace Legacy Parts - 6.3.2
Chatterer - 0.9.93.1804
Community Category Kit - 2.0.1
Community Resource Pack - 0.7.2
CommunityTechTree - 3.2
CryoEngines - 0.5.8
CryoTanks - 0.4.7
DistantObjectEnhancement - 1.9.1
DynamicBatteryStorage - 1.1
EditorExtensionsRedux - 3.3.13.1
Extraplanetary Launchpads - 5.8.2
Firespitter - 7.6
FShangarExtender - 3.5
Fuel Tanks Plus - 1.12.1
Interstellar Fuel Switch - 2.9.1
RasterPropMonitor - 0.29
Kerbal Attachment System - 0.6.3
KerbalAtomics - 0.4.8
Kerbal Engineer Redux - 1.1.3
Kerbal Foundries - 2.0.2.10
Kerbal Joint Reinforcement - 3.3.3
HyperEdit - 1.5.4
Kerbal Inventory System - 1.5
Kopernicus - 1.3.0.6
KSP-AVC Plugin - 1.1.6.2
KSPWheel - 0.9.5.20
Lithobrake Exploration Technologies - 0.4
Infernal Robots - 2.0.12
MaritimePack - 0.1.10
Modular Rocket Systems - 1.13.1
ModularFlightIntegrator - 1.2.4
Docking Port Alignment Indicator - 6.7
NearFutureConstruction - 0.8.3
NearFutureElectrical - 0.9.5
NearFutureLaunchVehicles - 1.1.1
NearFutureProps - 0.1
NearFuturePropulsion - 0.9.4
NearFutureSolar - 0.8.6
NearFutureSpacecraft - 0.7.3
PartCommanderContinued - 0.1.2
PatchManager - 0.0.8
Kerbal Planetary Base Systems - 1.5.2
Precise Maneuver - 2.3.1
SCANsat - 1.1.8
SmartParts - 1.9.7
StationPartsExpansion - 0.5.1
TAC Fuel Balancer - 2.13
Trajectories - 1.7
Kerbal Alarm Clock - 3.8.5
Transfer Window Planner - 1.6.2
TweakScale - 2.3.6
UbioWeldingLtd-Continued - 2.5.1
USI Core - 0.4.2
Asteroid Recycling Tech - 0.10.3
Konstruction - 0.2.2
NuclearRockets - 0.4.2
USI Alcubierre Drive - 0.6.2
Kerbal Komets - 0.4
[x] Science! - 5.10

Edited by CttCJim

Share this post


Link to post
Share on other sites

I just discovered that I was running an outdated version of [x] Science: I had v5.7, while v5.10 was available.  Strangely, KSP-AVC didn't notify me about this — even though it works fine for other mods, and this one does have a .version file.  The AVC checking didn't report anything unusual in my log KSP.log:

[LOG 22:09:10.342] KSP-AVC -> /home/wyzard/.steam/steam/steamapps/common/Kerbal Space Program/GameData/[x] Science!/[x] Science!.version
        NAME: [x] Science!
        URL: https://themoose.co.uk/ksp/%5Bx%5D%20Science!.version
        DOWNLOAD: https://themoose.co.uk/ksp/downloads.html
        GITHUB: NULL
        VERSION: 5.7
        KSP_VERSION: 1.3
        KSP_VERSION_MIN: NULL
        KSP_VERSION_MAX: NULL
        CompatibleKspVersion: True
        CompatibleKspVersionMin: True
        CompatibleKspVersionMax: True
        CompatibleGitHubVersion: True
[LOG 22:09:10.346] KSP-AVC -> Identical remote version found: Using remote version information only.

(Note, I don't know whether the "identical remote version" line pertains to this mod, or the one that was checked after it.  The line after that one is the .version file URL for another mod.)

As a total guess on my part, maybe the encoded characters in the URL are causing some sort of problem with retrieving it, causing AVC to not know what version is current?

Share this post


Link to post
Share on other sites
7 hours ago, JedTech said:

Anyone had any success resolving the stutter that occurs when you get science?

I've reduced the stuttering dramatically by compiling my own dll from the source code and removing some of the functionality I didn't need to make the code run faster, which gets me from around the normal 300-350ms down to about 30-50ms.

Share this post


Link to post
Share on other sites
6 hours ago, John007qwe said:

I've reduced the stuttering dramatically by compiling my own dll from the source code and removing some of the functionality I didn't need to make the code run faster, which gets me from around the normal 300-350ms down to about 30-50ms.

Cool! Well if you feel inclined to share,  the by-nc-sa license allows adaptation and redistribution with attribution. :) 

Share this post


Link to post
Share on other sites
15 hours ago, JedTech said:

Cool! Well if you feel inclined to share,  the by-nc-sa license allows adaptation and redistribution with attribution. :) 

I've sent it to you in a pm. If anyone else is interested just pm me!

Share this post


Link to post
Share on other sites
4 minutes ago, linuxgurugamer said:

What functionality did you remove?

I changed it to only load science on the current planet, which means it has to generate much less objects. You lose the ability to see all possible science in the full list from the main x science window.

Share this post


Link to post
Share on other sites

 

4 minutes ago, John007qwe said:

I changed it to only load science on the current planet, which means it has to generate much less objects. You lose the ability to see all possible science in the full list from the main x science window.

Can we get it so that all planets are only loaded on the Science Center screen?

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

Can you send me the modified source?

https://www.dropbox.com/s/fhvpbmngu3t7kkm/KSP-X-Science modified.zip?dl=0

I added a couple lines in ScienceContext.cs

line 385, 386 and 390

 

1 minute ago, wile1411 said:

 

Can we get it so that all planets are only loaded on the Science Center screen?

It should do that already as long as you haven't loaded a flight yet, as it loads everything the first time while in the space station.

Share this post


Link to post
Share on other sites
On 9/27/2017 at 4:26 AM, John007qwe said:

I've sent it to you in a pm. If anyone else is interested just pm me!

I'd like to get it too, since I'm getting the lag pretty badly as well. Unfortunately, I haven't posted here enough to send PM's, so if you could PM it to me....

Share this post


Link to post
Share on other sites
8 hours ago, maximusfive said:

I'd like to get it too, since I'm getting the lag pretty badly as well. Unfortunately, I haven't posted here enough to send PM's, so if you could PM it to me....

Here is the 1.3.1 reduced lag dll. I haven't upgraded to ksp 1.3.1 myself yet, but it should work. If not let me know.

https://www.dropbox.com/s/cad7tc9wvcrx6dp/[x] Science!.dll?dl=0

Share this post


Link to post
Share on other sites
3 hours ago, 1990eam said:

Hello. Any plans to make this compatible with GPP?

 

As was answered in the GPP thread, [x]Science works fine with GPP.  I've used it in KSP versions 1.2.2 and 1.3.0.  I'd say it works fine in 1.3.1 as well, especially now that GPP is now updated for 1.3.1.

Edited by MaxxQ

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.