Jump to content

[KSP 1.4.5] [x] Science! - KSP Science report and checklist (V5.17)


Z-Key Aerospace
 Share

Recommended Posts

@Warezcrawler tested new 1.4.2 .dll - still popping when already transmitted science is available again.

The only exceptions I got are from newest Fusebox Continued.

 

Edit:

I just got this unverified clue that perhaps multiple channels for CommnetConstellation mod could be the reason? The vessel got 2 channels, each for one antenna (pod and additional antenna).
Only one channel is connecting to ground stations, the other is not.

Edit:

And I should mention that I use Kerbalism, as long as the science data is inside the Kerbalism transmission queue, it's not shown again in [x] Science! Here and Now - but as soon as the data is transmitted, it's shown again.

Edited by Gordon Dry
Link to comment
Share on other sites

6 hours ago, Gordon Dry said:

 

Edit:

And I should mention that I use Kerbalism, as long as the science data is inside the Kerbalism transmission queue, it's not shown again in [x] Science! Here and Now - but as soon as the data is transmitted, it's shown again.

Can't be problem here? Incompatibility between X-science and Kerbalism?

Link to comment
Share on other sites

9 hours ago, Gordon Dry said:

@Warezcrawler tested new 1.4.2 .dll - still popping when already transmitted science is available again.

The only exceptions I got are from newest Fusebox Continued.

 

Edit:

I just got this unverified clue that perhaps multiple channels for CommnetConstellation mod could be the reason? The vessel got 2 channels, each for one antenna (pod and additional antenna).
Only one channel is connecting to ground stations, the other is not.

Edit:

And I should mention that I use Kerbalism, as long as the science data is inside the Kerbalism transmission queue, it's not shown again in [x] Science! Here and Now - but as soon as the data is transmitted, it's shown again.

Does it still pop if you save and reload?

Does it still pop if you use the original X-Science mod?

I've only messed around with when the mod does it calculations, not how it does it. That part is still not clear to me, and hopefully I will not need to find out. If the problem is Kerbalism and X-Science together, then I cannot help.

Link to comment
Share on other sites

I found a little error but could fix it myself.

like on Baikerbanur the game thinks on Woomerang its on Shores but its on Grassland so [x] Science gets confused and never deletes that entry in its list. it also cant show most of the alerts for new science on the launchpad.

so i did change science.cfg text filters to the same as that one for Baikerbanur

 

TextFilters
    {
        // --- Text Filters - Stock System-----------------
        // In the stock system these combinations are not possible
        TEXT_FILTER = Kerbin Splashed Mountains|Highlands

        // [x] Science! is assuming this is in Shores not Grasslands
        // probly need a special case in code, banning it for now.
        TEXT_FILTER = Baikerbanur
        // same problem with Woomerang on DLC its on Grassland but KSP thinks it is Shores so same solution.                                                                                                                                         
        TEXT_FILTER = Woomerang
    }

 

this hotfix should work until someone fixes the code.

 

this Info seems also outdated, because I have done at least the mountain splash down 70. 26. 39 N, 297. 39. 4 E if someone want to test it. Highlands I am searching right now

// --- Text Filters - Stock System-----------------
        // In the stock system these combinations are not possible
        TEXT_FILTER = Kerbin Splashed Mountains|Highlands
 

 

some other annoying error with the island airstrip and the shores biome:

I observed a strange behavior on the normal shores on ksc runway biome and the shores on the island. Are they different biomes? Because shores always showed me that I can perform an EVA Report, but I had already done that, after i did one on the shores of the island airstrip that gave me new science, with all other experiments too. After that it disappears on runway/shores on ksc.

Someone has to try to reproduce that error first. No time today sry.

 

On 22.4.2018 at 1:43 PM, Gordon Dry said:

This should be newly introduced then, I had both mods working together regarding this specific issue just a week ago.

 

Hm i observed some strange behavior with Kerbalism, but nothing that is too annoying. If i made an eva report and go back in [x] science shows nothing but if I eva again the dialog for new science EVA report pops up, same with surface samples. This happens until the science is brought back to ksc, Do not know if its normal behavior also without Kerbalism (the original science system is too annoying  to play without) or if its caused by another mod, but since I do not use something else that makes changes to science until someone reworks this one a sane way.

 

That science progression is so broken. with 100 percent science you do not have to grind science. But if you do than you can make halve the tech tree on kerbin alone. If you try to play with less you get forced to grind, like me with a 40%.

I would like something like: first biome 100% (first time landed first time splashed). second one 50% third one 25% fourth one 10% and then goes to 0 the rest of the science is provided as raw data. (if you get out 25% science you get 75 % as raw data resource).

Since Labs are too strong I would change them in a way that the more advanced experiments also only give a raw data resource that you have to process first(would take goo and materials bay, moving goo up in tech tree and the thermometer/pressure/other sensors down). 

Maybe if I can motivate myself...

Edited by SchitzoSchaf
added some more stuff
Link to comment
Share on other sites

Hey all -

I am new to the new, enjoying it , but I need a little help understanding and perhaps a setting change?  I have no made any changes to any setting and was wondering is there anything that I can do, to only hear and be taken out of warp if there is new science to collect based upon the science that I can collect with the current craft?

Link to comment
Share on other sites

1 hour ago, gamerscircle said:

Hey all -

I am new to the new, enjoying it , but I need a little help understanding and perhaps a setting change?  I have no made any changes to any setting and was wondering is there anything that I can do, to only hear and be taken out of warp if there is new science to collect based upon the science that I can collect with the current craft?

There are a couple of settings (buttons) in the here&now window, which does change behavior.... Whether they do exactly what you are asking for, I'm not sure about.

I don't remember any other relevant settings in X-Science...

Link to comment
Share on other sites

32 minutes ago, Gordon Dry said:

@Warezcrawler see

and also

which is an old thread but still actual.

So you are basically saying the same as in that that 4 year old thread 

Quote

When *X* exits warp, it does so in a manner that is a bit more "crude" than how the game typically exits warp, and the combination results in a glitch where orbits would be thrown off.

So going from full warp to 1x physics can have unintended effects basically. I have noticed that KAC actuals turns down warp one step at a time, probably because of such issues then. Interesting.

Link to comment
Share on other sites

Hello, first of all I would like to thank you for this very useful mod.

I now come to my question/suggestion :)
would it be possible (now that KSP is officially multi-lingual) to give the non-English-speaking community the possibility to translate the texts of this mod (I may be wrong but everything seems to be hard coded in the dll).

Thank you (again) for this mod, for reading me and thinking about my suggestion.

(translator used to make this post)

Link to comment
Share on other sites

Hey I am loving this mod so far.

However, it would be great if you could filter to show only which "first time" science tests are available. This way you won't constantly get notifications for science experiments which are already partially complete (and thus not worth it). Or perhaps a threshold for experiments which yield more than X science?

Edited by Nikecow
Link to comment
Share on other sites

  • 2 weeks later...
On 5/10/2018 at 7:43 PM, Nikecow said:

Hey I am loving this mod so far.

However, it would be great if you could filter to show only which "first time" science tests are available. This way you won't constantly get notifications for science experiments which are already partially complete (and thus not worth it). Or perhaps a threshold for experiments which yield more than X science?

Well, maybe you should look at Science Alert. It pretty much specializes in the notification part, and you can adjust the thresholds there.

Link to comment
Share on other sites

On 5/10/2018 at 10:43 AM, Nikecow said:

Hey I am loving this mod so far.

However, it would be great if you could filter to show only which "first time" science tests are available. This way you won't constantly get notifications for science experiments which are already partially complete (and thus not worth it). Or perhaps a threshold for experiments which yield more than X science?

I think that is one of the features-- "assume complete" or something similar? Maybe not to the extent of only notifying on first-time, though.

Link to comment
Share on other sites

@Z-Key Aerospace is there a way to add an automatic sum indicator on the lower right corner of the [x]Science window that sums all the available science to gather of the currently shown list with search filter applied?

Also, I think that the two alternative launch site biomes are not being detected by the Science Now!(in flight status) window

Edited by EstebanLB
Link to comment
Share on other sites

Hey everybody, i am playing on 1.3.1 and since last day when I click on an experiment it does not open the Science /exp. Window but instead says that "xxx data was transferred to the command module.

Any idea what is happening there ?

 

Link to comment
Share on other sites

1 hour ago, FerritCore said:

Hey everybody, i am playing on 1.3.1 and since last day when I click on an experiment it does not open the Science /exp. Window but instead says that "xxx data was transferred to the command module.

Any idea what is happening there ?

"Supress results window" active? Installed another mod which can be incompatible? Which mod version do you have installed?

Link to comment
Share on other sites

On 5/23/2018 at 7:59 AM, 4x4cheesecake said:

"Supress results window" active? Installed another mod which can be incompatible? Which mod version do you have installed?

Reinstalled and works fine now.

On the other hand, i still get a lag, everytime i click an experiment.

Is there a workaround?

Link to comment
Share on other sites

AFAIK, there is no workaround for lag caused by this mod. If you have some RAM to spare, you can try to install MemGraph and add some space to the monoheap (this will reduce stuttering in generell) but in my expierience it also causes some very long loading times after running the game for a while. The mod is a bit out-dated but is still running on 1.4.x. If you want to try it, read the OP carefully and maybe some other posts in the thread, it can be a bit complicated in the beginning.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...