Sign in to follow this  
severedsolo

[1.0.4] Contract Pack: ScanSat Lite 1.3 (23/08/15)

Recommended Posts

I have noticed this mistake in the ScanSatLite.version file:

I don`t know if it is a big issue...

Not so much a bug as it is a nag message red herring. :sticktongue:

Severedsolo - just in case you didn't notice, the KSP-AVC plugin is referencing this file as being the wrong version with the message that the Kerbin Space Station contract pack is incorrect. No biggie but I did scratch my head when I went to update and my version numbers were correct for the station pack. Keep up the good work, really like your lite version port of the original pack. Thanks so much for getting rid of the 100 day orbit contracts!

Share this post


Link to post
Share on other sites
Not so much a bug as it is a nag message red herring. :sticktongue:

Severedsolo - just in case you didn't notice, the KSP-AVC plugin is referencing this file as being the wrong version with the message that the Kerbin Space Station contract pack is incorrect. No biggie but I did scratch my head when I went to update and my version numbers were correct for the station pack. Keep up the good work, really like your lite version port of the original pack. Thanks so much for getting rid of the 100 day orbit contracts!

Is this still happening? It should have been fixed about 24 hours after release. I copy/pasted the KSS file, and changed everything but the name, but I fixed it a while ago.

Share this post


Link to post
Share on other sites

I love this idea...

However:

I accepted the 1st contract to do a low resolution altimetry scan of Kerbin and have been scanning for ages in a polar orbit.

I have complete covereage of ScanSat map.

It is stuck at 94.4% and will not go any higher.

The threshold for success is 95%.

Really annoying!

Any ideas?

Share this post


Link to post
Share on other sites
I love this idea...

However:

I accepted the 1st contract to do a low resolution altimetry scan of Kerbin and have been scanning for ages in a polar orbit.

I have complete covereage of ScanSat map.

It is stuck at 94.4% and will not go any higher.

The threshold for success is 95%.

Really annoying!

Any ideas?

You sure you have complete coverage, not missing the poles? What is your inclination?

Share this post


Link to post
Share on other sites

I have complete coverage.

Inclination is 90 degrees.

EDIT: my bad... turns out my inclination was wrong.

Edited by dommcq

Share this post


Link to post
Share on other sites

The science rewards for the magnetometer/radio plasma wave scanner seem completely out of balance. I just got 600 science for a relatively easy to do task. Maybe 60-75% of current values? Or give the majority of the science at the end of the 140 days rather than front loaded.

Share this post


Link to post
Share on other sites
The science rewards for the magnetometer/radio plasma wave scanner seem completely out of balance. I just got 600 science for a relatively easy to do task. Maybe 60-75% of current values? Or give the majority of the science at the end of the 140 days rather than front loaded.

Sounds like you're looking at a contract for DMagic's orbital science mod.

Share this post


Link to post
Share on other sites
Is this still happening? It should have been fixed about 24 hours after release. I copy/pasted the KSS file, and changed everything but the name, but I fixed it a while ago.

No longer. Once I got the last update right after I made that post, the nag message went away and is flagged properly under KSP-AVC now.

Share this post


Link to post
Share on other sites

So my turn for a bug report - turns out that my target selection code will happily churn out sun (and probably jool) as scannable targets. I will be fixing this in the next release, so bear with me

Share this post


Link to post
Share on other sites
So my turn for a bug report - turns out that my target selection code will happily churn out sun (and probably jool) as scannable targets. I will be fixing this in the next release, so bear with me

I think the rewards for successfully scanning the Sun should be buffed ;']

Share this post


Link to post
Share on other sites

A "lite" version of ScanSat contracts? This is everything I wanted! Now I can download ScanSat again. Have some rep.

Share this post


Link to post
Share on other sites

Hi, just downloaded this (and Contract Configurator, of course) as am playing a game on hardish settings with not much money and have been finding difficulty justifying the expense of orbiting ScanSats. Anyway, I have a couple of questions

As long as ScanSat hasn't been actually used in the save, does this work OK in existing saves?

Also I was looking through the mod and was wondering if it gives contracts for the SAR/hi res scanner, as there only seems to be a cfg for the lo res and Multi Spectral/biome scanner.

Share this post


Link to post
Share on other sites

As long as ScanSat hasn't been actually used in the save, does this work OK in existing saves?

Yes, it does.

Share this post


Link to post
Share on other sites

As long as ScanSat hasn't been actually used in the save, does this work OK in existing saves?

Absolutely fine. The only requirement for a body to be considered as a target is that it has been orbited, and you have scanned less than 95% of the surface using the relevant scanner. (This will change slightly in the next update, due in the next few days. After that, the body must have a surface too).

You MAY find that once the next update drops, and removes the "1 mission at a time per scanner" requirement (because the bug it's working around will be fixed) you'll get a lot of contracts together, if you've got alot of valid targets, but that's not the end of the world.

Also I was looking through the mod and was wondering if it gives contracts for the SAR/hi res scanner, as there only seems to be a cfg for the lo res and Multi Spectral/biome scanner.

That's something I have considered, DT85 only ever had the LoRes scanner. I was thinking of making it so you can either do a Hi or a Lo Res altimitery scan

I don't know about you, but personally I never use the Hi Res one, as all I want is a slope scanner, and Lo Res does that.

Edited by severedsolo

Share this post


Link to post
Share on other sites

Thanks for the answer.

It may just be me, but I like to do Hi Res scans as well. Of course, once I unlock that node I'll probably have a lot more funds so the need for a contract to send up a ScanSat probably won't be as great, and I would probably be slapping them on any new ScanSats as a matter of course. Still, I think it might be handy to have contracts for SAR scans

Share this post


Link to post
Share on other sites
I don't know about you, but personally I never use the Hi Res one, as all I want is a slope scanner, and Lo Res does that.

A slope scanner for the instruments readout? Or for the big map? I hope the former, the low resolution slope map is even more worthless than the high resolution map.

Share this post


Link to post
Share on other sites
A slope scanner for the instruments readout? Or for the big map? I hope the former, the low resolution slope map is even more worthless than the high resolution map.

I have to agree, trying to use the low res slope map is an exercise in frustration with everywhere being flat except the cliff edged borders between low res pixels.

Share this post


Link to post
Share on other sites

ScanSat Lite 1.1 Released!

Target Selection

Bodies that do not have a surface (such as Jool and Sun), will no longer be considered when looking for scannable targets.

If a body already has a contract of the same type offered/active, that body will no longer be considered.

Misc

As the duplicate body bug is now fixed, maxSimultaneous reset to 3.

Dependencies

ScanSat Lite now requires Contract Configurator 1.1.0 or higher

Share this post


Link to post
Share on other sites

For some reason, my scanat satellite in 90 degree orbit around Kerbin, launched after the contract was accepted, and scanned to 95% of the planet, isn't triggering the contract success. I even analyzed the data and sent it home, but that didn't trigger it either. Low resolution scan is the contract, and I have your latest version.

drTojGZ.png

Just noticed the contract even notes that I've surpassed the goal, but it still won't give me the completion status.

Edited by jordanjay29

Share this post


Link to post
Share on other sites
For some reason, my scanat satellite in 90 degree orbit around Kerbin, launched after the contract was accepted, and scanned to 95% of the planet, isn't triggering the contract success. I even analyzed the data and sent it home, but that didn't trigger it either. Low resolution scan is the contract, and I have your latest version.

http://i.imgur.com/drTojGZ.png

Just noticed the contract even notes that I've surpassed the goal, but it still won't give me the completion status.

jordanjay, I took a look at this issue, and couldn't see anything in the code that would obviously cause this, and my testing was successful (both watching the probe in flight and warping at KSC). Can you provide a log file?

Note that I discovered a fairly major issue that affects this contract pack and am releasing a fix to Contract Configurator for it. I do suspect it may be related to this issue...

Share this post


Link to post
Share on other sites
jordanjay, I took a look at this issue, and couldn't see anything in the code that would obviously cause this, and my testing was successful (both watching the probe in flight and warping at KSC). Can you provide a log file?

Note that I discovered a fairly major issue that affects this contract pack and am releasing a fix to Contract Configurator for it. I do suspect it may be related to this issue...

Hmm, I should locate the log file where?

Share this post


Link to post
Share on other sites
Hmm, I should locate the log file where?

I just released Contract Configurator 1.1.1 - please try that one, and if you still have the issue provide the log file for that version.

Share this post


Link to post
Share on other sites

I'm getting this now with Contract Configurator 1.1.1:

Exception occured while loading contract contract 'LoRes':

System.NullReferenceException: Object reference not set to an instance of an object

at ContractConfigurator.ConfiguredContract.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0

Share this post


Link to post
Share on other sites

Can you post a full log please, it's not possible from that excerpt to tell exactly where it fell over

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this