seanmcdougall

[1.1.2] Take Command - Launch Kerbals in External Command Seats [v1.4.1 - May 6, 2016]

Recommended Posts

binary sort. I don't know why I abbreviated it. Just makes it confusing since a bin sort is another name for a bucket sort. Anyways, back on topic...

Share this post


Link to post
Share on other sites

AGE dev here, the issue people are seeing with this mod not activating with AGE installed has been identified and so should be fixed soon.

However, it is not limited to AGE, any mod that locks any inputs with the stock InputLockManager in KSP will cause this mod to not work.

I presume this is what has happened to you Robotengineer but without seeing your mod list I can not be sure.

D.

Share this post


Link to post
Share on other sites

Version 1.2 is now up, which should fix the compatibility problem with Action Groups Extended (and likely other mods as well).

Share this post


Link to post
Share on other sites

I'm new to CKAN so I apologize if this is user error, but I can't seem to get Take Command to install with it. First of all, it seems to be stuck on v1.1.3 no mater what I do. And when I attempt to install I get this:

"Failed to download "https://kerbalstuff.com/mod/776/Take Command/download/1.1.3" - error: The remote server returned an error: (404) Not Found."

Share this post


Link to post
Share on other sites
I'm new to CKAN so I apologize if this is user error, but I can't seem to get Take Command to install with it. First of all, it seems to be stuck on v1.1.3 no mater what I do. And when I attempt to install I get this:

"Failed to download "https://kerbalstuff.com/mod/776/Take Command/download/1.1.3" - error: The remote server returned an error: (404) Not Found."

Hi Godit. I can think of two possible issues that might be causing this.

#1 - Your CKAN metadata is out of date. Make sure you're running the latest version of CKAN, then click the "Refresh" button in the toolbar to update it.

#2 - You're running an old version of KSP. TakeCommand 1.1.3 was the last version compiled for KSP 1.0.2. More recent versions were compiled against KSP 1.0.4. So if you were still on KSP 1.0.2 for some reason, then CKAN would try to install 1.1.3 instead of grabbing the most recent version (1.2). However 1.1.3 is no longer available for download through KerbalStuff because I don't want new users grabbing old, buggy versions. If you're unable/don't wish to upgrade to KSP 1.0.4 then you can try installing TakeCommand manually. I haven't tried 1.2 with 1.0.2 myself, but I don't see any reason why it shouldn't work.

Share this post


Link to post
Share on other sites

I made a better core config that makes this mod compatible with other mods that have command chairs.


@PART
[*]:HAS[@MODULE[KerbalSeat]]{
CrewCapacity = 1
MODULE
{
name = TakeCommand
minimumCrew = 1
}
INTERNAL
{
name = GenericSpace1
}
}

Share this post


Link to post
Share on other sites
#2 - You're running an old version of KSP.

So thanks for your advice, otherwise I may never have noticed Steam failed to up date me to 1.04. I've been running 1.02 this whole time. All good now that I forced an update!

Share this post


Link to post
Share on other sites

Looks like this isn't working properly with 1.05... I'll see if I can track down the problem and get a new version up sometime this week.

Share this post


Link to post
Share on other sites

I didn't have any problems actually. But I'm happy with the update, thank you!

Share this post


Link to post
Share on other sites
I didn't have any problems actually. But I'm happy with the update, thank you!

Yeah, I'm thinking it was just my computer :-) I tried again later and it worked fine. I've pushed out a new update anyways though.

Share this post


Link to post
Share on other sites
sean,

Bug report 1: transferring any Kerbal from a Crew Cabin or Cockpit to a Command Seat moves the Kerbal, but the Kerbal is rendered invisible in the chair until I transfer him back to a cockpit or crew cabin.

Bug report 2: spawning Kerbals after launch into Command Seats renders them also invisible in the seat (such as when you launch a plane with a pilot, but you have an active tourist contract), if you select to load the passengers after launch, the loaded passengers/tourists also fail to visibly appear in the Command Seats even though they are there when you click to transfer them to other places on the craft. If you pre-load the tourists in the seats while in SPH, they render fine on launch. This bug only happens if you launch a vessel initially without tourists, but then decide to load them only after you are asked by KSP if you want to load the tourists.

See related Contract Configurator issue #355: [url]https://github.com/jrossignol/ContractConfigurator/issues/355[/url] Edited by inigma

Share this post


Link to post
Share on other sites
[quote name='inigma']sean,

Bug report 1: transferring any Kerbal from a Crew Cabin or Cockpit to a Command Seat moves the Kerbal, but the Kerbal is rendered invisible in the chair until I transfer him back to a cockpit or crew cabin.

Bug report 2: spawning Kerbals after launch into Command Seats renders them also invisible in the seat (such as when you launch a plane with a pilot, but you have an active tourist contract), if you select to load the passengers after launch, the loaded passengers/tourists also fail to visibly appear in the Command Seats even though they are there when you click to transfer them to other places on the craft. If you pre-load the tourists in the seats while in SPH, they render fine on launch. This bug only happens if you launch a vessel initially without tourists, but then decide to load them only after you are asked by KSP if you want to load the tourists.

See related Contract Configurator issue #355: [URL]https://github.com/jrossignol/ContractConfigurator/issues/355[/URL][/QUOTE]

Thanks for the reports, I'll take a look and see if I can figure out what's going on.

Share this post


Link to post
Share on other sites
On 11/26/2015, 7:32:42, seanmcdougall said:

[quote name='inigma']sean,

Bug report 1: transferring any Kerbal from a Crew Cabin or Cockpit to a Command Seat moves the Kerbal, but the Kerbal is rendered invisible in the chair until I transfer him back to a cockpit or crew cabin.

Bug report 2: spawning Kerbals after launch into Command Seats renders them also invisible in the seat (such as when you launch a plane with a pilot, but you have an active tourist contract), if you select to load the passengers after launch, the loaded passengers/tourists also fail to visibly appear in the Command Seats even though they are there when you click to transfer them to other places on the craft. If you pre-load the tourists in the seats while in SPH, they render fine on launch. This bug only happens if you launch a vessel initially without tourists, but then decide to load them only after you are asked by KSP if you want to load the tourists.

See related Contract Configurator issue #355: https://github.com/jrossignol/ContractConfigurator/issues/355

Thanks for the reports, I'll take a look and see if I can figure out what's going on.

Salivating... I have a contract pack dependent on this working... :)

Share this post


Link to post
Share on other sites

Alright, I've cooked up a new version that should now properly spawn Kerbals that are transferred into a chair post-launch.  I've posted it as a beta version here:

https://github.com/seanmcdougall/TakeCommand/releases/tag/v1.3-beta

I'd appreciate it if folks could test it out and report back with any issues (in particular, please test it out with Contract Configurator - I haven't had a chance to try that mod out yet myself).

Thanks!

Share this post


Link to post
Share on other sites

I tested the beta. works great. perfect fix. compatible now with 1.8.4 of Contract Configurator too.

Share this post


Link to post
Share on other sites

Thank you so much for this. Take Command has become one of my mandatory mods. 

Share this post


Link to post
Share on other sites
On 12/2/2015, 1:54:41, greydragon70 said:

Thank you so much for this. Take Command has become one of my mandatory mods. 

Yeah, it should be stock. Squad should pick this up ASAP!

Share this post


Link to post
Share on other sites

...double post...

Edited by inigma

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.