Orionkermin

[1.0.2]Corvus -Size 1, two Kerbal command pod(Version 1.1.1)

Recommended Posts

just found this its AWSOME you sir ROCK

keep up the awesome work

and to think I found it on ckan

Share this post


Link to post
Share on other sites

Besides some weird heating issues, Corvus is functional with 1.0.4 am i correct? It's become the absolute lynchpin to my early career game

Share this post


Link to post
Share on other sites
Besides some weird heating issues, Corvus is functional with 1.0.4 am i correct? It's become the absolute lynchpin to my early career game

The only issue is the corvus heat shield -- it needs to be updated to reflect the changes made in 1.0.3 and 1.0.4. Int the meantime use the stock heat shield unless you like krispy kernels.

Share this post


Link to post
Share on other sites
The only issue is the corvus heat shield -- it needs to be updated to reflect the changes made in 1.0.3 and 1.0.4. Int the meantime use the stock heat shield unless you like krispy kernels.

Try to use a shallower descent profile. start further out, use (-120, 0, 0) node if you are in a ~71km circular orbit (which is a darned fast orbit). Start the burn (~12 seconds retrograde with the monoprop engine) about 75-80 degrees clockwise from KSC to end up pretty close - jettison back end after the burn and enter with just the capsule, nose, and heat-shield. Go hands off after you set the capsuel to hold retrograde the whole way with torque and SCS (use RCs once you're in the flames if necessary and if you have much). The rest is just watching until parachute time. You should hit 60k altitude going about 2200 m/s. You'll see red (dynamic pressure 500pa) as you cross 50K at about 2250m/s. It will get a bit toasty at 45-35k but the speed bleeds off starting at 35K, and and the heat and speed drop rapidly between 30K (2000m/s) and 10K (700 m/s). By 1500-1200m altitude your speed should be about 225m/s, and you can pop the chute. Landing is a nice thump at 6-7 m/s.

Edited by Murdabenne

Share this post


Link to post
Share on other sites

Is there any Launch Escape Towers for this pod. Can't find any mods with launch escape towers, that would fit 1.25 pods. Any suggestions?

Share this post


Link to post
Share on other sites

I dont have the slightest clue how to write a MM patch, but for someone who can, or for those of you brave enough to manually edit the config for the heatshield, here are the changes needed to bring this in line with the stock 1.25m heatshield in 1.0.4.

Change

thermalMassModifier = 0.001

to

thermalMassModifier = 1.0

Change

MODULE    {
name = ModuleAblator
ablativeResource = Ablator
lossExp = -9000
lossConst = 20
pyrolysisLossFactor = 10000
reentryConductivity = 0.01
ablationTempThresh = 500
}

to

MODULE
{
name = ModuleAblator
ablativeResource = Ablator
lossExp = -6000
lossConst = 1
pyrolysisLossFactor = 600
reentryConductivity = 0.01
ablationTempThresh = 500
}

Fair warning, these are untested changes that im implementing myself as I write this, but the values make it identical to the stock heat shield, exception being that the Corvus heatshield has a slightly higher maxTemp due to the additional weight of the pod vs a Mk 1. Good luck, pilots.

Edit: Just tested the above on a smooth re-entry from Minmus (initial Pe of 20km, speed on atmo entry 3250m/s) and it held up quite well. Lost about 35 ablator. Works great.

Edited by technerd89

Share this post


Link to post
Share on other sites

Yeah the heatshield caught me by surprise... wow my craft burned out of ablator in ten seconds and blew to smitherines.. I am definatly reinstating an older save file and changing the craft MM code. Thanks.

Perhaps you should just remove the HS from the pack. Safer that way.

Share this post


Link to post
Share on other sites

If that interests anyone, I included teacherd89's changes (and some CTT tech level adjustments) into a MM cfg file. Not tested too much yet, but I'll forget to post this later:

@PART[Corvus_Heatshield] {

@thermalMassModifier = 1.0

@MODULE[ModuleAblator] {

@lossExp = -6000

@lossConst = 1

@pyrolisysFactor = 600

}

@TechRequired = simpleCommandModules

}

@PART[Corvus_Exterior] {

@TechRequired = simpleCommandModules

}

Note: if you're not using CTT, drop @TechRequired lines.

Share this post


Link to post
Share on other sites
Whatever happened to the CST-100-ish thing? Can someone please update that?

it never got updated to 1.0 but im pretty sure there are configs out there for it

Share this post


Link to post
Share on other sites

Can confirm it works in 1.0.5. Can also confirm that it sinks to the bottom of the ocean. You have been warned.

Share this post


Link to post
Share on other sites
I just launched a rescue mission, 1 pilot, and I can't board my rescued Kerbal. Tried EVA with the pilot, and now she's stuck outside also.

Edit:
Updated Module Manager, and now I can board.

Also found that, with the heavier than water capsule, I can now set depth achievements! Edited by CompB

Share this post


Link to post
Share on other sites
hi all awsome mod and agreed its a must have any hope that this will be updated in the ckan repository

Share this post


Link to post
Share on other sites

I found a way to adjust the buoyancy to keep the pod from sinking.  The configuration files for the stock pods have a few other values that can be adjusted if anyone wants to experiment with it.

@PART[Corvus_Exterior]
{
	%buoyancy = 1.7	
}

 

Share this post


Link to post
Share on other sites
On November 14, 2015 at 8:13 AM, RoboRay said:

Any Winged Gemini fans?

3OJcHHQ.jpg

I'm doing flight-testing on Winged Corvus!

pbSMtVl.png

6R3TIxP.png

Here's some more pictures of the first runway landing after returning from orbit: http://imgur.com/a/AFY09

Can I ask, what mod did you get those wings from?

Share this post


Link to post
Share on other sites
49 minutes ago, Thraken said:

Can I ask, what mod did you get those wings from?

B9 Procedural wings

Share this post


Link to post
Share on other sites

Hey, I'm wondering if the generator automatically stops charging like the fuel cells. I've been afraid to leave it on in case I run out of monopropellant.

Share this post


Link to post
Share on other sites

I really love this mod. I know it still works in 1.0.5, but without it updating, I don't think it will hold into 1.1. It looks like Orionkermin is gone, so is anyone going to take on development?

Share this post


Link to post
Share on other sites
26 minutes ago, klipty said:

I really love this mod. I know it still works in 1.0.5, but without it updating, I don't think it will hold into 1.1. It looks like Orionkermin is gone, so is anyone going to take on development?

The license is all rights reserved. Nobody can do anything about it I'm afraid.

Share this post


Link to post
Share on other sites

I'm currently using this and loving it, but I have to wonder what's causing this issue. The issue is that when I deploy the parachute it starts slowing down the capsule gradually, but when it fully deploys it seems to fall faster as if the parachute didn't exist at all. I'm currently using RealChute so I have a feeling it something with the MM patch. This is also the only parachute that has this problem, so I'm quite stumped. I've also scanned the chute config and MM patch but I don't see anything alarmingly wrong that should cause this, so any help would appreciated!

Share this post


Link to post
Share on other sites
46 minutes ago, FiiZzioN said:

I'm currently using this and loving it, but I have to wonder what's causing this issue. The issue is that when I deploy the parachute it starts slowing down the capsule gradually, but when it fully deploys it seems to fall faster as if the parachute didn't exist at all. I'm currently using RealChute so I have a feeling it something with the MM patch. This is also the only parachute that has this problem, so I'm quite stumped. I've also scanned the chute config and MM patch but I don't see anything alarmingly wrong that should cause this, so any help would appreciated!

I recall this one; it's a weird model interaction between the chute, and the nosecone "cap", if I remember right. I've had it on a couple craft, of similar configuration, but I don't know the exact cause. Well. Here is what happens, I just don't know WHY ultimately. So, you can hit f12 to visualize aerodynamic forces. You'll note that they're represented as colored vectors. A red one is drag, such that as you fall, the drag results in an *upward* vector, opposing your flight path, slowing you down.  So, the snag, when that cap pops off, you can see it plainly: a new vector appears, also red (drag, I presume), but aimed pointing at the ground, 180 deg out of position. This effectively cancels out the actual drag vector, resulting in a very effective plummet. 

I don't know if a drag cube is out of whack, but that would be my guess. I don't know nearly enough about that system to guess how to adjust it. (Pinging @NathanKell, is there documentation anywhere on drag cubes? I've stared at them a few times, but beyond them appearing to be float curves (and I may be way off at that; it's been a little bit), I've not deciphered their savory details as of yet.) A dirty hack I found on accident (you try near anything in a sudden plummet...), which works sometimes, is to tumble the craft as much as possible off the nose up rear down bugged plummet orientation. Drag on the sides of the vessel seems to be still working correctly. This can sometimes jog whatever has gone nuts into working, or at least slow you enough to not destroy said chutes when they pop. 

That said, I've not played with realchutes (beyond the lite version with/from/for FAR, at least), so I'm not sure how it would tie in. It might be useful to test it in a sandbox save w/o realchutes to try to isolate some cause/effect. 

Good luck, brave test pilot! o7

Share this post


Link to post
Share on other sites
5 minutes ago, komodo said:

---- Snip ----

Thanks for the info! Hopefully Nathan might be able to chime if he has time and explain if it's drag cubes, and if so, how to configure them. I'm just glad that it wasn't just me getting a random bug as it means it's (most likely) not something unique to my install.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.