Jump to content

[1.8+] Custom Barn Kit 1.1.20 (19 October 2019) - Parachute Included


sarbian
 Share

Recommended Posts

5 minutes ago, New Horizons said:

@Jacke: Thank you for pinpointing to your link. I was aware of it, but this version is not compatible to KSP 1.7.3 as version file says.

CustomBarnKit v1.1.19 was released under KSP 1.6, but most mods released for 1.6.x still worked under 1.7.x.  You should test it.  Considering a version wasn't released until 1.1.20 and there was no other complaints about it not working, I'd say it likely will.  For KSP 1.7.3 under CKAN, I marked mods compiled for KSP 1.7.x, 1.6.x, and 1.5.x as compatible as they usually were.

Link to comment
Share on other sites

On 11/4/2019 at 8:46 PM, zer0Kerbal said:

quick question:

does CBK support more than three levels ? (so VAB/SPH) - am mulling over writing a config that has ten levels - mostly for the VAB/SPH/LP/RW to have more granularity in part count / max weight.

Yes, it does.

Now working on a config called Komplexity - :D

Link to comment
Share on other sites

  • 5 months later...
  • 2 weeks later...

Ok, first time here. 

I'm currently running ksp 1.8.2, with essentially 2 mods (+their dependancies) :

outer planet mod, 

procedural parts. 

 

so i have a science mode save, and I have that bug saying "EVA not possible, upgrade astro complex first" or equivalently : "can't launch current vessel : design is over x parts" wich shouldn't make sense because science mode. I've searched for clues for a few days but I feel out of options. Of course, right clicking on said buildings lets me know they are fully upgraded. 

 

I've noticed CBK was used by OPM to extend tracking station to a fourth level, wich is really helpfull. Noticing CBK was used to mess with building levels, I removed it from my mods (i use ckan to manage my mods) and, you guessed it, no more bugs. Turned it back on a few game hours later, bug is back.

Running out of other options than coming to beg for help here, well, here I am. 

 

(apologies for not clearly understanding what "logs" are or how can i get them) 

 

 

Link to comment
Share on other sites

 

1 hour ago, deltadart said:

Ok, first time here. 

I'm currently running ksp 1.8.2, with essentially 2 mods (+their dependancies) :

outer planet mod, 

procedural parts. 

 

so i have a science mode save, and I have that bug saying "EVA not possible, upgrade astro complex first" or equivalently : "can't launch current vessel : design is over x parts" wich shouldn't make sense because science mode. I've searched for clues for a few days but I feel out of options. Of course, right clicking on said buildings lets me know they are fully upgraded. 

 

I've noticed CBK was used by OPM to extend tracking station to a fourth level, wich is really helpfull. Noticing CBK was used to mess with building levels, I removed it from my mods (i use ckan to manage my mods) and, you guessed it, no more bugs. Turned it back on a few game hours later, bug is back.

Running out of other options than coming to beg for help here, well, here I am. 

 

(apologies for not clearly understanding what "logs" are or how can i get them) 

 

 

 

 

33 minutes ago, Poodmund said:

This issue was been posted on the Git tracker a while back: https://github.com/sarbian/CustomBarnKit/issues/8. If anyone can find a consistent way to reproduce the issue then, please, let us all know. :D 

same to me in 1.8.1 running 157 various mods also with OPM. Thing is, everything works fine until I open the tracking station. After that creation of maneuver nodes and EVA are disabled. Only opening the Tracking Station produces the bug; the astronaut complex, mission control, admin building do work rather fine. My current workaround is to close the save and open it again from the main menu, though.

edit: I can also EVA without problem using Ship Manifest though, even when bug is active.

Edited by flamerboy67664
Link to comment
Share on other sites

  • 1 month later...

This appears to work in 1.9.1

Here's a CFG file to make you have unlimited parts from the start in the VAB, being limited only by vehicle size and tonnage on the pad, in more logical increments:

@CUSTOMBARNKIT
{

!VAB{}// We nuke the old VAB.

VAB
{
	levels = 3
	upgradesVisual = 1, 2,  3
	upgrades = 50000, 75000, 112500
	actionGroupsStockUnlock = 2
	actionGroupsCustomUnlock = 3
	partCountLimit = -1, -1, -1
}

//------------------------------------------------

!LAUNCHPAD{}// We nuke the old LAUNCHPAD

LAUNCHPAD
{
	levels = 6
	upgradesVisual = 1, 1, 2, 2, 3, 3
	upgrades = 50000, 75000, 112500, 168750, 253125, 379688
	craftMassLimit = 18, 45, 145, 400, 1200, -1
	craftSizeLimit
		{
			size = 15, 20, 15 //width, height, length Level 1 Start
			size = 22.5, 30, 22.5 //width, height, length Level 2
			size = 33.8, 45, 33.8 //width, height, length Level 3
			size = 50.6, 67.5, 50.6 //width, height, length Level 4
			size = 75, 100, 75 //width, height, length Level 5
			size = -1, -1, -1 //width, height, length Level 6
		}
		useBuilding = false
}

//------------------------------------------------

}
//END OF FILE

This makes you have a launch pad that goes:

18 tonnes (20m height) START
45 tonnes (30m height) Level 2
145 tonnes (45m height) Level 3
400 tonnes (67.5m height) Level 4
1200 tonnes (100m height) Level 5
UNLIMITED UNLIMITED Level 6

Link to comment
Share on other sites

  • 2 months later...

Does CBK work with 1.10? I use it with Bureaucracy but in-game values for upgraded buildings are a weird mix of both. VAB for example:

CBK - VAB
	{
		levels = 3
		upgradesVisual = 1, 2, 3
		upgrades = 56000, 225000, 845000
		partCountLimit = 30, 255, -1
	}

BUREAUCRACY - @VAB
    {
        @levels = 5
        @upgradesVisual = 1, 1, 2, 2, 3
        @upgrades = 56000, 112000, 224000, 448000, 896000
        @partCountLimit = 30, 60, 120, 240, -1
    }   

What I get in-game for the first upgrade: cost 450000, parts 120. 

Or Mission Control

CBK -	MISSION
	{
		levels = 3
		upgradesVisual = 1, 2, 3
		upgrades = 19000, 75000, 282000
		activeContractsLimit = 2, 7, -1
	}

BUREAUCRACY -    @MISSION
    {
        @levels = 4
        @upgradesVisual = 1, 2, 2, 3
        @upgrades = 19000, 38000, 76000, 152000
        @activeContractsLimit = 2, 4, 8, -1
    }

In game first upgrade - cost 150000, active contracts - 8

In my KSP log I see that Bureaucracy values are applied correctly, so it seems that the game or CBK do not interpret them correctly. 

 

Link to comment
Share on other sites

Was looking through KSP.log again and found this:

[ERR 16:37:17.401] Exception handling event onNewGameLevelLoadRequestWasSanctionedAndActioned in class CustomBarnKit:System.ArgumentException: The Object you want to instantiate is null.
  at UnityEngine.Object.Instantiate[T] (T original) [0x0003d] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at CustomBarnKit.CustomBarnKit.LoadUpgradesPrices () [0x0015e] in <d1abfd90e526443c9289aaa81ce9b36e>:0 
  at CustomBarnKit.CustomBarnKit.LoadUpgradesPricesSceneChange (GameScenes data) [0x0000d] in <d1abfd90e526443c9289aaa81ce9b36e>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <c1858a3f77504bd1aaa946fdccf84670>:0 

[EXC 16:37:17.402] ArgumentException: The Object you want to instantiate is null.
	UnityEngine.Object.Instantiate[T] (T original) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
	CustomBarnKit.CustomBarnKit.LoadUpgradesPrices () (at <d1abfd90e526443c9289aaa81ce9b36e>:0)
	CustomBarnKit.CustomBarnKit.LoadUpgradesPricesSceneChange (GameScenes data) (at <d1abfd90e526443c9289aaa81ce9b36e>:0)
	EventData`1[T].Fire (T data) (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:LogException(Exception)
	EventData`1:Fire(GameScenes)
	<FireLoadedEvent>d__44:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

These prices from my examples didn't come from any of the configs and this error message says something about setting prices. Maybe it's important. 

Edited by JebIsDeadBaby
Link to comment
Share on other sites

  • 1 month later...
On 8/23/2020 at 5:00 AM, siimav said:

Try redownloading CBK. The latest version had an issue at first but it was fixed a few hours later.

If that still doesn't work then please try reverting to the previous release.

I am having the same issue in science mode with 1.1.21 and 1.1.20 where connectivity does not work, and I also had an issue where I could not EVA or make maneuver nodes.

Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...

I am running KSP 1.8.1 because I have a lot of mods running on that version, one of which is custom barn kits. I ran into an error on a sandbox save and I am checking mod forums to see if someone can help. The mod list  is long  so i wont go into it unless asked, but the error is my building on a sandbox playthrough are max level but will only let me launch vessels that satisfy the buildings level one build limits

Link to comment
Share on other sites

  • 2 weeks later...
On 1/20/2021 at 3:50 PM, justcausebr0 said:

I am running KSP 1.8.1 because I have a lot of mods running on that version, one of which is custom barn kits. I ran into an error on a sandbox save and I am checking mod forums to see if someone can help. The mod list  is long  so i wont go into it unless asked, but the error is my building on a sandbox playthrough are max level but will only let me launch vessels that satisfy the buildings level one build limits

^^^ Look a few posts above yours to find:

deltadart

  • Newbie
  •  
  • deltadart
  • New Members
  • 0
  • 1 post

Ok, first time here. 

I'm currently running ksp 1.8.2, with essentially 2 mods (+their dependancies) :

outer planet mod, 

procedural parts. 

 

so i have a science mode save, and I have that bug saying "EVA not possible, upgrade astro complex first" or equivalently : "can't launch current vessel : design is over x parts" wich shouldn't make sense because science mode. I've searched for clues for a few days but I feel out of options. Of course, right clicking on said buildings lets me know they are fully upgraded. 

 

I've noticed CBK was used by OPM to extend tracking station to a fourth level, wich is really helpfull. Noticing CBK was used to mess with building levels, I removed it from my mods (i use ckan to manage my mods) and, you guessed it, no more bugs. Turned it back on a few game hours later, bug is back.

Running out of other options than coming to beg for help here, well, here I am. 

 

(apologies for not clearly understanding what "logs" are or how can i get them) 

 

Link to comment
Share on other sites

  • 1 month later...
On 10/5/2020 at 6:37 PM, nsgallup said:

I am having the same issue in science mode with 1.1.21 and 1.1.20 where connectivity does not work, and I also had an issue where I could not EVA or make maneuver nodes.

I knew it was a long shot but i was hoping and praying that somehow this mod would work in 1.11, but after testing I get this same bug.  No vessel connectivity; only KSC connectivity. Kerbals will also refuse to take anything but a parachute with them lol.

Link to comment
Share on other sites

18 hours ago, Evco said:

I knew it was a long shot but i was hoping and praying that somehow this mod would work in 1.11, but after testing I get this same bug.  No vessel connectivity; only KSC connectivity. Kerbals will also refuse to take anything but a parachute with them lol.

I am playing in 1.11.1/2 and do not have this issue at all; perhaps it's some interaction with another mod? I've had no such problem even with various planet packs that use CBK differently (add more or fewer levels of DSN, different strategies, etc.)

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...