astecarmyman

Wat's your worst Ksp 1.0 glitch?

Recommended Posts

OddFunction    247

One time, I had an unmanned satellite with all the bells and whistles. I attached an empty cockpit on it for the reaction wheels with a decoupler. When the satellite was in position, i jettisoned the cockpit into space... for about 20 seconds.. and then it comes FLYING straight back at me at like 10,000 m/s and annihilates my satellite. I was blindsided, to say the least.

Your glitch seems to win though LOL

Share this post


Link to post
Share on other sites
astecarmyman    136
One time, I had an unmanned satellite with all the bells and whistles. I attached an empty cockpit on it for the reaction wheels with a decoupler. When the satellite was in position, i jettisoned the cockpit into space... for about 20 seconds.. and then it comes FLYING straight back at me at like 10,000 m/s and annihilates my satellite. I was blindsided, to say the least.

Your glitch seems to win though LOL

jPcYWJ6.png

You cannot comprehend the power of the kraken

Share this post


Link to post
Share on other sites
Vanamonde    6254

Moved to General, since there's no actual gameplay question. :)

Share this post


Link to post
Share on other sites

I seem to always get a crash right as a jet gets near some distant contract target, it is the most frustrating thing ever. Seems to be a result of repeatedly and rapidly switching back and forth between map view and ship view, when I am trying to judge how close I am to the target area..

The screen will start flashing between blue and white horizon effects, and a blown up screen-sized flag image, and ground or smoke textures, then it usually freezes when I try to hit escape or the space center button.. And another 15 or 20 minutes of play down the drain. I've had that happen 4 or 5 times recently, I've started land every couple minutes so the game can autosave, just in case.

Share this post


Link to post
Share on other sites
Jr6150x    22

We've been wrong on orbital mechanics this entire time! Instead of ellipses, orbits are much more squiggly.

Share this post


Link to post
Share on other sites
problemecium    1877

I think the worst glitch I've ever had (and had several times inceidentally) is that on occasion when using more than one Klaw on a ship, e.g. when klawing one ship and then using the klaw on that one to klaw a third ship, KSP throws a NullReferenceException when "packing" the vessel when I try to enter timewarp, causing the ship to fail to disable Physics and instead turn into a wiggly, noodley worm thing and undergo a constant ~1g acceleration that eventually throws it out of orbit.

Share this post


Link to post
Share on other sites
Sandworm    454

The memory leaks. They are hands down the worst bug I've seen from KSP. It's worse than the linux mousewheel bug because we may be stuck with it for months. Squad is tweeting out vacation picks while their just released product contains a documented memory leak. That is shocking.

Share this post


Link to post
Share on other sites
OddFunction    247
The memory leaks. They are hands down the worst bug I've seen from KSP. It's worse than the linux mousewheel bug because we may be stuck with it for months. Squad is tweeting out vacation picks while their just released product contains a documented memory leak. That is shocking.

What if I told you 99% of SQUAD could go on vacation and it would have 0 effect on the speed at which bugs were fixed?

Naw, easier to be dramatic :)

Share this post


Link to post
Share on other sites
Bev7787    247

Note: I'm still running 1.0.0. The "You spin me right round" while re entering due to massless part. (Don't know if it counts as a glitch)

Share this post


Link to post
Share on other sites
5thHorseman    7636
The memory leaks. They are hands down the worst bug I've seen from KSP. It's worse than the linux mousewheel bug because we may be stuck with it for months. Squad is tweeting out vacation picks while their just released product contains a documented memory leak. That is shocking.

Yes it would be much better if they vacationed in private.

Share this post


Link to post
Share on other sites
I seem to always get a crash right as a jet gets near some distant contract target, it is the most frustrating thing ever. Seems to be a result of repeatedly and rapidly switching back and forth between map view and ship view, when I am trying to judge how close I am to the target area..

The screen will start flashing between blue and white horizon effects, and a blown up screen-sized flag image, and ground or smoke textures, then it usually freezes when I try to hit escape or the space center button.. And another 15 or 20 minutes of play down the drain. I've had that happen 4 or 5 times recently, I've started land every couple minutes so the game can autosave, just in case.

I really wish they fixed the target tracking on the Navball when flying around Kerbin. It's so annoying how it moves down low on the ball so you can't see precisely where the point is. Also adding a Navball or compass on EVA would be amazing, showing the current target. Switching between map mode and normal to figure out if your heading in the right direction is so lame.

I've stopped doing surface missions for that reason.

Share this post


Link to post
Share on other sites
Sky_walker    390

Crashes.

Surprisingly enough - I have more of them in 1.0.x than I ever did in Alpha versions.

Share this post


Link to post
Share on other sites
Geschosskopf    4284
Crashes.

Surprisingly enough - I have more of them in 1.0.x than I ever did in Alpha versions.

Yeah, that's what I'm seeing as well. I actually haven't had nearly as many glitches and physics hiccoughs in 1.x. For instance, previously, nearly every time I went to Mun, if I did my transfer burn so that my Ap was about 50km, I'd get about 3/4 of the way to Mun and suddenly the game would burps and I'd have no Mun encounter at all. Then most of the time it would burp again and when I got really close and I'd have the encounter again. That hasn't happened at all in 1.x.

However, crashes happen all the time, and usually seem related to the heat gauges on F10. If those things are active for any period of time, the game just suddenly dies. It's especially annoying when you've struggled to get an SSTO up high enough and now it's coasting to Ap with heat gauges in numerous places and flickering engines, and then POOF, no game. So I'm having to train myself to hit F10 to turn off the heat gauges as a prophylactic measure as part of my takeoff checklist. T, Z, space, F10.

The other main annoyance I have is that when I revert something to the SPH or VAB, most times no parts show up. To be able to add parts to the ship, I have to leave the SPH/VAB to the KSC view and come back. Dunno if this is a KSP thing or a mod thing, though.

Share this post


Link to post
Share on other sites
Nansuchao    476

Fake terrain...

A couple of days ago, with my first long range spaceplanes, I successfully landed on Laythe, very short of fuel, but with a ISRU and a drill in the payload bay.

After the refuel operation, trying to take off, the plane sunk in the ground and suddenly exploded... That was very sad.

Share this post


Link to post
Share on other sites
RogalDorn    11
Fake terrain...

A couple of days ago, with my first long range spaceplanes, I successfully landed on Laythe, very short of fuel, but with a ISRU and a drill in the payload bay.

After the refuel operation, trying to take off, the plane sunk in the ground and suddenly exploded... That was very sad.

"F5 for Safety!"

As for me it was when I did my very first launch with a flea lander in the Kerbal Grasslands. Poor Jeb freaked out on his ladder and flew into the center of Kerbin never to be heard from again. I restarted the campaign immediately as I never thought I would need to F5 a flea launch from KSP...

Overall, 1.0 and the subsequent patches have been 100% stable on my rig. But I am the only person I think who actually plays completely vanilla stock KSP, so that's probably why...

Share this post


Link to post
Share on other sites
klgraham1013    2495

Apparently, if you even look at the rover wheel tweakables, your brakes may or may not work. Disaster may ensue.

Share this post


Link to post
Share on other sites

I played vanilla with only mechjeb for the tricky maneuvers I sucked at, I never had a glitch like that. btw, I recommend KIS, It's like KAS but much better and easier to use!

Share this post


Link to post
Share on other sites
Tobyz28    30

#1 Constant Crashes from memory leaks :(. Had a plane saved in orbit that needed to be landed... (the last of my crew was on it) on re-entry game would fall on its face every single time :T

#2 Imaginary Terrain landing on Bop (or maybe it was Pol?) ... was approaching the ground, a couple KM from the ground WHAM Ship explodes in mid air from a collision with invisible terrain. Reloaded from an F5, WhAM roughly the same place. 3rd try, descended REALLY slow and managed to land.

#3 VAB went bonkers. Designed a fancy dancy rocket (quite a lot of time in it) did some undo/redo combination... couldnt click on parts properly... hit save on the ship - all buttons greyed out :( Closed KSP, loaded my ship and it was buggy as hell(wouldnt let me click anything, shows all parts out of the staging on the right (even though they were solid in the VAB), had to start from scratch again.

Ran into so many more glitches, unbalances etc... been playing KSP since almost the very start, never seen it this buggy... I hope squad has a good vacation and comes back going bonkers on polishing the game for a month or 3....

Share this post


Link to post
Share on other sites
CrazyJebGuy    21
Yeah, that's what I'm seeing as well. I actually haven't had nearly as many glitches and physics hiccoughs in 1.x. For instance, previously, nearly every time I went to Mun, if I did my transfer burn so that my Ap was about 50km, I'd get about 3/4 of the way to Mun and suddenly the game would burps and I'd have no Mun encounter at all. Then most of the time it would burp again and when I got really close and I'd have the encounter again. That hasn't happened at all in 1.x.

However, crashes happen all the time, and usually seem related to the heat gauges on F10. If those things are active for any period of time, the game just suddenly dies. It's especially annoying when you've struggled to get an SSTO up high enough and now it's coasting to Ap with heat gauges in numerous places and flickering engines, and then POOF, no game. So I'm having to train myself to hit F10 to turn off the heat gauges as a prophylactic measure as part of my takeoff checklist. T, Z, space, F10.

The other main annoyance I have is that when I revert something to the SPH or VAB, most times no parts show up. To be able to add parts to the ship, I have to leave the SPH/VAB to the KSC view and come back. Dunno if this is a KSP thing or a mod thing, though.

I have had more bugs on this version than on Alpha or Beta. I actually prefer 0.90. (Too bad steam deleted my backup save)

1# With FAR (I know about far, but this I have no clue) I could not enter the VAB, I could not leave the R & D, the game crashed after I exited the runway, the SPH would not let me in. I did not try the other buildings.

2# I had a half built satellite in the VAB. I went to continue it but 9 parts could not be clicked on and were invisible.

3# A crazy plane I built ripped itself up on the runway. (Engines turned off) It was small! Then one half decided the do a U turn and bugger off. All while dropping landing gear through the ground into the water table.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now