Jump to content

[1.12.x] Mk2 Expansion v1.9.1 [update 10/5/21]


SuicidalInsanity
 Share

Recommended Posts

On 1/19/2021 at 9:02 PM, Mossconfig said:

Could you allow ckan to install the most recent versions on lower verions? This mod works on my 1.8 install, but ckan throws errors.

You can tell CKAN to allow mods from newer versions, which you can easily do to install a parts pack that's likely to work anyway. Then you can report a github issue to CKAN so they can update the metadata.

On 1/24/2021 at 3:31 PM, steelthunder said:

Hello I am stuck trying to get in the game and it looks like its this mod. Im on the latest KSP patch (GOG owner), here is a screenshot of where its hanging:

You need to follow the instructions at

- a screenshot tells the mod author very little.

Link to comment
Share on other sites

  • 2 weeks later...

Idea:

If the Rontogen can use intake air as fuel, as the concept of a thermal jet would imply the possibility, why can't it have 2 modes: intake air and liquid fuel (and maybe an afterburner mode with LFO)? It would be a great ssto engine!

unknown.png

 

Edit: also I feel like it needs a small buff in order for it to be usefull if it stays as is, but not too much to make it OP. Maybe increasing required intake significantly but bumping thrust to 170-200?

Edited by RedRoyal25
Added another suggestion.
Link to comment
Share on other sites

  • 2 months later...

Hi SuicidalInsanity, As I seem to have the latest version of your great mod and I jumped to the end of the forum post, I am assuming this hasn't been suggested. Your Mk2 endcap hatch is something I had wanted for a long time. The ability to put a door pretty much anywhere on a model. But I found I couldn't get out it, only in. I fixed this in my game by giving the config file a link to the simplist "Internal" model I had access to. A small inline passenger can made by "Kerbonov". So as a suggestion I was wondering If you could  create for your model a very simple "Internal" so that others could get in and out as well. A simple dark space or if you are feeling creative. A small airlock interior. Thanks for your time and for sharing your amazing work with us all.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I'm getting some errors for part textures missing. I'm guessing a KSP update has deprecated some legacy textures, which this was relying on? Should I just delete the legacy folders from Mk2 Expansion?

Example:

[LOG 22:53:46.159] PartLoader: Compiling Part 'Mk2Expansion/Parts/Aero/Chines/Legacy/RLong/M2X_RootChineLong'
[ERR 22:53:46.160] PartCompiler: Cannot replace texture 'Wings' as cannot find texture 'Squad/Parts/Aero/wings/Legacy/Wings' to replace with

Log: https://www.dropbox.com/s/6itdrww8zmrw4t2/KSP.log?dl=0

Link to comment
Share on other sites

11 hours ago, John007qwe said:

Hi, I'm getting some errors for part textures missing. I'm guessing a KSP update has deprecated some legacy textures, which this was relying on? Should I just delete the legacy folders from Mk2 Expansion?

Example:

[LOG 22:53:46.159] PartLoader: Compiling Part 'Mk2Expansion/Parts/Aero/Chines/Legacy/RLong/M2X_RootChineLong'
[ERR 22:53:46.160] PartCompiler: Cannot replace texture 'Wings' as cannot find texture 'Squad/Parts/Aero/wings/Legacy/Wings' to replace with

Log: https://www.dropbox.com/s/6itdrww8zmrw4t2/KSP.log?dl=0

Have you still got the folder/ file structure from your previous MK2 Expansion? I found refrence to the missing chines in the example craft when I first loaded Mk2 Expansion. So I went and simply repaired all the where to find and texture links in the config files. It's because the Author went from fixed shape to configurable ones. As for Wings texture. simply copy the current "Wings.dds" or "Wings.png", whatever you have ,into the folder that the pathway states it is looking for it. If the Legacy folder doesn't exist for you just create the folder in Squad/Parts/Aero/Wings. The program will only look where it is told for something. It won't go looking in other folders for it. Hope this helps.

Link to comment
Share on other sites

1 hour ago, ColdJ said:

Have you still got the folder/ file structure from your previous MK2 Expansion? I found refrence to the missing chines in the example craft when I first loaded Mk2 Expansion. So I went and simply repaired all the where to find and texture links in the config files. It's because the Author went from fixed shape to configurable ones. As for Wings texture. simply copy the current "Wings.dds" or "Wings.png", whatever you have ,into the folder that the pathway states it is looking for it. If the Legacy folder doesn't exist for you just create the folder in Squad/Parts/Aero/Wings. The program will only look where it is told for something. It won't go looking in other folders for it. Hope this helps.

Not sure what you mean by previous Mk2, I just have the files that comes with the ckan download, which contains a Chines/Legacy folder. The Wings.dds is just a white pixel. Do you mean I'm supposed to take the squad Aero/Wings/Wings.dds and copy it into a new folder called Aero/Wings/Legacy in the squad folder?

Link to comment
Share on other sites

  • 2 weeks later...
On 4/22/2021 at 9:12 PM, John007qwe said:

Not sure what you mean by previous Mk2, I just have the files that comes with the ckan download, which contains a Chines/Legacy folder. The Wings.dds is just a white pixel. Do you mean I'm supposed to take the squad Aero/Wings/Wings.dds and copy it into a new folder called Aero/Wings/Legacy in the squad folder?

Oops, sorry, missed the notification. A lot of Authors use a system where a simple pixel in the same folder as the cfg file named to the texture file the program is looking for, is there as a sort of place holder. In the actual config file it will have a texture designator like this.

texture = Wings, Squad/Parts/Aero/wings/Wings

 

The "Wings" before the comma is the pixel named Wings in the same folder. The next part tells the program where in the folder structure the actual texture is located.

So if your config said something like.

texture = Wings, Squad/Legacy/Parts/Aero/wings/Wings

or

texture = Wings, Squad/Parts/Legacy/Aero/wings/Wings

or any other combination

Then amending it to the first example, in the cfg file, to where there is a texture file called "Wings" will mean the cfg will look in the right place.

Sorry so late, you have probably already worked it out by now. Hopefully this will be of some help to someone.

 

 

 

 

Link to comment
Share on other sites

  • 3 weeks later...

Sorry about the delay, and apologies for the inconvenience. M2X V 1.9 is now up, grab it from SpaceDock | GitHub
ChangeLog:

KSP 1.11.x update
-New Part: Mk2 cargo container
-Mk2 adapter endcap now has internal model defined
-fixes chine texture url issue
-Adds Cargo/Inventory part functionality
-Adds System Heat compatibility MM patch
-Adds optional MM patch to add dual-cycle option to Rontgen Nuclear Jet

The dual cycle rontgen patch can be found in M2X-1.9/Extras/Mk2Expansion/patches, and is strictly worse than the dedicated nuclear rocket by design.

Edited by SuicidalInsanity
Link to comment
Share on other sites

25 minutes ago, SuicidalInsanity said:

M2X V 1.9 is now up

Thanks for your great work. my craft are so much better with your mod.

Edited by ColdJ
Link to comment
Share on other sites

  • 5 weeks later...

Just open them in Paint.net , invert the colour and then darken the image. Save as the name with a Capital N or B at the end before the fullstop. then add a part variant parameter to the end of the config file before the last bracket.

Link to comment
Share on other sites

1 hour ago, SuicidalInsanity said:

Which engines? Mk2/3 use stock texture maps, so if those have been removed/replaced somewhere, the engines will show up as white

With SXT I am having to update the batch file I provide which restores missing textures.  Looks like 6 or so were removed.

Edited by linuxgurugamer
Link to comment
Share on other sites

On 7/6/2021 at 10:38 AM, SuicidalInsanity said:

Which engines? Mk2/3 use stock texture maps, so if those have been removed/replaced somewhere, the engines will show up as white

The Aerospike engines, Mattock, and the MK3 one with two raptor looking engines that shoot blue circle flames. Sorry can’t remember the name of it. But the MK3 aerospike’s too

Link to comment
Share on other sites

Something I notice while building a SSTO.  When you use a MK2 expansion mod cockpit, such as the supersonic one and connect a stock Kerbal cabin like the MK2 4 seater one. In the editor you can’t put Kerbals in the cabin because the cabin doesn’t appear as an option. Only the supersonic cockpit is an option to put Kerbals in prior to launch. It’s like the supersonic cockpit cuts the rest of the craft off. Because when you try to auto strut to the heaviest part it only goes to the cabin it’s connected to and not the big fuel tank on the craft near the back. Any suggestions?

Link to comment
Share on other sites

3 hours ago, Navyjoker2000 said:

Something I notice while building a SSTO.  When you use a MK2 expansion mod cockpit, such as the supersonic one and connect a stock Kerbal cabin like the MK2 4 seater one. In the editor you can’t put Kerbals in the cabin because the cabin doesn’t appear as an option. Only the supersonic cockpit is an option to put Kerbals in prior to launch. It’s like the supersonic cockpit cuts the rest of the craft off. Because when you try to auto strut to the heaviest part it only goes to the cabin it’s connected to and not the big fuel tank on the craft near the back. Any suggestions?

Which version of KSP are you using? I used mk2 Expansion a lot with 1.10 and earlier and never had the issue you describe. Maybe there's a problem with your installation or maybe there's a new issue in 1.12. Regardless, if you post links to your log files (see directions below) other people can help diagnose your problem.

Link to comment
Share on other sites

11 hours ago, DeadJohn said:

Which version of KSP are you using? I used mk2 Expansion a lot with 1.10 and earlier and never had the issue you describe. Maybe there's a problem with your installation or maybe there's a new issue in 1.12. Regardless, if you post links to your log files (see directions below) other people can help diagnose your problem.

Awesome, thank you I will post the log files when I get home. I’m on 1.12 fresh install. 

Link to comment
Share on other sites

  • 3 weeks later...
2 hours ago, SiCaRiO31 said:

Hello! it seems like the new patch made changed the docking ports textures and as a result, some parts of MK2 Expansion are white (with no texture).

Hi. This following is an example of the model pathway in the Mk2 Expansion Endcap.

    MODEL

    {

        model = Mk2Expansion/Parts/Structural/Endcap/Model

        texture = Cockpit, Squad/Parts/Command/mk2CockpitStandard/Cockpit

        texture = ksp_l_cupola_diff, Squad/Parts/Command/cupola/ksp_l_cupola_diff

    }

Mk2 in a lot of cases points to Stock textures to skin their parts. In the above the where it says texture =  The  "Cockpit" and the "ksp_l_cupola_diff" that are before the comma and after the = are dummy textures that are used as place holders for the folder pathway that is after the comma. So you can see that the real textures are in Squad folders. When Squad changes it's folder structure then the pathway is no longer correct and the config can't find the textures. It does not go searching for them. So you either need to go look in an older version of KSP for the correct texture files and recreate their folder structure or you need to put the texture files in the same folder as the Mk2 config file replacing the dummy files and then as an example either simply remove the texture = lines out of the model subsection or rewrite the path as in this example that is specific for this config.

    MODEL

    {

        model = Mk2Expansion/Parts/Structural/Endcap/Model

        texture = Mk2Expansion/Parts/Structural/Endcap/Cockpit

        texture =Mk2Expansion/Parts/Structural/Endcap/ksp_l_cupola_diff

    }

Hope this helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...