Jump to content

[1.12.x] Mk2 Expansion v1.9.1 [update 10/5/21]


SuicidalInsanity
 Share

Recommended Posts

Alright, been a while, and for that I apologize. Many thanks to Araym and others for helping support the mod in my absence.
Update 1.9.1 is (finally) now up, which fixes the various texture issues that KSP 1.1.2 introduced - grab from SpaceDock or GitHub.
Changelog:
-Part Rework: fixes Aligned Docking port missing texture
-Part Rework: fixes shrouded docking port missing texture
-Fixes missing texture on Whirligig engine
-Fixes missing texture on Vector engine
-Fixes missing texture on MATTOCk engine
-Fixes missing texture on Mongrel engine
-Fixes missing texture on Service bay
-Fixes mesh issue on Engine Shroud
-Fixes spotlights on SC-TD cockpit

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
1 hour ago, baldamundo said:

Great mod, but has anyone got a workaround for symmetry on the modular chine segments? attaching them to the nodes, and the symmetry always gets loveed up

 

You'll have to change the default orientation of the part, which means you have to take an extra step or 2 to orient it when you place it, but that will help with node-attaching things after.

Rotate it so that the face that it attaches with is toward the ceiling, and the normally visible V faces are to the floor. That is, if its orientation is X+, change it to Z+/-. This might be all that you need to do.

Spoiler

Semi-related: Heat Control's graphene radiators need the same treatment. The triangle one's rotation is annoyingly asymmetric when placed and you have to break symmetry to fix it.

 

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
On 1/6/2022 at 10:19 AM, desert said:

I have added Waterfall configs for liquid-fuel engines.

Just checking if these updated Waterfall configs are included in the latest version of the MK2 Expansion download via CKAN and elsewhere? Or do I need to get these from GitHub?

Link to comment
Share on other sites

18 hours ago, scottadges said:

Just checking if these updated Waterfall configs are included in the latest version of the MK2 Expansion download via CKAN and elsewhere? Or do I need to get these from GitHub?

It is currently a pull request waiting to be approved by @SuicidalInsanity , so it's not in CKAN or GitHub yet. But I've released it as downloadable file for those who don't want to wait: https://github.com/Tagir-1/Mk2Expansion/releases/tag/v0.1

Link to comment
Share on other sites

  • 2 weeks later...
8 hours ago, Nazalassa said:

Would be cool if we had an inline ISRU and drill.

Stockalike Mining Expansion (also made by SuicidalInsanity) does have at least an inline drill, and if i am not mistaken, an inline mk2 ISRU

Link to comment
Share on other sites

  • 2 weeks later...

Sup @SuicidalInsanity
The Mk2 engines seem to be ignoring crossfeed rules.
 

eg if the part tree goes:

Rockomax x200-16 fuel tank <-- Hydraulic Detachment Manifold <-- Mk2 Rocket Fuel Fuselage short <-- any M2X rocket engine

The fuel in the Mk2 fuel tank will be used up first, but then instead of the engine flaming out, it will begin to consume the fuel in the Rockomax tank. 
I've checked that crossfeed is turned off on the detachment manifold, and also checked that other (non-M2X) engines work correctly.

Link to comment
Share on other sites

  • 2 weeks later...

I'm running into issues with the Nuclear Reactor and NFE/SystemHeat integration - the reactor is throwing a NaN error an does not produce any heat, and the description lists waste heat production as "-500 kW". Trying to use it in conjunction with other parts results in a crash. Is this a known problem?

13vjus.jpg2scjf7.jpg

EDIT:

@SuicidalInsanity

Looking at the patches for SystemHeat integration, none of the nuclear engines or the reactor appear to have any heat generation entries. Is this intended?

Edited by krautbernd12
Link to comment
Share on other sites

  • 2 weeks later...

The most obvious answer to this question is that you have not put the folders in the right place inside the GameData folder. Configs look at at very specific file path. If you have them in the wrong place they can't load them and nothing turns up. Check that you have unzipped into the correct place. Look at the model path of a config using a text editor. GameData is assumed and so won't be in the path but the pathway will show where it should be within that folder structure.

Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...

Does anyone know how to get the RPM MFDs to work in the Fishhead?

I noticed two things:

1) The TunaCockpit is the only one missing an "internal_RPM" file, and

2) In M2X_RPM_ASET.cfg, TunaCockpit is the only one missing a config.

I added 

@PART[*]:HAS[@INTERNAL[TunaCockpit]]:NEEDS[ASET]:Final
{
	@INTERNAL 
	{
		@name = TunaCockpitASET
	}
}

But all that did was break the IVA such that you can't even go internal at all anymore.

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
15 minutes ago, Kerbal410 said:

how do I access the prebuilt craft? where do I put that folder?

Not the folder. You copy the craft files into your save folder.

For example

C:\KSP1.12.2\Kerbal Space Program\saves\Zap\Ships\SPH\

Zap being the name of my save file..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...