SuicidalInsanity

[1.6.X] Mk2 Expansion v1.8.3.5 [update 1/212019]

Recommended Posts

59 minutes ago, SuicidalInsanity said:

First off, thanks for the video, I know what's going on now. Short answer, you're using an outdated version of M2X, and need at least the most recent version of the NFE patch (below). Long answer, earlier versions of M2X's NFE patch lacked an exhaustCooling value, which is why the Heat Rejected value for your Rontgen stays at 80kw instead of 880kw at full throttle. Replace the contents of your Mk2Expansion/Patches/Mk2X_NFE_Functionality.cfg with this

 

Updated the mod and now works like a charm. Thank you!

Share this post


Link to post
Share on other sites

I'm diggin' all the pieces of this.  Just made a Predator drone looking 2 seater with the on-edge cockpit and a couple inverters to complete my most recent contract to use the Bansee VTOL fans, and they worked a charm, only question I had is if there's a setting I can tweak somewhere to make them a little quieter.  They were far louder than any other engine or set of engines, including launch rockets. Almost thought my sound cut out when I turned them off to switch to just an afterburner, but even at full power, the sound didn't compare.  Thanks!

Share this post


Link to post
Share on other sites

I've been working on a tweakscale addon and checking mod parts, I did a pull request with alot of updates to the tweakscale config.  

  • Like 1

Share this post


Link to post
Share on other sites

Just wanna say what i LOVE this mod!  :)

Today i go to space with "hyperblast" scramjet and monopropelant only. Veeeerrrry interesting to build scramjet vessels!!!!  :cool:

Tooo bad stock parts not give us a chanse for scramjet ;.;

f825ddb12e33.png

 

a18b06f2f7d0.png

 

  • Like 1

Share this post


Link to post
Share on other sites

What happened to the Spadetail, it doesn't appear to be in the latest pack

Never mind, i found it.

I wanted to use it as a nose, for a Kuchemann style shovel nose.

Which it doesn't work very well for, so I settled on the standard Hypersonic nose.

Could you consider making a shovel nose variant?

It would fit well with your Scramjet.

Kuchemann_Tau.jpg

Edited by Nothalogh
  • Like 1

Share this post


Link to post
Share on other sites

I didn't have any luck in the KSPI-E thread so I'm also posting it here. KSP Interstellar Extended disables the nuclear jet. How do you re-enable that?

Share this post


Link to post
Share on other sites

@Fireheart318: Just tested the Rontgen with KSPI-E installed and had no issues with it, nor could I find anything that would disable it when I looked through the KSPI-E patches and code; can you describe the issue in more detail?

@Nothalogh: Easy enough. Gave me an excuse to redo the nosecap as well.
kSDQBK1.png

With the nosecap reworks in mind, looking through the M2X part lineup there's a range of quality between the older stuff and the new, and there's likely time to rework a few other parts before the KSP 1.3 update comes out. Are there any parts people would like to see given preference/priority for reworks/remodels?

Edited by SuicidalInsanity
  • Like 6

Share this post


Link to post
Share on other sites
On 4/13/2017 at 0:51 AM, SuicidalInsanity said:

@Fireheart318: Just tested the Rontgen with KSPI-E installed and had no issues with it, nor could I find anything that would disable it when I looked through the KSPI-E patches and code; can you describe the issue in more detail?

@Nothalogh: Easy enough. Gave me an excuse to redo the nosecap as well.
kSDQBK1.png

With the nosecap reworks in mind, looking through the M2X part lineup there's a range of quality between the older stuff and the new, and there's likely time to rework a few other parts before the KSP 1.3 update comes out. Are there any parts people would like to see given preference/priority for reworks/remodels?

Oh, that's beautiful.

Now to play airbreathing interplanetary lawndarts in style

  • Like 3

Share this post


Link to post
Share on other sites
46 minutes ago, Nothalogh said:

Are there any parts people would like to see given preference/priority for reworks/remodels?

I think the Scramjet's  intake box could stand to me lengthened some.

Also, a hypersonic friendly cockpit could be made from the Mk2 crew tank, this fits with the reality of sustained hypersonic flight, bubble cockpits and forward facing windows are somewhere between pointless and suicidal.

Perhaps just config a dronecore into a copy of the crewtank?

Share this post


Link to post
Share on other sites

Has this been reported? Does anyone have any fixes? CB-C cockpit.

ln9iALA.png

Share this post


Link to post
Share on other sites

Chines are broken when used with symmetry. They symmetry fine, but they dont rotate, so the chine on the right is fine, but the left is pointing the same way, thus shoing the flat side and the pointy bit sticking into the fuselage!

Share this post


Link to post
Share on other sites

How compatible is this with RO (realfuels) and RSS thrust/curves?

Share this post


Link to post
Share on other sites
On ‎1‎.‎5‎.‎2017 at 9:17 PM, kiwinanday said:

Has this been reported? Does anyone have any fixes? CB-C cockpit.

It looks like you're using this with prerelease version(1.2.9) of KSP.

Share this post


Link to post
Share on other sites
8 hours ago, sebi.zzr said:

It looks like you're using this with prerelease version(1.2.9) of KSP.

Steam is supposed to keep my KSP up to date. Dunno how I scored a prerelease (insane amount of hours spent playing notwithstanding)

Share this post


Link to post
Share on other sites
42 minutes ago, kiwinanday said:

Steam is supposed to keep my KSP up to date. Dunno how I scored a prerelease (insane amount of hours spent playing notwithstanding)

Having it set to use the newest beta version of your game is how you got the pre-release.  I see it as an option, too, but I've opted out for now.

Share this post


Link to post
Share on other sites

@kiwinanday: That looks like a RasterPropMonitor issue, as it adds the HUD element that's glitching there; RPM probabl;y hasn't been compiled for it yet.

@"Landed.at.Jool": Chine symmetry is a known issue. When attaching then via their attach nodes, use Radial symmetry, not Mirror - Mirror works for the initial chine segment, though.

@JeeF: RSS/RO compatibility? M2X tanks should be RealFuel compatible/enabled, but I'll have to double check, things might have changed since the last time I looked. M2X doesn't have a RSS calibrated thrust/engine curves patch, but someone did write a compatibility patch, though to the best of my knowledge it hasn't been updated in some time. The RSS/RO thread might know more.

Share this post


Link to post
Share on other sites

@Krakatoa @SuicidalInsanity I reinstalled the latest RPM (0.28.1, April 28th 2017), but still having the issue. Running KSP 1.2.2.1622

EDIT: When I tested the HV Mk2-1, I got the same visual, but noticed this text at the top:

tS3KqUH.png

Edited by kiwinanday

Share this post


Link to post
Share on other sites

Hey @SuicidalInsanity. I'd like to make a small request of you. I'm in need of a Mk2 long cabin for my mod, Airline Kuisine. May I have person to use and redistribute the model from the M2X science lab? Or can I give you reference images and ask you to make a custom long cabin? I don't need an IVA, just working lights and a custom layout for the glass portions.

Share this post


Link to post
Share on other sites

@kiwinanday: I've looked into the issue, and it looks like you're using a legacy version of ASET props, which could explain why its not playing nice with the latest RPM. Since the latest version of ASET props breaks even more stuff, the M2X ASET IVAS will be getting reworks

@jadeofMaar: You can use the scilab, but keep in mind it's getting a remodel for the next M2X update which may cause some issues if you're using a MODEL reference for the Kuisine part. If you'd prefer a custom model, that should be easy enough since an IVA isn't involved, just sent me a message with the reference images you want used.

  • Like 1

Share this post


Link to post
Share on other sites
27 minutes ago, SuicidalInsanity said:

@jadeofMaar: You can use the scilab, but keep in mind it's getting a remodel for the next M2X update which may cause some issues if you're using a MODEL reference for the Kuisine part. If you'd prefer a custom model, that should be easy enough since an IVA isn't involved, just sent me a message with the reference images you want used.

Do forgive me if my already going ahead is a problem. It shouldn't be, granted your license :) (but I copied the model itself. As much as I adore M2X, I can't have the entirety of a large mod be a dependency for just one part. Airline Kuisine doesn't seek to add to M2X). And I made sure to credit you. You can see what I did with the current model here: 

v9rQe2d.jpg

Now I'm really interested, knowing that a new model is coming for the lab. I'll be using it as much as possible versus the hulking stock lab when I return to my science game.

 

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites

3 suggestions:

  1. There should be conventional rockets (I.E. Skipper, Mainsail, Reliant, Swivel, etc. but in MK2 form). Sure, there's the aerospike, and the hybrid engines, but that's as far as it goes.
  2. Speaking of hybrid engines, it would be nice to have a hybrid engine with alternators. It would help a lot, especially for drones.
  3. The jet engines should have more power, or make one with more power. I'm trying to make an tail sitter, but It's not powerful enough to lift off on it's own with the jet engines.

Thanks for reading, and even more thanks if you follow my suggestions.

Share this post


Link to post
Share on other sites

I'm not sure why, but whenever I use any of the parts from this Mod, The ship I plan on launching, is super glued to the runway.  Eventual, if I wait long enough, the ship will slowly be crushed by an unknown force (as if gravity was on 1000 times normal) and of course the ship blows up.  I'm not sure what "logs" you would need to see this error, or if screen shots (or video) would help.  This may have to do with the post earlier about miss configuration, or possibly with Tweekscale, but I'm not sure.

Any help would be great, as I love this mod, and all of the wonderful parts it adds.

Any chance of picking up this piece and add it to the collection?

Thanks again.

Share this post


Link to post
Share on other sites

@Talvid: Almost certainly an interaction of some sort with another mod. The only thing that I can think of offhand that would cause that sort of behavior is if there's something causing negative mass somewhere; If I recall correctly the tweakscale MM patch needs some updates, so tweakscale might be at fault here. If you try with Tweakscale temporarily removed, does the problem persist? The log used for debugging is the Kerbal Space Program/ KSP_Data(or KSP-x64_Data if using the 64 bit version)/output_log.txt.
For nupols Mk2 part, I'm going to have to say no, because landing legs are absolutely unfun to work with in 1.2.2.

Share this post


Link to post
Share on other sites

Looked around and can't remember if I asked or not (memory not what it was).  I can't seem to get any thrust out of the 'Pluto" engine in orbit.  Get lovely plume and firing sound, but orbit doesn't change.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now