SuicidalInsanity

[1.6.X] Mk2 Expansion v1.8.3.5 [update 1/212019]

Recommended Posts

3 minutes ago, SuicidalInsanity said:

The M3X inline cockpit doesn't even have an IVA yet, but when it gets finished it will have both a standard and RPM IVA.

 

awesome, I thought I messed something up because I have been adjusting my RPM stuff all day.

Share this post


Link to post
Share on other sites
6 hours ago, SuicidalInsanity said:

@DaveLChgo: Found the error - When recompiling parts to fix their specular shaders, the Sledgehammer got exported as Model.mu instead of model.mu causing KSP's loader to skip it (Caps sensitive code strikes again!). A fixed version of 1.8 has been re-uploaded to the usual locations.
Alternatively, if you don't want to re-DL the whole thing,  go to Mk2Expansion/Parts/Engines/AugmentedRocket and open up the Part.cfg. Change "model = Mk2Expansion/Parts/Engines/AugmentedRocket/model" to "model = Mk2Expansion/Parts/Engines/AugmentedRocket/Model"

Awesome work finding the cause of the error so quickly,  gotta love those syntax errors.  But at least its a simple fix once its figured out.   I couldn't figure out the name difference to even start tracing the cause.  M2X augmented rocket is the sledge hammer....  who knew.

 

Thanks again.

Share this post


Link to post
Share on other sites

Just found a couple issues - the radial banshee seems to have something wrong with it's surface attachment, and it's missing a node for in-line attachment too.

And the blade cockpit's leftmost window's front point has s 'missing' patch of mesh or something, and the hatch window has some gaps around it too...
A9RxWAB.png

Share this post


Link to post
Share on other sites

I swear I read something somewhere that said a VTOL engine in this mod now runs on electriccharge. Is that true? Which one is it?

Also, if you could make all the parts radial-mounting options, it would be great. The ones I really want are the Rontgen, structural fuselages, science lab, and large crew cabin

Share this post


Link to post
Share on other sites

@rodger, whale_2: M2X 1.8.02 is now up, which fixes the problems you're having.

@Fireheart318: The Banshee fans have come with optional MM patches (Mk2Expansion-X.XX.X/Extras/Mk2Expansion/Patches) that convert them to run on either LF/Air or Ec instead of the default LF/O since 1.7.25.

 

  • Like 2

Share this post


Link to post
Share on other sites
On 09/09/2017 at 11:11 PM, SuicidalInsanity said:

The M3X inline cockpit doesn't even have an IVA yet, but when it gets finished it will have both a standard and RPM IVA.

 

If it's not yet underway, can I suggest a bridge-type IVA, ala Star Trek's USS Enterprise, where the main pilot sits in a central chair? That'd be awesome!

Share this post


Link to post
Share on other sites
On 9/13/2017 at 5:23 AM, SuicidalInsanity said:

@rodger, whale_2: M2X 1.8.02 is now up, which fixes the problems you're having.

@Fireheart318: The Banshee fans have come with optional MM patches (Mk2Expansion-X.XX.X/Extras/Mk2Expansion/Patches) that convert them to run on either LF/Air or Ec instead of the default LF/O since 1.7.25.

 

Thanks, @SuicidalInsanity, looks nicely now!

Share this post


Link to post
Share on other sites
On 9/13/2017 at 2:57 PM, Bluastrid said:

If it's not yet underway, can I suggest a bridge-type IVA, ala Star Trek's USS Enterprise, where the main pilot sits in a central chair? That'd be awesome!

I think the Hypersonic cockpit has one like that.

 

Maybe use that as a placeholder instead of nothing at all?

Share this post


Link to post
Share on other sites

Hi there! I'm currently having some problems with installing your MK2 Expansion Mod and it appears to not load in as I don't see it anywhere in my game or in the Space Hangar, I have tried Sandbox mode to see if they appear there and they don't seem to be there as well. I have downloaded the latest version of this mod and have followed its instructions as I put the proper files in the game data folder and I have Module Manager 2.8.1 installed at the moment. 

Output Log  

 

Share this post


Link to post
Share on other sites
5 hours ago, Bungthebadger said:

I'm currently having some problems

Your link seems to be broken. If it's on MediaFire then I guess the new forum software censors it more strongly. please post it elsewhere so it can be seen.

Share this post


Link to post
Share on other sites
3 minutes ago, Bungthebadger said:

Here's a proper download link since previous didn't work.

https://mega.nz/#!0BU2RY7a!tL9y90xis0PGPL8qnKiJ2iiiZ46Q9qJRFd0-H5lvTUA 

I took a quick glance at your log, it has a lot of lines like this:

 

PartCompiler: Cannot clone model 'Mk2Expansion/Parts/Utility/RCS/SCModule' as model does not exist
...
PartCompiler: Cannot clone model 'Mk2Expansion/Parts/Structural/StructuralTube/Model' as model does not exist

I guess that mod was not installed correctly. For instance, do you have the file GameData/Mk2Expansion/Parts/Structural/StructuralTube/Model.mu ?

Share this post


Link to post
Share on other sites

Well, I fixed the problem which was much more simple than I thought it would be. I read the "Readme" installation guide wrong since it said to put it in the Gamedata directory and I put it in the Gamedata directory into where my Gamedata folder is as well and I put the mod and dependencies in just the directory that fixed the problem. Sorry for bothering you guys. :( Well, thank you for helping, I appreciate it.

I also must say that this mod is quite great and really adds a lot to do in the Space Hanger. I think some of this deserves to be in stock as well.  

Edited by Bungthebadger
To make it sound better.
  • Like 1

Share this post


Link to post
Share on other sites

@SuicidalInsanity I've just discovered a crippling problem. The current version of Interstellar Fuel Switch breaks IntakeAtm (at least for me) and starves off any air-breathing engine used in atmosphere other than Kerbin.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites

That's incredibly odd. Testing on my end with the latest (2.9.3) version of IFS shows everything functioning normally - IFS shouldn't have anything to do with IntakeAtm, at least to the extent Mk2 Expansion makes use of it. Are you using the full version of IFS, or just the core IFS plugin? Can you post an Output_log?

Share this post


Link to post
Share on other sites
15 hours ago, SuicidalInsanity said:

That's incredibly odd. Testing on my end with the latest (2.9.3) version of IFS shows everything functioning normally - IFS shouldn't have anything to do with IntakeAtm, at least to the extent Mk2 Expansion makes use of it. Are you using the full version of IFS, or just the core IFS plugin? Can you post an Output_log?

Disregard my post. :blush: I just checked the latest version. I'm bothered now that I even had that problem.

Share this post


Link to post
Share on other sites

I have some bug reports to submit for this mod.

Version used : 1.8.02

Other Mods:

4a50625616.png

First issue: 3 engines have identical name and descriptions 43c3c81cd1.jpg

Spoiler

29fa015cf5.png

 

Second Issue, both air augmented SRBs do not add jettison option to staging when Ticking "Jettison Staged" and will jettison when the engine is activated via staging.

Third issue: Many of the stock blueprints do not load citing missing parts from the mod.

 

Great mod by the way I love every bit of it, just wish I could find more mods with stockalike asethetics and parts that aren't restricted to the Mk2 form factor like air augmented rocket engines, fission reactors, and the rontgen nuclear engine. Also any chance of giving the banshee lift fan a mode switch like the Edgar engines have? I love having an electric propulsion option for in atmosphere for those kerbin surveys but flying with these lift fans stuck in an orientation is less than ideal, though not sure how to set up rotating on two axis, front to back and side to side.

Edit: reposting this in dev thread now that I've seen it

Edited by Marxon
Remove post, replacing it in proper thread.

Share this post


Link to post
Share on other sites

@Marxon: The duplicate names is a a localization error, easy to fix. The lack of a second staging icon is due to parts getting only one, and clicking jettison staged means it does exactly what is says - it will jettison when the part is activated via staging. The way to use the AASRBS is either have them set to not staged and jettison via action group, or set to staged, activate them via action group, and jettison them via staging.

For the third issue, I'm going to need a list of stock craft that are affected, and ideally, what parts they are allegedly missing, because that shouldn't be happening at all; M2X does nothing to modify default stock craft.



 

Share this post


Link to post
Share on other sites
20 hours ago, SuicidalInsanity said:

@Marxon: The duplicate names is a a localization error, easy to fix. The lack of a second staging icon is due to parts getting only one, and clicking jettison staged means it does exactly what is says - it will jettison when the part is activated via staging. The way to use the AASRBS is either have them set to not staged and jettison via action group, or set to staged, activate them via action group, and jettison them via staging.

For the third issue, I'm going to need a list of stock craft that are affected, and ideally, what parts they are allegedly missing, because that shouldn't be happening at all; M2X does nothing to modify default stock craft.



 

The stocks are the ones in your mod only, I'll look into which ones.

 

 

Share this post


Link to post
Share on other sites

@robson1000: That's due to Interstellar Fuel Switch not grabbing the referenced localization text from the localization dictionary, but instead just grabbing the reference string itself from the part's config file when displaying variants in the mouse-over info display in the parts menu. Parts that have been placed in the SPH/VAB display the correct localized part variant names in the right-click menu.

Edited by SuicidalInsanity

Share this post


Link to post
Share on other sites

There's something wrong with the Banshee lift fan. It produces the same amount of thrust on Eve as it does on Kerbin:

9s57jLA.png

Eve's atmosphere is 5 times as dense as Kerbin's, so shouldn't the fan produce 5 times more thrust since it's an aerodynamic device and not a rocket or jet engine? The mass flow through the fan is 5 times greater on Eve too, but somehow it's still producing the same thrust.

Edited by CaptainKorhonen
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now