SuicidalInsanity

Mk3 Expansion - [KSP 1.7] Version 1.4.8 [4/23/19]

Recommended Posts

5 hours ago, JH4C said:

 

Issues with CKAN should usually be directed at the CKAN devs.

The NetKAN file for this mod is configured to pull from Spacedock. No errors on testing the zip directly from there.

Looks like it's already been reported in the CKAN thread, so I guess we'll have to wait.

Share this post


Link to post
Share on other sites

I assume you mean stuck on loading?

Please provide a complete log file (see my sig for a link)

Share this post


Link to post
Share on other sites
2 hours ago, KerbalValkyrie said:

So I'm having problems with MK3 Expansion. I have version 1.4.2 and it's stuck on a certain part. The part is MK3 Augumented Rocket/Part/MK3x_Augumented Rocket. Help.

You almost certainly don't have CommunityResourcePack installed, which is bundled with M3X and is a dependency.

Share this post


Link to post
Share on other sites
2 hours ago, SuicidalInsanity said:

Those of you with CKAN issues, those have been solved and CKAN installations should work now.

aye, ty! I assume the patched update should apply soon™

Share this post


Link to post
Share on other sites
On 11/19/2018 at 7:36 PM, SuicidalInsanity said:

Those of you with CKAN issues, those have been solved and CKAN installations should work now.

I wasnt able to update via ckan still. seems ckan didnt like the mk3x tweakscale patch, and error'd out.

I suppose its not a big deal tho..I just uninstalled the mod, purged the folder from gamedata, and reinstalled, case closed lol.

Share this post


Link to post
Share on other sites

FWIW M3X_FuelTankSwitch.cfg had M3X_XHub listed twice causing:

 

[EXC 06:16:43.570] Exception: Conflict found between ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub and ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub:
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: Oxidizer
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()

 

Share this post


Link to post
Share on other sites
3 hours ago, BrotherCavalier said:

FWIW M3X_FuelTankSwitch.cfg had M3X_XHub listed twice causing:

 


[EXC 06:16:43.570] Exception: Conflict found between ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub and ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub:
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: Oxidizer
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()

 

That error was fixed quite a while ago; I know, I found and reported it. Make sure you're using the latest version of the add-on.

Share this post


Link to post
Share on other sites
4 hours ago, BrotherCavalier said:

There is a newer version than  1.4.7.3 ? It wa the latest release I saw on gethub.

No, that's the latest version. My version's out of date; I think I skipped a couple because they only fixed problems I didn't have or had already fixed myself. Sorry about that!

To beat this bug (again), just change one of the XHub references into an LHub reference instead and that'll not only shut B9 up but also restore functionality you currently lack in the other part.

@SuicidalInsanity looks like a file got rolled back?

Share this post


Link to post
Share on other sites

I've been having a bit of an issue with the MK-3 X adapter. it immediately crashes with the following message.

B9PartSwitch - Fatal Error

Conflict between Module B9 Part Switch on part M3X.XHub

2 Modules cannot manage the same resource: Liquid Fuel.

2 Modules cannot manage the same resource: Liquid Fuel.

2 Modules cannot manage the same resource: Oxidizer

 

I also found this excerpt in the log. If you need the full file, you'll have to teach me how to upload the full thing without doing a copy-paste. This thing doesn't like doing the copy-paste when it's the full log. It just crashes.

[LOG 19:28:57.121] [Part M3X.XHub] [ModuleB9PartSwitch 'fuelSwitch'] Inferred subtype based on part's resources: 'LiquidFuel/Oxidizer'
[LOG 19:28:57.121] [Part M3X.XHub] [ModuleB9PartSwitch 'fuelSwitch'] Inferred subtype based on part's resources: 'LiquidFuel/Oxidizer'
[WRN 19:28:57.127] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[EXC 19:28:57.127] Exception: Conflict found between ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub and ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub:
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: Oxidizer
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()
[EXC 19:28:57.127] Exception: Conflict found between ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub and ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub:
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: Oxidizer
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()
[LOG 19:31:42.056] [UIApp] OnDestroy: EngineersReport
[LOG 19:31:42.056] ScaleModList: listSize 82 maxListSize 804

Share this post


Link to post
Share on other sites
13 hours ago, ExplodingExplorer said:

I've been having a bit of an issue with the MK-3 X adapter. it immediately crashes with the following message.

B9PartSwitch - Fatal Error

Conflict between Module B9 Part Switch on part M3X.XHub

2 Modules cannot manage the same resource: Liquid Fuel.

2 Modules cannot manage the same resource: Liquid Fuel.

2 Modules cannot manage the same resource: Oxidizer

 

I also found this excerpt in the log. If you need the full file, you'll have to teach me how to upload the full thing without doing a copy-paste. This thing doesn't like doing the copy-paste when it's the full log. It just crashes.

[LOG 19:28:57.121] [Part M3X.XHub] [ModuleB9PartSwitch 'fuelSwitch'] Inferred subtype based on part's resources: 'LiquidFuel/Oxidizer'
[LOG 19:28:57.121] [Part M3X.XHub] [ModuleB9PartSwitch 'fuelSwitch'] Inferred subtype based on part's resources: 'LiquidFuel/Oxidizer'
[WRN 19:28:57.127] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[EXC 19:28:57.127] Exception: Conflict found between ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub and ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub:
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: Oxidizer
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()
[EXC 19:28:57.127] Exception: Conflict found between ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub and ModuleB9PartSwitch (moduleID='fuelSwitch') on part M3X.XHub:
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: LiquidFuel
  Two modules cannot manage the same resource: Oxidizer
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()
[LOG 19:31:42.056] [UIApp] OnDestroy: EngineersReport
[LOG 19:31:42.056] ScaleModList: listSize 82 maxListSize 804

Are you using the most current version of M3X? This bug was squashed almost as soon as it first appeared, although it did make a comeback as can be seen in the posts above yours, which also explain how to fix it.

As for posting the log, you don't cut & paste it onto the forum because yes, it'll kill everything. Use something like pastebin or dropbox or whatever to host it, then post a link - but hopefully in this case that won't be required.

Share this post


Link to post
Share on other sites

are the mk3 ramp compatibe with tweakscale?

 

Share this post


Link to post
Share on other sites

the "Firestorm - Air Augmented Rocket" says it's more efficient in atmosphere, but has the same ISP and fuel consumption for both air-breathing an closed-cycle modes?

How is it more efficient in atmosphere, if at all?

Thanks in advance for any replies :) 

Share this post


Link to post
Share on other sites

BGYT - M3X comes with a TweakScale patch, so yes, the ramps are TS compatible. Because TS comes with a (very outdated) M3X patch of its own, you'll want to delete that to prevent it overriding the up-to-date M3X one; the old patch to be deleted can be found in GameData/TweakScale/patches/Mk3X_TweakScale.cfg.

RB101 - Firestorm atmo ISP scales with mach, as noted in the bottom of the description, with a max ISP of ~ 800 around mach 3. Since dynamic ISP scaling isn't taken into account when the game displays infocard data in the editor, it lists both modes as being the same.

Edited by SuicidalInsanity

Share this post


Link to post
Share on other sites

M3X 1.4.7.5 : SpaceDock - GitHub
Because the only change from the previous version is updating a few parts bulkhead profiles, I've also put together a MM patch for those of you who don't want to download a whole new update:

Spoiler

//adds missing bulkhead profiles
@PART[M3X_HeavySRB]
{
    %bulkheadProfiles = mk3
}
@PART[M3X_Size2Bicoupler]
{
    bulkheadProfiles = size2, mk3
}

 

Share this post


Link to post
Share on other sites
On 11/19/2018 at 1:33 PM, SuicidalInsanity said:

You almost certainly don't have CommunityResourcePack installed, which is bundled with M3X and is a dependency.

I can tell you this is  most definately -not- nececarily the issue, as I have it installed, and it stalls out there, meaning there is potentially a conflict with another mod as well since I have other mods, but it stalls on the exact same spot, and I double checked, the community resource pack was installed. *Note this is from installing both via Ckan, so I do realise now there -is- the chance Ckan messed it up somehow, but still.*

Edited by Ryusho
*note about ckan*

Share this post


Link to post
Share on other sites

Without additional info - output_log/KSPLog would be ideal - I am left best guessing the cause/solution based on previous error causes; the majority of hangups with loading this mod has come from missing dependencies, almost always CRP, which is why I gave the diagnosis I did.

Share this post


Link to post
Share on other sites

There's a minor problem with the Apoapsis Industries agency added by this mod. The large version of the flag displays fine, but the smaller version (AI_scaled) shows in-game as just a black rectangle.

Share this post


Link to post
Share on other sites

M3X Update 1.4.8 - SpaceDock | GitHub
Changelog:

Spoiler

-Fixes tweakscale patch, no longer conflicts with TS's M3X patch
-Hubs now have stack symmetry
-Fixes scaled flag for agency contracts
-Fixes missing bulkhead profiles
-Adds Whitelist for ReStock compatibility
-Fixes OMS engine white texture

 

Share this post


Link to post
Share on other sites

Is anyone having the oms engine load with an all white engine bell?? Is that what its supposed to be?? Thought itd be black or greyish. Looks like its not loading a texture. The base with rcs ports looks fine

Share this post


Link to post
Share on other sites
On 4/23/2019 at 12:14 PM, SuicidalInsanity said:

M3X Update 1.4.8 - SpaceDock | GitHub
Changelog:

  Hide contents


-Fixes OMS engine white texture

 

Can you confirm texture path?? I still have a white texture for the oms engine bell. I keep mk3x uptodate via ckan which I open daily. Im not at my pc currently..but im fairly certain I have v1.4.8.

Share this post


Link to post
Share on other sites
1 hour ago, Jesusthebird said:

Can you confirm texture path?? I still have a white texture for the oms engine bell. I keep mk3x uptodate via ckan which I open daily. Im not at my pc currently..but im fairly certain I have v1.4.8.

The texture exists in the path specified in the omsEngine.cfg file. The problem is it's a deprecated part, so the texture cannot be accessed for use by the mod. There is something special about the Squad/zDeprecated tree that prevents using assets in the path.

I worked around it by copying the texture to my personal patches directory and edited omsEngine.cfg to point to the new location.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.