Jump to content

Space Shuttle Pack for ksp 1.0.4 dev thread


Recommended Posts

I have not yet explored past those trusses but I have had help from JoseEduardo with a bunch of cfg edits he gave me as a starting point.

Is there still node issues on my release or is that how it has always been?

Thanks

- - - Updated - - -

Also has anyone had a copy of the iss from the person who says he has fixed it all on this page : http://forum.kerbalspaceprogram.com/threads/81754-Release-BobCat-Ind-Space-Planet-products/page107

- - - Updated - - -

Would be a good plan to merge our releases...?

Oh I am sorry! Yea there are still node attachment issues. The Mir docking ports both male and female. All of the Docking ports that come with the ISS. Finally I Think many of the attachment nodes on the MIR parts. I suppose its safe to assume these are similar all over the packs including the soyuz. Im sorry again. I didn't read. All I saw was ISS release. The trusses look wonderful. I have not tested them in game yet. Sorry for jumping the gun. My recommendations would be that you tackle the node issues next.

Link to post
Share on other sites
Oh I am sorry! Yea there are still node attachment issues. The Mir docking ports both male and female. All of the Docking ports that come with the ISS. Finally I Think many of the attachment nodes on the MIR parts. I suppose its safe to assume these are similar all over the packs including the soyuz. Im sorry again. I didn't read. All I saw was ISS release. The trusses look wonderful. I have not tested them in game yet. Sorry for jumping the gun. My recommendations would be that you tackle the node issues next.

Thank you good sir.

I will have fun joining the parts one by one in the VAB. Figuring out how it goes together and solve all the node issues and update tonight.

Link to post
Share on other sites

call me a noob. ive been on hiatus since .20. anyway theres no craft file(s) i see in the download. everythings changed so much i just put the space shuttle folder in ksp 1.0.4. game data folder. even ran a search and found no .craft files. am i missing something?

Link to post
Share on other sites
Oh I am sorry! Yea there are still node attachment issues. The Mir docking ports both male and female. All of the Docking ports that come with the ISS. Finally I Think many of the attachment nodes on the MIR parts. I suppose its safe to assume these are similar all over the packs including the soyuz. Im sorry again. I didn't read. All I saw was ISS release. The trusses look wonderful. I have not tested them in game yet. Sorry for jumping the gun. My recommendations would be that you tackle the node issues next.

Exactly which docking ports from ISS? I haven't downloaded the pack from Mike yet because I prefer simple stations such as Mir and Salyut, but the files I sent to Mike had CBM fixed, PMA commented out in the docking module (but they used to work just fine), and, the only one which I have no idea if it is working or not (mostly because I never use it), is the truss docking port, which I did mess with but didn't test beyond VAB...

as for the Mir ones, if Mike wants I can send him my copy of the Mir pack so he can merge in the release, I made for personal use (and somehow got rid of the Kvant experiment and only realized that a few days ago, but didn't bother to fix it as it is for personal use) but it's quite good to go, with nodes fixed, Mir core as a working Lab, Mechjeb support (don't recall which parts though as I use MJ for all parts with command modules) and CLS support... there might be other stuff that I don't recall now...

Link to post
Share on other sites
Exactly which docking ports from ISS? I haven't downloaded the pack from Mike yet because I prefer simple stations such as Mir and Salyut, but the files I sent to Mike had CBM fixed, PMA commented out in the docking module (but they used to work just fine), and, the only one which I have no idea if it is working or not (mostly because I never use it), is the truss docking port, which I did mess with but didn't test beyond VAB...

as for the Mir ones, if Mike wants I can send him my copy of the Mir pack so he can merge in the release, I made for personal use (and somehow got rid of the Kvant experiment and only realized that a few days ago, but didn't bother to fix it as it is for personal use) but it's quite good to go, with nodes fixed, Mir core as a working Lab, Mechjeb support (don't recall which parts though as I use MJ for all parts with command modules) and CLS support... there might be other stuff that I don't recall now...

Honestly Im not sure its was the docking ports attachment nodes or the attachment nodes on the modules. Mike said earlier that he hadn't gotten to the modules yet to most likely its the atthment nodes on the modules. However one of the APAS attach and the other doesn't. There are two in the VAB. I am not sure which one goes with which pack however one of them attaches and the other doesn't. This leads me back to thinking that its possible that the attachment nodes need a once over look to make sure they are al working.

Link to post
Share on other sites
call me a noob. ive been on hiatus since .20. anyway theres no craft file(s) i see in the download. everythings changed so much i just put the space shuttle folder in ksp 1.0.4. game data folder. even ran a search and found no .craft files. am i missing something?

Welcome back!!! Open up the folder that you downloaded called "Space Shuttle 1.7.3" You will see two craft files. They are labeled .craft. You cant miss them.

h0jlF5z.png

Throw them in the VAB Folder in the Ships Folder.

bQQ2XDB.png

haSS7yl.png

- - - Updated - - -

We should all pool together and buy that ISS model. LOL!

I totally agree!!!

Link to post
Share on other sites

How did the sections join anyway? Thete are no mention of dockings in the cfg's so I put them in. And they have control from here also now.

- - - Updated - - -

Exactly which docking ports from ISS? I haven't downloaded the pack from Mike yet because I prefer simple stations such as Mir and Salyut, but the files I sent to Mike had CBM fixed, PMA commented out in the docking module (but they used to work just fine), and, the only one which I have no idea if it is working or not (mostly because I never use it), is the truss docking port, which I did mess with but didn't test beyond VAB...

as for the Mir ones, if Mike wants I can send him my copy of the Mir pack so he can merge in the release, I made for personal use (and somehow got rid of the Kvant experiment and only realized that a few days ago, but didn't bother to fix it as it is for personal use) but it's quite good to go, with nodes fixed, Mir core as a working Lab, Mechjeb support (don't recall which parts though as I use MJ for all parts with command modules) and CLS support... there might be other stuff that I don't recall now...

If you could send them I would be happy.

Link to post
Share on other sites
How did the sections join anyway? Thete are no mention of dockings in the cfg's so I put them in. And they have control from here also now.

What do you mean? Are you talking about the trusses? There were truss docking ports. They were shaped like the end of the trusses. From what I recall in my experience useing them in the past. There was no way of telling which side was the docking side and the attachment side. So on numerous occasions I would send the segment all the way to station only for it not to connect because I put the docking port on wrong. I was noob at the time. Perhaps Dragon took them away because they were frustrating. If you are talking about the modules they go together with the array of docking ports that come in the pack. APAS, CBM, etc.

Link to post
Share on other sites
call me a noob. ive been on hiatus since .20. anyway theres no craft file(s) i see in the download. everythings changed so much i just put the space shuttle folder in ksp 1.0.4. game data folder. even ran a search and found no .craft files. am i missing something?

Version 1.7.3.1 latest on page 1 has no crafy file yet

Names have changed for some parts so the old craft file wont work.

I need to make crafts for Enterprise, onepiece, dreamer and the same for the RO version.

Ran out of time yesterday.

- - - Updated - - -

We should all pool together and buy that ISS model. LOL!

O could splash out and buy ot but ksp wpuld drop its performance so bad with it

- - - Updated - - -

Ok so the plan is this:

1. Get the iss functioning, now that we have the s5p5 truss section, this will include the russian parts also.

may include remodel of the Zarya panel

so nodes and core functions.

2. Once one is completed, start work on beautifying the iss. One part at a time.

In such a way that updates will not require rebuilding or damaging any current iss builds in game. Parts will just auto upgrade. Hopefully.

And also add any additional functions. KIS etc

- - - Updated - - -

What do you mean? Are you talking about the trusses? There were truss docking ports. They were shaped like the end of the trusses. From what I recall in my experience useing them in the past. There was no way of telling which side was the docking side and the attachment side. So on numerous occasions I would send the segment all the way to station only for it not to connect because I put the docking port on wrong. I was noob at the time. Perhaps Dragon took them away because they were frustrating. If you are talking about the modules they go together with the array of docking ports that come in the pack. APAS, CBM, etc.

So extra parts made to look like they are part of the truss. I have it built in now. So the trusses have an invisible port on each end

Link to post
Share on other sites
Welcome back!!! Open up the folder that you downloaded called "Space Shuttle 1.7.3" You will see two craft files. They are labeled .craft. You cant miss them.

http://i.imgur.com/h0jlF5z.png

Throw them in the VAB Folder in the Ships Folder.

http://i.imgur.com/bQQ2XDB.png

http://i.imgur.com/haSS7yl.png

- - - Updated - - -

I totally agree!!!

well im using google chrome canary. just assuming maybe i need firefox? ive downloaded both the space shuttle with extras and the space shuttle downloads and there are no craft files anywhere in either. its not even labled as you showed. it just says "space-shuttle". i click on that and all is is gamedata folder, licenses, 2 txt docs and a readme doc. thank you for the reply too :)

Link to post
Share on other sites

Yes as I said I didnt include one because I ran out of time.

I can post a link tonight. I am at work for a few more hours.

Its not hard to make anyway I think. If you want to you can just see what it looks like in the pictures on page one and try to copy that while you wait for the new craft file

- - - Updated - - -

.

Is it really that hard to build...?

Have a go you might have fun building it...

Link to post
Share on other sites
oh ok mike sorry, missed your post. i see now. no worries take your time! just glad to know the problem wasnt on my end. ill check back time to time and thank you!

Its ok check back in about 3 hours.

Not sure where we are all at so I thaught I might as well mention.

Craft files are basically a save file for a built ship.

If you build one in the VAB and click save you make a craft file.

It is not NEEDED for the mod to work it just means you dont have my saved ship to load up ingame.

However you can still put it together yourself in the VAB.

Link to post
Share on other sites
Aren't those SRBs from that SLS mod someone was working on?

They are from the Spice Launch System mod. Mike got permission and has modified them to fit with the shuttle. He changed the color and scaled them down quite a bit.

Link to post
Share on other sites

Because the .craft files aren't present, I went ahead and built it myself and ran into a couple of problems. When I add the SRB nose cones, there is a gap between the bottom of the nose cone and the top of the SRB. Also, the SRBs do no have solid fuel. When I tried to launch the first time, the SRBs did not fire because they had no fuel. I reverted and took another look and sure enough, the tooltip for the SRBs do not show any solid fuel in them. This is when I downloaded the full version of your addon, so I thought maybe there was a bug in the SRB in that package, so I went ahead and got rid of the mod and downloaded the minimal package with just the orbiter but I'm having the same problem.

Link to post
Share on other sites
Its ok check back in about 3 hours.

Not sure where we are all at so I thaught I might as well mention.

Craft files are basically a save file for a built ship.

If you build one in the VAB and click save you make a craft file.

It is not NEEDED for the mod to work it just means you dont have my saved ship to load up ingame.

However you can still put it together yourself in the VAB.

oh ok lol well ill try that then. that should have been a big duh. i remember doing that very same thing before .20 on the original component shuttle. thats how long its been for me! work.. and moved to kansas city. thanks again mike i surely will check back!

Link to post
Share on other sites
oh ok lol well ill try that then. that should have been a big duh. i remember doing that very same thing before .20 on the original component shuttle. thats how long its been for me! work.. and moved to kansas city. thanks again mike i surely will check back!

Yes few hours I will upload

- - - Updated - - -

Because the .craft files aren't present, I went ahead and built it myself and ran into a couple of problems. When I add the SRB nose cones, there is a gap between the bottom of the nose cone and the top of the SRB. Also, the SRBs do no have solid fuel. When I tried to launch the first time, the SRBs did not fire because they had no fuel. I reverted and took another look and sure enough, the tooltip for the SRBs do not show any solid fuel in them. This is when I downloaded the full version of your addon, so I thought maybe there was a bug in the SRB in that package, so I went ahead and got rid of the mod and downloaded the minimal package with just the orbiter but I'm having the same problem.

Ok I understand you are using realism overhaul. I noticed these problems but must if forgot whel I realised I should upload what I have done knowing I only have 2 hours I can sleep before get up for work.

Its the ro configs. Its hard to test all aspects everytime edits are done on 2 installs running 2 different modsets on each and make sure both stock and modded work alongside with the iss and keep it compatible. I do miss things sometimes. These are huge mods to do alone and keep updated constantly during changes.

But I will do what I can.

Feedback is key here.

thanks

Link to post
Share on other sites
Yes few hours I will upload

- - - Updated - - -

Ok I understand you are using realism overhaul. I noticed these problems but must if forgot whel I realised I should upload what I have done knowing I only have 2 hours I can sleep before get up for work.

Its the ro configs. Its hard to test all aspects everytime edits are done on 2 installs running 2 different modsets on each and make sure both stock and modded work alongside with the iss and keep it compatible. I do miss things sometimes. These are huge mods to do alone and keep updated constantly during changes.

But I will do what I can.

Feedback is key here.

thanks

ok so i dont see the parts of the shuttle in the parts list of either the vab or sph.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...