Papa_Joe

[1.4.x] Connected Living Space v1.2.6.2 (13 Jun 2018)

Recommended Posts

32 minutes ago, Kerbas_ad_astra said:

-snip-

OK... :D
The way you had it worded, and my slip in reading comprehension, I thought BOTH files were removed (implying support for the parts was removed all together)...
But thanks for the clarification on the filenames.. Thats a good bit to know for future reference... ;)

Edited by Stone Blue

Share this post


Link to post
Share on other sites
On 22.3.2016 at 2:55 AM, Papa_Joe said:

Ok, new release.

release v1.2.0.2
* New:  Added Changes to configurations based on conversations in forums and a Pull Requests by Technologicat, khr15714n &  Kerbas-ad-astra.
* Fixed:  Correct build deploy automation to project (missing icons for blizzy). 
* Fixed:  CLS tweakables incorrectly visible when custom passability is disabled.
 

On SpaceDock and Github

Looking forward to KSP 1.1.  Soon now...

Congrats for the release!

Minor issue detected: the download URL in ConnectedLivingSpace.version points to KerbalStuff, although the hosting has been moved to the new SpaceDock. Maybe

"DOWNLOAD":"http://spacedock.info/mod/190/Connected%20Living%20Space",

?

Share this post


Link to post
Share on other sites
43 minutes ago, Technologicat said:

Congrats for the release!

Minor issue detected: the download URL in ConnectedLivingSpace.version points to KerbalStuff, although the hosting has been moved to the new SpaceDock. Maybe


"DOWNLOAD":"http://spacedock.info/mod/190/Connected%20Living%20Space",

?

Thanks.   I updated the version and the server copy correctly but forgot the link on the distribution copy.....

 

Edited by Papa_Joe

Share this post


Link to post
Share on other sites

Dunno if this is still relevant, but about the duplicate stock toolbar button bug, I think stupid_chris posted something relevant in the thread for KSP 1.1. (See that post and a few posts back.)

EDIT: ...unless you already read about it, didn't notice you posting in the thread when I posted this :)

Edited by Technologicat

Share this post


Link to post
Share on other sites
On 3/31/2016 at 5:43 PM, Technologicat said:

Dunno if this is still relevant, but about the duplicate stock toolbar button bug, I think stupid_chris posted something relevant in the thread for KSP 1.1. (See that post and a few posts back.)

EDIT: ...unless you already read about it, didn't notice you posting in the thread when I posted this :)

Thanks.   I do have the work around AND the original event handler in place, so it's possible this is causing the double icons.   this is also in SM so probably there too.   

In other news,  I've just gotten a past a particularly difficult time.   I'm now back and focusing on KSP again.   Tough times are past now.  I've converted my account to steam (I resisted as long as I could)  and I'm working on getting a working build.   I'm trying to work thru the changes to screen messages so we can properly report our actions when cls is involved with stock transfers...  More to come.

  • Like 3

Share this post


Link to post
Share on other sites
2 hours ago, Papa_Joe said:

Thanks.   I do have the work around AND the original event handler in place, so it's possible this is causing the double icons.   this is also in SM so probably there too.   

In other news,  I've just gotten a past a particularly difficult time.   I'm now back and focusing on KSP again.   Tough times are past now.  I've converted my account to steam (I resisted as long as I could)  and I'm working on getting a working build.   I'm trying to work thru the changes to screen messages so we can properly report our actions when cls is involved with stock transfers...  More to come.

Good news, glad you're in a better place. Looking forward to new builds, thanks!

Share this post


Link to post
Share on other sites
19 hours ago, Papa_Joe said:

Thanks.   I do have the work around AND the original event handler in place, so it's possible this is causing the double icons.   this is also in SM so probably there too.

Ok. In any case, it seems this is specific to the stock toolbar - with Blizzy's toolbar it doesn't seem to occur. (I have SM configured to use that and have never seen a duplicate button.) Probably completely different initialization procedure, though :P

 

19 hours ago, Papa_Joe said:

In other news,  I've just gotten a past a particularly difficult time.   I'm now back and focusing on KSP again.   Tough times are past now.  I've converted my account to steam (I resisted as long as I could)  and I'm working on getting a working build.   I'm trying to work thru the changes to screen messages so we can properly report our actions when cls is involved with stock transfers...  More to come.

Glad that you're back.

Yeah, API changes can be a pain. Good luck with the upgrade!

Share this post


Link to post
Share on other sites

Update.   have a working build on 1.1

Stock toolbar button changes icons, but the CLS window does not appear.  working that.

ScreenMessages are a wip with the changes to 1.1.

When I solve the toolbar activation issue, I'll release a prerelease version.  Should be within a few hours.

  • Like 4

Share this post


Link to post
Share on other sites

Really looking forward to including this in my 1.1 install.  Thanks for all you do!

  • Like 1

Share this post


Link to post
Share on other sites

Version 1.2.0.9, KSP compatability update is now live on Git.  I'll be adding to spaceDock momentarily

changelog:
----------
prerelease v 1.2.0.9
* New:  Updated mod for KSP 1.1 compatability.
* New:  Corrected Stock Screen Messages so that they are properly removed when CLS overrides a Stock Crew Transfer.
* Fixed:  CLS would not display a window when the stock Icon was clicked.
* Fixed:  CLS should now only display 1 icon in Editor or flight.  Removed redundant icon call in Start, now that stock buttons now behave as intended.

 

  • Like 2

Share this post


Link to post
Share on other sites

Many thanks for the update!  However, there's still a problem with the release packaging -- there are config files in the repo (e.g. TaurusHCV.cfg) that are not in the download.

  • Like 1

Share this post


Link to post
Share on other sites
12 minutes ago, Kerbas_ad_astra said:

Many thanks for the update!  However, there's still a problem with the release packaging -- there are config files in the repo (e.g. TaurusHCV.cfg) that are not in the download.

I imagine so.  I have a wonky distribution process leftover from when Codepoet was handling it.   I need to rebuild the whole process like I did SM.   I'l be sure to get that corrected before proper release.

 

Share this post


Link to post
Share on other sites

Thank you for the update.

I have one question. I usually have a lot of mods, and I use to have MM files to add CLS to parts for those mods. Should I make a pull request for those files?, right now I have one for MK2 extension, but this number can be increased as I add more mods to my install ;)

  • Like 1

Share this post


Link to post
Share on other sites
On 4/15/2016 at 3:24 PM, KaiserSoze said:

Thank you for the update.

I have one question. I usually have a lot of mods, and I use to have MM files to add CLS to parts for those mods. Should I make a pull request for those files?, right now I have one for MK2 extension, but this number can be increased as I add more mods to my install :wink:

It depends on the changes you have made.   the last distribution omitted one config as posted above.   Changes/additions to MM configs have to be weighed against realism and other factors, so you can submit a PR (in fact that is the preferred method), but please explain in your comments what you are doing and why. 

Thanks!

 

Also, now that 1.1 is official, I'll be revisiting both CLS and SM for updates.

Edited by Papa_Joe

Share this post


Link to post
Share on other sites
On 22/4/2016 at 4:19 AM, Papa_Joe said:

It depends on the changes you have made.   the last distribution omitted one config as posted above.   Changes/additions to MM configs have to be weighed against realism and other factors, so you can submit a PR (in fact that is the preferred method), but please explain in your comments what you are doing and why. 

Thanks!

 

Also, now that 1.1 is official, I'll be revisiting both CLS and SM for updates.

I will do. The explanation will be quite simple: to provide connectivity for parts that either allow kerbals to staty (cabins, etc) or pass (docking ports).

Share this post


Link to post
Share on other sites

@Papa_Joe I found that the API isn't returning any crew when scene is editor, and I noticed the UI isn't displaying any crew either (always in the editor).

I think its related to changes in CMAssignmentDialog: now that class is alive but does nothing, the data is in KSP.UI.CrewAssignmentDialog instead.

Also filed an issue about this here. Cheers and nice work, this is becoming one of favorite mod! :D

  • Like 1

Share this post


Link to post
Share on other sites
On 4/26/2016 at 1:19 PM, ShotgunNinja said:

@Papa_Joe I found that the API isn't returning any crew when scene is editor, and I noticed the UI isn't displaying any crew either (always in the editor).

I think its related to changes in CMAssignmentDialog: now that class is alive but does nothing, the data is in KSP.UI.CrewAssignmentDialog instead.

Also filed an issue about this here. Cheers and nice work, this is becoming one of favorite mod! :D

Thanks.   I take a look at this.

  • Like 1

Share this post


Link to post
Share on other sites

Just tipping in to say thank you to @Papa_Joe for keeping CLS on the road and up to date with 1.1. 

Also I am delighted to see that kerbalism is making use of the CLS concept to link various life support / environmental factors to the design of ships and stations, which is something I always hoped would happen.

I remember the old days of sticking a monoprop tank on top of a mark2 capsule before topping it off with a docking port. These days no-one with even think of doing such a thing!

  • Like 3

Share this post


Link to post
Share on other sites
1 hour ago, codepoet said:

Just tipping in to say thank you to @Papa_Joe for keeping CLS on the road and up to date with 1.1. 

Also I am delighted to see that kerbalism is making use of the CLS concept to link various life support / environmental factors to the design of ships and stations, which is something I always hoped would happen.

I remember the old days of sticking a monoprop tank on top of a mark2 capsule before topping it off with a docking port. These days no-one with even think of doing such a thing!

Thanks for creating such a great mod.   I couldn't conceive of Ship Manifest being without it!

Share this post


Link to post
Share on other sites

Hi!

I have created an cfg File to Support some Parts from Kerbalism Mod.

Maybe you can add this to your next update.

 

CLSKerbalism.cfg

@PART[InlineFoodBig]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
    MODULE
	{
		name = ModuleConnectedLivingSpace
		passable = true
	}
@PART[GravityRing]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
    MODULE
	{
		name = ModuleConnectedLivingSpace
		passable = true
	}
@PART[Greenhouse]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
    MODULE
	{
		name = ModuleConnectedLivingSpace
		passable = true
	}

 

  • Like 1

Share this post


Link to post
Share on other sites

@Papa_Joe

I am experiencing a strange NRE. The mods I used to cause the NRE are the latest dev version of FAR and latest MFI, almost lastest RemoteTech (will be verifying with the latest as well, but am currently assuming the NRE is still present), latest Connected Living Space and latest MM. It seems when placing certain antenna on a vessel connected living space somehow triggers FAR to keep running its update cycle and never finishing it. The strangest part is only some antenna trigger the constant update cycle, but all of them cause the NRE to be thrown. The NRE happens when selecting an antenna from the part list, and the constant updates are triggered after placing the antenna on the vessel. Nothing in my cache/part.cfgs correlates with which antenna trigger the constant updates. I found it easiest to trigger with antennas from the mod BlueDog Design Bureau. I do not expect you to DL part mods to test, but I want to give all relevant details from my testing. I will edit this post when I have tested with the latest RT. If you need more info or me to test dlls LMK. Thank you! Below is the NRE in question and a demo of the updates triggered after snipped for brevity.

Spoiler


NullReferenceException: Object reference not set to an instance of an object
  at ConnectedLivingSpace.CLSAddon.RebuildCLSVessel (.Vessel newVessel) [0x00000] in <filename unknown>:0 

  at ConnectedLivingSpace.CLSAddon.OnVesselWasModified (.Vessel data) [0x00000] in <filename unknown>:0 

  at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0 

  at RemoteTech.Modules.ModuleRTAntenna.AddTransmitter () [0x00000] in <filename unknown>:0 

  at RemoteTech.Modules.ModuleRTAntenna.SetState (Boolean state) [0x00000] in <filename unknown>:0 

  at RemoteTech.Modules.ModuleRTAntenna.OnStart (StartState state) [0x00000] in <filename unknown>:0 

  at Part.ModulesOnStart () [0x00000] in <filename unknown>:0 

  at Part+<Start>c__Iterator25.MoveNext () [0x00000] in <filename unknown>:0 
    
	Updating Untitled Space Craft
	Updating Untitled Space Craft
    Updating Untitled Space Craft
	Updating Untitled Space Craft
    Updating Untitled Space Craft
	Updating Untitled Space Craft
    Updating Untitled Space Craft
	Updating Untitled Space Craft
    Etc...

 

 

Share this post


Link to post
Share on other sites

Thanks.   I'm now taking look at both CLS and Sm. to bring them up to 1.1.2 compliance.  There were a lot of changes from 1.0.5 to 1.1 and then a lot of changes from 1.1 to 1.1.2.

I wanted to wait for the dust to settle, and found a new woman during the break from coding.  The dark days of the past year are definitely behind me now.  WIn WIn!

 

Edited by Papa_Joe
  • Like 8

Share this post


Link to post
Share on other sites

Well I tried 3 different times to edit that post on mobile and had it lockup my browser :mad: . So it still happens with the latest RT. 

Share this post


Link to post
Share on other sites

Wanted to try this out with Kerbalism, but I don't know how compatible it is with 1.1.2. Eagerly awaiting any news on this mod :D

Anyway, congratz on the girlfriend.

Share this post


Link to post
Share on other sites
On 08/05/2016 at 4:23 AM, Budz42 said:

Wanted to try this out with Kerbalism, but I don't know how compatible it is with 1.1.2. Eagerly awaiting any news on this mod :D

Anyway, congratz on the girlfriend.

Yes!!! This please ^^^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now