Avera9eJoe

[1.3+] WindowShine-v16 - Gold foil update (26 December 17)

Recommended Posts

Hello, after some test i discover incompatibility with scatterer + trajectories when this mod installed. In map view there is ocean flickering or other lines when this mod installed. I did created bug reports to this mods first as i thought it was caused by conflict between this two mods, but later i understand that conflict is with WindowShine and not between this two mods. 

Here is screenshots:
https://imgur.com/a/pSq0W

And issues in other mods:
https://github.com/LGhassen/Scatterer/issues/30
https://github.com/neuoy/KSPTrajectories/issues/119

Edited by AlexALX

Share this post


Link to post
Share on other sites
1 hour ago, AlexALX said:

Hello, after some test i discover incompatibility with scatterer + trajectories when this mod installed. In map view there is ocean flickering or other lines when this mod installed. I did created bug reports to this mods first as i thought it was caused by conflict between this two mods, but later i understand that conflict is with WindowShine and not between this two mods. 

Here is screenshots:
https://imgur.com/a/pSq0W

And issues in other mods:
https://github.com/LGhassen/Scatterer/issues/30
https://github.com/neuoy/KSPTrajectories/issues/119

This is a known bug between WindowShine and Scatterer :/ It happens even without trajectories. Doing a quicksave and reloading should fix it. Only other option would be to disable some of the effects in Scatterer. I'm afraid I don't know much about it. @blackrack is aware as well but I don't think it's his todo list. I for one am a tad too busy to look into it much myself right now :P

Share this post


Link to post
Share on other sites
20 minutes ago, Avera9eJoe said:

This is a known bug between WindowShine and Scatterer :/ It happens even without trajectories. Doing a quicksave and reloading should fix it. Only other option would be to disable some of the effects in Scatterer. I'm afraid I don't know much about it. @blackrack is aware as well but I don't think it's his todo list. I for one am a tad too busy to look into it much myself right now :P

Main problem is when trajectories installed and they showing red/white lines (airbrake) then this lag occupts and its very annoying because you can't properly see trajectory with aero brake. And yes without trajectories it still happens in some random cases and this should be fixed somehow. Please contact with addons authors so maybe you will figure out something together.

Share this post


Link to post
Share on other sites

I used to use WindowShine but stopped for awhile due to FPS issues, using it again now and it's kind of hard to say I guess but I feel like some parts aren't working correctly?

The solar panels are reflective enough as well as the Mk1 inline cockpit is just like I remember.

The Cupola though seems very low-res and dull, the Toroidal tanks don't seem reflective at all either. I installed the latest version of TRR and followed all the instructions faithfully.

The install path looks like:

Gamedata>

Squad

WindowShine

TextureReplacerReplaced

000_TRR_Config

ModuleManager.2.8.1.dll

Other random mods that probably have nothing to do with this. (No I don't have Scatterer or Trajectories.)

Are they supposed to be "side by side" like such? Or does the WindowShine "default" folder go in the TRR default folder like some other TRR dependent mods? Does the config file go in the 000TRRConfig folder or something? The instructions seemed to imply that you just throw it in gamedata and call it a day.

Thanks in advance for any thoughts/help.

Edited by Rocket In My Pocket

Share this post


Link to post
Share on other sites
4 hours ago, Rocket In My Pocket said:

I used to use WindowShine but stopped for awhile due to FPS issues, using it again now and it's kind of hard to say I guess but I feel like some parts aren't working correctly?

The solar panels are reflective enough as well as the Mk1 inline cockpit is just like I remember.

The Cupola though seems very low-res and dull, the Toroidal tanks don't seem reflective at all either. I installed the latest version of TRR and followed all the instructions faithfully.

The install path looks like:

Gamedata>

Squad

WindowShine

TextureReplacerReplaced

000_TRR_Config

ModuleManager.2.8.1.dll

Other random mods that probably have nothing to do with this. (No I don't have Scatterer or Trajectories.)

Are they supposed to be "side by side" like such? Or does the WindowShine "default" folder go in the TRR default folder like some other TRR dependent mods? Does the config file go in the 000TRRConfig folder or something? The instructions seemed to imply that you just throw it in gamedata and call it a day.

Thanks in advance for any thoughts/help.

Yo! To install WindowShine right you put ModuleManager.dll floating inside GameData, install TextureReplacerReplaced how it says putting it inside GameData next to ModuleManager, and then install WindowShine next to both MM and TRR. They all sit next to each other. Sorry to hear your cupola module looks so bad.. Could you take a picture and post it here to show what's wrong? As for the toroidal ring, it used to have a very overblown shine to it and I dimmed it down a lot in the most recent release. Do you think it needs more shine?

Share this post


Link to post
Share on other sites
45 minutes ago, Avera9eJoe said:

Yo! To install WindowShine right you put ModuleManager.dll floating inside GameData, install TextureReplacerReplaced how it says putting it inside GameData next to ModuleManager, and then install WindowShine next to both MM and TRR. They all sit next to each other. Sorry to hear your cupola module looks so bad.. Could you take a picture and post it here to show what's wrong? As for the toroidal ring, it used to have a very overblown shine to it and I dimmed it down a lot in the most recent release. Do you think it needs more shine?

Do you think it has anything to do with over all resolution? I just got a new rig and I'm playing at 4k now.

It's very possible the differences I'm noticing are all in my head?

Thanks for the reply, I'll get back to you with some comparison screenshots in a min; I think I still have some old ones from my prior WindowShine install lying around as well.

Here's some comparison shots, I'll put them under the spoiler:

Spoiler

701ADC4BCEEAC63A595556543C511BA8A0C0BB78

Cupola current; Seems very low res/dull. (Even in space during a brightly lit scene, I realize the VAB isn't the best example setting.)

CE6D205929DE95783A73A4E72B6AD75D69396B41

Current inline cockpit looks fine, but the toroidal tank seems to have no reflection what-so-ever. Very matte and flat.

266C316FE77A6C29C844AFE0EFB269FCFB8E107A

Best shot I could find of the old cupola; you can see that reflection in the one window is very bright and crisp.

BD997904C098A50C2855B34C2E7F73BFF72B8572

Old screenshot of toroidal tank, reflection is a bit overblown admittedly but it's clear that there is one.

Here is a pic of my current Gamedata folder as well if that helps you at all.

Spoiler

4zcezgU.png

Awesome mod btw, one of the first that popped into my head when I got KSP installed on my new rig!

Edited by Rocket In My Pocket

Share this post


Link to post
Share on other sites

Huh. Thanks for the screenshots - you've got it installed correctly :) I might have to up the reflection on the cupola and toroidal tanks. I agree they do look pretty flat in those pictures. I don't know when I'll next have time to make a new release though. Thanks for the feedback!

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
10 hours ago, Jalaris said:

@Avera9eJoe Any plans on using Sigma Replacements instead of TRR?

Personally no - I've barely any time on my hands to even update WindowShine in the free time that I have :P That being said though if someone makes a version of WindowShine that uses Sigma Replacements, I'd be happy to link it in the top.

Share this post


Link to post
Share on other sites
12 hours ago, Avera9eJoe said:

Personally no - I've barely any time on my hands to even update WindowShine in the free time that I have :P That being said though if someone makes a version of WindowShine that uses Sigma Replacements, I'd be happy to link it in the top.

Given that SR does not provide reflection I think it wouldn't make much sense. Unless I am missing the purpose of this mod

Share this post


Link to post
Share on other sites
23 hours ago, Jalaris said:

@Avera9eJoe Any plans on using Sigma Replacements instead of TRR?

Why would you use that ?

Sigma Replacements is a collection of mods that currently includes:

  • Sigma Replacements: Heads
  • Sigma Replacements: Suits
  • Sigma Replacements: Navigation
  • Sigma Replacements: Skybox
  • @Jalaris have you seen would fit the bill better

Share this post


Link to post
Share on other sites

Has anyone else noticed that After the last texture replacer replaced, the parts with Windowshine are now see through if a light source hits them?  Noticing I can see all the way into the MKII lander can now if the sun hits it.  You can also see through solar panels.

Share this post


Link to post
Share on other sites

Can somebody make reflection maps for the Feline Utility Rovers by the same guy who made KPBS?

Considering the quality of the mod and how it was made by the guy who made planetary bases, it's really underrated, and deserves proper reflection maps (I'm not able to do these things myself as I'm not a modder, have no artistic skill, etc)

Edited by Pavel ☭

Share this post


Link to post
Share on other sites
26 minutes ago, Pavel ☭ said:

Can somebody make reflection maps for the Feline Utility Rovers by the same guy who made KPBS?

Considering the quality of the mod and how it was made by the guy who made planetary bases, it's really underrated, and deserves proper reflection maps (I'm not able to do these things myself as I'm not a modder, have no artistic skill, etc)

I've seen these before! It's a lovely mod and definitely deserves a set of reflectives, but I'm afraid I don't have the time for it myself sadly.

Share this post


Link to post
Share on other sites
48 minutes ago, Pavel ☭ said:

Can somebody make reflection maps for the Feline Utility Rovers by the same guy who made KPBS?

Considering the quality of the mod and how it was made by the guy who made planetary bases, it's really underrated, and deserves proper reflection maps (I'm not able to do these things myself as I'm not a modder, have no artistic skill, etc)

How about the whole rover ? 

F2eIMpN.pngCome with 3 settings ?
eHAo2Wf.pngnot a good shot of the windows and it's a real quick dirty patch for but it did add reflection to the glass with out TU installed and TRR installed but there was a side effect I could see through the  reflection looking down on front of the pod I could see the tires if you want will post it

Share this post


Link to post
Share on other sites

I would always prefer the hull itself to not shine like it has chrome all over it. Also, it looks almost as if the windows don't shine at all. Maybe because the hull is so much more shiny.

Also, post the thing you said you can post

Edited by Pavel ☭

Share this post


Link to post
Share on other sites
2 minutes ago, Pavel ☭ said:

I would always prefer the hull itself to not shine like it has chrome all over it.

Also, post the thing you said you can post

I have 2 quick and dirty patches one is TRR and one is TU so you can use what ever now these patch will target every thing made by ( author Nils277 )  https://www.dropbox.com/s/blfnj10ntutxib0/TRR_KerbetrotterLtd.zip?dl=0

and https://www.dropbox.com/s/zyzzic49alniqo6/TexturesUnlimited_KerbetrotterLtd.zip?dl=0

It will take some time to do the windows and solar panels with out the dirty patch

Share this post


Link to post
Share on other sites

Hey, I've got a little issue with WS especially in SPH. After some time all text of the UI (craft title, description, buttons and all other text) just disappears. Leaving and entering the SPH fixes it. Less frequent it happens in VAB too.

The log file doesn't show any exceptions or errors, nothing what would determine the culprit. But since I removed WS everything is working fine.

I'm running a ton of visual and informational mods: https://imgur.com/wcogGYi

KSP Version 1.3.1 64bit

System:16GB RAM, 8GB VRAM, I5

Because it's not game breaking I just want to know if anybody experienced the same? Maybe it is just a RAM/GC thing... or a conflict with another mod?

Edited by funk

Share this post


Link to post
Share on other sites
16 hours ago, funk said:

Hey, I've got a little issue with WS especially in SPH. After some time all text of the UI (craft title, description, buttons and all other text) just disappears. Leaving and entering the SPH fixes it. Less frequent it happens in VAB too.

The log file doesn't show any exceptions or errors, nothing what would determine the culprit. But since I removed WS everything is working fine.

I'm running a ton of visual and informational mods: https://imgur.com/wcogGYi

KSP Version 1.3.1 64bit

System:16GB RAM, 8GB VRAM, I5

Because it's not game breaking I just want to know if anybody experienced the same? Maybe it is just a RAM/GC thing... or a conflict with another mod?

Huh... I've never heard that mentioned here before so my guess is it's probably a mod conflicting. Can you post an image of your GameData folder?

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
8 minutes ago, Avera9eJoe said:

Huh... I've never heard that mentioned here before so my guess is it's probably a mod conflicting. Can you post an image of your GameData folder?

Thx for your answer, it's really weird. The link in the post above shows my gamedata folder. WS was already removed but the rest is the same. I'll test it with some mod configurations, but because it's related to time spend, not sure how long it will take.

Edit: Btw I'm remembering now, that the text in map view (AP, PE etc') disappeared too.

Edited by funk

Share this post


Link to post
Share on other sites

I've started getting parts that have this semi-transparent effects.  It only really shows up when the part is in sunlight and I'm looking at it from the lit side.  The parts affected seem to be only stock KSP parts.  Someone on Reddit suggested it was WindowShine, so I uninstalled the mod and that indeed fixed the issue.  Not sure if this is a known bug or not.

Installed Mods

https://imgur.com/uf6qugX

https://imgur.com/HVNkYtI

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.