Jump to content

Can we get some advanced post editing tools?


Pingonaut
 Share

Recommended Posts

Obviously you can bold, italics, create urls, etc. your text on the forum by typing it out, but I'd really like to see buttons for this stuff. It's a simple suggestion, but I'm guessing it'd take a little bit of working to do. How likely is this to happen?

Edit: Okay, well apparently my forum layout isn't the same. Mine looks like below. It's been that way since I joined the forums 3 years ago, on 2 different computers over the years. What's going

Edit 2: Got it fixed, thanks for the help everyone. I came here hoping for the forum to get an update and found out it already existed. That's great!

xBVfiPc.png

Edited by Pingonaut
Link to comment
Share on other sites

Obviously you can bold, italics, create urls, etc. your text on the forum by typing it out, but I'd really like to see buttons for this stuff.

ok so then you want to Italic something, highlight it and click the italic button

Here

HRUwfnT.png

Link to comment
Share on other sites

ok so then you want to Italic something, highlight it and click the italic button

Here

HRUwfnT.png

See also the "Go Advanced" button, if the "Quick Reply" box is insufficiently buttony for your tastes.

Wait, what? Neither quick reply nor advanced reply have those options for me. Mine looks like this, what's up?

xBVfiPc.png

Link to comment
Share on other sites

No. Laptop with Chrome. As I said, 2 different computers. I didn't even know that those options should have been there, as I've never seen them before.

What does your forum main page look like? You may be in Mobile mode somehow.

Link to comment
Share on other sites

This is the main page. Would it have something to do with Chrome? I find it hard to believe both of my computers over the years somehow had been set to mobile mode by default, even from the first time I made an account.

Ymg9SIs.png

Link to comment
Share on other sites

Go to your General Settings, and check which Message Editor Interface you have set.

Yup, that was it. Wow, I can't believe I've gone this long with it this way. Was this the default setting in 2011-2012 or something?

Link to comment
Share on other sites

Whoah. "Advanced" mode is really weird. (In the "General Settings" menu) When you do Ctrl+I for Italics, it doesn't spawn the BBCode for it; rather, you can type directly into the reply box in italic text, as I am doing now.

Same goes for bolded and underlined text.

This is creepy...

EDIT:

Ermegherd. You can also directly insert smilies. :sealed:

Edited by Starwhip
Link to comment
Share on other sites

Whoah. "Advanced" mode is really weird. (In the "General Settings" menu) When you do Ctrl+I for Italics, it doesn't spawn the BBCode for it; rather, you can type directly into the reply box in italic text, as I am doing now.

Same goes for bolded and underlined text.

This is creepy...

EDIT:

Ermegherd. You can also directly insert smilies. :sealed:

Are you sure you're not in WYSIWYG mode? (the A/A button at the top left of the editor).

Link to comment
Share on other sites

Yeah, that's WYSIWYG (What You See Is What You Get) mode. You can enable it for Quick Reply boxes too, depending on your profile setting. I rather like it, but it has one or two irksome bugs.

Link to comment
Share on other sites

Yeah, that's WYSIWYG (What You See Is What You Get) mode. You can enable it for Quick Reply boxes too, depending on your profile setting. I rather like it, but it has one or two irksome bugs.

Yeah, I was talking about the one that you enable in the profile settings. I turned it off, because I found the bugs. :P

Would these include hitting backspace and the cursor teleporting some random number of spaces back?

(Well, I thought I turned it off... it appears to be persistent! DIE!!!)

Link to comment
Share on other sites

I get a bug with pasting a lot. When I paste, especially in my company thread OP, afterwords it teleports me to a random place in the post. (its really long thanks to spoilers)

Also, just tried the WYSIWYG mode, first stroke of "backspace" and it teleported 3 spaces back XD

Link to comment
Share on other sites

The teleporting cursor is usually the result of how it handles the formatting. Using backspace or arrow keys to move the cursor often causes it to reset the cursor to the endpoint of the last formatting change. No idea why, though.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...