Jump to content

[1.0.5] Behemoth Aerospace Engineering Large Parts v1.3.5 (2015-11-15)


Recommended Posts

NOTICE: Although all the parts of this mod, except for the 8m landing legs, seem to function in KSP 1.1, Behemoth Aerospace Engineering Large Parts is no longer maintained by the author.

 

vThIE7A.png

Behemoth Aerospace Engineering

Large Parts Pack

GD3fu57.png

Download from SpaceDock

Download from CurseForge

 

 

This parts pack contains engines, tanks, and other part categories in three sizes that do not exist in stock KSP, namely 5m, 7.5m, and 10m. Parts are color-coded according to the universal electronic color code, simply because the author is an old RDAF radar technician. Hence, size4 (5m) is yellow, size5 (7.5m) is green, and size6 (10m) is blue.

Engines are kept at reasonable thrust figures and are thus not overpowered compared to the thrust/size curve of stock parts. The same goes for reaction wheels. Big spaceships are going to be sluggish, as one would expect.

This parts pack contains config snippets from the Community Tech Tree by Chris Adderley.

NOTE: As of version v1.3.5, BAE no longer includes the Firespitter plugin, but supports both it and Interstellar Fuel Switch. Either must be installed to enable multi-fuel tanks. In addition, Cross Feed Enabler is required to enable cross feed to radially attached 'Predator' tanks.

Recommended mods:

 

Enjoy!

Change Log

v1.3.5
± Fixed engine heat animations
± Updated test subjects to new format.
± 'Predator' tanks now support ModuleCrossFeed.
± Multi fuel tanks now default to LiquidFuel/Oxidizer if neither InterstellarFuelSwitch nor Firespitter is installed.
v1.3.4
± KSP 1.0.5 compatibility upgrade
v1.3.3
+ Added scaled flag in /Agencies to fix problems with Texture Replacer mod.
v1.3.2
± Converted flag decal to PNG to fix problems with Texture Replacer mod.
v1.3.1
± Fixed visual bug with solar panel arrays.
v1.3.0
± Replaced Firespitter plugin with newer version.
+ Added parachutes.
+ Added bi-, tri-, and quad-couplers.
+ Added docking ports.
+ Added solar panels.
± Adjusted drag for all things red and/or checkered.
v1.2.3
± Adjusted procedural fairing parameters to better reflect KSP 1.0.4 fairing values.
± Adjusted thermals and drag for SRB nose cones to better reflect KSP 1.0.4 nose cone values.
± Adjusted drag for radial tanks and nose tanks.
v1.2.2
± Fixed KSP version number in version file.
v1.2.1
- Deleted Firespitter version file.
± Adjusted engine heatProduction to better reflect KSP 1.0.3 engine values.
± Adjusted SRB thrust and Isp to better reflect KSP 1.0.3 SRB values.
± Adjusted heat shield maxTemp, etc., to better reflect KSP 1.0.3 heat shield values.
± Fixed landing leg piston retraction
v1.2.0
+ Added 8m landing legs.
+ Added modular solid rocket boosters.
+ Added resource ModularSolidFuel, allowing for modular SRBs.
+ Added large radial decoupler.
+ Added ablative heat shields.
± Fixed A1 & A2 engine strut normals.
± Fixed A2 engine texture.
± Fixed agency logo loading error.
± Moved nose tanks to correct tech tree locations.
v1.1.0
+ Added procedural fairings.
+ Added nose cone tanks.
± Fixed Ajax engine cost.
v1.0.3
± Fixed engine overheat problem.
v1.0.2
± Tweaked engine ISP curves to better reflect realistic payload capabilities.
v1.0.1
± Converted all textures to DDE, so they will load faster.
± Corrected location of version file, so it will actually work.
v1.0.0
Release!

 

 

 

 

Edited by greystork
Link to post
Share on other sites

I... I... Woah... This parts are simply magnificent in every way! The way they fit into the stock alike style is amazing! :D (Btw, did my Mod Request have anything to do with the creation of this mod or is it just some sort of awesome coincidence? http://forum.kerbalspaceprogram.com/threads/123802-Part%28s%29-Request-Stockalike-10-metre-spacecraft-aircraft-parts)

Link to post
Share on other sites
congrats on release

Thanks!

I... I... Woah... This parts are simply magnificent in every way! The way they fit into the stock alike style is amazing! :D (Btw, did my Mod Request have anything to do with the creation of this mod or is it just some sort of awesome coincidence? http://forum.kerbalspaceprogram.com/threads/123802-Part%28s%29-Request-Stockalike-10-metre-spacecraft-aircraft-parts)

Can't say that it was your request - it is just something I've wanted for a while for science sandbox games. Maybe it isn't that useful for people running career games, but if someone has a dire need for an extra large part, it's there. Anyway, regardless of the reasons why, you can now play with 10m parts!

Will there be CKAN support, cause DANG!!! this is great and soooo awesome.

Thanks, that is something I will look into.

Link to post
Share on other sites
Wow! Awesome! These are just what I was looking for to finish my tech tree branch./

Glad I could help.

I'm not a huge fan of the colors, however.

The colors are there to make it easier for players to discern between tank sizes in the part preview window. Your opinion is noted, however, and I might do a survey down the line on how many people like/dislike the color scheme if I see enough misgivings about it.

Link to post
Share on other sites

Gonna give this one a whirl tonight. I don't mind the colors at all, but many people tend to "colorize" their ships with colored lights, so perhaps that's something to think about if you decide to make a neutral scheme? The textures are at least symmetrical and crisp, something you don't see in many (most?) other mods. Good show!

Link to post
Share on other sites

i think i found a bug in this mod,i installed them mod,run the ame and now i cant enter into the vab in my career mod.

at first i was not sure that it was the BAE folder that causing this,so i removed it and everything was fine again.

EDIT: ok so i try to reinstall,and this mod do not work in career mod,it works fine in sandbox.

Edited by Life on Europa
Link to post
Share on other sites
i think i found a bug in this mod,i installed them mod,run the ame and now i cant enter into the vab in my career mod.

at first i was not sure that it was the BAE folder that causing this,so i removed it and everything was fine again.

EDIT: ok so i try to reinstall,and this mod do not work in career mod,it works fine in sandbox.

I just started a new career mode game and cannot replicate what you're seeing. Could you do me a favor and see if there are any errors occurring when you try to enter the VAB with Behemoth installed? (Hit Alt+F12 and select the Debug tab before clicking the VAB, so you can see the log messages as they occur.)

Thanks in advance!

Link to post
Share on other sites
I just started a new career mode game and cannot replicate what you're seeing. Could you do me a favor and see if there are any errors occurring when you try to enter the VAB with Behemoth installed? (Hit Alt+F12 and select the Debug tab before clicking the VAB, so you can see the log messages as they occur.)

Thanks in advance!

its says: " Exception]: NullReferenceException: Object reference not set to an instance of an object"

no idea why it works fine in sandbox but not in career mode,i think it has something to do with CTT?

Link to post
Share on other sites
its says: " Exception]: NullReferenceException: Object reference not set to an instance of an object"

no idea why it works fine in sandbox but not in career mode,i think it has something to do with CTT?

Okay, that is a pretty generic error message. Does it say anything other than that, like for instance '...at Contracts.Templates.RescueKerbal.GetTitle ()'?

Link to post
Share on other sites

Thanks, this looks very usefull!

Simple, but very clean artstyle, usefull parts, generally a very nice addition. Definitly gonna take it into a real solar system game! :D

A small suggestion, if you plant to expand the mod, is there a possibility for you to make stock style fairings for the launchers? I'd imagine they look would fantastic with your style.

Edited by Temeter
Link to post
Share on other sites

no,just the "NullReferenceException: Object reference not set to an instance of an object"

everything else looks fine.

so just to be sure i started new science mod new sandbox mod and than new career mod and everything seems to be working fine.

but in my current career mod for some reason the mod locks the vab buildings,i think it has something to do with my current tech tree in my career mod.

Link to post
Share on other sites
no,just the "NullReferenceException: Object reference not set to an instance of an object"

everything else looks fine.

so just to be sure i started new science mod new sandbox mod and than new career mod and everything seems to be working fine.

but in my current career mod for some reason the mod locks the vab buildings,i think it has something to do with my current tech tree in my career mod.

Very strange. For the record, Behemoth LP does support CTT. I'm sorry I can't be of any more help, but there isn't a lot to go on, unfortunately.

Link to post
Share on other sites
now i cant enter into the vab in my career mod.

... works fine in sandbox.

Mostly - in my experience - thats "broken" vessel-files and/or "missinstalled" mods.

Sometimes i also think its the order/sequence you drop mods into gamedata-folder.

Link to post
Share on other sites

Does someone else have an issue with decoupled tanks? The 3.75 drop tanks tend to tilt inside during decoupling, possibly destroying the inside tank/engine. Basically similar to the old decoupler bug of KSP.

Link to post
Share on other sites
Does someone else have an issue with decoupled tanks? The 3.75 drop tanks tend to tilt inside during decoupling, possibly destroying the inside tank/engine. Basically similar to the old decoupler bug of KSP.

Are you referring to the 'Penguin' tanks? Behemoth LP tanks only come in 5m, 7.5m, and 10m varieties.

Link to post
Share on other sites

Just checked the penguins in all of their configurations. Seems like the real issue isn't really tilting, but the yellow tanks not having any decoupling force. The bigger green and blue ones always moved outside, but the yellow ones always just slide down the rocket.

Edited by Temeter
Link to post
Share on other sites
Just checked the penguins in all of their configurations. Seems like the real issue isn't really tilting, but the yellow tanks not having any decoupling force.

Oh? Maybe you did find a bug; let me check and get back to you.

Link to post
Share on other sites

Edit: Looks like it's a bit more complicated. Just took them into my vanilla save to see if it works there. Sorry for the wrong alert, seems like i've got a mod conflict.

Edited by Temeter
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...