Mike-NZ

ISS 1.1.2 development thread

Recommended Posts

If you're redoing the solar arrays, I'd recommend a look at the solar arrays in this mod: 

The arrays seem to have 2 axis of rotation, just like the ISS arrays. Worth a look.

Share this post


Link to post
Share on other sites
12 minutes ago, Tristonwilson12 said:

LEgF3jo.jpg

Make sure to either ask for permission or give proper credit if you are going to rip textures and models from other peoples work

Share this post


Link to post
Share on other sites
15 minutes ago, liquidhype said:

Make sure to either ask for permission or give proper credit if you are going to rip textures and models from other peoples work

I'm not suggesting to use the same arrays. The ones in that mod are for Orion, not ISS. I'm just suggesting to perhaps inquire how they were set up in blender/unity/cfg to allow them to rotate in that way. It would be a lot easier than having to use robotics parts.

Share this post


Link to post
Share on other sites
3 minutes ago, sciencepanda said:

I'm not suggesting to use the same arrays. The ones in that mod are for Orion, not ISS. I'm just suggesting to perhaps inquire how they were set up in blender/unity/cfg to allow them to rotate in that way. It would be a lot easier than having to use robotics parts.

My previous reply was to Triston, not you, hence why I quoted him specifically. I'm just saying if someone is going to rip off models and textures from either Orbiter or NASA, they need to either ask permission or give proper credit.

Share this post


Link to post
Share on other sites
40 minutes ago, liquidhype said:

My previous reply was to Triston, not you, hence why I quoted him specifically. I'm just saying if someone is going to rip off models and textures from either Orbiter or NASA, they need to either ask permission or give proper credit.

yes i talked with the creator of the BEAM module and he said i could optimize it for KSP (there were lots of things that needed fixing i remodeled a lot of it), i will give proper credit when i release it,

Share this post


Link to post
Share on other sites
12 hours ago, sciencepanda said:

If you're redoing the solar arrays, I'd recommend a look at the solar arrays in this mod: 

The arrays seem to have 2 axis of rotation, just like the ISS arrays. Worth a look.

definitely, thanks for that

12 hours ago, liquidhype said:

Make sure to either ask for permission or give proper credit if you are going to rip textures and models from other peoples work

its ok, you are right but don't be too harsh. he is doing well and seems to be doing the right thing

Share this post


Link to post
Share on other sites
On 6/20/2016 at 6:19 AM, Mike-NZ said:

https://www.dropbox.com/sh/l0zhrwryo9zwbl8/AAAakWC6jja_IfeW4Iv2c9xma?dl=0

 

current state of ISS. everything joins up in the VAB, not tested docking in space yet

Beautiful work, however not all the parts seem to be loading for me. Iv'e attached my log file to try and help you find the source of the problem.

http://pastebin.com/BQDTLy1T

  • [ERR 19:01:16.564] - Texture loading errors start
  • [LOG 19:01:36.793] - Part compiling errors start

I have tried KSP version 1.1.2 and 1.1.3, games are stock other than this mod.

Edited by lpam

Share this post


Link to post
Share on other sites

version 1.1.3 is out?

 

I will check all parts in my game to see what isn't working

 

download for the current version is added to page one

it is still being worked on in the meantime and will update as I go

Share this post


Link to post
Share on other sites

ok so I went through the log and made some changes, a couple of parts were not showing but now I have everything ingame

I recommend redownloading and deleting the old files before reinstalling

 

there are texture normal missing but not all my models are fully textured yet

 

let me know if it still happens

 

download added to page one

Share this post


Link to post
Share on other sites
14 hours ago, Mike-NZ said:

let me know if it still happens

Everything loads fine now, thank you 

Share this post


Link to post
Share on other sites

hey, @Mike-NZ in the future you have a plan to change at Soyuz U First Stage to put decoupler (for not using the stock or from other mods) and on fairing?

Ariane 5 the node is not working, Proton Rocket is not stable at launch (bend).

Share this post


Link to post
Share on other sites
8 hours ago, Viruzzz said:

Ariane 5 the node is not working

For the Ariane only have to change these lines in the CFG files of each part that I show below.

 

DecouplerSylda
node_stack_bottom = 0.0, -0.306, 0.0, 0, -1, 0, 1

Ariane5EPS
node_stack_bottom = 0.0, -1.263, 0.0, 0, -1, 0, 2
node_attach = 0.0, 0.0, 0.0, 0.0, 0.0, -1.0, 1

Ariane5FairingBig
node_stack_top = 0.0, 0.0, 0.0, 0, -1, 0, 2

Ariane5FairingSmall
node_stack_top = 0.0, 0.0, 0.0, 0, -1, 0, 2

Ariane5NoseCone
node_stack_bottom = 0.0, 0.0, 0.0, 0, -1, 0, 2
node_attach = 0.0, 0.0, 0.0, 0, -1, 0, 1

Sylda
node_stack_bottom = 0.0, -0.457, 0.0, 0, -1, 0, 1

Ariane5tank
node_stack_bottom = 0.0, -14.996, 0.0, 0, -1, 0, 2

 

Share this post


Link to post
Share on other sites

Welcome back Mike, we have been missing you :D

After you are done with the bugfixes, i can send you some cfg tweaks i did with your mod, like adding SAS to Z1, Battery to S6, tweaked science setup for the labs etc

Share this post


Link to post
Share on other sites

I have few questions about ISS part and Shuttle.

1. Truss 0 -> Truss 6, the node is working to put it on the shuttle? for me not goes

2. Truss 0 with Destiny module, can be attached it (open connector), I not see any point on module where to can put it. (maybe is needs to be connect with Z1, port, without any port, but to working only with node. )

3. Z1 port doesn't work, I think are something wrong in config.

4. all Truss, have ports for couple, to can use with canadarm, and to assembly in space without problems ?

I want to know about all or I not doing correct.

Thanks.

Share this post


Link to post
Share on other sites
On 7/8/2016 at 8:56 AM, Viruzzz said:

I have few questions about ISS part and Shuttle.

1. Truss 0 -> Truss 6, the node is working to put it on the shuttle? for me not goes

2. Truss 0 with Destiny module, can be attached it (open connector), I not see any point on module where to can put it. (maybe is needs to be connect with Z1, port, without any port, but to working only with node. )

3. Z1 port doesn't work, I think are something wrong in config.

4. all Truss, have ports for couple, to can use with canadarm, and to assembly in space without problems ?

I want to know about all or I not doing correct.

Thanks.

1. Please be more clear, i believe you need a rack in the shuttle bay (issue with shuttle nodes, not ISS parts)

2. The 0 Truss attaches to the top of the Destiny module, the node placement is not perfect though but it should allow docking

3. which port ?

4. as far as i remember these were working but the Canadarm itself has problems grabbing parts (seems to be a problem with the colliders)

What is your native language ?

Share this post


Link to post
Share on other sites

Hello, because I am Chinese, I am not very understand English, so I can not find the space shuttle MOD and ISS mechanical arm of the MOD;.; you can send a web site to me? Or email to 16470146922@qq.com Thanks

Share this post


Link to post
Share on other sites

I have Realism overhaul but the zvezda module use monopropellant and the proton uses liquid fuel and oxidizer.I can't use it for my rss/ro Is there any special config for RO?

Share this post


Link to post
Share on other sites

Does this still work? When I had soviet pack on it the game kept crashing, now I don't have the most of the Russian parts. HELP!!!!

Edited by COMMON NAMES

Share this post


Link to post
Share on other sites
2 hours ago, COMMON NAMES said:

Does this still work? When I had soviet pack on it the game kept crashing, now I don't have the most of the Russian parts. HELP!!!!

Can you link what soviet pack your using will take a look

Share this post


Link to post
Share on other sites
37 minutes ago, MeCripp said:

Can you link what soviet pack your using will take a look

hen I download this ISS community it installs Soviet pack as well. Then when I load KSP it just crashes when its loading it

Share this post


Link to post
Share on other sites
15 hours ago, COMMON NAMES said:

hen I download this ISS community it installs Soviet pack as well. Then when I load KSP it just crashes when its loading it

To stop the crashing there is a plugin folder in the Soviet pack zip it up or delete it and it will load

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.