YANFRET

[1.6.1] Chaka Monkey 161

Recommended Posts

Bummer, you guys broke about 10 of my rockets again :( Are you closing in on a solid file structure? So we don't need to rebuild or creations so often due to removed or missing parts? I love Chaka and I don't mean to vent, just a lot of hours of building to loose is all.

Share this post


Link to post
Share on other sites

Yeah, but we update when KSP updates. If we don't, then you can't have Chaka because Squad breaks at least ten of our rockets when they do. (see I get to vent as well!) Our last version came out when 1.0.4 went live, that's a pretty long time!

Edited by YANFRET

Share this post


Link to post
Share on other sites
12 hours ago, tees said:

Ejs29hRI have some part missing when i try load any off ship included in zip file.

http://imgur.com/Ejs29hR

 

 

Try again with a clean install

 

 

8 hours ago, dresoccer4 said:

thanks a ton for this awesome, awesome thing y'all have made.

so i'm a huge fan of the scatterer and the EVE to make the game look all purtty, but they like to eat a lot of memory as well. i tried to load up the EMLV Snacks craft, but KSP dies before it even makes it to the launch pad. 

any tips/tricks out there to allow these high-memory mods to play nice together? i know Chaka is basically a complete parts replacement so i tried to remove the Squad folder from GameData, but the game wouldn't load so assuming there's something kind of important in there.

thanks!

Okay! So we can actually help you with this. Sometimes, when we test new things for Chaka, it becomes helpful to get a little extra headroom on memory, so we have in the past removed certain parts of the Squad folder to make space. You can remove large chunks of it but yes, there are a few squad parts used in the craft files.

 

Here is the short list which we reserve the right to edit!

Cupola interior space

stock lights

several radial decouplers

RCS ports

Sound and FX files

Squad ladders! 

 

Maybe more will do some critical thinking.

 

 

So if you leave those in place there is a huge chunk of the squad folder you can toss and gain a sizable amount of memory.

 

Good question!

Edited by YANFRET

Share this post


Link to post
Share on other sites

To anyone asking for RO configs (and to relieve YANFRET): i am responsible for the CMES RO configs. Unfortunately, updating all the parts will take at least a week so be patient.

Share this post


Link to post
Share on other sites

Hey the Orion Spacecraft adapter appears to have a collider issue. If you build an Orion ship with the Orion service module, an LV-900 2 under that and finally a spacecraft adapter under the engine. When separating from the ICPS the force is so strong it breaks everything on the service module under the capsule. But remove the LV-900 2 and it separates smooth as silk. I believe the collider needs to be convex? I Don't really know my way around unity and Blender enough to really be of any real help here but. I do Know something changed with the colliders in 1.0.5. The other thing is the collider on the adapter may just not be hallow.

Edit:

17 hours ago, YANFRET said:

Regarding the ejection, it's a known issue and we chose to roll with the update before having time to fix it, so as the first askor of the question, your inquiry has been attached to Monkey Action Ticket #646-28219. Thank you!

Oops You already answered this. Sorry for the duplicate post

Edit:

Something that might be more useful. The nodes for both Orion pods appear to have been changed. Any reason for "node_stack_2" in either cfg? Also "node_stack_1" is needed for the internal single parachute in the black pod

Orion Pod White
node_stack_bottom = 0.0, -1.157, 0.0, 0.0, -1.0, 0.0, 3
node_stack_top = 0.0, 0.885, 0.0, 0.0, 1.0, 0.0, 3
node_stack_1 = 0.0, 0.085, 0.0, 0.0, 1.0, 0.0, 3
node_stack_2 = 0.0, 1.72, 0.0, 0.0, 1.0, 0.0, 3

Orion Pod Black
node_stack_bottom = 0.0, -1.157, 0.0, 0.0, -1.0, 0.0, 3
node_stack_top = 0.0, 0.885, 0.0, 0.0, 1.0, 0.0, 3
//node_stack_1 = 0.0, 0.085, 0.0, 0.0, 1.0, 0.0, 3
//node_stack_2 = 0.0, 1.72, 0.0, 0.0, 1.0, 0.0, 3

 

Edited by V8jester

Share this post


Link to post
Share on other sites

I also found an issue with the animation module for the inflatable heatshields. If you use this module instead, the heatshields can be toggled through an action group as well as not be deployed when you launch. And finally it will display inflate and deflate properly

MODULE
{
	name = ModuleAnimateGeneric
	animationName = InflateShieldL
	startEventGUIName = Inflate Heatshield
	endEventGUIName = Deflate Heatshield
	actionGUIName = Toggle Heatshield
	isOneShot = true
	allowAnimationWhileShielded = False
}

 

Share this post


Link to post
Share on other sites
1 hour ago, V8jester said:

I also found an issue with the animation module for the inflatable heatshields. If you use this module instead, the heatshields can be toggled through an action group as well as not be deployed when you launch. And finally it will display inflate and deflate properly


MODULE
{
	name = ModuleAnimateGeneric
	animationName = InflateShieldL
	startEventGUIName = Inflate Heatshield
	endEventGUIName = Deflate Heatshield
	actionGUIName = Toggle Heatshield
	isOneShot = true
	allowAnimationWhileShielded = False
}

 

 

Good catch, I will make the adjustment. Your Monkey Action Ticket # is 646-29773A

 

 

2 hours ago, V8jester said:

Hey the Orion Spacecraft adapter appears to have a collider issue. If you build an Orion ship with the Orion service module, an LV-900 2 under that and finally a spacecraft adapter under the engine. When separating from the ICPS the force is so strong it breaks everything on the service module under the capsule. But remove the LV-900 2 and it separates smooth as silk. I believe the collider needs to be convex? I Don't really know my way around unity and Blender enough to really be of any real help here but. I do Know something changed with the colliders in 1.0.5. The other thing is the collider on the adapter may just not be hallow.

Edit:

Oops You already answered this. Sorry for the duplicate post

Edit:

Something that might be more useful. The nodes for both Orion pods appear to have been changed. Any reason for "node_stack_2" in either cfg? Also "node_stack_1" is needed for the internal single parachute in the black pod


Orion Pod White
node_stack_bottom = 0.0, -1.157, 0.0, 0.0, -1.0, 0.0, 3
node_stack_top = 0.0, 0.885, 0.0, 0.0, 1.0, 0.0, 3
node_stack_1 = 0.0, 0.085, 0.0, 0.0, 1.0, 0.0, 3
node_stack_2 = 0.0, 1.72, 0.0, 0.0, 1.0, 0.0, 3

Orion Pod Black
node_stack_bottom = 0.0, -1.157, 0.0, 0.0, -1.0, 0.0, 3
node_stack_top = 0.0, 0.885, 0.0, 0.0, 1.0, 0.0, 3
//node_stack_1 = 0.0, 0.085, 0.0, 0.0, 1.0, 0.0, 3
//node_stack_2 = 0.0, 1.72, 0.0, 0.0, 1.0, 0.0, 3

 

With the new interim docking port, which is temporary until we roll out the all new Nasa Docking System part to the entire system, there needs to be an independent node for the launch abort tower to attach to, which also simplifies the structural load path. This new node was added for that reason.

Share this post


Link to post
Share on other sites
29 minutes ago, YANFRET said:

With the new interim docking port, which is temporary until we roll out the all new Nasa Docking System part to the entire system, there needs to be an independent node for the launch abort tower to attach to, which also simplifies the structural load path. This new node was added for that reason.

That makes sense. I didn't realize that docking port was for the Capsule. Also I can confirm that the collider is the issue. You can surface attach items right where the LV-900 2 would be. So when you decouple the engine is "inside" the Adapter.

 

Share this post


Link to post
Share on other sites
3 hours ago, V8jester said:

That makes sense. I didn't realize that docking port was for the Capsule. Also I can confirm that the collider is the issue. You can surface attach items right where the LV-900 2 would be. So when you decouple the engine is "inside" the Adapter.

 

Yeah. The extended nozzle just makes it worse. Our Crack team already has it taken apart on the floor, but we didn't want to hold up the update for that fix because it's slightly delicate work.

Share this post


Link to post
Share on other sites

I don't know if this issue has already been addressed, but you cannot put anything int he Duna Hab Lander's box ports (might be the same for the Duna Altair lander as well, but didn't test it). 

Share this post


Link to post
Share on other sites

@YANFRETthe new Orion docking system is absolutely awesome! Thumbs up! :)

Edit: are you also going to completely remove the old docking system & parachute part(s)?

Edited by Phineas Freak

Share this post


Link to post
Share on other sites
3 hours ago, Phineas Freak said:

@YANFRETthe new Orion docking system is absolutely awesome! Thumbs up! :)

Edit: are you also going to completely remove the old docking system & parachute part(s)?

 

Well, those parts are not huge, so maybe we leave them in, update sooner than later and that way we don't necessarily break saves 

 

9 hours ago, lynwoodm said:

I don't know if this issue has already been addressed, but you cannot put anything int he Duna Hab Lander's box ports (might be the same for the Duna Altair lander as well, but didn't test it). 

 

You can put hings in the back, were you looking for nodes to be in there? We did a lot of experimentation with that when it was first made and it all got very complicated.

Share this post


Link to post
Share on other sites
1 hour ago, YANFRET said:

 

Well, those parts are not huge, so maybe we leave them in, update sooner than later and that way we don't necessarily break saves 

 

 

You can put hings in the back, were you looking for nodes to be in there? We did a lot of experimentation with that when it was first made and it all got very complicated.

No, I wasn't looking for a node, but I understand what you are talking about now. I was just used to sliding things in there from the front. Just slide it on the back of the box and flip it around or flip it first and then place it where the box is. I, apparently, wasn't aware of this. Thank you for pointing that out. 

 

Share this post


Link to post
Share on other sites
2 hours ago, Delta_8930 said:

Is that docking port compatible with the KURS docking camera?

The model was made by xxhansonmaxx , for his CST-100 pack and he was gracious to bring one over to chaka in a large box for Monkey activities.

It shares all compatibilities with the original found in the CST-100 pack except it's size.

Share this post


Link to post
Share on other sites

Next Gen Docking Update

After a few odd glitches, things are getting very predictable with the new dock port. Testing with a 5 ton part for reduced docked system flex, and doing all the mech jeb tests to make sure everyone's got the right modules in the right places, it's working very well.

 

9bio1i.jpgSCHPln.jpg

 

 

 

In this scenario the station has no RCS capability so Orion is swinging it around from the port, and there was almost no flex or resonance aligning it to the right situation.

Edited by YANFRET

Share this post


Link to post
Share on other sites

Revised Altiar + Next Gen Dockport

A flawless performance by the NOS Altair pod, now increased in size by 12% 

 


Adaenr.jpgKEGV9y.jpgd9vcvn.jpg

Edited by YANFRET

Share this post


Link to post
Share on other sites

Hello and greetings to all.

I am 'trying' to figure out how to get the parachute part to attach internally to the orion pod.  I am selecting the part that says it has the ability to do this, but I am doing something wrong.

I am sure there is a simple trick, and if someone could pass it on i would be very appreciative.

Cheers and happy holidays to all.

 

Share this post


Link to post
Share on other sites
3 hours ago, drtedastro said:

Hello and greetings to all.

I am 'trying' to figure out how to get the parachute part to attach internally to the orion pod.  I am selecting the part that says it has the ability to do this, but I am doing something wrong.

I am sure there is a simple trick, and if someone could pass it on i would be very appreciative.

Cheers and happy holidays to all.

 

There where some changes to the cfg files for both the white and black Orion. On the black Orion pod the internal node was fomented out with "//" before it. Just open the cfg in notepad and remove the "//" to deactivate the jade and the parachute will attach. I'm on my phone else I would have shown you the exact line in the cfg. If you still have questions just ask and I'll post the code you need and how it works.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.