Jump to content

[1.3.0, 1.2.2] G-Effects: blackouts, redouts, G-LOCs [v0.4.2] (2017 Jun, 25)


Ser
 Share

How do you like sounds in the mod?  

107 members have voted

  1. 1. How do you like sounds in the mod?

    • It's nice that the mod has sounds but some of them definitely need to be replaced
      67
    • Too annoying, I disabled them
      19
    • I don't like the mod completely
      1


Recommended Posts

People, why have you started to download v0.1.2 of this mod?

Is that just a kerbalstuff statistic bug or are there any troubles with the latest versions noone is telling about?

Edited by Ser
Link to comment
Share on other sites

  • 2 months later...

Version 0.2.3 is out

Changes:

  • Loss of color vision (a.k.a "greyout") effect added
  • KeepFit mod interoperability implemented. This means that if you have KeepFit installed (optional) then kerbals' ability to withstand over G will also depend on their fitness levels from KeepFit. You'll need KeepFit of version not lower than 0.8.3.3 for that.
  • Default damping threshold lowered to eliminate over G effects when going EVA
  • Recompiled with KSP 1.0.5

Edited by Ser
Link to comment
Share on other sites

  • 2 weeks later...
Bug report for 0.2.3: with this mod installed, the stock mach and reentry effects seem to be broken.
[SPOILER="screenshot"]A slightly modified version of the stock Osprey being flown in sandbox
[IMG]http://i.imgur.com/fP9xRCn.jpg[/IMG][/SPOILER]

I've tried installing via CKAN and kerbalstuff, same issue in both cases.
Running the steam version of the game (1.0.5 w/ silent update) on windows 10.

Great mod though besides this one issue :D Edited by armagheddonsgw
Link to comment
Share on other sites

[quote name='armagheddonsgw']Bug report for 0.2.3: with this mod installed, the stock mach and reentry effects seem to be broken.[/QUOTE]
That's strange. I play with this mod all the time and reentry and mach effects seem to be ok. I cannot even suppose how my mod might affect that. Could you provide your output_log.txt file from KSP_Data folder when that happens? Edited by Ser
Link to comment
Share on other sites

[quote name='Ser']Could you provide your output_log.txt file from KSP_Data folder when that happens?[/QUOTE]
Sure: [URL="https://dl.dropboxusercontent.com/u/96846275/Logs.zip"]Logs[/URL]
I've included KSP.log and settings.cfg from the main folder as well, although a quick look through both logs doesn't point to anything. For some reason though KSP identifies win10 as 8.1.

As for what might be affecting it, shader bugs can cause all sorts of weird stuff in my experience :confused: - especially the platform specific kind.

EDIT: I should add, I'm running the game from a copy separated from steam so potential game updates don't break things, hence the steamworks errors in the log. I've checked with the copy in my steam folder, and it doesn't matter. Edited by armagheddonsgw
Link to comment
Share on other sites

armagheddonsgw, I've managed to repeat it but can't figure out why it happens in certain cases. You can use [URL="https://github.com/SerTheGreat/G-Effects/releases/download/v0.2.2/G-Effects-0.2.2.zip"]the previous version 0.2.2[/URL] until I fix the issue. It has not much difference from the current one, just lacks that greyout shader and KeepFit integration. If you choose to use the previous version set gDampingThreshold to 44 in the config file to get rid of weird effects when going on EVA. Edited by Ser
Link to comment
Share on other sites

[quote name='Galenmacil']Does the crash to desktop bug still occur when you launch an unmanned vehicle?[/QUOTE]
How often do you experience that? I'm not aware of the bug. So please figure out that yourself and if something weird happens with the mod post your output_log.txt from KSP_Data folder here.
In the majority of cases the crash to desktop is caused by memory overflow due to several heavy mods used (parts and visuals). If you're on Win you could also install the mod named GCMonitor that displays the available amount of memory. That'll help to sort things out. Edited by Ser
Link to comment
Share on other sites

I've tried several other mods using post-processing shaders (like b/w cams etc.) and found that they eat up reentry and mach visual effects too. Seems like it is a common KSP trouble with the main camera and post-processing conflicts.

A version with workaround is on the way.

Edited by Ser
Link to comment
Share on other sites

Version 0.3.1 is out

This version still supports interoperability with KeepFit.

Changes:

  • Slightly improved greyout effect
  • Added config options to enable/disable greyouts

There are separate options to disable greyouts for 3rd person and IVA. By default only IVA greyout is enabled. 3rd person one is disabled to solve the not visible mach and reentry effects issue. If you wish you can enable it back but most likely you won't see reentry effects in that case.

If you are going to use mods like MovieTime or HullCam it is advised to disable corresponding greyout for desired camera effects worked properly.

All that's because of how post-processing effects work in KSP: there can be only one.

 

I'll keep trying to find a more functional solution to implement it in future versions.

Edited by Ser
Link to comment
Share on other sites

  • 2 months later...
12 hours ago, Matuchkin said:

In the video, did you just survive being unconcious in a damn airplane? What?

Yes, why not? Over-G had been caused by a pilot pushing on the stick. When he loses consciousness he drops the stick, control surfaces return to neutral positions and thus G-load relaxes too. Having normal G, a pilot wakes up after a few seconds and if the airplane wasn't pointing towards the ground he survives.

Of course, in the real life there's a problem of a possible pilot's leaning on controls on G-LOC. And if that doesn't happen there's a risk of some uncontrolled muscular contractions on wake up causing some random inputs + several seconds of disorientation afterwards. That's not simulated, but... may be it should.

Link to comment
Share on other sites

  • 3 weeks later...
8 hours ago, theonegalen said:

I am not seeing any G-Effects, no matter how high G's I pull.  Is this mod known to conflict with anything?

No, it's not known to conflict with anything. Post a link to your output_log.txt please

Link to comment
Share on other sites

20 hours ago, Ser said:

No, it's not known to conflict with anything. Post a link to your output_log.txt please

here - on google drive because my dropbox is full

This log is from when I just now dropped G-Effects into my completely stock install, and saw no G-Effects.

EDIT: Upon further testing, I'm only seeing red-out effects, not blackouts.

Edited by theonegalen
Link to comment
Share on other sites

On ‎09‎.‎03‎.‎2016 at 6:44 AM, theonegalen said:

here - on google drive because my dropbox is full

This log is from when I just now dropped G-Effects into my completely stock install, and saw no G-Effects.

EDIT: Upon further testing, I'm only seeing red-out effects, not blackouts.

The same issue has been reported once. Have you any non-standard settings? Could you also change the enableLogging to true in the mod's cfg file and post that output_log.txt?

Sorry for delays, I'm at a ski resort now so I won't be able to launch KSP and try anything for the next week.

On ‎11‎.‎03‎.‎2016 at 8:55 PM, dcompart said:

I don't know if this has been added or discussed, but could you add lateral Gs as well?

 

What do you mean by "lateral Gs"? The ones that act in the forward - backward direction are already implemented, they just have higher tolerances than longitudal Gs. Or may be you mean the forces that act in the direction from one shoulder to another? They are not implemented because of two reasons: first, it is hard to imagine a vessel design that makes them significant and second, there's few to none info about RL tolerances and effects of such forces. If you still need them in the mod I could think about implementing them somehow.

Edited by Ser
Link to comment
Share on other sites

16 hours ago, Ser said:

The same issue has been reported once. Have you any non-standard settings? Could you also change the enableLogging to true in the mod's cfg file and post that output_log.txt?

Sorry for delays, I'm at a ski resort now so I won't be able to launch KSP and try anything for the next week.

No problem, thanks for the help. I think I'm using all the settings that the mod came with. I'll try again with logging enabled tomorrow. :)

Link to comment
Share on other sites

  • 2 weeks later...
On 13.03.2016 at 1:28 PM, theonegalen said:

No problem, thanks for the help. I think I'm using all the settings that the mod came with. I'll try again with logging enabled tomorrow. :)

Do you still have the issue? I'd like to fix it but can't reproduce.

Link to comment
Share on other sites

  • 2 weeks later...

I wanna report of some stange bug - I don't see any G-Effects (the black, the reds and a G-loc) after I add more than 3 kerbals in a crew. Yet, for a single and two members everything works perfectly tho.

Here is some screens: 

Spoiler

5 crew, no effects during maneuvers and after the loosing of control:

002095.jpg


Same goes for 3 kerbals (notice the G-indicator at max there):

002101.jpg


But for a two and a single pilot works just perfectly:

002098.jpg

002097.jpg

I have no idea why it's so..

My specs and mods are:

Spoiler
  • CPU i7-5820K, RAMM 16Gb DDR4, Video AMD Radeon HD 5800 (2Gb), 

    Windows 7 64bit 

  • KSP 1.0.5 (64bit hack, forced OpenGL, on max graphics, stable as hell)

    Mods:

 002102.jpg

002106.jpg

002105.jpg

All of them works perfectly tho, but maybe some may cause a conflict with G-Effects? or idk

Link to comment
Share on other sites

1 hour ago, quadro7f said:

I wanna report of some stange bug - I don't see any G-Effects (the black, the reds and a G-loc) after I add more than 3 kerbals in a crew. Yet, for a single and two members everything works perfectly tho.

All of them works perfectly tho, but maybe some may cause a conflict with G-Effects? or idk

Thanks for reporting, I'll try to reproduce that. No conflicts are known to cause the behaviour you are reporting.

EDIT: as I can see on the first screenshot only Valentina is unconscious and no effects, that's strange. Have you ever made them all lose consciousness?

Also it would be useful if you enabled logging in G-Effects config, achieved the issue and posted a link to output_log.txt after that.

Edited by Ser
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...