Jump to content

[1.8.x] Docking Sounds!! v2.1.12.27690 (10/7/16)


Recommended Posts

On 6.5.2016 at 7:38 AM, tg626 said:

No modder has control over when or if CKAN gets updated - I listed it's compatibility with 1.1.2 on spacedock.info beyond that it's out of my hands.

Not completely, as long as your main download file linked in this thread from github is still marked as max 1.1.1:
"KSP_VERSION_MAX":{"MAJOR":1,"MINOR":1,"PATCH":1}}

Which is the same as on spacedock.info, the download you offer there is marked as 1.1.1 max compatibility in "DockingSounds.version"

Edited by Tekener
Link to post
Share on other sites

Are you sure? (Seriously I have no idea) because that's a file for KSP-AVC. Which due to how it handles checking is perfectly fine with that file in the archive.

If you know this to be a fact, I'd appreciate a reference to that documentation since CKAN is largely a mystery to me.  The only reason my mods are listed in it is because of that "include in ckan" check box that is/was on spacedock/kerbalstuff, and me thinking "Sure, why not?" and selecting it.

Link to post
Share on other sites

I can probably clear some things up. Before anything else I'm sorry our users are bugging you directly. CKAN users should be bugging CKAN for all CKAN-related issues. It's a message we've wholly failed to get across.

Quote

No modder has control over when or if CKAN gets updated - I listed it's compatibility with 1.1.2 on spacedock.info beyond that it's out of my hands.

Modders determine their own level of involvement in how CKAN manages their metadata. Some write their own metadata and CKAN only references it, some simply ping us when something is wrong and some don't even know CKAN indexes their mod. @Tekener is half-correct: CKAN does indeed read the .version file in a given mod's zip. In the case of your mod you use a remote .version file so CKAN will prioritize that info over the local file (but only if the version of the mod in the remote version file matches the mod version).

The issue arose because the spacedock release was delayed. Within seconds of 2.1.1 hitting the spacedock server it was on CKAN. Would it be best for us to target your github releases? Just read a quote from you " Github is the master, spacedock the mirror." So we'll be changing where we pull releases to GitHub.

As for documentation for CKAN a decent primer might be https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Edited by plague006
Link to post
Share on other sites
  • 3 weeks later...
  • 3 months later...

I'm around :)

Once Module Manager gets updated, we'll see if I need any updates.  This mod (and many others) relies on Module Manager for integration into the stock parts, so no MM, no DS. :(

If it proves to be borked, then I probably won't update until the v1.2 final release.

 

Edited by tg626
Link to post
Share on other sites
  • 3 weeks later...
  • 2 months later...

Finally got around to installing this last night. Many thanks to @tg626 for this great bit of ambiance.

Also, for @Dashman I laughed so hard when I listened to your alternate docking sound. The old Star Trek door whoosh, and the "doi-oi-oi-oi-nnng" near the end, make it just perfectly Kerbal :)

Link to post
Share on other sites
  • 4 months later...
  • 2 months later...
  • 2 months later...
  • 4 months later...
  • 5 months later...
  • 4 months later...
  • 4 months later...
On 2/4/2019 at 1:02 AM, DomiKamu said:

Hi,

I'm testing this mod against KSP 1.6.1, and report exception on every load (when starting KSP).

Link to KSP.log (Dropbox)

Line 158.

However, the mod seems work when I dock/undock vessel to another (having sounds, no exceptions).

Regards.

Does that slow down the game, having all those exceptions?

Link to post
Share on other sites
17 minutes ago, jpinard said:

Does that slow down the game, having all those exceptions?

Did you even look a the log? He has one exception during load. The exception itself is because the mod was compiled against the wrong version of .NET but doesn't seem to create any problems.

Link to post
Share on other sites
3 minutes ago, Tonka Crash said:

Did you even look a the log? He has one exception during load. The exception itself is because the mod was compiled against the wrong version of .NET but doesn't seem to create any problems.

Oh cool thanks - Sorry!

Link to post
Share on other sites
  • 2 months later...

@tg626 DMagic's flexo docking tubes have a different module [FlexoTube], requiring an additional MM code segment to give them sounds. I tried it out and it works seamlessly with flexotubes docking both with each other and standard ports.

 

@PART[*]:HAS[@MODULE[FlexoTube],!MODULE[DPSoundFX]]:FOR[DPSoundFX]
{
	MODULE
	{
		name = DPSoundFX
		sound_docking = FP_DPSoundFX/Sounds/dock
		sound_undocking = FP_DPSoundFX/Sounds/undock
		internalSoundsOnly = false
	}
}

 

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...