Sign in to follow this  
AstroRick

Soooo tired of updating.....

Recommended Posts

Does anyone know if there's an automatic patcher out there that works? I am tired of updating KSP and all my mods every time there's a change from 1.0.x to 1.0.y. Alternately, I suppose I can just bite the bullet, be happy with the stable version I have now and try to ignore any new minor updates.

I do worry about newer mods being incompatable with older versions though. I'm currently on 1.0.2. Are 1.0.4 version mods still compatable? Or will I get an incompatibility warning every time I start the game?

Share this post


Link to post
Share on other sites

Some are compatible, some aren't; pretty much any mod that works with the heating system in some barely-connected way will need updating for sure, others might not.

You'll need to update any of the ones giving compatibility warnings though, those won't automatically go away.

For auto-updating mods, there is that CKAN thing that people talk about, but in my experience, it's screwed up a surprising number of mod installs, so if you want to risk it, you can try that.

Edited by ferram4

Share this post


Link to post
Share on other sites

Very unfortunate this. If the Game is officially out of Beta, they need to give people a chance to play the game before issuing updates which require them to wait for mod updates and then download a slew of them, having to hope that the mods needed for a game save are updated too.

Share this post


Link to post
Share on other sites
Very unfortunate this. If the Game is officially out of Beta, they need to give people a chance to play the game before issuing updates which require them to wait for mod updates and then download a slew of them, having to hope that the mods needed for a game save are updated too.

This is the nature of using mods. You can either not update the game or if you're using Steam you can rollback to the previous version (under properties) and/or select "Do Not Update" ... then update it when all of mods you're using have been updated.

Share this post


Link to post
Share on other sites
This is the nature of using mods. You can either not update the game or if you're using Steam you can rollback to the previous version (under properties) and/or select "Do Not Update" ... then update it when all of mods you're using have been updated.

One of the nightmares Steam recently introduced (like within the last few months) is removing the "do not update" option. The best you can do now is only update next time you launch the game, which is hell if you run the game without noticing that a patch has come out (like from a shortcut or what have you).

And PLEASE correct me if I'm wrong there and there's a way around it, because I'd love to know if there is.

Share this post


Link to post
Share on other sites
Very unfortunate this. If the Game is officially out of Beta,

Oh come on, that ship has sailed so long ago. And SQUAD *does* show a certain commitment by providing hotfixes to the worse issues. With the cargo bay pressure cooker, I'm afraid that there may soon be a 105. All things considered, I'd rather have too frequent updates than none at all.

I wonder if they will provide us with a public beta of the unity5 build. Why fix things in U4 that are to be entirely rewritten in U5? Also, this would effectively put us into beta where this game (sadly) belongs. That would be a daring move and I can already hear the moaning... but I feel sorry for squad having to provide a lot of fixes to a codebase that is nearly obsolete already.

Share this post


Link to post
Share on other sites

You can always copy the game folder out of Steam folders and run it without Steam. It won't get updated in a separate location.

Another option is waiting a couple of years to make sure the game is somewhat complete...

Share this post


Link to post
Share on other sites
One of the nightmares Steam recently introduced (like within the last few months) is removing the "do not update" option. The best you can do now is only update next time you launch the game, which is hell if you run the game without noticing that a patch has come out (like from a shortcut or what have you).

And PLEASE correct me if I'm wrong there and there's a way around it, because I'd love to know if there is.

I'm pretty sure it has always been this way and you don't have to run the game through Steam.

Share this post


Link to post
Share on other sites

KSP mods are similar to Minecraft mods when a major change comes along. You kinda have to accept that the game may break the mods.

Also they did give people a chance to play, like a month.

Share this post


Link to post
Share on other sites
I'm pretty sure it has always been this way and you don't have to run the game through Steam.

Yep, I've copied the KSP folder and play without Steam. CKAN can export the mods you are using to a file. In a couple of weeks when all mods are updated to 1.0.4 I make another copy and let CKAN do ist magic. If everything fails, I can still play 1.0.2.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this