JPLRepo

[1.9.x] AmpYear Main & Reserve Power Manager (v1.5.7.0) 8th Mar 2020

Recommended Posts

Ampyear 1.5.6 released for KSP 1.8.x

Will try to do all my other mods this weekend as well.

Share this post


Link to post
Share on other sites
7 hours ago, JPLRepo said:

Ampyear 1.5.6 released for KSP 1.8.x

Will try to do all my other mods this weekend as well.

Thanks for this.  I was going to ask you when you were present in someone's Twitch stream the other day (Rocketology's, perhaps) but I thought I'd just wait.

Share this post


Link to post
Share on other sites

The AmpYear settings screen at the KSC is busted and KSPedia pages are busted. Working on fixing it.

Share this post


Link to post
Share on other sites

Hello,

I don't see anyone mentioning a similar problem.

I got the latest 1.5.6.0 of AmpYear on KSP 1.8

The mod seems to be working fine, I can see the menu in the VAB, it's responsive and updating.

But I can't seem to find the reserve batteries anywhere.

ampYear_Z1K_ReserveBatteryBank

ampYear_Z100_ReserveBatteryPack

ampYear_Z400_ReserveBatteryPack

These part files and folders are in GameData, but they're not showing up in the game.

Also interestingly, the "Janitor's Closet" filtering mod doesn't seem to list AmpYear, so I can't filter by it.

I tried to filter by "Reserve Power" option, but the batteries still not showing up.

I would be happy if you could help me figure out what's wrong.

If you are interested, I can send you my log files, just tell me how and from where would you like to receive them.

Thank you so much in advance.

Share this post


Link to post
Share on other sites
10 hours ago, Problemless Mods Wanter said:

If you are interested, I can send you my log files, just tell me how and from where would you like to receive them.

See the link in my sig block on how to report problems/issues.  You should post log as a link to a file sharing service such as Dropbox, Google Drive, One Drive, etc.  Never post full logs directly to the forums; the moderators will remove log posted this way because it makes it difficult for people on mobile devices.

Edited by Brigadier

Share this post


Link to post
Share on other sites

Hello,

I believe the curved solar panels from Near Future have lost their compatibility again.

The parts which are not calculated, that I can find are;

NIV-30 Curved Solar Array and NIV-45 Curved Solar Array.

I haven't tested all parts from Near Future but other parts seems to be calculated.

Thank you so much in advance for your concern and have a wonderful day...

UPDATE:

I'm also noticing that the PB-NUK Radioisotope Thermoelectric Generator is not calculated. =(

Edited by Problemless Mods Wanter
About PB-NUK Radioisotope Thermoelectric Generator

Share this post


Link to post
Share on other sites

I'm getting a strange issue with AmpYear in KSP 1.7.3, running RO / RP-1 along with TAC-LS and USI-MKS: 

The KSP loading sequence gets stuck when it tries to compile the USI-MKS Tundra PDU part. KSP doesn't crash or even become unresponsive. The loading screen continues to turn over, but it doesn't progress. No warnings, errors, or exceptions are thrown in the KSP log. Removing AmpYear allows the game to load normally. 

Thoughts? Suggestions?

EDIT: SOLUTION FOUND

It turned out to be an issue with the AmpyYear MM config file. The definition for integration with RO is incorrect. Why this causes it to choke on this particular part? I have no idea. However, the fix is simple because you change one line:

@RESOURCE

should be

@RESOURCE[ReservePower]

Happy to submit an issue on github or just upload my fixed version if you'd like.

Edited by Omnipius
Solution found

Share this post


Link to post
Share on other sites
On 12/16/2019 at 12:38 PM, Omnipius said:

I'm getting a strange issue with AmpYear in KSP 1.7.3, running RO / RP-1 along with TAC-LS and USI-MKS: 

The KSP loading sequence gets stuck when it tries to compile the USI-MKS Tundra PDU part. KSP doesn't crash or even become unresponsive. The loading screen continues to turn over, but it doesn't progress. No warnings, errors, or exceptions are thrown in the KSP log. Removing AmpYear allows the game to load normally. 

Thoughts? Suggestions?

EDIT: SOLUTION FOUND

It turned out to be an issue with the AmpyYear MM config file. The definition for integration with RO is incorrect. Why this causes it to choke on this particular part? I have no idea. However, the fix is simple because you change one line:


@RESOURCE

should be


@RESOURCE[ReservePower]

Happy to submit an issue on github or just upload my fixed version if you'd like.

Suggest updating to the latest version of KSP and the mod. I only support the latest version.

Share this post


Link to post
Share on other sites

Hello !

 

So, KSP 1.9 is out !!

But unfortunately "Vessel xx wasn't loaded because it had the following part missing : reserveBatteryPack".

Good luck :)

(Gonna search in KSP.log if I can find anything, but could take a bit of time, or I could not find anything...)

 

turn out I found them pretty fast :

Spoiler

[ERR 21:26:48.466] The file can not be loaded because it was created for another build target that is not compatible with this platform.
Please make sure to build AssetBundles using the build target platform that it is used by.
File's Build target is: 6


[ERR 21:26:48.466] Unknown error occurred while loading 'archive:/CAB-8e02495c2ff1dac395e0e501cd533753/CAB-8e02495c2ff1dac395e0e501cd533753'.

[ERR 21:26:48.467] The AssetBundle 'file://C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\REPOSoftTech\AmpYear\KSPedia\ampyear.ksp' can't be loaded because it was not built with the right version or build target.

[ERR 21:26:48.467] Error while getting Asset Bundle: The AssetBundle 'file://C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\REPOSoftTech\AmpYear\KSPedia\ampyear.ksp' can't be loaded because it was not built with the right version or build target.

[ERR 21:26:48.467] AssetLoader: Bundle is null

[ERR 21:26:48.757] The file can not be loaded because it was created for another build target that is not compatible with this platform.
Please make sure to build AssetBundles using the build target platform that it is used by.
File's Build target is: 6


[ERR 21:26:48.757] Unknown error occurred while loading 'archive:/CAB-11a38aa0119483f89fa119c50d4030d9/CAB-11a38aa0119483f89fa119c50d4030d9'.

[ERR 21:26:48.757] The AssetBundle 'file://C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\SCANsat\Resources\KSPedia\scansat.ksp' can't be loaded because it was not built with the right version or build target.

[ERR 21:26:48.757] Error while getting Asset Bundle: The AssetBundle 'file://C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\SCANsat\Resources\KSPedia\scansat.ksp' can't be loaded because it was not built with the right version or build target.

[ERR 21:26:48.757] AssetLoader: Bundle is null

 

 

Edited by Sppion1

Share this post


Link to post
Share on other sites
4 minutes ago, Sppion1 said:

So, KSP 1.9 is out !!

It's been out for like an hour. Why would you expect this mod, or ANY mod, to be updated?

Share this post


Link to post
Share on other sites
Just now, leatherneck6017 said:

It's been out for like an hour. Why would you expect this mod, or ANY mod, to be updated?

I don't expect any of them to be, just telling modders which parts are criticals. Just trying to help. But I'm sure I need to wait for some mod to be updated, with some still being 1.7 :)

Share this post


Link to post
Share on other sites

Release time for update to my mods to 1.9 = When I have some time over the coming week + a logarithmic multiplier for each person that asks for when it's going to be updated.

Share this post


Link to post
Share on other sites
1 minute ago, JPLRepo said:

Release time for update to my mods to 1.9 = When I have some time over the coming week + a logarithmic multiplier for each person that asks for when it's going to be updated.

Don't worry, take the time you need :)

Share this post


Link to post
Share on other sites
16 minutes ago, Sppion1 said:

I don't expect any of them to be, just telling modders which parts are criticals. Just trying to help. But I'm sure I need to wait for some mod to be updated, with some still being 1.7 :)

Reporting that a mod doesn't function in an unsupported version helps no one.

Share this post


Link to post
Share on other sites
7 hours ago, JPLRepo said:

Release time for update to my mods to 1.9 = When I have some time over the coming week + a logarithmic multiplier for each person that asks for when it's going to be updated.

Just curious, what's the base of that log function?  It makes a difference if I'm going to be the first person to ask? :P

Share this post


Link to post
Share on other sites

Version 1.5.7 Released for KSP 1.9.x. See Op for details and download links.

Share this post


Link to post
Share on other sites

Hello, I'm having an issue with your recent update (at least I think it is Ampyear. Had trouble triangulating which mod in your folder is causing the issue).

The red exit button along with the VAB and SPH no longer work. the back button seems to try and bring me to X1 Warp. Attaching a log file.

If you need anything else, lmk. I had a lot of mods installed (100+) but the log file is only of the test with just reposoft folder +MM

Thankyou for all the hard work!

https://drive.google.com/file/d/1hzfoj7xVsr-0k0vROBqV08CLG-sZQndK/view?usp=sharing

Share this post


Link to post
Share on other sites
1 hour ago, kirmie44 said:

Hello, I'm having an issue with your recent update (at least I think it is Ampyear. Had trouble triangulating which mod in your folder is causing the issue).

The red exit button along with the VAB and SPH no longer work. the back button seems to try and bring me to X1 Warp. Attaching a log file.

If you need anything else, lmk. I had a lot of mods installed (100+) but the log file is only of the test with just reposoft folder +MM

Thankyou for all the hard work!

https://drive.google.com/file/d/1hzfoj7xVsr-0k0vROBqV08CLG-sZQndK/view?usp=sharing

Straight off the bat. I can see you have Contract Configurator and ResearchBodies installed under KSP 1.9.1. Both of these mods don't support 1.9.1 yet.

Share this post


Link to post
Share on other sites
20 minutes ago, JPLRepo said:

Straight off the bat. I can see you have Contract Configurator and ResearchBodies installed under KSP 1.9.1. Both of these mods don't support 1.9.1 yet.

yeah, ill give you a third strike against me. After reinstalling it, it seems to work fine. I think CKAN must have installed the update wrong.

I'm asking for trouble, but the other mods "work" and I've tried the process of reverting all my mods and game back to 1.8.1 and I spend hours figuring out what's broken. good luck on future updates!

Share this post


Link to post
Share on other sites
On 11/19/2017 at 5:13 AM, JPLRepo said:

1 = hi, 2 = med, 3 = low

Highest priority = most critical. So last to shutdown and first to restart

High priority = 1. And will be last to shutdown and first to restart.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.